15:02:00 <adamw> #startmeeting Fedora QA Meeting
15:02:00 <zodbot> Meeting started Mon Sep 24 15:02:00 2012 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:02 <adamw> #meetingname fedora-qa
15:02:02 <zodbot> The meeting name has been set to 'fedora-qa'
15:02:24 <adamw> #topic roll call
15:02:29 * tflink is here
15:02:30 <dan408-> here somewhat
15:02:30 <adamw> who's about for a QA meeting?
15:02:52 <brunowolff> I'll be lurking for a little while, but have a work meeting soon.
15:03:04 <dan408-> ill be joining from the diner
15:03:20 <dan408-> providing my phone holds a decent charge
15:03:41 <Cerlyn> I'm hear to QA the QA meeting
15:03:59 <adamw> well I'm QA'ing your QA'ing of the QA meeting, and you spelled 'here' wrong
15:04:05 <dan408-> you can HEAR the QA meeting?
15:04:18 <Cerlyn> Clearly that's the fault of the IRC channel and not me.
15:04:33 <dan408-> do you have speech assistance turned on?
15:04:59 <spoore> oh that'd be sweet....can you assign different voices to different nicks?
15:05:43 <dan408-> i'll code that in to the next version of BitchX
15:05:57 <Southern_Gentlem> spoore,  no but i am sure festival would love help to do that
15:06:25 <adamw> mine should sound like krusty the klown
15:06:32 <adamw> alrighty
15:06:46 * dan408- = apu
15:07:08 <tflink> looks like we're missing the brno folks - is today a holiday?
15:07:24 <adamw> dan408: I had you down as stan the coffin salesman from monkey island.
15:07:49 <dan408-> i had you down as marge..
15:07:53 <adamw> tflink: i think someone said something about that on the internal list, let me see
15:07:54 <adamw> dan408: hehe
15:08:20 <tflink> adamw: the 28th is a holiday
15:08:21 <adamw> huh. they said fri 28 is a holiday
15:08:23 <adamw> yeah
15:08:25 <adamw> nothing about today
15:08:30 <adamw> maybe the network's down there?
15:08:35 <misc> nope
15:08:35 <dan408-> holiday is 1 week long!
15:08:49 <adamw> or they all finally decided to go get drunk instead of coming to the meeting?
15:08:50 <jreznik> only Friday is a free day here :)
15:09:02 <misc> adamw: or being drunk then coming to the meeting
15:09:10 <adamw> jreznik: can you go check if there's a QA team in the nearest gutter? :)
15:09:11 <jreznik> adamw: you can't get drunk here - there's still prohibition on going...
15:09:20 <dan408-> that's peculiar
15:10:41 <jreznik> hmm, seems like brno's qa guys are really drinking :) I don't see them :)
15:11:28 * maxamillion is here-ish (I swear every time I try to make this meeting something happens right in the middle .... going to try and stay focused today)
15:11:42 <adamw> grr
15:11:44 <adamw> the drives on this laptop are losing it, methinks
15:11:46 <adamw> well we'll get by as best we can without kparal and co., i guess
15:12:01 <adamw> #topic previous meeting follow-up
15:12:11 <jreznik> adamw: I pinged jskladan, seems like the only one online...
15:12:33 <adamw> "adamw to find out who's writing the release announcement and make sure it calls out the biggest Alpha bugs" - I done that, got the biggest stuff listed in the mail
15:12:45 <adamw> also thanks to bcotton who made sure it was in big red letters in lots of places
15:13:08 <adamw> #info "adamw to find out who's writing the release announcement and make sure it calls out the biggest Alpha bugs" - this was done successfully
15:13:09 <jreznik> adamw: yep, I asked him to be RED :) btw. thanks! good job
15:13:21 <adamw> " tflink to draft up a freeze entrance requirements proposal for the list and we can take the idea from there "
15:13:22 <adamw> tflink?
15:13:41 <tflink> I'm still struggling with a way to quantify freeze readiness
15:13:57 <tflink> I did do a smoketest build with post-alpha stable
15:14:24 <adamw> #info "tflink to draft up a freeze entrance requirements proposal for the list and we can take the idea from there" - tflink still working on quantifying freeze readiness
15:14:24 <dan408-> what is "post-alpha" stable these days?
15:14:25 <tflink> and I put together a list of components that could potentially cause beta to slip (according to the current release requirements)
15:14:27 <dan408-> 3.1 or 3?
15:14:35 <adamw> dan408: neither of those.
15:14:40 <dan408-> ok what
15:14:41 <tflink> https://fedoraproject.org/wiki/User:Tflink/F18_alpha_smoketest1_results
15:14:44 <adamw> dan408: he means a build with all the stuff that's in stable now
15:14:46 * jskladan hides in the shadows
15:15:00 <tflink> I need to move that wiki page, though
15:15:02 <dan408-> okay i reinstalled last night, used 3
15:15:09 <tflink> it should be F18_beta
15:15:13 <dan408-> i heard something bad about 3.1
15:15:22 * dan408- double checks
15:15:36 <adamw> dan408: doesn't matter now anyhow, alpha is done.
15:15:39 <jreznik> tflink: also there's https://fedorahosted.org/fesco/ticket/946 - so we can talk about the criteria there with FESCo... they understand this ticket the same way
15:15:39 <dan408-> http://dl.fedoraproject.org/pub/alt/stage/ <-- not here.. is it on the other mirror?
15:16:11 <tflink> If anyone has suggestions on realistic ways to measure release readiness other than 'all potential release blocking features must be testable', I'd love to hear them
15:16:26 <tflink> s/release readiness/freeze entrance readiness/
15:16:37 <dan408-> tflink: how about just basic functionality and usability.. since the design is so radically different?
15:17:08 <dan408-> and i dont mean "should be able to install and xxx"
15:17:08 <adamw> dan408: it's not an official build of any kind so it's not mirrored
15:17:15 <tflink> dan408-: that's even more nebulous than what I have already :)
15:17:20 <maxamillion> and like clock work ... $dayjob duties call ...
15:17:25 <jreznik> dan408-: you have to define "basic functionality" and I think it should be based on beta release criteria
15:17:27 <adamw> maxam: hi, bye :)
15:17:32 <maxamillion> ;)
15:17:47 <adamw> #info https://fedorahosted.org/fesco/ticket/946 is a ticket related to freeze entrance criteria topic
15:17:50 <dan408-> tflink: i can get detailed but im trying to keep it short and concise as i dress for work.
15:18:13 <adamw> shall we keep it for open floor, since we have other stuff to get through?
15:18:18 <tflink> the problem I'm having is defining "ready for freeze" without getting needlessly complicated or vague
15:18:24 <tflink> yeah, works for me
15:18:46 <dan408-> k brb
15:18:58 <adamw> tflink: now you know why all those criteria are so damn long =)
15:19:02 * tflink doesn't want to specify something that's ready for release - just something that has a chance of being released after a 2 week freeze
15:19:20 <tflink> adamw: I already knew the reason behind that :-P
15:19:22 <adamw> #info "pschindl to kill 'uncategorized package groups' criterion" - pschindl is not around today, but this got done and reported on the list
15:20:21 <adamw> #info "kparal to refine 'release-blocking package sets' criterion" - this is still going on but it looks like we're pretty close
15:20:50 <adamw> we've got a criteria topic coming up right after this so no need for discussion of any of these right now btw
15:21:06 <adamw> #info "adamw to refine alpha partitioning criterion" - I didn't get around to this yet, sorry
15:21:06 <jreznik> tflink: adamw: also for checking criteria it would be great to have some pre-TC image with latest anaconda & company... /me has to leave now, will be back in approx. 1 hour :( so lets hope for open floor still going on :) or #fedora-qa :D
15:21:18 <adamw> #action adamw to refine alpha partitioning criterion
15:21:52 <adamw> ok, anything I'm missing that we should follow up on from last week that's not in the agenda to come?
15:23:19 <adamw> #topic release criteria revision
15:23:46 <adamw> so I put this on the list mainly because we went on a long time last week and i thought there may be stuff people still wanted to bring up, about any of the existing proposals
15:24:16 <adamw> if everyone's broadly happy with the current proposals, i figured we could take a look at the current beta criteria together and see if any aside from the ones already undergoing revision might need changes
15:26:01 <adamw> welp, i guess that's what we're doing then =)
15:26:05 <tflink> jreznik_afk: that's what the beta smoketest image is for - it has the latest anaconda build (feature-wise, there was a rebuild for new glade)
15:27:11 <adamw> so it would obviously be good for Beta if we can stand confidently by the criteria we have instead of fudging as much as we did for alpha
15:28:20 <tflink> do we know what kinds of disk usage will be ready for beta (free space, etc.)
15:28:28 <adamw> so what i'm thinking there is we all take a look at https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria and see if there's any of those requirements we might need to change or loosen
15:28:38 <adamw> tflink: i don't yet, but that's definitely something we need to nail down
15:29:10 <tflink> that's one of the bigger potential fudges that I see
15:29:17 <tflink> that and what's going on with upgrade
15:29:20 <adamw> well we have little in the way of partitioning for beta
15:29:28 <adamw> but that's because the alpha criterion was quite strong before
15:29:37 <tflink> but the alpha release requirements still hold for beta
15:29:44 <adamw> now we're weakening the alpha one, we'll need a new beta one, but i did want to see what the beta partitioner will look like before drafting one
15:30:03 <adamw> right, but the alpha criteria is now just 'wiping an entire existing disk must work', remember.
15:30:07 <adamw> criterion*
15:30:21 <tflink> yeah, I was going off of what is currently in the wiki and what it used to be
15:30:31 <adamw> right, that's why i need to get the alpha change done, it keeps confusing people :/
15:30:41 <tflink> under the assumption that we aren't going to release final with just full disk autopart
15:30:47 <adamw> #action adamw to draft new partitioning criterion for Beta once we know what will be in anaconda
15:31:54 <adamw> on upgrades, yeah, that's another significant one
15:32:11 <adamw> i think what we should change there is the text "either via preupgrade or by booting to the installer manually"
15:32:28 <tflink> from what I remember hearing, preupgrade is going to die and be replaced by a single upgrade mechanism
15:32:35 <tflink> something related to the current upgrade work
15:32:36 <adamw> it should say "using the officially recommended upgrade method"
15:32:44 <adamw> imho obviously
15:33:10 <adamw> since what we should really enforce at beta is that our 'official' upgrade method should work.
15:33:12 <tflink> s/method/method(s)/ but yeah, that's more flexible
15:33:18 <adamw> yeah.
15:33:39 <adamw> jumping back a bit there's also 7. and 8.
15:33:47 <tflink> do we have any ETAs on partitioning and upgrade?
15:34:01 <adamw> i could see us fudging on 7, though we've discussed its place quite heavily so maybe not
15:34:10 <adamw> and for 8. too, if some really obscure method didn't work
15:34:14 <tflink> alpha or beta 7 and 8?
15:34:16 <adamw> beta
15:34:29 <tflink> isn't serial console install working for the most part?
15:34:32 <adamw> ETAs, i don't right now, but we should definitely find out
15:34:35 <adamw> i dunno, i haven't tested it :)
15:35:00 <tflink> IIRC, that's the only working method of install for ppc and they've been mostly able to get serial working
15:35:07 <tflink> wait, that's text based. not serial
15:35:38 <adamw> right
15:36:32 <adamw> tbh 7. is probably OK, we seem pretty firm on having that one. 8 is more fudgeable i guess.
15:36:40 <adamw> and the other one that might be a candidate is 13.
15:36:51 <tflink> yeah, I'd be OK with weakening 8 for beta
15:36:53 <adamw> since it seems we don't really care as much about rescue mode as we did.
15:37:13 <tflink> and we don't know if LVM or RAID will be supported for install in beta
15:37:25 <adamw> 13 is rescue mode, not partitioning, note.
15:37:40 <tflink> yeah, but it talks about being able to detect and use LVM/RAID
15:38:02 <tflink> what are the other options for fixing a busted install w/o rescue mode?
15:38:07 <adamw> #info adamw/tfink propose to replace specific upgrade methods in the Beta upgrade criterion with 'officially supported upgrade method(s)'
15:38:14 <adamw> tflink: live image.
15:38:32 <adamw> either a fedora one or any one of the several that exist specifically for system rescue purposes...
15:38:56 <tflink> I can see some of the logic there, but do the lives have the right packages to re-install grub?
15:39:03 <adamw> all rescue mode really has going for it is a) you definitely have it right there and b) it auto-mounts your install in the correct hierarchy. but neither of those is really critical.
15:39:10 <tflink> I suppose they would since they install grub during install
15:39:14 <adamw> yeah, they have to.
15:39:37 <tflink> it just seems a little odd to require downloading of another iso if the install breaks
15:39:49 <tflink> rather than being able to use the same iso you installed from
15:39:57 <adamw> mounting the installed system for you is pretty convenient, admittedly, especially if it uses LVM. but even there, there are tools to help. the GNOME Disks tool is pretty useful for e.g.
15:40:16 <adamw> sure, but is 'a little odd' enough for us to delay Beta release for a fourth week? these are the tough questions =)
15:40:26 <adamw> i just want to make sure the criteria are as bulletproof as possible in advance
15:41:01 <adamw> #info 'all kickstart delivery methods' criterion is agreed to be possibly overstated
15:41:03 <tflink> is rescue mode enough to delay beta for the fourth week? Maybe, maybe not. Honestly, it shouldn't be a huge issue @ beta, IMHO
15:41:11 <adamw> #action adamw to consider revisions to 'kickstart delivery method' criterion
15:41:16 <tflink> it should work already
15:42:10 <adamw> OK, well let's leave that one alone for the present
15:42:17 <adamw> looks like enough work to be going on with anyhow
15:42:48 <adamw> anyone else spotted anything in the criteria they think might be overambitious?
15:42:49 <tflink> if we're going to have a rescue mode, it should work by beta - there should be little/no need for it @ final
15:43:20 <tflink> adamw: that would be a good question for the anaconda devs and/or fesco
15:45:56 <adamw> tflink: yeah, that's a point
15:46:05 <adamw> tflink: do you feel like an action? i've had a lot this week ;)
15:46:13 <tflink> sure
15:47:17 <adamw> #action tflink to ask other interested parties (anaconda team, fesco...) to look over the beta criteria and see if there's anything they feel should be dialled down
15:47:58 <adamw> ok, i think that covers the criteria issue
15:48:20 <adamw> #topic Naming of TCs/RCs
15:48:32 <adamw> so i really meant to go through the archives and call out specific proposals for this discussion
15:48:46 <adamw> unfortunately i forgot :/ so we don't really have all the various proposals that have been made to hand
15:49:01 <adamw> still, does anyone have a particular favourite proposal for changing the naming of TCs/RCs or anything?
15:49:12 <adamw> we can always continue this next week if necessary
15:50:33 <tflink> works for me :)
15:52:26 <robatino> kparal and i had a proposal that involved making the names of all proposes lexicographically ordered and adding an "R" suffix for release candidates, i'd have to dig it up in the archives
15:52:37 <robatino> s/proposes/composes
15:52:39 <adamw> yeah, i remember that one
15:52:57 <adamw> C1, C2, C3R, C4, C5R - something like that
15:53:14 <robatino> btw, is it still possible to have tcs after rcs? if so, this would make that less confusing
15:53:24 <adamw> i like it because it's flexible and it's also obscure so should frighten people off and not make them confuse it with an official release, which is a good thing
15:53:36 <adamw> robatino: right now it is being intentionally left a grey area
15:53:45 <adamw> but that scheme would certainly allow for it in a nice way
15:54:00 <tflink> it might be good to add in a PC to make it more clear that it isn't a release
15:54:18 <adamw> pc?
15:54:19 <tflink> I can see how F18 beta C3 could be mistaken for something released
15:54:22 <tflink> pre-compose
15:54:28 <tflink> or something along those lines
15:54:52 <adamw> yeah...maybe needs more tweaking
15:55:05 <adamw> i guess there's the danger people just ignore the bit they don't understand and read 'f18 beta'
15:55:44 <nirik> how about... TC's stay the same and RC's change to "AC" "BC" (alpha compose, beta compose)
15:57:10 <adamw> so we go from Alpha TC4 to AC1?
15:57:33 <nirik> yeah
15:57:39 <robatino> as long as the announcement explicitly says "test compose" or "release candidate" doesn't that avoid the confusion?
15:57:53 <nirik> s/release/alpha/
15:58:23 <adamw> robatino: no-one reads announcements, apparently.
15:58:35 <adamw> i don't think it's people on test list who get confused
15:58:41 <adamw> but the builds do get spread around via forums and irc to an extent
15:58:49 <adamw> it's usually people picking them up through those channels who get confused
15:59:20 <robatino> in that case, i'd think "TC" would be just as confusing
15:59:39 <adamw> well yeah, that's why the topic includes TC *and* RC naming...
15:59:55 <nirik> Fedora-18-Beta-NOT_A_RELEASE!.iso
16:00:13 <adamw> heh
16:00:25 <adamw> so i guess the lesson here is we still don't have a proposal everyone's in love with
16:00:30 <adamw> but we all at least agree on the goal
16:00:33 <adamw> sound about right?
16:00:56 <tflink> yeah
16:01:18 * nirik nods.
16:01:44 <nirik> I don't care what colour the bike shed is, just that it's a better shade of bright red to let people know what things are what.
16:01:51 <adamw> #agreed we still don't have a proposed scheme that everyone loves, but we agree the goal is to come up with a TC/RC naming scheme as unlikely as possible to confuse people about what each build is
16:01:58 <adamw> BRIGHT BLUE
16:02:08 <adamw> okey dokey
16:02:12 <adamw> #topic open floor
16:02:36 <adamw> anything for open floor? if you wanted to continue the freeze entrance discussion now would be the time
16:03:02 <tflink> does anyone have something to add about that discussion?
16:03:33 <adamw> yellow.
16:03:39 <adamw> that bikeshed should be yellow.
16:03:55 * tflink will be sending out an announcement about a devel version of the blocker tracking app once he fixes a bug or two - hopefully in the next day or so
16:04:29 <adamw> #info tflink will be announcing a new release of the blocker bug tracking app (also known as Skynet) shortly
16:04:40 <adamw> everyone stock up on tin foil hats
16:04:57 <tflink> hey, skynet isn't planned until the next release :-P
16:05:05 <Southern_Gentlem> skynet already exist in the UK
16:05:59 <tflink> sounds like nothing more to add on the freeze entrance stuff ATM
16:06:00 <adamw> sounds like that's all
16:06:02 <adamw> ayup
16:06:05 * adamw sets fuse for 1 minute
16:06:12 <adamw> i ran out of quantum fuses
16:06:46 <tflink> oh, any thoughts on starting the blocker review meetings this week?
16:06:51 * adamw stamps on fuse
16:06:52 <tflink> the list is getting _long_
16:06:57 <adamw> yeah, that might not be a bad idea
16:07:10 <adamw> though we should try to get criteria revisions done or at least proposed ahead of the meeting
16:07:12 <adamw> anyone else?
16:07:16 <adamw> i know we all love blocker meetings
16:07:37 <tflink> they're the highlight of my week - I get lost between releases when we don't have blocker meetings
16:08:12 <tflink> we can skip over bugs that hit criteria under contention
16:08:17 <adamw> i mostly just curl into the foetal position and lie there crying
16:08:19 <adamw> wait, i do that anyway.
16:08:31 <adamw> that's a point.
16:08:38 <tflink> I doubt that we're going to hear much back from the anaconda devs or fesco on what's actually going to make it into beta by wednesday
16:08:56 <tflink> all the more reason to start that conversation now, I suppose
16:09:08 <adamw> sure
16:09:21 <adamw> one good way to start it is to accept a bunch of bugs as blockers so clumens explodes
16:09:25 <adamw> i always like watching that
16:09:41 <tflink> motivation :)
16:10:19 <adamw> well i think we bored everyone else to sleep
16:10:22 <adamw> so, blocker meeting on wednesday it is!
16:10:32 <tflink> and one way to phrase the conversation - "we're starting blocker review this week - if you have issues with the current criteria, now would be a good time to raise them"
16:11:36 * adamw re-lights fuse
16:11:46 * tflink runs away
16:11:53 <Cerlyn> I believe you mean fuze
16:12:43 <adamw> i'm pretty sure i don't?
16:12:53 <adamw> anyhow! boom
16:12:55 <adamw> #endmeeting