15:03:42 <Kevin_Kofler> #startmeeting KDE SIG Meeting – https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2012-09-25
15:03:42 <zodbot> Meeting started Tue Sep 25 15:03:42 2012 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:07 <Kevin_Kofler> #meetingname kde-sig
15:04:07 <zodbot> The meeting name has been set to 'kde-sig'
15:04:20 <Kevin_Kofler> #topic roll call
15:04:32 <Kevin_Kofler> So, who's present?
15:04:42 * dvratil is
15:04:43 <rdieter> yo
15:04:46 * jgrulich is present
15:04:51 <Kevin_Kofler> Present.
15:05:04 <Kevin_Kofler> (Obviously. ;-) )
15:05:09 <than> present
15:06:08 <Kevin_Kofler> ltinkl, jreznik_: Are you here? Or busy with other stuff?
15:06:14 <Kevin_Kofler> #chair dvratil rdieter jgrulich than ltinkl jreznik_
15:06:15 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik_ ltinkl rdieter than
15:06:15 * ltinkl is here
15:06:28 <Kevin_Kofler> jreznik_ said something about another meeting today.
15:06:48 <rdieter> yeah, some partial overlap I believe
15:07:00 <Kevin_Kofler> #info dvratil, rdieter, jgrulich, Kevin_Kofler, than, ltinkl present.
15:07:15 <Kevin_Kofler> #topic agenda
15:07:26 <Kevin_Kofler> The wiki page is depressingly empty…
15:07:45 * jreznik_ is somehow here... just another conflicting meeting today :(
15:07:47 <rdieter> usual, kde-4.9.1 status update
15:08:03 <jreznik> so sorry for not filling up meeting page :)
15:09:17 <Kevin_Kofler> #chair jreznik
15:09:17 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik jreznik_ ltinkl rdieter than
15:09:21 <rdieter> could discuss new nepomuk-core bug, that's getting quite a few dups
15:09:36 <Kevin_Kofler> #info jreznik present, but has another conflicting meeting.
15:09:57 <rdieter> .bug 858271
15:10:02 <zodbot> rdieter: Bug 858271 [abrt] nepomuk-core-4.9.1-1.fc17: isEmpty: Process /usr/bin/nepomukservicestub was killed by signal 11 (SIGSEGV) - https://bugzilla.redhat.com/show_bug.cgi?id=858271
15:10:12 <Kevin_Kofler> We also need to discuss the comps and/or live kickstart cleanups for Beta, now that the Alpha freeze is over.
15:10:20 <Kevin_Kofler> rdieter: You said you were going to work on those.
15:10:44 <rdieter> yup, on my todo list, near the top
15:10:59 <rdieter> but haven't reviewed anything, so nothing new to report yet
15:11:33 <Kevin_Kofler> #action rdieter to work on comps and live kickstart cleanups for Beta (nothing to report yet)
15:11:53 <Kevin_Kofler> But one sub-item we may want to discuss: print-manager by default (s-c-p-kde die die die ;-) ).
15:12:07 <rdieter> (any help with comps/kickstarts would be very welcome)
15:12:26 <than> coud disuss about  konsole issue (starting in Document)
15:12:30 <Kevin_Kofler> #halp any help with comps/kickstarts would be very welcome
15:12:49 <Kevin_Kofler> than: Already fixed in updates-testing, I tested the fix, it works fine.
15:13:02 * Kevin_Kofler is giving +1 karma.
15:13:09 <than> Kevin_Kofler: reverting in kdelibs?
15:13:14 <rdieter> konsole's been fixed, unless we want to consider reverting the commit(s) that was the source of that issue
15:13:28 <rdieter> than: konsole.desktop: +Path=$HOME
15:13:36 <rdieter> workaround
15:13:53 <than> i prefer reverting the fix in kdelibs
15:14:20 <rdieter> than: I would tend to agree (from earlier discussion today in #fedora-kde)
15:14:21 <than> but it's ok with workaround
15:14:48 <rdieter> but let's save that for later in the meeting, when it's on-topic I suppose
15:14:53 <Kevin_Kofler> -1 to reverting kdelibs
15:15:28 <Kevin_Kofler> We can start with that, unless there's more stuff to add to the agenda?
15:16:12 <Kevin_Kofler> #topic default working directory
15:17:16 <Kevin_Kofler> So the issue there was that the default working directory for all apps is now ~/Documents and this also affected Konsole.
15:17:50 <Kevin_Kofler> #link https://bugzilla.redhat.com/show_bug.cgi?id=841471
15:17:51 <rdieter> having the kdelibs workaround to set CWD to Documents made some sense way back when it was originally committed (2005), but these days, much less so.
15:18:16 <Kevin_Kofler> #info Konsole has been fixed in konsole-4.9.1-2.fc17 to explicitly set the startup CWD to $HOME.
15:18:16 <than> rdieter: i agree with you
15:18:20 <rdieter> it's time for legacy apps to be patched/fixed, and kde workarounds dropped
15:18:23 <Kevin_Kofler> #link https://admin.fedoraproject.org/updates/FEDORA-2012-14700
15:18:30 <Kevin_Kofler> IMHO this is the right fix.
15:18:35 <Kevin_Kofler> (The Konsole fix.)
15:19:02 <Kevin_Kofler> The XDG user dirs spec says that all documents should by default go to ~/Documents.
15:19:29 <than> other apps like xterm/gnome-terminal still have this issue
15:19:40 <Kevin_Kofler> And in GUI apps, the CWD has normally only one of 2 effects: 1. nothing, then it doesn't matter what we set it to or 2. the default directory for file dialogs.
15:20:03 <Kevin_Kofler> So IMHO setting the CWD to ~/Documents is exactly what the XDG spec intends us to do.
15:20:12 <Kevin_Kofler> The ONLY apps where this is causing problems are terminal emulators.
15:20:26 <Kevin_Kofler> Those should explicitly request the current directory to be $HOME in their .desktop file as Konsole now does.
15:20:31 <rdieter> there are other side effects, but that is the main one
15:20:35 <Kevin_Kofler> I'm surprised no other desktop has been hit by that.
15:20:57 <than> Kevin_Kofler: does it work for xterm/gnome-minimal with adding PATH=$HOME
15:21:34 <Kevin_Kofler> One strange thing is, why did the behavior for Konsole change with 4.9?
15:21:36 <rdieter> I recall one bug report whose site was hit hard because they symlinked or redirected the Documents dir to some network share, and now simply logging in held that open/locked indefinitely.
15:22:02 <Kevin_Kofler> I can't see anything on 4.8 which would set a different CWD for Konsole, yet it starts up in ~.
15:22:08 <rdieter> Kevin_Kofler: krunner (kdeinit actually) was patched recently to respect this too.
15:22:14 <Kevin_Kofler> But the kdelibs feature to set the CWD to ~/Documents was supposed to be there.
15:22:19 <rdieter> prior it was only apps launched via .desktop files in kickoff, etc...
15:22:21 <Kevin_Kofler> rdieter: I always use the (classic) menu.
15:22:38 <Kevin_Kofler> Right here on 4.8.5 on F16, Konsole starts in ~ and has always done that.
15:22:39 <rdieter> so maybe kdeinit fix affected more than just krunner
15:23:11 <Kevin_Kofler> Changing this in kdeinit means KDE apps will start up in ~/Documents also.
15:23:25 <Kevin_Kofler> Back in 2005, this was intentionally NOT done in kdeinit so that it'd be applied only to legacy apps, not KDE apps.
15:23:41 <Kevin_Kofler> KDE apps don't need this workaround.
15:24:24 <rdieter> i'm not sure then.
15:24:27 <rdieter> https://bugs.kde.org/show_bug.cgi?id=183534#c5
15:24:27 <Kevin_Kofler> Though apart from Konsole, I guess they shouldn't be affected by it, either.
15:25:32 <rdieter> that seems rather old too, doesn't explain any recent behavior change
15:25:35 <Kevin_Kofler> So that change was to KRun::runCommand.
15:25:37 <rdieter> (that commit)
15:25:42 <Kevin_Kofler> It's used everywhere, menu etc.
15:25:46 <than> Kevin_Kofler: konsole (4.8.5) still  starts in Document via krunnuer
15:25:49 <Kevin_Kofler> Not just KRunner.
15:26:22 <Kevin_Kofler> than: Ah OK, so what was actually changed was KRun, which is uses in the menu and NOT in KRunner.
15:26:29 <rdieter> interestingly, my konsole (and yakuake) has always been in $HOME, I never witnessed any use of ~/Documents personally
15:26:35 <Kevin_Kofler> Very "helpful" naming there. ;-(
15:27:08 <rdieter> sorry, I indeed saw krun, but said and assumed krunner
15:27:28 <Kevin_Kofler> KRun::runCommand is actually what the menus use.
15:27:42 <Kevin_Kofler> Not sure what KRunner (Alt+F2) uses.
15:27:58 <Kevin_Kofler> (Too many ways to run something in kdelibs.)
15:28:22 <than> as i know krunner uses other code
15:30:47 <Kevin_Kofler> It uses the kinit.cpp code which was changed back in 2008, I guess.
15:31:01 <Kevin_Kofler> (Not in 2005. The bug report was from 2005, but it took them 3 years to address it.)
15:32:24 <rdieter> anyway, anyone else with an opinion on if we should address this, or what to do about it?
15:32:36 <Kevin_Kofler> IMHO, keep it as is.
15:32:47 <Kevin_Kofler> Or get upstream to change it if you think it's broken.
15:33:34 <Kevin_Kofler> But David Faure seems convinced that it's the right thing to do, he did both the original kinit.cpp change and now also the krun.cpp one.
15:33:34 <than> we can keep it if xterm/gnome-terminal work with adding PATH=HOME in desktop file
15:33:53 <Kevin_Kofler> Why do we care about running non-KDE terminals at all?
15:34:27 <tibbs|w> I do have users who still insist on running xterm.
15:34:29 <Kevin_Kofler> I know neither gnome-terminal upstream nor its Fedora maintainers (they're mostly the same anyway) support running it outside of GNOME in any way.
15:34:48 <Kevin_Kofler> It still misbehaves with KWin (sizing issues) and I don't think it'll get fixed, ever, or at best by accident.
15:35:05 <than> reverting the change in kdelibs causes side effect that other apps like openoffice starts in $Home instead in Document
15:35:09 <rdieter> updating the .desktop files won't hurt anything, I'll patch xterm
15:35:26 * rdieter hopes libreoffice supports xdg_dirs these days
15:36:07 <Kevin_Kofler> You're very optimistic. ;-)
15:38:59 <Kevin_Kofler> So, do we have any agreement? Doesn't look like it… Maybe defer to next week?
15:39:53 <Kevin_Kofler> There are 2 more topics to discuss, can we defer and move on?
15:39:59 <than> let defer to next week
15:40:08 <than> next topic please
15:40:18 <Kevin_Kofler> #info deferred to next week
15:40:49 <Kevin_Kofler> #topic #858271 nepomuk-core crash
15:40:56 <Kevin_Kofler> #link https://bugzilla.redhat.com/show_bug.cgi?id=858271
15:41:01 <Kevin_Kofler> .bug 858271
15:41:03 <zodbot> Kevin_Kofler: Bug 858271 [abrt] nepomuk-core-4.9.1-1.fc17: isEmpty: Process /usr/bin/nepomukservicestub was killed by signal 11 (SIGSEGV) - https://bugzilla.redhat.com/show_bug.cgi?id=858271
15:41:29 <Kevin_Kofler> Yet another Nepomuk crash. :-(
15:42:12 <than> is it regession in 4.9.1?
15:42:23 <rdieter> basically, anyone able/willing to triage this, and report upstream?
15:42:36 <rdieter> than: seems so
15:42:48 <Kevin_Kofler> There's no evidence that it has happened before, at least.
15:44:31 <than> dvratil_:  could you please triage this and report upstream?
15:44:46 <dvratil_> ok
15:44:54 <than> dvratil_: great, thanks!
15:45:34 <Kevin_Kofler> So this is either a KInotify bug or Nepomuk abusing KInotify somehow.
15:46:08 <Kevin_Kofler> There's a QList which is checked for emptiness, but which seems to be entirely invalid (NULL pointer or whatever), even isEmpty crashes.
15:46:32 <Kevin_Kofler> Valgrind may or may not help, depending on what exactly the bug is.
15:46:37 <Kevin_Kofler> It needs to be reported upstream in any case.
15:46:47 <Kevin_Kofler> (unless it already is)
15:46:56 <dvratil_> I'll check it tomorrow, report upstream and try to fix it if possible
15:47:14 <Kevin_Kofler> #action dvratil_ will report the bug upstream and try to fix it
15:47:34 <Kevin_Kofler> OK, thanks! I think we can move on.
15:47:43 <Kevin_Kofler> #topic print-manager by default
15:48:19 <rdieter> i've used print-manager on/off over the past few weeks, only tested as systray applet for print jobs.
15:48:22 <Kevin_Kofler> So my proposal: now that print-manager is in F18, replace system-config-printer-kde with print-manager in F18 and all future releases, effective immediately.
15:48:36 <rdieter> imo, it's still a bit less user-friendly and quirky, but gets the job done
15:48:50 <Kevin_Kofler> Is it more or less quirky than s-c-p-kde? ;-)
15:49:01 <rdieter> it can also be used to configure printers.  I only tested this once when 0.1 version was available, and it failed.
15:49:18 <rdieter> more quirky than s-c-p-kde
15:49:35 <rdieter> err, sorry, there's 2 pieces it can replace, s-c-p-kde and kde-printer-applet
15:49:45 <rdieter> it's more quirky than the latter
15:50:05 <than> +1 for print-manager
15:50:07 <Kevin_Kofler> It's hard to have more bugs than the main s-c-p-kde app.
15:50:10 <Kevin_Kofler> ;-)
15:50:12 <rdieter> and it failed as a replacement for the former, last I tested.  needs more testing obviously
15:50:35 <rdieter> so, ok, +1 to try it out.
15:50:36 <Kevin_Kofler> It's true that the s-c-p-based kde-printer-applet worked surprisingly well.
15:51:48 <Kevin_Kofler> So I think we agreed on print-manager, or does anybody object?
15:52:28 <Kevin_Kofler> #agreed default to print-manager in F18+
15:52:34 <Kevin_Kofler> #topic open discussion
15:52:38 <Kevin_Kofler> Anything else?
15:53:12 <rdieter> f18 kde-4.9.1 update needs karma
15:54:10 <rdieter> or timeout will hit today I think, then I can queue stable tomorrow
15:54:31 <rdieter> f17 kde-4.9.1 update went stable a coupld days ago already
15:55:13 <rdieter> it's why I haven't queue'd konsole-4.9.1-2.fc18 for updates-testing yet
15:55:32 <Kevin_Kofler> I think the timeout will be in 4 hours.
15:55:39 <rdieter> k
15:55:42 <Kevin_Kofler> Uh, 6 hours.
15:55:51 <rdieter> can probably skip karma'ing then
15:56:36 <Kevin_Kofler> It's 15:56 UTC now, the timeout should be at 21:41:17 UTC, unless they already changed it to the 7 day timeout.
15:57:53 <rdieter> fyi, submitted https://admin.fedoraproject.org/updates/xterm-278-3.fc18
15:57:54 <Kevin_Kofler> This Bodhi bureaucracy really sucks, it's not like the update is magically going to become more stable in less than 6 hours.
15:59:38 <Kevin_Kofler> #info rdieter submitted https://admin.fedoraproject.org/updates/xterm-278-3.fc18 for the initial working directory issue.
16:01:24 <Kevin_Kofler> Looks like we're out of time…
16:01:44 <Kevin_Kofler> #endmeeting