15:00:05 <adamw> #startmeeting fedora-qa
15:00:05 <zodbot> Meeting started Mon Oct 15 15:00:05 2012 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:10 <adamw> #meetingname fedora-qa
15:00:10 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:15 <adamw> #topic roll call
15:00:19 <adamw> call me a roll!
15:00:29 * kparal arrives late
15:00:31 * satellit_e listening
15:00:40 * mkrizek is here
15:01:07 * maxamillion is here
15:01:24 * Cerlyn watches
15:01:54 * Southern_Gentlem [icks up a roll and says hello adamw
15:01:56 * Martix_ waives from Eiffel Tower on FUDCon Paris!
15:02:18 * brunowolff is here
15:02:27 * jreznik is here
15:02:52 * nirik is lurking
15:03:22 * tflink is here late, got the time mixed up
15:03:33 * adamw can just see martix from here
15:04:13 * jskladan lurks
15:05:02 <adamw> #topic Previous meeting follow-up
15:05:24 <adamw> #info  adamw to consider revisions to 'kickstart delivery method' criterion - still didn't get enough round tuits, sorr
15:05:27 <adamw> #undo
15:05:27 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2678d350>
15:05:30 <adamw> #info  adamw to consider revisions to 'kickstart delivery method' criterion - still didn't get enough round tuits, sorry
15:05:52 <adamw> #chair tflink brunowolff
15:05:52 <zodbot> Current chairs: adamw brunowolff tflink
15:06:08 <adamw> " tflink to ask other interested parties (anaconda team,fesco...) to look over the beta criteria and see if there's anything they feel should be dialled down"
15:06:13 <adamw> you got somewhere on that, right?
15:07:05 <tflink> yeah, there has been a discussion going on test@
15:08:12 <tflink> but unless there is something I'm forgetting at the moment, there wasn't much in the way of specific requests
15:08:35 <tflink> some interesting insight into how the blocker process is viewed, though
15:08:45 <adamw> right, we got a bit sidetracked there
15:08:51 <brunowolff> Yeah, Redhat should be more like us.
15:09:00 <jreznik> brunowolff: ?
15:09:06 <adamw> brunowolff: shhh, don't make the big pouty giant angry =)
15:09:28 <adamw> jreznik: rhel still uses what is essentially the old Fedora blocker list process: everyone throw crap at the list then arbitrarily take it off when it's time to ship.
15:09:49 <adamw> which turns out to have been the source of most of dcantrell's concerns, when he thought the fedora blocker list still worked like the rhel one...
15:09:54 <brunowolff> Red Hat (made oops on the spelling above) doesn't have Nice to Have and overloads blockers which has some interesting effects.
15:10:03 <jreznik> ah, you mean this
15:10:04 <jreznik> ok
15:10:23 <adamw> so yeah, maybe we could go for a reboot of that discussion with more emphasis on blocker criteria changes
15:10:42 <tflink> probably wouldn't hurt
15:11:28 * pschindl had some problem with connection, but is here now
15:11:55 <adamw> hi pschindl
15:12:22 <adamw> #info tflink to ask other interested parties (anaconda team,fesco...) to look over the beta criteria and see if there's anything they feel should be dialled down - tflink posted a thread that got some responses but it went down a detour, we will try again
15:12:38 <tflink> adamw: action?
15:12:55 <tflink> I suppose I could do it :)
15:12:59 <adamw> #action tflink try again with asking other teams to review the updated release criteria
15:13:10 <adamw> #topic Fedora 18 Beta status check
15:13:33 <adamw> #info F18 Beta TC4 landed Friday
15:13:41 <adamw> or possibly saturday.
15:13:43 <adamw> #undo
15:13:43 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x283815d0>
15:13:48 <adamw> #info F18 Beta TC4 landed Saturday
15:13:58 <adamw> i've been a bit out of the loop since then, any major explosions show up?
15:14:13 <kparal> NM regression
15:14:16 <kparal> a lot of related bugs
15:14:42 <kparal> sometimes NM crashes and then a lot of weird things happen in anaconda
15:15:03 <jreznik> and still no fedup in testable state, asking wwoods on #anaconda... latest status I have is from Friday...
15:15:12 <jreznik> don't expect change there
15:15:43 <tflink> jreznik: are we still planning to enter freeze tomorrow?
15:16:07 <adamw> #info TC4 comes with a regression in NetworkManager
15:16:49 <kparal> adamw: bug 866434
15:16:53 <jreznik> tflink: that's the question..
15:16:54 <adamw> #undo
15:16:54 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x17625490>
15:17:00 <jreznik> I don't see any objections in the ticket
15:17:07 <adamw> #info TC4 comes with a regression in NetworkManager: http://bugzilla.redhat.com/show_bug.cgi?id=866434
15:17:17 <jreznik> and by default, we freeze
15:17:35 <adamw> jreznik: well, we'd advise against it still if the upgrade tool still isn't done.
15:17:55 <tflink> we should probably update the ticket, then
15:18:07 <nirik> any news on fedup? ;(
15:18:26 * nirik is happy to help package or the like if it will help.
15:18:28 <tflink> has it even been submitted for review yet?
15:18:35 * nirik doesn't think so, looks.
15:18:40 <jreznik> no, it wasn't
15:19:08 <adamw> #info new upgrade tool is still not testable so far as we know
15:19:58 <jreznik> from Friday - The current status is: ALMOST WORKING.
15:20:06 <jreznik> but packaging on todo
15:20:25 <jreznik> wwoods: are you around?
15:21:10 <adamw> propose #agreed as new upgrade tool is still not complete, QA does not recommend freezing for Beta at this time
15:22:01 <tflink> ack
15:22:07 <kparal> ack
15:22:09 <mkrizek> ack
15:22:10 <pschindl> ack
15:22:36 <adamw> #agreed as new upgrade tool is still not complete, QA does not recommend freezing for Beta at this time
15:22:44 <adamw> #action adamw to update fesco freeze ticket
15:22:53 <adamw> shall we do some blocker review tflink? looks like there's a few to get through
15:23:05 <adamw> #topic Fedora 18 Beta mini blocker review
15:23:43 <dan408-> sorry im late, but here
15:24:03 <adamw> hi dan
15:24:13 <adamw> tflink: want to run this bit?
15:24:19 <dan408-> hi adamw
15:24:19 <tflink> adamw: ok, give me a sec to get ready
15:24:25 <adamw> SEC DENIED
15:24:29 <dan408-> heh
15:24:32 <dan408-> happy monday
15:25:12 <dan408-> adamw: i made a change to comps for mate-desktop so anytime you guys wanna do a new compose lemme know :)
15:26:42 <dan408-> pretty quiet for a meeting
15:27:02 <adamw> we're waiting on tflink to start up the blocker review bit
15:27:04 <tflink> ok, the sorting is going to be off
15:27:32 <dan408-> adamw: did you reproduce the hostname issue? and did anyone report the mouse/cursor issue for firstboot?
15:27:32 <tflink> since that stuff takes a bit until I get it into the main app
15:28:24 <tflink> do we want to go through all of them today or just the ones that changed?
15:28:39 <adamw> just go with the new ones / ones that changed
15:28:42 <dan408-> ^
15:28:47 <adamw> ones where we're obviously gonna have nothing, skip 'em
15:28:51 <adamw> and proposed blockers only
15:29:38 <jreznik> +1
15:30:04 <tflink> well, lets just do the 6 that have been proposed recently
15:30:19 <tflink> #topic (864981) BootLoaderError: bootloader install failed
15:30:19 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=864981
15:30:19 <tflink> #info Proposed Blocker NEW
15:30:41 <Viking-Ice> should blocker bug meeting *always* be held on the QA channel and started after the official QA meeting has ended so we do not wind up hogging the meeting channel?
15:30:51 <dan408-> hi Viking-Ice
15:31:07 <jreznik> Viking-Ice: it makes sense
15:31:22 * kparal thinks we should not make meeting on #fedora-qa at all, always use a different channel
15:31:24 <adamw> we only have 6
15:31:32 <dan408-> let's go
15:31:37 <adamw> let's just do these
15:31:46 <adamw> we have 1.5hrs till anyone else needs the room, i believe.
15:32:04 <jreznik> yep, fesco moved to wed
15:32:12 <dan408-> wed same time jreznik?
15:32:46 <tflink> I'm a little fuzzy on the partitioning setup here
15:32:50 <adamw> this is a pretty wonky error
15:33:02 <dan408-> i can still crash the partitioning
15:33:22 <adamw> it sounds like it's maybe a hybrid MBR
15:33:38 <tflink> it's autopart, sure but something sounds strange in the VM setup
15:33:41 <kparal> unfortunately we don't have Jan here
15:33:51 <dan408-> well if i do reclaim space without clicking the check box then hit continue it crashes
15:34:03 <Viking-Ice> yeah this is weird
15:34:40 <tflink> do we have enough info totake a vote?
15:34:44 <adamw> dan408-: that's not on topic.
15:34:59 <kparal> let's punt and ask Jan to reproduce and provide more data about existing layout on disk
15:35:25 <adamw> kparal: the key question is the disklabel here i believe. might be worth asking clumens/pjones what's needed.
15:35:28 <adamw> but yeah, sounds like a punt.
15:35:47 <kparal> it seems clumens might have an idea what's wrong in there
15:35:50 * jreznik have not seen everything, does not know where to look :)
15:36:06 <jreznik> kparal: yep, seems like clumens has an idea
15:36:16 <tflink> proposed #agreed 864981 - This seems severe but it would be good to have some more information - ask reporter to reproduce and provide more details on VM setup
15:36:29 <Viking-Ice> ack
15:36:36 <adamw> ack
15:36:39 <kparal> (ask reporter and clumens)
15:36:42 <kparal> ack
15:36:46 <jskladan> ack
15:36:53 * jreznik is asking clumens for more info in #anaconda...
15:36:55 <tflink> #agreed 864981 - This seems severe but it would be good to have some more information - ask reporter to reproduce and provide more details on VM setup
15:37:07 <tflink> #topic (866115) ValueError: ('invalid size specification', '0 b')
15:37:07 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=866115
15:37:07 <tflink> #info Proposed Blocker NEW
15:37:15 <jreznik> well, "i'm just amazed by that error message"
15:37:54 <Viking-Ice> btw you will need to use either grub-install --force --boot-directory=/mnt/boot /dev/sda1 or grub-install --boot-directory=/mnt/boot /dev/sda so this might have been triggered by wrong or unavailable path
15:38:04 <Viking-Ice> in anaconda
15:38:25 <kparal> Viking-Ice: maybe you can add that information to the bugzilla? thanks
15:38:31 <adamw> several people hitting this, looks pretty blockery.
15:38:38 <tflink> yeah, sounds like
15:39:01 <adamw> comment #17 is a pretty straightforward case that definitely ought to work
15:39:08 <adamw> so +1 blocker, alpha part criterion
15:39:33 <tflink> proposed #agreed 866115 - AcceptedBlocker - Violates the following F18 alpha release criterion: "The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data"
15:39:36 <Viking-Ice> ack
15:39:40 <kparal> ack
15:39:42 <brunowolff> ack
15:39:45 <jreznik> ack
15:39:53 <tflink> #agreed 866115 - AcceptedBlocker - Violates the following F18 alpha release criterion: "The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data"
15:40:06 <tflink> #topic (866486) Apper: cannot perform system update
15:40:06 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=866486
15:40:06 <tflink> #info Proposed Blocker NEW
15:40:33 <adamw> no graphical updates in kde
15:40:41 <jreznik> rdieter: any news on this?
15:40:46 <adamw> that sounds blockery.
15:40:54 <tflink> it would be nice to have some logs here, though
15:41:30 <mkrizek> rdieter mentioned that he's seen that and 'killall packagekitd' helped, not in my case though
15:41:32 <jreznik> seems like apper issue, pkcon updates works
15:41:38 <kparal> I guess this could be influenced by recent PK update. it automatically cancels background operations when some foreground operations are active
15:41:56 <kparal> so that you can use gpk-application when system tries to download system updates in the background
15:42:16 <tflink> I'm going to have to go with -1 blocker, though
15:42:17 * kparal will include relevant info into the bugzilla
15:42:28 <tflink> the change to the criteria never made it onto the list
15:42:42 <tflink> and by list I mean the list in the wiki
15:42:47 <Viking-Ice> -1 blocker as well
15:43:01 <adamw> er
15:43:03 <adamw> what change?
15:43:09 * kparal is confused as well
15:43:14 <adamw> the criteria require graphical updating to work at *alpha* and have for years
15:43:30 <adamw> viking and i were planning to _loosen_ that  requirement to beta, but that's pretty irrelevant :)
15:43:49 <tflink> alpha - graphical or text method must work @ alpha
15:44:01 <adamw> yes. right now both must work at alpha.
15:44:07 <tflink> beta - graphical AND text must work (might have been final)
15:44:20 * adamw waits for tflink to catch up
15:44:20 <tflink> ok, I thought that part had ghone through
15:44:31 <kparal> actually Alpha is still AND
15:44:36 <kparal> just looking at it
15:44:42 <Viking-Ice> we never changed it?
15:44:51 <adamw> it doesn't matter whether we changed it or not.
15:44:51 <Viking-Ice> or decided to change it after F18
15:44:58 <adamw> this would be a beta blocker under the old version and the new version.
15:45:00 <jreznik> in alpha we said graphical is not needed, I don't remember any mention of beta thus...
15:45:06 <mkrizek> but it's beta we're talking about
15:45:09 <tflink> proposed #agreed 866486 - VIolates the following F18 alpha release criterion: "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops"
15:45:11 <adamw> the old version requires graphical updating to work at alpha. the new version requires graphical updating to work at beta. this is beta.
15:45:16 <Viking-Ice> ack
15:45:17 <adamw> ack
15:45:19 <jreznik> ack
15:45:20 <kparal> yes we loosened this in Alpha, but never updated the wiki
15:45:25 <kparal> ack
15:45:26 <mkrizek> ack
15:45:37 <adamw> kparal: i need to check back on that thread, yeah
15:45:42 <tflink> #agreed 866486 - Violates the following F18 alpha release criterion: "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops"
15:45:57 <tflink> #topic (866434) DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.0 was not provided by any .service files
15:46:00 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=866434
15:46:03 <tflink> #info Proposed Blocker NEW
15:46:14 <kparal> this is the NM regression
15:46:26 <kparal> anaconda blows in all sorts of different places because of that
15:46:36 <kparal> (at least that's what anaconda devs suppose)
15:47:34 <tflink> is anyone else seeing  this?
15:48:07 <adamw> yeah, it sounds like other people were getting farther, or else they wouldn't hit that 0b size bug...
15:48:12 <kparal> today I saw it like 20 times
15:48:30 <kparal> it's racy, so sometimes you see it, sometimes you don't
15:48:33 <adamw> oh there's several bugs duped off as this one
15:48:46 <kparal> all of that are mine reports
15:48:56 <kparal> that's what I mean by blowing up in different places
15:48:56 <adamw> all from kparal
15:48:57 <adamw> heh
15:49:08 <adamw> is this in a VM?
15:49:11 <kparal> yep
15:49:19 <kparal> tomorrow I can try bare metal
15:50:17 <tflink> thoughts on blockery-ness?
15:50:40 <adamw> it'd help if others could reproduce
15:50:44 <adamw> punt till wed
15:50:51 <adamw> we should have a better idea by then
15:51:00 <jreznik> punt
15:51:27 <tflink> proposed #agreed 866434 - It would be good to have more data on the number of people affected by this an more confirmation of the cause - will revisit when more information is available
15:51:33 <jreznik> ack
15:51:38 <jskladan> ack
15:51:39 <kparal> ack
15:51:40 <Viking-Ice> ack
15:51:43 <pschindl> ack
15:51:46 <mkrizek> ack
15:51:49 <tflink> #agreed 866434 - It would be good to have more data on the number of people affected by this an more confirmation of the cause - will revisit when more information is available
15:51:56 <tflink> #topic (866441) TypeError: 'NoneType' object is not iterable
15:51:57 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=866441
15:51:57 <tflink> #info Proposed Blocker NEW
15:52:32 <tflink> it sounds like we coulduse more infomration on this one
15:53:23 <kparal> there is some problem that might disable the integrated exception reporter, which would be a bad thing
15:53:33 <kparal> but we really need anaconda devs feedback
15:53:42 <jreznik> but more nth like for me
15:54:02 <kparal> let's punt and I'll ask Vratislav tomorrow for more details
15:54:03 <adamw> could this be the same NM bug?
15:54:08 <kparal> no idea
15:54:09 <adamw> just happening at a different time?
15:54:20 <kparal> might be, I never saw it before
15:54:41 <kparal> but I have seen a lots of empty anaconda-tb-* files today and that makes me nervous
15:54:45 <tflink> proposed #agreed 866441 - More information is needed on the cause of this before deciding on blocker status - will wevisit later
15:54:48 <kparal> something is really broken in there
15:54:49 <Viking-Ice> ack
15:54:57 <adamw> ack
15:54:58 <kparal> ack
15:55:00 <jskladan> ack
15:55:08 <Viking-Ice> hmm feels like a non blocker to me though
15:55:12 <tflink> #agreed 866441 - More information is needed on the cause of this before deciding on blocker status - will wevisit later
15:55:24 <tflink> #undo
15:55:24 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x1bd964d0>
15:55:37 <tflink> #agreed 866441 - More information is needed on the cause of this before deciding on blocker status - will revisit later
15:55:51 * tflink seems to be channeling elmer fudd ATM
15:56:04 <tflink> #topic (866519) BIOS RAID is not shown on harddrive screen
15:56:04 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=866519
15:56:04 <tflink> #info Proposed Blocker NEW
15:56:55 <Viking-Ice> is supported ?
15:57:19 <adamw> yeah, we have an explicit criterion for RAID at beta, inc BIOS RAID
15:57:25 <tflink> in general, yes
15:58:29 <adamw> right, we usually set the bar quite high though
15:59:14 <adamw> i.e. an error in some particular config isn't enough, we need to be sure it's like all BIOS RAID configs or at least all Intel BIOS RAID configs or something
15:59:14 <Viking-Ice> I was more wondering if it was supposed to be shown on the harddrive screen
15:59:18 <adamw> so it'd be nice to have another check on this, or if the anaconda team checks and it's definitely a generic issue
15:59:28 <adamw> Viking-Ice: yes, a bios raid array ought to show up as a single disk on the diskssel screen
15:59:41 <tflink> it would be nice to know what HW was used, too
15:59:49 <adamw> yeah
15:59:51 <tflink> I see RAID6 but haven't found the HW yet
15:59:52 <Viking-Ice> punt for more data?
15:59:52 <adamw> and it'd be nice to know what shows on custom partitioning
16:00:25 <adamw> i see 'ID_FS_TYPE': 'isw_raid_member', which I think looks like intel bios raid.
16:00:52 <adamw> punt sounds good, yeah
16:01:01 <adamw> this looks like intel bios raid which means i ought to be able to test and see if i can reproduce
16:01:54 <tflink> proposed #agreed 866519 - We need more information on the affected HW and how many people are affected before making a decision on blokcker status
16:02:01 <adamw> ack
16:02:47 <Viking-Ice> ack
16:03:04 <jskladan> ack
16:04:23 <tflink> #agreed 866519 - We need more information on the affected HW and how many people are affected before making a decision on blokcker status
16:04:23 <tflink> OK, that's all of the newly proposed blockers
16:04:23 <tflink> since we're over time, I propose we move on
16:04:23 <Viking-Ice> finish that proposed nth?
16:04:38 <tflink> Viking-Ice: that shouldn't be on the list, actually
16:04:47 <tflink> I need to figure out why it's showing up
16:05:05 <adamw> that's all teh blockers?
16:05:50 <tflink> all of the recently changed ones, yes
16:05:50 <adamw> yay.
16:06:06 <adamw> thanks tflink
16:06:06 <adamw> #topic open floor
16:06:06 * kparal recently changed 847831
16:06:37 * adamw taps on zodbot
16:07:03 <adamw> so, anyone have anything for open floor?
16:07:03 <Viking-Ice> nothing from me
16:07:10 <adamw> i do have a heads-up: i'm having a change of heart on the partitioning criteria and wondering if we're getting too ambitious at beta
16:07:11 <jsmith> nothing from me
16:07:18 <adamw> but i'll work up a more detailed proposal for the list
16:07:25 * tflink is planning to release the new blocker tracking app soon
16:07:33 <jsmith> adamw: Looking forward to reading it
16:08:07 <tflink> not sure when the downtime will work best, though
16:08:07 <Viking-Ice> adamw, define ambitious
16:08:07 <adamw> the basic idea is 'require much less from custom part at beta, focus on the non-custom path as we did for f17 and earlier'
16:08:08 <adamw> Viking-Ice: as in, requiring too much to work at beta
16:08:53 <Viking-Ice> yeah well if those changes dont take effect until next development cycle
16:09:22 <Viking-Ice> but I'm of the opinion that by beta custom partitioning ought to work
16:09:22 <adamw> well we can kick it further on the list
16:09:39 <adamw> that was just a sneak preview =)
16:10:02 <Viking-Ice> but still the old one is valid until next development cycle
16:13:06 <Viking-Ice> since this is not lack change in anaconda's behavior
16:13:06 <adamw> so if we don't have anything else...
16:13:06 * adamw sets fuse for pi minutes
16:13:06 * kparal looks at his stopwatch
16:13:07 <adamw> it doesn't have a pi function? well pfah
16:13:25 <adamw> thanks for coming, folks
16:13:35 <adamw> #endmeeting