15:11:52 <Kevin_Kofler> #startmeeting KDE SIG Meeting – https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2012-10-23
15:11:52 <zodbot> Meeting started Tue Oct 23 15:11:52 2012 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:12:05 <Kevin_Kofler> #meetingname kde-sig
15:12:05 <zodbot> The meeting name has been set to 'kde-sig'
15:12:10 <Kevin_Kofler> #topic role call
15:12:15 <Kevin_Kofler> Who's present?
15:12:18 * ltinkl is present
15:12:20 <dvratil> present!
15:12:21 * Kevin_Kofler is obviously present. :-)
15:12:29 * jgrulich is present
15:13:16 <Kevin_Kofler> than: Ping?
15:13:23 <than> present
15:13:30 <Kevin_Kofler> #chair ltinkl dvratil jgrulich than
15:13:30 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich ltinkl than
15:13:43 * rnovacek is here
15:13:44 <Kevin_Kofler> #info Kevin_Kofler, ltinkl, dvratil, jgrulich, than present.
15:13:54 <Kevin_Kofler> #chair rnovacek
15:13:54 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich ltinkl rnovacek than
15:13:59 <Kevin_Kofler> #info rnovacek also present.
15:14:33 <Kevin_Kofler> #topic agenda
15:14:47 <Kevin_Kofler> https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2012-10-23 is as empty as it could be.
15:14:57 <Kevin_Kofler> Not even an empty page template.
15:15:36 <Kevin_Kofler> Suggested agenda items from #fedora-kde:
15:15:43 <Kevin_Kofler> <rdieter> one thing to discuss, consider submitting qt-4.8.3 to f16/f17 updates-testing
15:15:51 <Kevin_Kofler> <than> https://bugzilla.redhat.com/show_bug.cgi?id=868530 should be added to agenda
15:16:00 <Kevin_Kofler> <than> Kevin_Kofler: KDE block bugs status
15:16:05 <than> Kevin_Kofler: added to agenda
15:17:54 <Kevin_Kofler> I guess that'll be the agenda. :-)
15:18:04 <Kevin_Kofler> #topic submitting qt-4.8.3 to f16/f17 updates-testing
15:18:19 <Kevin_Kofler> +1
15:18:31 <Kevin_Kofler> Bugfix release, I see no reason why it wouldn't go out ASAP.
15:18:47 <Kevin_Kofler> rdieter said on #fedora-kde that he's tentatively in favor, too.
15:19:24 <Kevin_Kofler> Plus, our 4.8.3 builds now finally have a fix for the longstanding issue https://bugzilla.redhat.com/show_bug.cgi?id=694385
15:19:43 <Kevin_Kofler> which made a mess of the file system and/or caused SELinux alerts, depending on how you had SELinux set up.
15:19:58 <than> +1 for qt-4.8.3 in update-testing
15:20:07 <Kevin_Kofler> (disabled = mess on the file system, enforcing = AVCs, permissive = both)
15:20:39 <Kevin_Kofler> Any objections? Or can I file this as agreed?
15:22:06 <than> Kevin_Kofler:  +1
15:22:21 <Kevin_Kofler> ltinkl? dvratil? jgrulich? rnovacek?
15:22:28 <ltinkl> +1
15:22:29 <rnovacek> +1
15:22:29 <jgrulich> +1
15:22:32 <Kevin_Kofler> :-)
15:22:45 <Kevin_Kofler> #agreed We will push Qt 4.8.3 to updates-testing ASAP.
15:22:46 <ltinkl> silence means no objection :)
15:23:14 <Kevin_Kofler> #topic https://bugzilla.redhat.com/show_bug.cgi?id=868530
15:23:22 <Kevin_Kofler> .bug 868530
15:23:25 <zodbot> Kevin_Kofler: Bug 868530 Delay and cpu spike in file open/save dialogs - https://bugzilla.redhat.com/show_bug.cgi?id=868530
15:23:55 <than> can someone reproduce this issue?
15:24:59 <ltinkl> so far I couldn't...
15:25:24 <ltinkl> the weird thing is that even the reporter says it can only be reproduced in bare metal, not in VM!
15:25:54 <than> i can reproduce this issue too
15:26:19 <than> it's extrem slow to open a file dialog
15:26:48 <than> or resize the window
15:27:09 <than> it doesn't happen in udisks
15:28:12 <ltinkl> perhaps we should ask for better/wider testing on fedora-kde ML
15:28:14 <nucleo> and delay in starting dolphin?
15:29:09 <Kevin_Kofler> Are we even sure it is related to udisks2 stuff and not to some stock upstream issue?
15:29:37 <than> nucleo: delay in opening kde/qt's filedialog
15:29:48 <than> every kde/qt is effected
15:30:17 <ltinkl> Kevin_Kofler: yup, udisksd hogs the CPU for several seconds
15:30:36 <nucleo> no problem in F17, and looks like udisks2 is the main difference between F18 and F17
15:30:39 <ltinkl> Kevin_Kofler: but only on F18 and only for some people and only in bare metal :)
15:31:35 <Kevin_Kofler> Everything points to a bug inside udisks2 then.
15:31:54 <Kevin_Kofler> Some problem handling some specific hardware.
15:31:58 <ltinkl> not so sure
15:32:06 <ltinkl> no Gnome/Gtk app exhibits this
15:32:16 <Kevin_Kofler> The VM obviously has different "hard"ware.
15:32:20 <ltinkl> and they must be calling the same code
15:32:48 <ltinkl> another weird point is that it never happens on F17
15:33:08 <ltinkl> there could be something else too, like different dbus, gcc optimization, whatever
15:33:14 <than> yes, this issue doesn't effected in gnome
15:33:21 <Kevin_Kofler> F17 doesn't use solid-udisks2, unless you rebuilt kdelibs with it enabled.
15:34:07 <ltinkl> Kevin_Kofler: I'm using exactly that setup
15:34:25 <ltinkl> oh and I forgot systemd, F18 has a completely different version
15:34:44 <than> ltinkl:  systemd and udev
15:34:50 <Kevin_Kofler> ltinkl: Yeah, but you weren't able to reproduce it on F18 either, were you?
15:35:03 <Kevin_Kofler> So it might just be that your hardware isn't affected.
15:36:01 <ltinkl> yup
15:36:31 <ltinkl> udev is different too, indeed
15:36:57 <ltinkl> which udisks2 uses internally
15:37:37 <than> ltinkl: do you have other hardware to test?
15:37:40 <nucleo> I have this problem on PC with samsung disks and on notebook with seagate disk
15:37:58 <Kevin_Kofler> We can't really say whether F17 is affected until we have more people trying with a kdelibs with solid-udisks2 enabled on F17.
15:37:59 <ltinkl> nucleo: so on 2 different PCs?
15:38:09 <nucleo> yes
15:38:09 <Kevin_Kofler> Especially those who can reproduce the issue on F18.
15:38:40 <ltinkl> we could put some test kdelibs builds out with the udisks2 backend enabled for ppl to try out
15:38:55 <nucleo> on PC I have installed F18 but on notebook I tested F18 live image
15:39:04 <than> ltinkl: it's not easy for f17
15:39:13 <ltinkl> than: why?
15:39:17 <Kevin_Kofler> That said, I don't know whether that is really so valuable.
15:39:29 <than> ltinkl: you have to update udev/systemd
15:39:30 <ltinkl> yup, I'd concentrate on F18
15:39:36 <ltinkl> than: ah right
15:39:37 <than> it could cause problem
15:39:53 <Kevin_Kofler> than: Uh, F17 already ships udisks2, doesn't it?
15:40:00 <than> Kevin_Kofler: yes
15:40:01 <Kevin_Kofler> We just didn't enable solid-udisks2 there.
15:40:11 <Kevin_Kofler> It's just a matter of toggling the flag in kdelibs.
15:40:13 <than> but it's not used in kde
15:40:42 <than> Kevin_Kofler:  udisks2-2.0.0 requries latest udev in f18
15:40:57 <than> Kevin_Kofler: and systemd
15:41:03 <Kevin_Kofler> And solid-udisks2 requires 2.0.0?
15:41:10 <ltinkl> than: there is older udisks2
15:41:14 <ltinkl> it should work fine
15:41:43 <Kevin_Kofler> In any case, I think we need more data on this before we can do anything.
15:41:49 <than> we can use the old udisks2 to avoid the updaze
15:41:50 <Kevin_Kofler> So should we move on?
15:42:57 <than> please move on
15:43:18 <ltinkl> yup
15:43:41 <Kevin_Kofler> #halp We need more data on #868530.
15:43:58 <Kevin_Kofler> #topic F18 KDE blocker bugs
15:44:06 <Kevin_Kofler> So, what's the status there?
15:44:53 <than> do we have any F18 blocker?
15:48:45 <Kevin_Kofler> Not really. https://bugzilla.redhat.com/show_bug.cgi?id=F18Blocker-KDE
15:49:16 <Kevin_Kofler> Only https://bugzilla.redhat.com/show_bug.cgi?id=829881 is "open" (in ON_QA actually) and that's the Polkit rules issue, not really a blocker. ;-)
15:49:27 <than> it looks clean -)
15:49:28 <Kevin_Kofler> It needs karma or a few more days.
15:49:33 <than> move on please
15:49:54 <Kevin_Kofler> https://bugzilla.redhat.com/show_bug.cgi?id=F18Target-KDE has some stuff on it.
15:50:23 <Kevin_Kofler> than: Well, we're out of topics. :-)
15:50:34 <Kevin_Kofler> #info No remaining blockers.
15:50:39 <Kevin_Kofler> #topic open discussion
15:51:33 <dvratil_> just FYI, I started packaging some Nepomuk apps yesterday
15:52:06 <Kevin_Kofler> #info dvratil started packaging some Nepomuk apps yesterday.
15:52:28 <ltinkl> dvratil_: like for example? :)
15:52:50 <dvratil_> nepomuk-music-kio-slave, nepomuktvnamer, nepomushell (NepSaK)
15:52:55 <than> dvratil_: which apps, do you have links ?
15:53:07 <Kevin_Kofler> #info The qwt5 compatibility package finally passed review, so rdieter updated qwt to Qwt 6 and imported qwt5 in Rawhide and F18 updates-testing.
15:53:19 <dvratil_> than, http://trueg.wordpress.com/2012/02/11/a-fun-release-nepomuk-tv-namer-0-2/
15:53:38 <dvratil_> http://trueg.wordpress.com/2012/02/10/just-for-the-fun-of-it-browsing-music-with-nepomuk/
15:54:10 <than> dvratil_: nice :)
15:54:27 <dvratil_> I use the nepomuktvnamer a lot, it's awesome to just type "Castle S05E13" to krunner, hit enter and it starts playing the right ep
15:56:24 <Kevin_Kofler> Looks like the nameless Big Brother now has a first name: Nepomuk. ^^
15:56:33 <dvratil_> :)
15:56:59 <Kevin_Kofler> I'm really worried about what's going to happen when the "social" part of all this is going to become real.
15:57:14 <Kevin_Kofler> Facebook will look harmless in comparison.
15:59:28 <Kevin_Kofler> I've also looked into what would be needed to package Simon, now that there's a backend based on Free Software (PocketSphinx).
16:00:11 <Kevin_Kofler> So, Qwt 6 is required, that is now in. QAccessibilityClient is optional, but needed for the AT-SPI plugin.
16:00:21 <Kevin_Kofler> Everything else seems to be already in Fedora.
16:01:08 <Kevin_Kofler> Upstream is planning a 0.4.0 release soon, and betas even sooner.
16:03:10 <nucleo> libkdcraw which will be in KDE 4.10 needs libjpeg8 https://bugzilla.redhat.com/show_bug.cgi?id=866062 but this feature for F19  https://fedoraproject.org/wiki/Features/libjpeg-turbo-jpeg8-ABI so for updating KDE to 4.10 in < F19 some fix needed
16:03:31 <Kevin_Kofler> Also if we want to update Digikam, which needs the new libkdcraw.
16:03:34 <Kevin_Kofler> Yeah, what a mess!
16:04:26 <Kevin_Kofler> #action Kevin_Kofler to look into the libkdcraw libjpeg issue, trying to coax full functionality out of it with the libjpeg 6.2 API/ABI to the possible extent.
16:04:48 <Kevin_Kofler> I hope F19 will really get the new API/ABI!
16:05:06 <Kevin_Kofler> I'll do what I can for F18.
16:05:18 <Kevin_Kofler> (and F17 if wanted)
16:05:31 <Kevin_Kofler> (I guess we won't be doing that Digikam update on F16.)
16:06:24 <Kevin_Kofler> I guess that's all for today, we're already 6 minutes over time. :-) If you have anything else to discuss, use #fedora-kde or the mailing list, as usual. Thank you for attending and see you next week!
16:06:29 <Kevin_Kofler> #endmeeting