15:14:38 <rdieter> #startmeeting kde-sig
15:14:39 <zodbot> Meeting started Tue Nov  6 15:14:38 2012 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:14:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:14:41 <rdieter> #meetingname kde-sig
15:14:41 <zodbot> The meeting name has been set to 'kde-sig'
15:14:49 <rdieter> #topic roll call
15:14:59 <rdieter> howdy all, who's around today
15:15:03 * jgrulich is present
15:15:08 * ltinkl is here
15:15:16 <than> present
15:15:18 <rdieter> jreznik, Kevin_Kofler: kde*foo: ping
15:15:34 * jreznik is here
15:15:35 <Kevin_Kofler> Present.
15:15:36 * rnovacek is here
15:15:40 <rdieter> #chair jgrulich ltinkl than jreznik Kevin_Kofler  rnovacek
15:15:40 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik ltinkl rdieter rnovacek than
15:15:49 <rdieter> #info rdieter jgrulich ltinkl than jreznik Kevin_Kofler rnovacek present
15:16:13 <rdieter> #topic agenda
15:16:13 <dvratil> late, but present!
15:16:23 <rdieter> #info dvratil present too :)
15:16:30 <rdieter> what to discuss today?
15:16:31 <jreznik> rdieter was faster :)
15:16:33 <Kevin_Kofler> #chair dvratil
15:16:33 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik ltinkl rdieter rnovacek than
15:16:58 <jreznik> f18 test matrices
15:17:35 <rdieter> from me:  qyoto/cmake-2.8.10; PyQt/PyKDE(3) FTBFS... time to eol?  find new maintainer(s)?
15:17:47 * rdieter gets more coffee
15:18:12 <Kevin_Kofler> Is it still the same old failure or do we have a new one?
15:18:41 <Kevin_Kofler> I think I already had a look, but I can have another one.
15:19:02 <Kevin_Kofler> (at the Py*3 stuff)
15:19:46 <rdieter> ok, let's get started
15:19:58 <rdieter> #topic f18 test matrices
15:20:02 <rdieter> jreznik: ?
15:20:54 <Kevin_Kofler> Oh, another topic (late, sorry): print-manager status.
15:21:30 <jreznik> we are getting closer to beta release - so please help with filling kde test matrices
15:21:32 * rdieter notes
15:21:35 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_18_Beta_TC7_Desktop
15:21:54 <jreznik> hope to have rc soon and not to block on unfilled matrices...
15:22:37 <rdieter> cool, i'd encourage everyone to help test and provide results
15:22:45 <jreznik> that's all from me, I'll ping you once rc is ready
15:22:55 <rdieter> k, that was going to be my next question. :)
15:22:59 <jreznik> from the first look, we are in a good shape
15:23:10 <jreznik> (as for desktop)
15:23:27 <rdieter> moving on...
15:23:37 <rdieter> #topic qyoto/cmake-2.8.10
15:24:05 <rdieter> fyi, there's a FTBFS against cmake-2.8.10 currently, seems to be some sort of behavior change, thankfully still only affects rawhide, so it's not urgent
15:24:17 <rdieter> upstream is aware, and a thread is going on kde-packager/kde-buidsystem lists
15:24:38 <rdieter> Kevin_Kofler suggested a fix/workaround in our downstream bug, i hadn't had a chance to try it yet
15:25:06 <rdieter> .bug 872829
15:25:08 <zodbot> rdieter: Bug 872829 qyoto FTBFS with cmake-2.8.10 - https://bugzilla.redhat.com/show_bug.cgi?id=872829
15:25:33 <Kevin_Kofler> I think my change should make it work, but of course if CMake upstream thinks the change is a mistake, then we better backport the upstream fix which reverts it.
15:25:34 <rdieter> i'll try to look at it before the end of the week, but any help before then would be appreciated.
15:25:52 <Kevin_Kofler> Because the version comparison in my patch assumes the patch is here to stay.
15:26:06 <rdieter> ok
15:26:11 <Kevin_Kofler> Otherwise you want to check for exactly 2.8.10 rather than ≥ 2.8.10 as now.
15:26:31 <rdieter> sure, hopefully upstream will sort it out quickly
15:26:39 <Kevin_Kofler> (but even that is bad if we're going to get a 2.8.10 build with the change reverted)
15:26:59 <Kevin_Kofler> (so in that case applying my patch probably does more harm than good)
15:27:19 <rdieter> sure, any fixes/changes in cmake will require corresponding changes in qyoto
15:28:02 <rdieter> i guess that's about it, moving on...
15:28:30 <rdieter> #topic PyQt/PyKDE(3) FTBFS
15:28:34 <rdieter> .bug 863104
15:28:37 <zodbot> rdieter: Bug 863104 PyQt FTBFS against sip-4.14+ - https://bugzilla.redhat.com/show_bug.cgi?id=863104
15:29:06 <rdieter> PyQt/PyKDE(3) seems to be break about every other sip release these days, may be worth considering eol'ing
15:29:15 <than> rdieter: +1
15:29:28 <Kevin_Kofler> Question of the day: Does anything in Fedora still use them?
15:29:34 <rdieter> or find new maintainers... honestly i've lost interest a long time ago
15:29:47 <rdieter> Kevin_Kofler: a few items
15:29:51 * rdieter repoqueries
15:30:00 <Kevin_Kofler> I see you already did in the bug.
15:30:12 <rdieter> ScientificPython-qt, kodos, kphotobymail, pipviewer, smart-gui
15:30:41 <Kevin_Kofler> I think we should at least try to fix the FTBFS before killing those packages.
15:30:42 <jreznik> ask the maintainers if they are still working on these packages?
15:30:53 <Kevin_Kofler> I'll try to fix the FTBFS.
15:31:03 <than> Kevin_Kofler: thanks
15:31:05 <rdieter> intersting, luma showed up in  the list before, but it doesn't for me anymore
15:31:21 <rdieter> #actino Kevin_Kofler will try to fix the FTBFS
15:31:32 <Kevin_Kofler> s/actino/action/ :-)
15:31:49 <rdieter> #action Kevin_Kofler will try to fix the FTBFS
15:31:52 <rdieter> better. :)
15:31:58 <rdieter> moving on...
15:32:14 <rdieter> #topic kde-print-manager status
15:32:34 <rdieter> so, the general idea was to replace kde-printer-applet with kde-print-manager sooner or later
15:32:51 <jreznik> dantti will be in brno this week...
15:33:05 <rdieter> it's in comps-f19 as default now, no f18 yet unfortunately
15:33:29 <rdieter> my own minimal testing has been mixed.  it serves well as print queue manager
15:34:04 <Kevin_Kofler> FYI, luma was upgraded to a PyQt4 version ~a month ago: http://pkgs.fedoraproject.org/cgit/luma.git/commit/?id=c0fc13c34b385f526a58798720dda89a05a78a76
15:34:08 <rdieter> it failed to correctly configure my avahi-detected network printer @ home (though that may well be a cups bug recommending the wrong driver/setup)
15:34:18 <rdieter> Kevin_Kofler: woo, one less to worry about.
15:34:33 <rdieter> so, more testing/feedback using it is needed
15:34:50 <rdieter> has anyone else tried it much yet?
15:35:17 * Kevin_Kofler would love having printer-applet by default ASAP, if anything because it's not system-config-printer-kde (and its kde-printer-applet). ;-)
15:35:24 <ltinkl> it correctly setup both my local USB printer and the remote CUPS printers at Brno RH office
15:35:25 <rdieter> it's one of those 'manually add to systray plasma applet' like things
15:35:33 <Kevin_Kofler> s-c-p-kde is just horribly buggy.
15:35:36 <rdieter> ltinkl: oh goodie
15:35:58 <rdieter> Kevin_Kofler: true, even with some faults, it probably is still the lesser of 2 evils
15:36:01 <Kevin_Kofler> "manually add to systray plasma applet" – uh, that's what the init and update scripts are for. :-)
15:36:15 <Kevin_Kofler> We need to ship some of those if we want to make it the default.
15:36:24 <ltinkl> handy but you must always remember not to send any sensitive data to the "wrong" printers :)
15:37:17 <rdieter> that's good enough for me.  any volunteer for writing the plasma init/update script?
15:37:24 <ltinkl> rdieter, jreznik: is there still a possibility to include it for F18 by default?
15:37:51 <rdieter> ltinkl: even though it's a bit late, I'm ok with that.
15:37:57 <jreznik> ltinkl: not for beta
15:38:34 <ltinkl> jreznik: sure, after beta and after having a thorough discussion with dantti this weekend
15:39:32 <rdieter> given how bad s-c-p-kde is
15:40:15 <jreznik> ltinkl: yep
15:40:48 * rdieter was disconnected for a couple minutes there, can you repeat anything said after my "I'm ok with that", and now?
15:41:50 <jreznik> nothing after [16:39] <rdieter> given how bad s-c-p-kde is
15:42:05 <rdieter> anyway, as an aside, anyone object to eol'ing s-c-p-kde and kde-printer-applet altogether (ie, not ship them, and add Obsoletes: to kde-print-manager) ?
15:42:20 <jreznik> ltinkl: will discuss it with dantti this week personally
15:42:54 <ltinkl> rdieter: no objection
15:45:32 <Kevin_Kofler> [16:37] <rdieter> ltinkl: even though it's a bit late, I'm ok with that.
15:45:33 <Kevin_Kofler> [16:37] <jreznik> ltinkl: not for beta
15:45:35 <Kevin_Kofler> [16:38] <ltinkl> jreznik: sure, after beta and after having a thorough discussion with dantti this weekend
15:45:36 <Kevin_Kofler> [16:39] <rdieter> given how bad s-c-p-kde is
15:46:03 <rdieter> i'll open a bug to track adding kde-print-manager as default, plasma init/update scripts, and Obsoletes
15:46:26 <Kevin_Kofler> rdieter: No objection to EOL/Obsoletes IFF print-manager works as advertised and becomes the default.
15:46:31 <rdieter> f19 is a given (right?), once we have that in place, we can seriously consider f18'ifying it too
15:46:39 <Kevin_Kofler> It's good to have one default.
15:47:17 <Kevin_Kofler> Now we just need to lobby upstream to officially replace s-c-p-kde/printer-applet there too. :-)
15:48:08 * jreznik is switching to the phone...
15:49:18 <rdieter> moving on...
15:49:24 <rdieter> #topic open discussion
15:49:27 <rdieter> anything else for today?
15:50:01 <rdieter> oh, kde-4.9.3, all build in rawhide (minus qyoto).  was waiting for f18 beta freeze to lift before charging ahead with f17/f18 builds.
15:50:34 <rdieter> just in case, we needed to fix anything else at the last minute for beta
15:50:47 <Kevin_Kofler> The question is, how long will we be in freeze?
15:51:05 <rdieter> does it matter?
15:51:13 <Kevin_Kofler> It may well be worth starting to build 4.9.3 stuff right now. If we need an urgent fix, we can build it from a quick branch.
15:51:31 <rdieter> maybe so, jreznik, what's your best guess?
15:51:38 <rdieter> jreznik_n9: ^^ too ?
15:52:06 * rdieter is ok with charging ahead
15:52:16 <Kevin_Kofler> Just to be sure, do we have any open blockers against KDE SC right now?
15:52:25 * rdieter double-checks
15:52:35 <Kevin_Kofler> (because if so, we want those fixed first :-) )
15:52:51 <rdieter> .bug 873746
15:52:53 <rdieter> fyi ^^
15:52:54 <zodbot> rdieter: Bug 873746 make kde-print-manger default - https://bugzilla.redhat.com/show_bug.cgi?id=873746
15:53:00 * rdieter fixes typo
15:54:10 <Kevin_Kofler> kde-print-manger, is it Christmas already? ^^
15:54:17 <rdieter> lol
15:55:00 <rdieter> .bug  846844
15:55:03 <zodbot> rdieter: Bug 846844 Fedora 18 Blocker KDE Tracker - https://bugzilla.redhat.com/show_bug.cgi?id=846844
15:55:06 <rdieter> i don't see anything on our plate ^^
15:55:11 <Kevin_Kofler> Good.
15:56:22 <rdieter> one more fyi, i took a baby step adding initial power-related systemd-login support to lightdm yesterday
15:56:46 <rdieter> so now shutdown/restart action is handled via systemd now
15:58:03 <rdieter> kudos to Tim Lauridsen for the initial polkit rules and proof-of-concept patch
15:58:28 <rdieter> .bug 872797
15:58:33 <zodbot> rdieter: Bug 872797 lightdm: provide polkit .rules for actions - https://bugzilla.redhat.com/show_bug.cgi?id=872797
15:59:05 <rdieter> than, ltinkl : what do you think about moving ahead doing kde-4.9.3 builds for f17/f18 now?
15:59:33 <than> rdieter: i'm fine with 4.9.3 for f17/f18
15:59:49 <ltinkl> rdieter: sure, go ahead
16:00:04 <rnovacek> rdieter: +1
16:00:24 <rdieter> ok, I can, unless someone else wants the fun? :)
16:00:35 <Kevin_Kofler> +1, go ahead.
16:00:41 * rdieter breaks out build-it.sh script
16:01:09 <rdieter> I belive the f17-kde/f18-kde koji targets should be ready
16:01:26 <rdieter> anything else for today?  we're at the top of the hour.
16:02:03 <than> .bug 868530
16:02:07 <zodbot> than: Bug 868530 Delay and cpu spike in file open/save dialogs - https://bugzilla.redhat.com/show_bug.cgi?id=868530
16:02:29 <dvratil> than, patch for Dolphin is in KDE RB, as soon as it's approved, I'll put it to Fedora
16:02:43 <Kevin_Kofler> But we really need caching inside solid-udisks2.
16:03:04 <than> dvratil: it seems it's affected in qfiledialog too
16:03:12 <dvratil> that has already been fixed
16:03:18 <dvratil> wait, Q?
16:03:27 <than> dvratil: yes qfiledialog
16:03:31 <than> not kde
16:03:40 <Kevin_Kofler> KDE overrides the Qt file dialogs under some conditions.
16:04:01 <Kevin_Kofler> So chances are the dialog that's the subject of complaints here isn't really the Qt-only one, but actually the KDE one.
16:04:03 <dvratil> If it's Solid issue, it can't affect the pure Qt dialog, they don't use Solid
16:04:13 <than> dvratil:  please try standarddialogs from qt-examples
16:04:20 <than> and you will see the issue
16:04:49 <Kevin_Kofler> than: Does the dialog you see look exactly like in a KDE app (other than possibly missing translations)?
16:04:55 <rdieter> reminds me, we need karma for kdelibs update
16:04:59 <dvratil> than, that's KDE dialog
16:05:03 <dvratil> probably injected somehow by KDE
16:05:17 <Kevin_Kofler> Because then it's not the Qt-only dialog, it's the dialog overridden from KDE.
16:05:22 <rdieter> https://admin.fedoraproject.org/updates/FEDORA-2012-17234/kdelibs-4.9.2-11.fc18
16:05:22 <dvratil> Pute Qt dialog cannot have Nepomuk timeline :)
16:05:32 <rdieter> https://admin.fedoraproject.org/updates/FEDORA-2012-17385/kdelibs-4.9.2-11.fc17
16:05:44 <rdieter> need to be queue'd for stable before we can submit kde-4.9.3 for -testing
16:05:54 <Kevin_Kofler> There are at least 2 things which can load KDE file dialogs into Qt-only apps: the KDE Platform Plugin and the Oxygen style.
16:06:27 <Kevin_Kofler> So it's the same issue as in KDE apps.
16:06:43 <dvratil> and that should be fixed already in upstream and in our kdelibs
16:06:46 <Kevin_Kofler> The same fix should fix it.
16:06:49 <than> i removed all oxygen stuff before trying the qfiledialog
16:07:00 <Kevin_Kofler> than: There's also the platform plugin.
16:08:05 <ltinkl> than: that's a KDE dialog (for Qt apps running under KDE)
16:08:51 <dvratil> I must admit I didn't notice until now that KDE injects kdialogs to pure Qt apps :)
16:09:21 <than> i will investigate more
16:12:55 <than> dvratil: do you have the link for the patch in dolphin?
16:13:05 <dvratil> than, https://git.reviewboard.kde.org/r/107168/
16:13:15 <than> thanks
16:14:17 <rdieter> dvratil: if it's not too much trouble, we could include the patch in our packaging now (for testing, feedback)
16:15:04 <dvratil> rdieter, well the patch works (at least for me and ltinkl), but it's not sure whether Frank will accept it as it is now
16:15:29 <rdieter> ok, reading the review, yeah, seems maybe we should wait until we're closer to some consensus
16:15:40 <ltinkl> rdieter: yup, I'd suggest waiting in this case
16:16:04 <dvratil> I'll ping you when things are sorted out
16:16:04 <than> how about other kde apps like gwenview?
16:16:06 <rdieter> ok, will close meeting in 2 min
16:16:33 <than> dvratil: i assume it could be affected in other kde apps too
16:16:33 <dvratil> than, gwenview is already doing smart-enough cacheing so that the performance impact is not really visible
16:17:18 <dvratil> maybe using the asynchronous cache could speed up start up time a bit, but there is no major usability issue like with dolphin
16:17:44 <Guest123321> gwenview also have delay when starts
16:18:27 <dvratil> yeah and it indeed is caused by waiting for Solid, but at least you don't wait ~4 seconds for context menu :)
16:18:28 <than> someone has reported that resizing of gwenviews's window takes so long
16:18:43 <ltinkl> no problem here
16:18:59 <Guest123321> it starts but at first shows empty window about 10 seconds before items shown
16:19:01 <dvratil> can reproduce either
16:19:03 <dvratil> *can't
16:19:15 <than> ltinkl: have you tried to resize the windows?
16:19:20 <ltinkl> than: yup, no prob
16:19:34 <Kevin_Kofler> So what about adding caching to Solid itself?
16:19:49 <Kevin_Kofler> If the problem is that it has to enumerate the whole device tree all the time, it should cache the tree somehow.
16:19:52 <ltinkl> Kevin_Kofler: already there, from the start
16:20:01 <dvratil> Kevin_Kofler, the problem is the initial query
16:20:05 <dvratil> which is synchronous
16:20:20 <than> dvratil: tested on f18?
16:20:25 <dvratil> than, yop
16:21:01 <dvratil> Kevin_Kofler, the patch of mine moves the query to another thread so it should not block...that's something you can't fix in Solid, until kdelibs is unfrozen
16:22:24 <Kevin_Kofler> The kdelibs freeze really sucks.
16:22:55 <Kevin_Kofler> What sucks the most is that they don't want to budge despite all the problems it's causing.
16:23:25 <dvratil> what really sucks is Solid's synchronous API (and whoever made it)
16:24:45 <ltinkl> out of scope of this meeting, we're running out of time :)
16:25:15 <Kevin_Kofler> I think we need to look into improving things in Solid with the API we have.
16:25:26 <Kevin_Kofler> So try to get response times of the sync calls down.
16:25:46 <dvratil> uhm, sorry I got ksmscrash - what did I miss since my complaints about solid's API?
16:25:50 <Kevin_Kofler> Maybe we should even try to ask udisks2 folks for the missing APIs instead of trying to work around it in expensive ways?
16:25:52 <dvratil> *ksmserver crash
16:26:01 <Kevin_Kofler> [17:24] <ltinkl> out of scope of this meeting, we're running out of time :)
16:26:02 <Kevin_Kofler> [17:25] <Kevin_Kofler> I think we need to look into improving things in Solid with the API we have.
16:26:33 <Kevin_Kofler> "Enumerate everything, then filter" is a quite lame approach. :-(
16:27:13 <than> Kevin_Kofler: +1
16:28:03 <rdieter> i think we've beaten that topic into submission, let's end the meeting.  followup and further discussion can go on outside of the meeting
16:28:04 <dvratil> I don't see a problem with this approach, because we should have async API and sane caching - we have the caching, the synchronous API is the killer here
16:28:48 <rdieter> thanks everyone.
16:28:50 <rdieter> #endmeeting