16:01:56 <adamw> #startmeeting Fedora QA meeting
16:01:56 <zodbot> Meeting started Mon Dec  3 16:01:56 2012 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:00 <adamw> #meetingname fedora-qa
16:02:00 <zodbot> The meeting name has been set to 'fedora-qa'
16:02:03 <jreznik> and a good afternoon/evening for the rest :)
16:02:04 <adamw> #topic roll call
16:02:06 * kparal still here
16:02:09 * mkrizek is here
16:02:11 * tflink is here
16:02:12 * pschindl is here
16:02:16 * jreznik is here
16:02:44 * nirik is lurking, ping if needed.
16:02:53 * jskladan still lurks
16:03:37 <adamw> morning everyone
16:04:19 * maxamillion is here
16:04:53 * Viking-Ice fetches coffee
16:05:20 <adamw> #topic previous meeting follow-up
16:05:24 <adamw> oooh. coffee. good idea.
16:05:32 <maxamillion> +1
16:05:34 <adamw> so we have a giant pile of stuff here
16:05:40 <adamw> "tflink to ensure some kind of upgrade documentation is ready for beta availability tomorrow"
16:05:45 <adamw> i believe that got done?
16:06:31 * jreznik thinks so too
16:07:09 <Viking-Ice> I'm starting to get a bit worried upgrading encrypted partitions
16:07:18 <tflink> yeah, it got mostly done
16:07:36 <Viking-Ice> mean upgrading + encrypted partitions
16:07:37 <tflink> done enough for beta, anyways
16:07:57 <tflink> Viking-Ice: yeah, I want to give that a test - it sounds like there may be dragons in there
16:08:20 <kparal> I didn't see any problems except for the timeout
16:08:24 <adamw> #info this was done - https://fedoraproject.org/wiki/FedUp#How_Can_I_Upgrade_My_System_with_FedUp.3F
16:08:31 <adamw> gr
16:08:32 <adamw> #undo
16:08:32 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2b6039d0>
16:08:38 <adamw> #chair kparal tflink viking-ice
16:08:38 <zodbot> Current chairs: adamw kparal tflink viking-ice
16:08:52 <adamw> #info "tflink to ensure some kind of upgrade documentation is ready for beta availability tomorrow" - this was done: https://fedoraproject.org/wiki/FedUp#How_Can_I_Upgrade_My_System_with_FedUp.3F
16:08:58 <tflink> there are some issues with the release notes, but I think those are getting taken care of
16:09:07 * tflink will check on that
16:09:14 <adamw> "tflink to brief #fedora ops and fedora-user-list regulars on fedup" - did that happen?
16:09:54 * satellit late and listening
16:09:57 <tflink> not so much and it shows - it looks like many people are using old instructions for testing
16:10:27 <adamw> okay
16:10:31 <adamw> do you want to take it again or should I?
16:10:35 <adamw> or anyone else?
16:10:51 <tflink> either way, I'm not so sure who the best people to ping are
16:11:34 <Viking-Ice> kparal, the timeout issue is present in current GA afaik ( unless it has been fixed have not tested it recently ) just wait entering the password for let's say 5 minutes ( cant remember what the default is ) and you get dropped to systemd shell
16:11:54 <tflink> I think that's known, though
16:11:59 <tflink> there are multiple bugs filed about it
16:12:16 <adamw> yeah, one for dracut and one for systemd.
16:12:25 <tflink> two for systemd, I think
16:12:26 <kparal> Viking-Ice: it's present in Beta, yes. and the timeout is much shorter, I think 1-2 minutes
16:12:26 <jreznik> that's #881670 at least
16:12:30 <adamw> #info "tflink to brief #fedora ops and fedora-user-list regulars on fedup" - this was not done yet
16:12:30 <tflink> one for regular, one for fedup
16:12:38 <adamw> #action adamw to brief #fedora ops and fedora-user-list regulars on fedup
16:12:51 <tflink> it shouldn't cause problems that aren't workaround-able by rebooting, though
16:12:53 <adamw> it's a bug party!
16:12:58 <Viking-Ice> the problem with fedup is that people start upgrade and go doing something else
16:13:06 <adamw> "adamw to co-ordinate with anaconda team on TC1 date planning" - yeah, so, oops.
16:13:24 <adamw> dgilmore just poked me about this this morning, so i guess we'll work it out after the meeting. but we probably should start doing TCs this week. any objections to that?
16:13:35 <tflink> none here
16:13:43 * jreznik is ok with TCs this week
16:13:48 <Viking-Ice> not the more the merrier  ;)
16:13:52 <Viking-Ice> mean no
16:15:15 <adamw> #info "adamw to co-ordinate with anaconda team on TC1 date planning" - not done yet, will do today, TCs likely to land this week
16:15:31 <adamw> "jskladan to review final criteria and test cases for obvious revision candidates"
16:15:36 <adamw> jskladan?
16:15:59 * jskladan is skilled in delegation
16:16:10 <jskladan> pschindl did it
16:16:15 <pschindl> adamw: I did it, but haven't yet sent the mail
16:16:19 <jskladan> he just needs to send the email IMHO
16:16:44 <pschindl> I'm going to send it after this meeting
16:16:44 <adamw> damnit, petr, stop slacking on jskladan's work ;)
16:16:51 <pschindl> :)
16:17:13 <adamw> #info "jskladan to review final criteria and test cases for obvious revision candidates" - passed on to pschindl, he has completed work but needs to send email
16:17:50 * jskladan is good at training up good interns ;)
16:18:10 <tflink> or slacking off, depends on how you look at it :-P
16:18:12 <adamw> truly, you are on the road to project colada
16:18:29 <adamw> #info "viking-ice or tflink to try and get a fedup design document out of wwoods" - speaking of projects, how is bloodfromastone going?
16:18:38 <adamw> alternatively: project excalibur
16:18:48 <tflink> not a whole lot of change as of late
16:19:05 <Viking-Ice> we need booze lot of booze to get that information
16:19:08 <tflink> someone from design (I don't remember who off the top of my head) has started to look @ the gui for gedup-client
16:19:32 <Viking-Ice> not the cheap stuff I might add ;)
16:19:55 <tflink> as far as a design document goes, the current "design document" is ... (searching for a link)
16:20:13 <tflink> http://ohjeezlinux.wordpress.com/2012/11/13/fedup-a-little-background/
16:20:42 <adamw> #info "viking-ice or tflink to try and get a fedup design document out of wwoods" - currently rejoicing in the title of 'design document' is http://ohjeezlinux.wordpress.com/2012/11/13/fedup-a-little-background/
16:20:42 <tflink> there has been some initial work to change mirror manager such that --instrepo won't be required anymore and the .treeinfo will be signed
16:21:43 * tflink is a little behind on fedup bugs right now - too much blocker bug happy fun time
16:21:49 <jreznik> btw do we have a list of required work that has to be done for fedup for final?
16:21:57 <tflink> nothing official, no
16:22:30 * jreznik will start working on it as we really need it (and also opinion from FESCo what they require for final - gui is known...)
16:22:49 <adamw> sounds like a plan
16:22:50 <jreznik> to avoid late surprises...
16:22:58 <adamw> #action jreznik to draft a list of required functionality for fedup for Final
16:23:05 <adamw> fffff
16:23:19 <adamw> okely dokely
16:23:21 <adamw> #topic Fedora 18 Final status/planning
16:23:35 <tflink> jreznik: late surprises? we never get those :)
16:23:43 <adamw> not sure what tflink meant by 'beta docs status'?
16:23:55 <adamw> we have a release announcement which mentioned fedup (yay) and kparal and I worked on commonbugs
16:24:11 <tflink> followup from last week to make sure we got everything
16:24:45 <jreznik> adamw: thanks for help with the announcement!
16:25:20 <tflink> at some point, we might want to think about coordinating better with docs about release notes - there was a mention of a bz flag for highlighting issues but that doesn't need to happen today
16:25:28 <tflink> better/differently
16:26:34 <adamw> yeah, there is one, i kinda assume people know about it, but maybe not.
16:26:37 <adamw> i use it now and again.
16:26:50 * tflink had never heard of it before that devel@ thread
16:27:21 <adamw> welp, the 'fedora_requires_release_note' flag is it, folks.
16:27:30 <adamw> i think you set it to ? .
16:31:09 <adamw> okay, the other thing was "Final: potential sore points, areas that need testing?", which i guess we've kind of been covering :)
16:31:13 <adamw> anything else we didn't cover yet?
16:32:04 <Viking-Ice> bootup + black screen
16:32:05 <tflink> fedup is mostly what I'm worried about
16:32:44 <Viking-Ice> I think I saw people mentioning that it was not only happening with the ati drivers
16:33:41 <Viking-Ice> i'm free of it with 3.7 rc kernels
16:34:36 <adamw> Viking-Ice: well, i mean, as i explained in a mail, 'it boots to a black screen' is one of the most generic symptoms we *have*.
16:34:58 <adamw> a few people seeing that alone doesn't tell us much useful - could be five different bugs.
16:35:17 <Viking-Ice> yeah they need to ssh into the machine and grap the log
16:36:57 <Viking-Ice> adamw, anyway I dont think those are 5 different bugs thou I think they all relate to that grub gfxpayloud stuff that we changed between releases
16:38:13 <adamw> what changed there?
16:38:16 <adamw> don't think i'm up on that one
16:39:32 <Viking-Ice> the gfxpayload settings
16:39:42 <adamw> i mean, what changed specifically
16:40:05 <adamw> or are you just talking about that we put in the theming for grub2?
16:40:14 <adamw> we were modesetting in f17, i think, but without theming
16:40:40 <tflink> I thought that there was a theme in F17 but it might have been added post-release
16:42:11 <adamw> okay, anyhow, in general: if we have people hitting black screens, we need more data.
16:44:05 <Viking-Ice> hm looks like I never mentioned that on the bug report
16:44:19 <Viking-Ice> well I mentioned it to airlied
16:45:17 <Viking-Ice> in anycase the "it boots to a black screen" is a regression in my case
16:45:49 <adamw> oh, you're hitting it yourself? well, should be easy enough to mess with the grub config and see if that fixes it?
16:45:51 <Viking-Ice> F16/F17 ( and pre 3.6 kernel ) worked just fine
16:46:00 <Viking-Ice> adamw, I know it fixes it
16:46:09 <Viking-Ice> well removing that line atleast does
16:46:22 <adamw> ah, okay.
16:46:37 <adamw> well, if it looks like other people have the same problem, elevate it to proposed blocker...
16:47:24 <adamw> moving on, in the interests of time
16:47:29 <adamw> #topic Test case / criteria revision
16:47:39 <adamw> do we have much here?
16:47:48 <adamw> i don't see any proposals since memory test
16:47:55 <adamw> i'm still not getting to the partitioning criteria :(
16:48:38 <tflink> it sounds like we're waiting a bit on petr's email
16:48:54 * kparal didn't manage to write up the kickstart proposal
16:49:11 <kparal> somewhere in the queue
16:49:43 <adamw> #info no new criteria proposals at present, adamw, kparal and pschindl all have some in pipeline
16:51:31 <adamw> #topic Blocker Meeting Scheduling and Length
16:51:39 <adamw> tflink, want to take this one?
16:53:13 <tflink> sure
16:53:29 <tflink> there have been some complaints/suggestions around the blocker meetings recently
16:54:02 <tflink> one was the time is inconvenient for some people and it might better to not always use the same time if we want more participation
16:54:18 <tflink> which may be true, but I'm tempted to leave that one alone for now
16:54:39 <tflink> ie, leave the discussion around that for post-f18
16:54:46 <tflink> the other is about frequency and duration
16:55:19 <tflink> any thoughts on whether the current format of 3 hour meetings at least once a week vs. 1 hour meetings several times per week?
16:55:44 <adamw> i prefer getting it done in one go
16:55:52 <adamw> there's quite a bit of 'overhead' which gets multiplied with multiple meetings
16:55:59 <tflink> yeah, but we tend to lose people after a while
16:56:03 <adamw> obviously, though, 3x3 hour meetings is the worst of the worst :)
16:56:13 <jskladan> ^ :)
16:56:16 <Viking-Ice> dont we have criteria that hits "* Put advanced storage (filtering, multipath/iscsi/zfcp dialogs) back in." item ( from post-f18 newui TODO on anaconda list )
16:56:16 <Viking-Ice> is anaconda in f18 in good shape for "enterprise storage"
16:56:18 <Viking-Ice> ?
16:56:24 <Viking-Ice> ?
16:56:24 <Viking-Ice> dont we have criteria that hits "* Put advanced storage (filtering, multipath/iscsi/zfcp dialogs) back in." item ( from post-f18 newui TODO on anaconda list )
16:56:25 <Viking-Ice> is anaconda in f18 in good shape for "enterprise storage"
16:56:27 <jreznik> but seriously - is that even possible? looking on proposed blocker bugs list?
16:57:13 <Viking-Ice> adamw, do you have any clue on the enterprise storage part of anaconda
16:57:16 <tflink> yeah, I don't think anyone likes the current method
16:57:22 <tflink> Viking-Ice: that seems to be a bit off topic
16:57:39 <Viking-Ice> you where speaking of the criteria to begin with
16:57:48 <tflink> but installing to iSCSI, FC, FCoE etc. is not in F18, will return in F19 IIUC
16:58:00 <tflink> I was?
16:58:06 <adamw> Viking-Ice: like half an hour ago?
16:58:29 <adamw> so we tried this thing this week where tflink categorized the bugs for on-bug voting
16:58:32 <adamw> what did everyone think about that?
16:58:32 <Viking-Ice> adamw,  more like 10 minutes
16:58:47 <Viking-Ice> and I'm the actual one that was proposing we go for one hour meetings
16:58:48 <adamw> Viking-Ice: still, we moved on to a new topic since then...there's always open floor if you want to bring up something from before
16:58:52 <adamw> otherwise we just get confused
16:58:56 <Viking-Ice> adamw aha
16:59:00 * maxamillion is almost always confused anyways
16:59:04 <adamw> =)
16:59:11 <Viking-Ice> more frequently
16:59:24 <adamw> Viking-Ice: since we're discussing the length of blocker meetings now, talking about enterprise storage criteria seems a bit out of place :)
16:59:32 * maxamillion is just getting worse at multi tasking ... $day_job is more busy than $old_day_job
16:59:42 <Viking-Ice> adamw,  you weren't when I asked those questions
16:59:53 <Viking-Ice> you conveniently ignored it
17:00:09 <adamw> Viking-Ice: er - i set the topic at xx:51 to "Blocker Meeting Scheduling and Length"
17:00:16 <adamw> you asked your questions at xx:56
17:00:26 <adamw> after there had already been several minutes of discussion on the blocker meeting length topic
17:00:32 <Southern_Gentlem> move on and deal with this later
17:00:37 <tflink> yep
17:00:39 <Viking-Ice> adamw,  no I re-asked those question at that time
17:00:52 <tflink> the blocker meeting is supposed to be starting soon
17:01:04 <kparal> (now)
17:01:11 <Viking-Ice> yeah I proposed for 3x1 hour or 5x1 meeting instead of 3 hours meeting
17:01:20 <adamw> Viking-Ice: oh. i never got the originals. maybe they were affected by that netsplit i see in the history. sorry
17:01:41 <tflink> I didn't see them either
17:01:54 * jreznik does not have that question neither...
17:01:57 <Southern_Gentlem> perfer we dont have that many blockers so 1 -1 hr meeting can deal
17:02:44 <adamw> that's obviously the best
17:02:56 <adamw> but it seems unrealistic
17:03:08 <tflink> especially right now
17:03:12 <adamw> how can we have such a low blocker count without evaluating proposed blockers and rejecting some? which is...what we do in the meeting? :)
17:04:03 <jreznik> clean-up in tickets should help a little - /me voted in several bugs today
17:04:18 <adamw> yeah, i think that was a good idea
17:04:34 <adamw> is anyone worried about covering at least 'obvious' bugs with in-bug voting?
17:04:41 <adamw> it seems like the best way to reduce the load a little
17:04:42 <tflink> yeah, I need to go through and modify the ones that have enough -1s or +1s
17:04:49 <adamw> ah, i was about to ask if you'd done that
17:05:15 <tflink> I'm making the list for today's meeting from bugs that weren't on the 'more obvious' list
17:05:22 <tflink> we have enough to go through that it shouldn't be an issue
17:05:24 <adamw> sounds good
17:05:46 <adamw> shall we take a vote on the 'many short meetings' proposal?
17:05:50 <adamw> or more discussion on it?
17:06:15 <Viking-Ice> should we have it 1 hour or 1 and half hour
17:06:18 <kparal> if the obvious list is compiled by someone and sent to the list, I'm OK. just going randomly though blocker list doesn't seem great
17:06:21 <Viking-Ice> ( takes 10 minutes to start )
17:06:32 <tflink> kparal: I sent the list out to test@ on friday
17:06:39 <kparal> tflink: yeah, I know
17:06:46 <tflink> ok, you meant in general
17:06:48 <adamw> right, you're saying it should always be done that way, make it a process?
17:07:02 <kparal> yes, something like that
17:07:22 <kparal> it's better to have a list of obvious blockers, and then people can vote in the bugzilla or say "no this is not obvious"
17:07:26 <adamw> maybe we should have some kind of threshold at which the 'formal on-bug voting' process kicks in - >20 proposed blockers or something
17:07:50 <kparal> if we don't have the list, each person have a different opinion what is obvious
17:08:05 <adamw> sure
17:08:08 <jreznik> kparal: but you can still vote and other people can say no
17:08:09 <tflink> yeah, but I think that's a bit unavoidable for now
17:08:22 <kparal> jreznik: without the list I don't know they voted
17:08:28 <adamw> Viking-Ice: i'd prefer 1.5 to 1, yeah, the 10 minute overhead is significant
17:08:51 <tflink> the point of going through and doing some sorting is to reduce the number of bugs to discuss in meetings - I don't see a way to do that without one person doing the initial sorting
17:09:07 <jreznik> would it be possible to parse the bug for "-1/+1 blocker" in the current blocker bug list and show it?
17:09:08 <tflink> which is unavoidably biased to a certain point
17:09:09 <Viking-Ice> so try 3x1.5 ( monday/wednesday/friday )
17:09:27 <jreznik> tflink: but yeha, someone has to do the initial sort
17:10:04 <tflink> jreznik: yeah, that wouldn't be too hard in principle - the hard part is making sure to catch all the minor variations in +/-1
17:10:47 <tflink> it might be interesting to add some support for flagging "obvious" bugs in the tracker app
17:10:58 <tflink> but there is no way I'm going to get to that until after F18
17:11:00 <adamw> okay, so sounds like we're broadly on board with the in-bug voting, i'm not hearing much discussion of 'multiple short meetings'
17:11:03 <adamw> and we're 10 minutes over time
17:11:43 <tflink> I think it's an interesting idea but I also think we need to get through the monster list sooner than later
17:11:49 <Viking-Ice> so should we discuss in-bug the gray area we might be hitting
17:12:15 <tflink> so for now, I'm -1 on the idea of shorter meetings
17:12:44 * tflink emphasizes "for now" as in at least until we get through the initial list
17:12:53 <Viking-Ice> I'm not so sure that maintainers will be happy about the bug spam we introduce by voting in the bugs themselves
17:12:57 * adamw is +/-0 - personally i prefer longer-but-fewer, but i certainly acknowledge the problem of losing people as the meetings go on
17:13:07 <adamw> Viking-Ice: that's a good point, actually, hadn't thought of that
17:13:11 <adamw> maybe we should check on devel@
17:13:22 <adamw> #info viking-ice points out that a drawback of in-bug voting is bugzilla spam
17:13:40 <jreznik> let's go through the current list and we will see how many left - we can be flexible
17:13:49 <adamw> #info aside from that, general support for in-bug voting on 'obvious' blockers when the blocker count is high, but it should be a defined process
17:14:24 <adamw> #info no-one seems to have strong feelings either way on the multiple-short-meetings plan, but we don't have time to thrash it out further today
17:14:49 <tflink> I think that the blocker process could use some work, but that doesn't help for now
17:14:51 <adamw> anyone want to take an action item for considering a formal in-bug-review process further?
17:15:10 <tflink> I'm not against the idea, but I don't really want to do it right now
17:15:22 * tflink won't stop anyone else from doing it, though
17:15:50 <adamw> i guess everyone's a bit overloaded at present
17:16:02 <adamw> let's go on to open floor so we can discuss viking's missed question and get to blocker review
17:16:05 <adamw> #topic open floor
17:16:05 <kparal> I'm not really against in-bug voting, but I really like meeting voting more
17:16:16 <adamw> Viking-Ice: sorry your criteria question got missed earlier, what was it again?
17:17:05 <Viking-Ice> adamw, let's just add enterprise storage support in anaconda ( if any ) to next meeting item and start working on the blocker bugs
17:17:12 <adamw> okay
17:17:29 <adamw> #info viking-ice is concerned about storage support in newUI but meeting has overrun so we'll cover it next week
17:17:45 <adamw> #action adamw to put 'enterprise storage support in newui' on next week's agenda
17:17:46 <Viking-Ice> *enterprise*
17:17:51 <adamw> yeah, got it in the action item :)
17:17:57 <Viking-Ice> ;)
17:18:01 <adamw> anything else for open floor?
17:19:09 <mel-> what does 'open floor' mean?
17:19:28 <adamw> topics that weren't covered elsewhere in the meeting
17:19:35 <adamw> though we'd like to finish quickly to get on to the blocker review meeting
17:19:47 <adamw> did you have something to bring up quickly?
17:20:17 <jreznik> blocker fun! any other topic could be re-raised after it... if not serious one
17:20:46 <mel-> adamw: well, i need to fill a fedup bug. dunno of that is appropriate here
17:20:52 <mel-> s/of/if/
17:21:50 <adamw> mel-: are you having trouble filing it in bugzilla?
17:23:07 <mel-> adamw: no, i think will be fine :)
17:23:10 <adamw> okay, let's move on to blocker review, we can help mel outside of the meeting
17:23:13 <adamw> thanks for coming everyone!
17:23:14 <adamw> #endmeeting