06:03:36 <tagoh_> #startmeeting i18n
06:03:36 <zodbot> Meeting started Thu Jan 24 06:03:36 2013 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:03:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:03:36 <tagoh_> #meetingname i18n
06:03:36 <zodbot> The meeting name has been set to 'i18n'
06:03:37 <tagoh_> #topic agenda and roll call
06:03:37 <tagoh_> #link https://fedoraproject.org/wiki/I18N/Meetings/2013-01-24
06:03:42 <epico> hi
06:03:43 <mfabian> hi!
06:03:45 <tagoh_> okay, shall we have i18n meeting now
06:03:54 <anish_> hi!
06:04:00 <pravins> hi
06:04:08 <dueno> hi
06:05:56 <tagoh_> okay, let's get started.
06:06:00 <juhp> hi
06:06:04 <tagoh_> #topic Upcoming schedule
06:06:04 <tagoh_> #info 2013-01-29        Feature Submission Deadline
06:06:21 <tagoh_> no updates in the schedule yet.
06:06:34 <fujiwarat> hi
06:07:21 <tagoh_> the feature submission deadline is next Tuesday. so if anyone is planning to submit, need to do that asap
06:07:58 <tagoh_> #topic Outstanding topics
06:07:58 <tagoh_> #info #9: Fedora 19 Feature planning (tagoh)
06:07:59 <tagoh_> #link https://fedorahosted.org/i18n/ticket/9
06:08:24 <tagoh_> any plans for f19 features? except libkkc?
06:09:22 <tagoh_> lohit? i-t-b?
06:09:26 <tagoh_> or anything else?
06:09:42 <anish_> tagoh_, Not from me as F19 time line would be small and I don't want be give half baked features.
06:09:53 <tagoh_> sure
06:10:54 <tagoh_> maybe good time to improve and polish i18n support on f19 perhaps.
06:12:09 <juhp> yeah
06:12:09 <tagoh_> if not, better move on then.
06:12:42 <tagoh_> okay
06:12:45 <tagoh_> #info #12: language support installation command (pnemade)
06:12:45 <tagoh_> #link https://fedorahosted.org/i18n/ticket/12
06:13:01 <pravins> tagoh_: nothing no lohit side. Though development in in plan but i am not sure whether we will able to do it in F19 timeframe
06:13:21 <tagoh_> I see
06:14:12 <tagoh_> well, from the last update from Parag, do we agree to update the related docs with the use of both groupinstall and langinstall?
06:14:14 <tagoh_> any comments?
06:15:56 <pravins> we need both command, since langinstall only installs package having lang-code in name
06:16:10 <pravins> we still in groupinstalll lang-support for input-method etc.
06:16:27 <tagoh_> right
06:17:48 <pravins> paragan: does langinstall execute groupinstall command as well for particular language?
06:17:55 <paragan> no
06:18:08 <tagoh_> also need to update wiki to have generic information for them rather than Indic-specific content.
06:18:23 <pravins> i think, it will be great to have some linkage between these two commands, so user can use either of this
06:18:24 <paragan> langinstall just installs translations(language specific) packages
06:20:11 <tagoh_> pravins: hmm, that may be required to have hardcoding groups to map to the lang tag. guess unlikely
06:21:13 <tagoh_> any volunteers to sort them out on wiki?
06:21:19 <pravins> tagoh_: yes
06:21:38 <pravins> s-c-l already has locale-list fiel
06:21:47 <pravins> s/fiel/file it will be useful in that case
06:22:11 <pravins> /usr/share/system-config-language/locale-list
06:22:50 <pravins> oops somewhere else i think
06:23:07 <tagoh_> it would be a good feature in s-c-l but yum.
06:23:56 <pravins> yes
06:24:20 <tagoh_> paragan: for initial work, can you add or open wiki for this as generic information? if something missing there, we can add/improve it later then.
06:25:17 <paragan> https://fedoraproject.org/wiki/I18N#How_to_Install.2FRemove_Language_Support
06:25:57 <tagoh_> ah, great. missed that.
06:26:40 <tagoh_> maybe good to have the maps from group name to tag?
06:26:41 <paragan> sorry forgot to update ticket
06:27:08 <tagoh_> anyway, thanks for updates.
06:27:18 <paragan> you want matrix to be added to above link?
06:27:31 <paragan> available groups to locale code?
06:27:52 <tagoh_> yeah, something like that
06:28:07 <paragan> ok I can add it
06:28:12 <tagoh_> cool
06:29:13 <tagoh_> #action paragan to add matrix of language group and locale code
06:29:30 <tagoh_> #info #14: Fedora 16 bugs cleanup (tagoh)
06:29:30 <tagoh_> #link https://fedorahosted.org/i18n/ticket/14
06:30:03 <tagoh_> thanks for updating f16 bugs. we still have 30 bugs open but good start.
06:31:47 <tagoh_> if you want any helps to triage, we can discuss it
06:34:24 <tagoh_> I'm planning to revisit f16 bugs though, any volunteers for testing are welcome.
06:35:38 <tagoh_> you can see on the agenda page what bugs we have on f16 so far. please check it out
06:36:21 <pravins> tagoh_: i moved 3 of my bugs to f18
06:36:44 <tagoh_> aha. thanks
06:37:52 <tagoh_> anything else? shall we move on next topic then?
06:38:49 <tagoh_> #topic Outstanding task
06:38:49 <tagoh_> #info #15: F19 Feature: libkkc (ueno)
06:38:49 <tagoh_> #link https://fedorahosted.org/i18n/ticket/15
06:39:03 <tagoh_> dueno: can you update?
06:39:19 <dueno> sure
06:39:38 <tagoh_> https://fedoraproject.org/wiki/Features/libkkc
06:40:25 <dueno> I released 0.0.1 today, which is usable though phrase dictionary support is not merged
06:41:31 <dueno> (and set up a private repo: http://repos.fedorapeople.org/repos/ueno/libkkc/, for those interested to test)
06:41:32 <tagoh_> aha
06:41:50 <tagoh_> nice to see the first release
06:42:24 <tagoh_> so what's the pending task to submit the feature? any concerns there?
06:43:26 <dueno> my main concern is the phrase dictionary support, but I'll submit the feature anyway
06:43:50 <tagoh_> okay
06:44:55 <tagoh_> btw are you planning to change the default engine for Japanese in f19?
06:45:59 <juhp> I think it would be nice to try but probably we can make a decision on that nearer feature freeze time?
06:46:21 <tagoh_> sure. just wonder what "in worst case" points to.
06:46:52 <dueno> I'd like to hear the opinions first - since I'm not a native user of sentence-based IME ;)
06:47:06 <juhp> sure
06:47:25 <tagoh_> have to try first can't say anything off hand :)
06:51:21 <tagoh_> I suppose development of libkkc may be priority. providing anthy compatible interface may be nice. so we may have a plan to replace anthy only and keep ibus-anthy in some cases?
06:52:13 <dueno> agreed
06:52:33 <tagoh_> anyway, good to try first how it works. let me try to find some time for testing :)
06:53:14 <tagoh_> once submitting feature, we may see some discussion on the list for that.
06:53:42 <dueno> tagoh_, thanks
06:53:46 <tagoh_> okay, shall we move on
06:53:50 <tagoh_> #topic Open Floor
06:53:58 <tagoh_> any other topics to discuss in the meeting?
06:57:28 <tagoh_> okay, let's stop here then.
06:57:36 <tagoh_> thanks everyone for the meeting!
06:57:45 <tagoh_> #endmeeting