#fedora-meeting: Fedora QA meeting

Meeting started by adamw at 16:00:17 UTC (full logs).

Meeting summary

  1. roll call (adamw, 16:00:26)
    1. https://fedoraproject.org/wiki/QA/Meetings/20130204 (adamw, 16:04:02)
    2. https://fedoraproject.org/wiki/QA/Meetings/20130128#Blocker_process_revision (adamw, 16:05:07)

  2. Criteria revision (adamw, 16:05:30)
    1. adamw will be trying to come up with a proposal for better presenting the release criteria (adamw, 16:12:22)
    2. ideas to keep in mind: (adamw, 16:12:28)
    3. kparal - draw a line between simple explanations and lawyerish complex clauses (adamw, 16:13:01)
    4. kparal/viking-ice - define terms that we're familiar with but a general reader may not be (adamw, 16:13:18)
    5. tflink - ensure there's short text for each criterion for IRC meeting purposes (adamw, 16:13:32)
    6. kparal - group the criteria (installation, desktop, networking...) (adamw, 16:13:42)
    7. kparal - link to background info on each criterion (esp. discussion when it was created) (adamw, 16:14:31)
    8. kparal - some mechanism for tagging criteria - "I hate when I search for PXE, but it is called "network boot" or similar" (adamw, 16:16:04)
    9. criteria revision proposal is just wiki-based for now, but there's a possibility we could move the criteria into the blocker tracking app in future if it gives us useful results (adamw, 16:18:21)
    10. ACTION: adamw to draft up a proposal for revising the presentation of the release criteria (adamw, 16:18:32)
    11. https://fedoraproject.org/wiki/Releases/19/Schedule (dan408, 16:19:05)

  3. Test case revision (adamw, 16:20:30)
    1. adamw - maybe expand upgrade test case set a little (adamw, 16:23:31)
    2. viking-ice - identify hw-dependent and non-hw-dependent test cases (adamw, 16:26:48)
    3. kparal - finish revising the partitioning criteria (adamw, 16:27:04)
    4. adamw - come up with a set of common partitioning operation test cases (adamw, 16:27:19)
    5. kparal - explicit Secure Boot criterion? (adamw, 16:28:33)
    6. we should try and get criteria revision and test case revision done before Alpha as much as possible (adamw, 16:32:15)

  4. Fedora 19 Feature list review (adamw, 16:32:18)
    1. https://fedoraproject.org/wiki/Releases/19/FeatureList (dan408, 16:32:27)
    2. https://fedoraproject.org/wiki/QA/Meetings/20130204#Fedora_19_Feature_list_review (adamw, 16:33:22)
    3. https://fedoraproject.org/w/index.php?title=Releases/19/FeatureList&diff=321788&oldid=320463 looks like the change to FeatureList from last time (adamw, 16:35:27)
    4. https://fedoraproject.org/wiki/Features/ReplaceMySQLwithMariaDB is clearly a significant change but doesn't directly hit the release criteria and it's pretty hard for us to come up with a reasonably scoped test plan (adamw, 16:40:21)
    5. tflink - maybe if we can find a comprehensive mysql benchmark suite and check that runs, it would indicate a good level of compatibility (adamw, 16:41:06)
    6. viking-ice - make sure we cover testing upgrade from f18 to f19 achieves the mariadb swap cleanly (adamw, 16:42:42)
    7. if mysql is to still be available in f19, check it can be installed and used (adamw, 16:48:45)
    8. on predictable network names - check behaviour of firewalld and libvirt, particularly on upgrades; check 'em0' is still used by new scheme (adamw, 16:50:04)
    9. tflink - KScreen might be worth keeping an eye on for KDE validation (adamw, 16:51:45)
    10. https://fedoraproject.org/wiki/Features/SyslinuxOption also worth testing (adamw, 16:52:27)
    11. ACTION: adamw to draft up a kickstart criterion for f19 (adamw, 16:57:10)
    12. consider whether syslinux should come in the subset of blocking kickstart options (adamw, 16:57:29)

  5. open floor (adamw, 17:01:09)


Meeting ended at 17:04:55 UTC (full logs).

Action items

  1. adamw to draft up a proposal for revising the presentation of the release criteria
  2. adamw to draft up a kickstart criterion for f19


Action items, by person

  1. adamw
    1. adamw to draft up a proposal for revising the presentation of the release criteria
    2. adamw to draft up a kickstart criterion for f19


People present (lines said)

  1. adamw (175)
  2. dan408 (63)
  3. Viking-Ice (46)
  4. tflink (38)
  5. kparal (20)
  6. satellit (5)
  7. zodbot (4)
  8. pjones (3)
  9. misc (2)
  10. jskladan (1)
  11. mjg59 (1)
  12. jskladan_ (1)
  13. nb (1)
  14. mkrizek (1)
  15. pschindl (1)


Generated by MeetBot 0.1.4.