16:01:26 <adamw> #startmeeting Fedora QA meeting
16:01:26 <zodbot> Meeting started Mon Mar  4 16:01:26 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:30 <adamw> #meetingname fedora-qa
16:01:30 <zodbot> The meeting name has been set to 'fedora-qa'
16:01:33 <adamw> #topic roll call
16:01:45 * satellit listening
16:01:53 * nirik is lurking in the back
16:02:01 * mkrizek is here
16:03:05 <adamw> where in tarnation is everyone else?
16:03:14 * pschindl is here
16:03:20 * jreznik is here
16:04:11 * Martix is here
16:04:22 * Viking-Ice joins in
16:04:53 <keramidas> #help
16:05:03 <adamw> we all feel like that sometimes'
16:05:26 <keramidas> sorry first time
16:05:32 <adamw> pschindl: any idea where kparal is?
16:05:35 <adamw> keramidas: just kidding :)
16:05:59 <adamw> #chair satellit pschindl
16:05:59 <zodbot> Current chairs: adamw pschindl satellit
16:06:00 <pschindl> adamw: kparal is ill, so probably at home in the bed
16:06:01 <adamw> oh there you are viking
16:06:17 <adamw> ah, so we're missing kparal and tflink. okay
16:06:30 <pschindl> and jskladan is also ill
16:06:38 <Viking-Ice> does not look like a long meeting agenda anyway
16:06:47 <adamw> wow, the plague's hit brno
16:06:53 <jreznik> everyone will be ill in the end of meeting
16:07:06 <Viking-Ice> except those that had the shark
16:07:25 <pschindl> I missed it :(
16:07:49 * jreznik missed it too, maybe that's the reason pschindl and /me are not ill :D
16:07:59 <adamw> #topic Previous meeting follow-up
16:08:00 <adamw> heh
16:08:32 <adamw> sigh. i hate mondays. juggling qa meetings and vomiting cats
16:08:37 <adamw> so easy to mistake one for the other
16:08:53 <adamw> "adamw to push 'automatic blocker' proposal to production" - did that
16:08:54 <Martix> adamw: I may be ~5-10mins late each time from now for next 3 months
16:08:59 <adamw> .fire martix
16:08:59 <zodbot> adamw fires martix
16:09:38 <Martix> adamw: biking between university faculties
16:09:44 <adamw> #info "adamw to push 'automatic blocker' proposal to production" - done: https://lists.fedoraproject.org/pipermail/test/2013-February/114004.html
16:09:57 <jreznik> thanks!
16:10:05 <Viking-Ice> hurray!
16:10:11 <adamw> Martix: c'mon, call up lance armstrong, he has some stuff to help you with that :)
16:10:22 <adamw> yay automatic blockers indeed
16:10:33 <adamw> should reduce the load some for alpha
16:10:55 <keramidas> #commands
16:10:55 <zodbot> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #rejected #restrictlogs #save #startmeeting #topic #unchair #undo #unlurk
16:11:02 <adamw> "adamw to try and gather a bit more feedback on blocker process changes this week" - well, I poked dgilmore and he didn't object
16:11:36 <adamw> i guess at this point we can put those into production, i'm just surprised there were no proposed changes from the tentative ideas from the meeting
16:11:53 <adamw> so anyone have any thoughts on those before i go ahead and stick an action item in?
16:13:00 <Viking-Ice> do you have a link to that discussion so it can be refreshed in peoples mind again
16:13:58 <jreznik> adamw: I like the idea, the description sounds good for me too
16:14:13 <adamw> Viking-Ice: just lemme grab it
16:14:19 <adamw> Viking-Ice: it'
16:14:24 <adamw> it's the stuff about capping at 3hrs etc
16:14:41 <adamw> https://lists.fedoraproject.org/pipermail/test/2013-February/113910.html
16:15:38 <Viking-Ice> there is nothing i think to add to that from us anyway
16:16:15 <Viking-Ice> did you get anyfeed back from -devel/fesco ?
16:16:55 <Viking-Ice> which are probably the only wildcard since releng did not object
16:17:12 <adamw> it's kinda hard to define 'devel'
16:17:32 <adamw> the mail went to devel@ , and no-one said anything
16:17:47 <adamw> so we can count that as acceptance, i think :)
16:17:58 <Viking-Ice> yup ;)
16:18:06 <jreznik> I don't see a reason for objections from devels/fesco
16:18:26 <jreznik> all these automatic blockers would end up on the list
16:19:02 <jreznik> I hope nobody will abuse the system... to propose other bugs this way (and block the meeting again ;-)
16:19:02 <adamw> okay
16:19:27 <adamw> let's go ahead and push the button then
16:19:51 <Viking-Ice> we can always revisit this stuff anyway
16:20:00 <jreznik> yep
16:20:04 <adamw> #info "adamw to try and gather a bit more feedback on blocker process changes this week" - dgilmore seems okay with the changes, no objections from devel or fesco
16:20:16 <adamw> #action adamw to push the blocker meeting changes live this week
16:20:39 <adamw> "viking-ice or adamw to file a trac ticket for the smoke-test-for-spins idea"
16:20:44 <adamw> did you do that, viking? i didn't
16:21:43 <Viking-Ice> nope not yet
16:22:54 <adamw> well, we fail
16:23:04 <adamw> #info "viking-ice or adamw to file a trac ticket for the smoke-test-for-spins idea" - not done yet, back on for next week
16:23:07 <adamw> #action viking-ice or adamw to file a trac ticket for the smoke-test-for-spins idea
16:23:27 <adamw> "tflink to take a look at the question of tracking qa tool discussion and bugs/tickets and make a broad proposal about what to do"
16:23:40 <adamw> so, tim did do that - i was hoping to continue the discussion here, but without tim and kamil it seems a bit pointless
16:24:00 <tflink> I'm here - late but here
16:24:34 <adamw> #info "tflink to take a look at the question of tracking qa tool discussion and bugs/tickets and make a broad proposal about what to do" - proposals made: https://lists.fedoraproject.org/pipermail/test/2013-February/113997.html and discussion is underway
16:24:35 <Viking-Ice> is there anything  left to discuss seperated qa-devel mailing list which is up and running and a seperated trac instance
16:25:40 <adamw> i thought we hadn't made a decision between options 1 and 2 yet.
16:26:13 <Viking-Ice> I'm planning on replacing the fedora-qa trac instance with an actual request tracker
16:26:35 <Viking-Ice> which scales well and is 21 century mobile friendly
16:27:35 <adamw> that would be nice, but we can still improve the trac setup as things stand
16:28:03 <adamw> tflink: did you have any further thoughts on option 1 vs. option 2?
16:28:09 <jreznik> Viking-Ice: that's that "actual request tracker"?
16:28:34 <Viking-Ice> jreznik, not a bug tracker an request tracker there is a difference
16:28:49 <jreznik> specific one?
16:29:20 <tflink> adamw: not a whole lot - it's a question of how much effort separation is worth
16:29:26 <Viking-Ice> jreznik, best practical rt
16:29:27 <tflink> jreznik: I think he's talking about RT
16:31:22 <Viking-Ice> http://www.bestpractical.com/rt/
16:32:11 <adamw> god, they lose many points for me - how can you scare people with an example ticket like "There is no coffee to be found anywhere in the office"? *shivers*
16:32:48 <jreznik> do we have any running instance?
16:32:53 <tflink> with as close as we are to starting up F19 testing, I'm leaning  more towards "leave them in fedora-qa trac" at least until F19 is over
16:32:57 <Viking-Ice> jreznik, nope not yet
16:33:04 <tflink> jreznik: there are several internal instances, I think
16:33:26 <Viking-Ice> tflink, yeah this is F20 item
16:33:39 <adamw> looking back over the thread, it looks like there's no real strong objections to going with the 'keep sharing qa trac for now but direct blocker app ticket mails to the qa-devel list' option
16:33:40 <Viking-Ice> not that it actually matters
16:33:44 * nirik has about 0 desire to support another ticketing system. :)
16:33:54 <jreznik> the thing is with fesco, we are looking for a better way for tracking features, egh. changes
16:33:55 <Viking-Ice> nirik, I will be maintaining this one
16:34:00 <nirik> Viking-Ice: cool.
16:34:06 <adamw> i think we reassured you that the defaultcc plugin wouldn't affect your migration idea, right viking?
16:34:11 <Viking-Ice> had anticipated we dont have knowledge or resource for anything else but trac
16:34:21 <Viking-Ice> from infra
16:34:43 <Viking-Ice> adamw, no I needlessly worried there
16:34:47 <adamw> okay
16:35:00 * jreznik is interested in that wokflow part, should check it
16:35:19 * nirik is also interested in anything we can do to improve trac to meet folks needs better.
16:35:36 <adamw> so i think for now we can just use defaultcc to send the blocker bug tickets to qa-devel , and we can revisit this topic in future a) if anyone is still unhappy with devel tickets being in the QA trac and/or b) when viking's ready to formally propose RT
16:35:47 <jreznik> nirik: that's another option but you know how guys react on just mentioning trac...
16:35:55 <adamw> nirik: the idea of a usable mobile interface is kinda nice.
16:36:00 <tflink> adamw: works for me
16:36:02 <adamw> but not any super high priority for me.
16:36:46 <nirik> sure, can look into it.
16:37:43 <adamw> #agreed for now we will go with the least-invasive option 1: use the defaultcc plugin to send blocker bug app ticket mails to the qa-devel list.
16:37:47 <Viking-Ice> trac is less then optimal as an request tracker
16:37:55 <Viking-Ice> it should die ;)
16:38:14 <adamw> #agreed we can revisit the topic if there turn out to be problems with that, or if someone is unhappy with the volume of development tickets in qa trac, or when viking is ready to propose RT as an alternative tracker
16:38:53 <adamw> okay - so martix has to go do his Tour de University Campus, so I said i'd move open floor up the agenda and the Test Day topic down the agenda to give him time
16:38:58 <adamw> so:
16:39:01 <adamw> #topic open floor
16:39:11 <adamw> anyone have anything to bring up that isn't on the agenda? preferably not involving martix? :)
16:39:41 <Viking-Ice> how  does killing that stupid test day schedule involve him
16:39:51 <jreznik> adamw: have you seen my reply to scheduling blocker bug meetings?
16:40:00 * jreznik changed the day to Wed
16:40:10 <adamw> Viking-Ice: he's doing the test day co-ordination for this cycle
16:40:14 <adamw> he actually added the topic
16:40:45 <Viking-Ice> adamw, I assume on your authority as the team leader for RH Fedora QA
16:40:46 <adamw> #info jreznik changed the QA calendar for F19 to show blocker meetings on wednesdays: http://fedorapeople.org/groups/schedule/f-19/f-19-quality-tasks.html
16:40:57 <adamw> Viking-Ice: nope, on his authority as 'just decided to go do it'
16:41:01 <jreznik> so another topic - scheduling test composes and blocker bug meetings - at least the first ones
16:41:09 <adamw> no-one else volunteered, and it doesn't need any authority, so hey
16:41:28 <adamw> jreznik: ayup?
16:41:42 <jreznik> ?
16:41:49 <adamw> oh, i see.
16:42:07 <adamw> well, first blocker meeting should be wednesday, i guess.
16:42:12 <jreznik> for example test composes are in TJ tight to submission deadline
16:42:20 <jreznik> adamw: agree :)
16:42:33 <adamw> you're suggesting moving TC1 back a week?
16:42:34 * Viking-Ice points out last release cycle we more or less had blocker bug meetings everyday ;)
16:42:37 <adamw> er, forward?
16:42:40 <adamw> er, making it earlier? :)
16:42:44 <adamw> Viking-Ice: let's hope that doesn't happen again ;)
16:42:55 * adamw is generally always in favour of earlier TCs
16:43:36 <jreznik> adamw: well, currently it's Thu 2013-01-17 ;-) as it's scheduled based on feature submission deadline for some reason
16:43:54 <adamw> hm? qa calendar has Test Alpha 'Test Compose' on 03-26
16:44:08 <adamw> releng calendar has "Create Alpha Test Compose (TC)" on same date
16:45:03 * satellit is there something to test atm? (f19) latest smoke netinstall fails http://alt.fedoraproject.org/pub/alt/stage/rawhide-20130301/Fedora/
16:45:03 <jreznik> ah, you're right - I was confused by Create Installable Images for QA testing #1 during the schedule cleanup
16:45:22 * jreznik is trying to cleanup non-senses in the schedule...
16:45:39 <adamw> that's for the RATS stuff i believe
16:45:45 <adamw> which is still hanging around the schedule...
16:45:52 <satellit> ok
16:46:00 * tflink needs to update the BBA so that it's working with the new naming convention and has F19 milestones
16:46:15 <tflink> the production instance, anyways - the code is all there
16:46:17 <jreznik> RATS?
16:46:30 <adamw> Rawhide Acceptance Test Suite or something like that
16:46:36 <jreznik> but I expect I can get rid of it?
16:46:50 <adamw> where we run some (supposedly) automated tests on an iso build
16:46:51 * jreznik has never heard about rats...
16:46:55 <satellit> https://dl.fedoraproject.org/pub/alt/anaconda/  work for f18
16:47:02 <adamw> (but in fact it winds up being some poor intern doing them all manually, so it's like a TC but worse)
16:47:29 <jreznik> ok
16:47:37 <jreznik> sorry for confusion
16:47:38 <adamw> i think last cycle we left one 'rats' run in there as a kind of sanity check
16:47:49 <adamw> just for someone to go through some basic smoke tests on a boot.iso, ahead of tc1
16:48:04 <jreznik> so do we want to continue with that?
16:48:21 <jreznik> (with a different schedule of course)
16:48:58 <jreznik> there's really a lot of stuff nearly nobody has a clue what does it mean anymore... polluting useful milestones
16:49:02 <adamw> yeah, i'm thinking
16:49:14 <adamw> TC1 03-19, RATS 03-12 ?
16:49:30 <adamw> where 'rats' would just be twu or someone going over a boot.iso
16:49:44 <adamw> what do people think of that?
16:49:50 <Martix> back
16:50:07 <adamw> http://fedorapeople.org/groups/schedule/f-19/f-19-quality-tasks.html is the reference for anyone who doesn't have it
16:50:07 <jreznik> it makes sense on 03-12
16:51:02 <adamw> i always wonder why we have the release notes stuff on our schedule, but hey.
16:51:06 <Martix> adamw: historical data states that schedule could be slipped aprox. 2-3 weeks at least :-)
16:51:26 <adamw> Martix: historical data bedamned!
16:51:36 <Martix> but I hope F19 won't :-)
16:52:00 * adamw starts poking people at random and saying 'feedback, damnit'
16:52:06 <Martix> adamw: wiki-history? :-D
16:52:10 <jreznik> adamw: if you don't want RN in a schedule, np
16:52:21 <adamw> jreznik: well i mean, maybe someone knows why it's there
16:52:24 <adamw> viking, any idea?
16:52:55 <jreznik> adamw: that's why I try this cleanup round - it's huge and half of schedule does not make sense even for related teams :)
16:53:01 <adamw> heh :)
16:53:03 <adamw> good idea
16:53:05 <tflink> yeah, it doesn't make a whole lot of sense to have RN in the quality schedule
16:53:22 <adamw> i'm guessing maybe we're supposed to help them go over new features? or something? hell if i knoiw.
16:53:34 <adamw> anyway, we're running short on time here
16:53:55 <adamw> jreznik: can you pencil it in as i suggested (03-19 and 03-12) and i'll try and get more feedback on the list?
16:54:10 <adamw> #action adamw to propose RATS/TC1 dates on the list
16:54:27 <adamw> #action tflink to announce first blocker meeting for wednesday, and get blocker bug tracker app ready
16:54:30 <Viking-Ice> adamw, you mean with RN?
16:54:35 <adamw> Viking-Ice: yeah
16:54:42 <adamw> thought you might remember why it's in our schedule
16:55:26 <Viking-Ice> because we are usually those that needed to fill out those "workarounds" ;)
16:55:37 <Viking-Ice> or had to in the past
16:55:40 <adamw> ah
16:55:44 <adamw> seems kinda obsolete now?
16:55:50 <jreznik> adamw: you can action me too :)
16:55:54 <adamw> or maybe we just forgot :0
16:56:11 <adamw> #action jreznik to pencil in QA changes as discussed
16:56:18 <jreznik> (not to feel bad in the beginning of the meeting for not having any single follow up ;-)
16:56:36 <adamw> #info viking-ice says release notes stuff is in QA's schedule "because we are usually those that needed to fill out those "workarounds" ;) or had to in the past"
16:56:39 <adamw> #topic Test Days
16:56:48 <adamw> sorry for the railroad, just wanted to get onto this before we run out of time
16:57:08 <adamw> so martix says we're nearly out of thursdays but people still want test days
16:57:17 <Martix> yep
16:57:36 <Martix> going to add Tuesdays
16:57:37 <Viking-Ice> kill testday schedule
16:57:45 <pschindl> I don't see any problem with other days
16:57:48 <adamw> we can open up tuesdays, or make it a free-for-all, or allow any day but wednesday, i guess...
16:58:05 <Martix> and Mondays, Fridays...
16:58:05 <Viking-Ice> the period opens at branch time and closes before we start composing final
16:58:13 <adamw> i'm not really opposed, but just for the record, the idea of doing it on thursdays was to try make it a kind of regular 'tune in next week!' thing - get people to come back for more
16:58:14 <Viking-Ice> that's how we intended test day to work
16:58:31 <Viking-Ice> when we set it of
16:58:36 <adamw> i'm not sure we ever quite got people onto that schedule, though, which may be why no-one but me really minds losing it
16:58:37 <pschindl> on TD page is said that Thursdays are only recommended
16:58:39 <jreznik> if Martix is willing to spend the time, I'm ok with any day...
16:58:55 <jreznik> and it's great there's such demand for test days
16:58:59 <adamw> true
16:59:25 <Martix> jreznik: I'm just going to add Tuesday to schedule, I run only Desktop-related Test Days :-)
16:59:28 <adamw> Viking-Ice: i just copy/paste the schedule from release to release, basically - do yell if you see any errors in it
16:59:41 <Viking-Ice> adamw, yes there being schedule et al
16:59:49 <Viking-Ice> we only put one to start with something
16:59:57 <jreznik> any help with schedule needed? ;-)
17:00:04 <Viking-Ice> but already knew if it would take of ( as it has ) it would outgrow it self ;)
17:00:14 <Martix> jreznik: I'm glad we got so many proposals, now we need to do better marketing and attract more users to attend
17:00:21 <adamw> Viking-Ice: well, we need to have the calendar of test days, of course
17:00:34 <jreznik> it's not a bad idea to add test days period to the main schedule
17:00:39 <adamw> it seems like there's a consensus to let test days be any time, so let's go with that
17:00:44 <adamw> jreznik: sure
17:00:59 <pschindl> maybe there shouldn't be anything like "free slot"
17:01:02 <adamw> #agreed let's let test days happen any day the proposer wants
17:01:08 <adamw> pschindl: right, that's what viking is suggesting
17:01:16 <Viking-Ice> what we discussed in the past
17:01:21 <jreznik> (and when it works for QA)
17:01:22 <Viking-Ice> before you guys got all hired
17:01:23 <adamw> and everyone seems fine with it
17:01:41 <adamw> so i just 'agreed' it - we can figure out the details later
17:01:57 <adamw> Martix: do you want an action item to draft up changes to the test day process docs, or shall i?
17:02:09 <Martix> sure, you can
17:02:49 <jreznik> just make sure we do not "over test day" people in one week etc.
17:02:57 <adamw> right
17:03:04 <adamw> but up to the test day co-ordinator to ensure that
17:03:15 <jreznik> some distribution over time makes sense, and yes, it's for coordinator
17:03:26 <Viking-Ice> fyi test event can span more then single day and arguable should ( even thou maintainer can only be present on one single day )
17:03:26 <adamw> #action adamw to draft up changes to the test day process docs to accommodate test days being on any day, test day co-ordinator to ensure they're balanced out
17:03:46 <adamw> Viking-Ice: we have been scheduling more 'test weeks' lately
17:03:55 <adamw> it used to be just graphics, but now we have i18n and networking ones too i think
17:04:03 <Viking-Ice> and there can be more then single test event on the same day
17:04:09 <jreznik> Viking-Ice: it can but it's better for feedback and even marketing to market 1 day with all maintainers around
17:04:40 <Viking-Ice> jreznik, we actually planed to host those days without requiring the presence of an maintainer
17:05:19 <jreznik> Viking-Ice: well, the main marketing around test days is always - somebody would listen to you and it will be developer (in the best case)
17:05:38 <keramidas> may i say something?
17:05:46 <adamw> keramidas: sure, you don't need to ask permission
17:05:48 <jreznik> but even without devs it makes sense and I like more flexibility up to coordinator
17:06:01 <keramidas> hello, i am new here
17:06:05 <adamw> hi, welcome
17:06:17 <Viking-Ice> jreznik, for what purpose is that coordinator ping marketing?
17:06:27 <keramidas> My name is Vasilis ( Bill if you prefer)
17:06:38 <Viking-Ice> we need a calender
17:07:24 <Viking-Ice> for the QA community
17:07:49 <tflink> weren't people working on fedocal stuff for QA?
17:08:08 <keramidas> I am from Greece. I am planning to host a presentation at the Univesity on how to contribute to open source communities. So far i have find a lot of people who are willing to participate
17:08:23 <pschindl> yes. Lukas is working on QA calendar
17:08:26 <adamw> tflink: i poked at the test deployment a bit, it works fine, but the data gets wiped every so often so there's no way to use it for 'production'
17:08:35 <adamw> keramidas: great
17:09:13 <keramidas> I am going to present the Fedora QA. And i believe this is a good way to attract a lot of people to participate at test days
17:09:23 <adamw> keramidas: that would help for sure
17:09:28 <adamw> when is your presentation?
17:10:14 <keramidas> Basicaly how i started to contribute to the QA
17:10:25 <keramidas> and how easy it is
17:10:34 <keramidas> and that anyone should do it
17:11:16 <keramidas> most of the persons i talked think that you have to be a "rocket scientis"
17:11:24 <keramidas> t
17:11:32 <adamw> well, that's a shame
17:11:45 <adamw> let us know if you have any feedback on how to make it less scary
17:13:07 <keramidas> read the wiki, go to the fedora-qa irc and say " Hi, i am new here. How i can help?"
17:13:20 <keramidas> that's how i started
17:13:32 <adamw> yup, that's what we hope people do!
17:13:41 <adamw> okay, we're getting past time now
17:13:57 <adamw> thanks for the feedback everyone
17:14:07 <jreznik> time to play angry birds for adamw? :)
17:14:13 <adamw> #endmeeting