15:08:17 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:08:17 <zodbot> Meeting started Tue Mar  5 15:08:17 2013 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:08:24 <Kevin_Kofler> #meetingname kde-sig
15:08:24 <zodbot> The meeting name has been set to 'kde-sig'
15:08:30 <Kevin_Kofler> #topic Roll Call
15:08:32 <tdfischer> o/
15:08:44 <Kevin_Kofler> Who's present?
15:09:12 * mbriza 's present although won't participate very much
15:09:33 <rdieter> yo
15:09:38 * rnovacek is here
15:09:41 * ltinkl is here
15:09:45 * jgrulich is present
15:10:05 * than is present
15:10:38 <Kevin_Kofler> jreznik: Ping?
15:10:49 * Martix_ is here
15:10:50 * jreznik is here
15:11:46 <Kevin_Kofler> #chair tdfischer mbriza rdieter rnovacek ltinkl jgrulich than Martix jreznik
15:11:46 <zodbot> Current chairs: Kevin_Kofler Martix jgrulich jreznik ltinkl mbriza rdieter rnovacek tdfischer than
15:12:07 <Kevin_Kofler> #info Kevin_Kofler, tdfischer, mbriza, rdieter, rnovacek, ltinkl, jgrulich, than, Martix, jreznik present.
15:12:13 <Kevin_Kofler> #topic Agenda
15:12:20 <Kevin_Kofler> So, what's there to discuss?
15:12:33 <Kevin_Kofler> I suppose we don't have a wiki page yet again, do we?
15:12:44 <than> 4.10.1 status
15:12:46 <rdieter> kde-4.10/f18 status, kde-4.10 for f17 (to do or not)
15:13:10 <Martix> Kevin_Kofler: thanks, I'm just poking around, randomly visited this IRC tab, but I start working tomorrow on KDE 4.10 Test Day: https://fedoraproject.org/wiki/Test_Day:2013-03-14_KDE_4.10
15:13:16 <than> yes, decision for 17 update
15:13:31 <Kevin_Kofler> Let's start with the status report, and then we can talk about F17.
15:13:37 <rdieter> ok
15:13:41 <Kevin_Kofler> #topic 4.10.1 status (Rawhide, F18)
15:14:12 <rdieter> so rawhide is done, f18-kde koji target builds are done and in kde-unstable repo (since ~12 hrs ago)
15:14:44 <rdieter> all that merging is ... time-consuming
15:15:37 <rdieter> anyway, that's all i have, can prepare a f18 bodhi update sometime soon
15:16:05 <Kevin_Kofler> #info rawhide is done, f18-kde koji target builds are done and in kde-unstable repo (since ~12 hrs ago
15:16:22 <Kevin_Kofler> #info rdieter can prepare a f18 bodhi update sometime soon
15:16:42 <rdieter> probably will move stuff to kde-testing prior to bodhi
15:16:53 <Kevin_Kofler> nucleo reported some issues with 4.10.1, but they don't seem to be reproducible. :-(
15:17:31 <Kevin_Kofler> There was also a report on the mailing list from Harald Reindl about 4.10.x messing up his plasmoids, has nobody else encountered that?
15:17:40 <rdieter> right, particularly that plasma didn't start up cleaning on first install after upgrade
15:17:52 <rdieter> s/cleaning/cleanly/
15:18:02 <Kevin_Kofler> I wonder if it's related to ihatethecashew, is anybody (other than him and me) using that?
15:18:07 <Kevin_Kofler> (I haven't tried 4.10 yet.)
15:18:14 <rdieter> Kevin_Kofler: no, I assume that's why there isn't any followup
15:19:03 <Kevin_Kofler> I think we should test it with ihatethecashew then, maybe then we can reproduce it.
15:19:20 <rdieter> drop ihatethecashew :)
15:19:23 <Kevin_Kofler> It might be that ihatethecashew is misbehaving with the changed internals in 4.10 (QMLization).
15:19:35 <Kevin_Kofler> ihatethesuggestionofdroppingihatethecashew ;-)
15:21:18 <rdieter> seriously though, everyone should be thoroughly testing all their favorite plasma bits
15:22:07 <Kevin_Kofler> Looks like upstream is dead, it has been deleted from kde-look.org. :-(
15:22:13 * than installed ihatethecashew
15:22:39 <than> it works fine here
15:23:09 <rdieter> than: probably need to restart your session, the problems all happened on startup
15:23:27 <than> ah ok, i will try it later
15:24:50 <rdieter> move on to f17/kde-4.10 ?
15:26:02 <Kevin_Kofler> #topic 4.10 for Fedora 17
15:26:28 * rdieter asked for more feedback onlist, got one more positive reply
15:27:33 <than> i have installed 4.10 on my f17 machine
15:27:48 <rdieter> I guess i'm tenatively on board with moving forward on f17 too, it'll be a lot of work (again) to merge all the git branches, but I think it'll be worth it too
15:28:10 <than> update from 4.9.5 to 4.10 works withhout any problem
15:28:15 <rdieter> when/if this happens again, will leave the merging task to someone else. :)
15:28:22 <nucleo> I am also using 4.10.0 on F17
15:28:28 <Kevin_Kofler> I'm for it too, I've always been in favor of doing those upgrades. :-)
15:28:37 <nucleo> works the same as in S18
15:28:43 <than> rdieter: i can take care of it :)
15:29:12 <rdieter> jreznik: ?  I recall you and me were the only ones last week not 100% behind the idea, how about now?
15:30:56 <than> jreznik: your  vote please :)
15:33:10 <jreznik> sorry
15:33:12 * jreznik is back
15:34:03 <jreznik> I'm not convinced to do it and even more -1, but consider me 0 - I'm not going to block it
15:34:47 * rdieter is 0 too
15:35:21 <jreznik> but please, be careful :)
15:35:53 <jreznik> kde repo is probably better option for everyone who really wants 4.10 on f17
15:37:16 <Martix> you can push 4.10 to f17-updates-testing only and let users test it first next Thursday
15:37:47 <rdieter> Martix: If we move forward, it will definitely sit in updates-testing for awhile
15:37:47 <Martix> and if something bad happen, drop it from updates
15:37:57 <rdieter> not to be rushed
15:38:13 <Kevin_Kofler> It'll definitely go through testing, we're not going to cheat with the karma and IMHO we should disable autokarma entirely.
15:38:21 <Martix> rdieter: ok, I'm not familliar with your updating schedule :-)
15:38:49 <Kevin_Kofler> But of course the plan is to go stable eventually, testing is not a dumping ground for crap that will never go stable.
15:38:56 <Kevin_Kofler> (I hate maintainers abusing it that way.)
15:39:35 <Martix> just tell me how can I help with 4.10 testing on all affected releases
15:39:37 <rdieter> so, I would've greatly prefered to reach more consensus.  I don't like not having all kde-sig'ers onboard and in favor of this
15:40:42 <than> Martix: what important for testing ist update process from 4.9.5 to 4.10
15:40:58 <rdieter> Martix: we'll be doing f18 for sure, at least.
15:41:15 <Martix> rdieter: than I'm counting with that on f18
15:41:27 <than> the update should work without any deps issue
15:41:58 <Kevin_Kofler> That's the minimum.
15:42:04 <Kevin_Kofler> It should also work without any runtime issue though. :-)
15:42:22 <than> Kevin_Kofler: yes, it's next step :)
15:43:24 <rdieter> So, anyone else share my reservations about having a lack of 100% consensus, or just move forward anyway?
15:44:09 <than> if there's no objecttion i can take care of the f17 build
15:45:32 <rdieter> no objections, fyi, builds in f17-kde tag already include: akonadi-1.9.1-1.fc17, soprano-2.9.0-1.fc17, iris-1.0.0-0.12.20110904svn812.fc17, sip-4.14.4-1.fc17, PyQt4-4.10-1.fc17
15:45:40 <jreznik> rdieter: we are too weak :)
15:46:36 <rdieter> jreznik: maybe.  it's definitely not black or white issue though.  I must admit that pros do seem to outweigh any cons
15:47:28 <rdieter> doing it means less work, better experience for fedora users in the long run
15:49:06 <Kevin_Kofler> So, can I log an #agreed that we're going to do this?
15:49:37 <rdieter> yes
15:50:03 <Kevin_Kofler> #agreed We will be pushing 4.10.1 to Fedora 17.
15:50:16 <Kevin_Kofler> #topic Test Day next week
15:50:28 <Kevin_Kofler> So, anything to say about the test day? Martix?
15:50:51 <Martix> I'm going to update test cases this week
15:51:26 <Martix> proposed list of new test cases would be helpful
15:52:11 <Kevin_Kofler> #action Martix is going to update test cases this week
15:52:18 <Kevin_Kofler> #halp proposed list of new test cases would be helpful
15:52:34 <rdieter> which day exactly?
15:52:40 * rdieter forgets
15:52:42 <Martix> 14 March
15:52:58 <rdieter> ok, thursday, gotcha
15:53:02 <Kevin_Kofler> #info Reminder: The Test Day is on Thursday, March 14, 2013.
15:53:21 <Kevin_Kofler> #topic Open Discussion
15:53:24 <Kevin_Kofler> Anything else?
15:54:46 <nucleo> appmenu-qt can be added somewhere to be installed by default? This feature added in 4.10
15:55:00 <Kevin_Kofler> -1
15:55:19 <Kevin_Kofler> Dragging this in in an update doesn't make sense.
15:55:21 <rdieter> nucleo: will add to comps
15:55:33 <nucleo> for new installations
15:55:37 <Kevin_Kofler> rdieter: But it should stay optional in F17/F18.
15:55:38 <rdieter> that's what we did for f19, install by default, but allow it to be removed
15:55:50 <rdieter> Kevin_Kofler: right, no hard dep
15:56:09 <Kevin_Kofler> I mean optional as opposed to default.
15:56:21 <Kevin_Kofler> (i.e. opt-in rather than opt-out)
15:56:35 <Kevin_Kofler> It doesn't make sense to add default components to comps in an update.
15:56:50 <Kevin_Kofler> People installing later should not get different packages than those who installed at GA and updated.
15:56:56 <rdieter> oh
15:57:04 <nucleo> it useful for small screens as on eeepc gives some more free space
15:57:21 <rdieter> Kevin_Kofler: they're already getting different packages due to packaging differences anyway
15:58:03 <rdieter> anyone else with an opinion for or against making appmenu-qt default in f18 comps ?
15:58:24 <Kevin_Kofler> s/differences/bugs/ then. ;-)
15:58:45 <nucleo> appmenu-qt can be added in 4.10.1 update for F17
15:59:00 <rdieter> nucleo: it's already available to be installed
15:59:08 <rdieter> now
15:59:21 <nucleo> f17-updates-candidate
15:59:24 <rdieter> the issue is whether @kde-desktop comps group should install it by default... or not
15:59:25 <nucleo> http://koji.fedoraproject.org/koji/buildinfo?buildID=397292
15:59:41 <rdieter> oh, oops
16:00:21 <rdieter> i assumed previous maintainer had done so
16:00:39 <nucleo> and this http://koji.fedoraproject.org/koji/buildinfo?buildID=397291 but -2 in f18-updates
16:01:10 <rdieter> notice it's changelog "cosmetics" , update for that is not needed
16:01:49 <nucleo> if -3 will be in F17 then -3 should be also in F18
16:02:14 <rdieter> not sure if appmenu-qt is useful for kde< 4.10, so if we do kde-4.10 then it can be added in the update group, sure
16:02:44 <rdieter> oh, no 2.fc17 build either?  rats, ok, update needed for both then it seems
16:02:57 * rdieter has to go to another appointment
16:02:58 <nucleo> http://koji.fedoraproject.org/koji/packageinfo?packageID=15117
16:03:20 <Kevin_Kofler> We're over time anyway, let's close the meeting here.
16:03:37 <Kevin_Kofler> #endmeeting