15:00:54 <rdieter> #startmeeting kde-sig
15:00:54 <zodbot> Meeting started Tue Mar 12 15:00:54 2013 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:57 <rdieter> #meetingname kde-sig
15:00:57 <zodbot> The meeting name has been set to 'kde-sig'
15:01:04 <rdieter> #topic roll call
15:01:11 <rdieter> hi all, who's present today?
15:01:20 * dvratil is here
15:01:22 * mbriza is present
15:01:23 * Martix is
15:01:23 * ltinkl is here
15:01:29 <jgrulich> present
15:01:40 <than> present
15:01:48 <Kevin_Kofler> Present.
15:02:12 * jreznik is (not) present
15:02:31 <rdieter> heh
15:02:47 <Kevin_Kofler> LOL, it's always fun when people report themselves absent. ^^
15:02:54 <rdieter> #info rdieter dvratil mbriza Martix ltinkl jgrulich Kevin_Kofler jreznik(not) present
15:03:07 <rdieter> #chair dvratil mbriza ltinkl jgrulich Kevin_Kofler jreznik
15:03:07 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik ltinkl mbriza rdieter
15:03:17 <rdieter> #info than present
15:03:19 <rdieter> (sorry)
15:03:21 <rdieter> #chair than
15:03:21 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik ltinkl mbriza rdieter than
15:03:25 <rdieter> #topic agenda
15:03:42 <Kevin_Kofler> 4.10(.1) blocker review
15:04:13 <rdieter> ok, will do that separate of : kde-4.10.1 update status, kde 4.10 test day (thu)
15:05:59 <rdieter> ok, that looks enough for now. :)
15:06:06 <rdieter> #topic kde-4.10.1 update status
15:06:31 <rdieter> current status is f18 bodhi update, has been out awhile, already received a good deal of positive feedback/karma
15:06:46 <rdieter> f17 stuff just got pushed out yesterday/last-night
15:07:44 <rdieter> I suppose that's about it.  any comment or feedback on that?  else, we can move on to blocker review...
15:09:05 <rdieter> moving on...
15:09:15 <rdieter> #topic kde-4.10 blocker review
15:09:35 <rdieter> see https://bugzilla.redhat.com/show_bug.cgi?id=kde-4.10
15:10:46 <Kevin_Kofler> So there are 3 items on the blocker:
15:10:49 <rdieter> remaining open issues include: kmix memleak (not entirely sure if it's kde-4.10 specific?), qaccessibilityclient review, plasmate review
15:10:51 <Kevin_Kofler> .bug 912457
15:10:55 <zodbot> Kevin_Kofler: Bug 912457 Kmix eats a lot of memory - https://bugzilla.redhat.com/show_bug.cgi?id=912457
15:11:15 <Kevin_Kofler> This one doesn't sound like a regression to me, nor like a blocker even if it were one IMHO.
15:11:16 <jgrulich> can someone test if this happens even in KDE 4.9? ^^^
15:11:27 <Kevin_Kofler> I propose we take this off the tracker.
15:11:53 <Kevin_Kofler> The other 2 are reviews which are waiting for a reviewer.
15:12:07 <mbriza> yes, kmix is acting weird in 4.10
15:12:10 <Kevin_Kofler> plasmate now includes plasmoidviewer which used to be in kde-workspace and which people might miss.
15:12:48 <Kevin_Kofler> And qaccessibilityclient is a new dependency of kmag. I guess it doesn't absolutely have to go out with 4.10, though it would have been nice!
15:12:51 <rdieter> I suppose I would probably consider all of these 3 closer to "nice to have" rather than blockers
15:13:51 <rdieter> though, still would be nice to get the low-hanging fruit (pkg reviews) done sooner rather than later
15:13:59 <Kevin_Kofler> Is qaccessibilityclient in kmag used for NEW functionality or for stuff which was previously done differently?
15:14:23 <rdieter> good question, i'd guess new functionality as it is a new dependency
15:14:23 <Kevin_Kofler> If it's new functionality, it's not a blocker, it just sucks not to have it.
15:14:55 <rdieter> it still works like it used to as far as I can tell
15:15:29 * Kevin_Kofler is checking projects.kde.org history for kmag.
15:16:33 <Kevin_Kofler> It's existing functionality! https://projects.kde.org/projects/kde/kdeaccessibility/kmag/repository/revisions/953e32917fe3a8a640b3338c6e4d75c3ad9a5f44/diff
15:16:48 <Kevin_Kofler> Code using org.kde.kaccessibleapp directly was replaced.
15:16:51 <Kevin_Kofler> So it's a blocker IMHO.
15:17:21 <rdieter> ok
15:18:09 <rdieter> that one should have priority then
15:18:59 <Kevin_Kofler> Mouse focus tracking is a quite important feature for KMag.
15:19:19 <Kevin_Kofler> plasmate is also really about existing functionality (plasmoidviewer).
15:20:15 <Kevin_Kofler> Do we have any volunteer for the review? Or do I have to consider myself "volunteered", just in the interest of getting this done?
15:21:15 * rdieter can't review his own pkg submissions :)
15:22:14 <Kevin_Kofler> I know (and this is a very broken thing in the policies, why do experienced packagers like you and me go through the review process?).
15:22:46 <Kevin_Kofler> Our policies put way too little trust in us packagers and too much in silly bureaucracy which just slows everything down.
15:23:05 <Kevin_Kofler> *have to go through
15:24:02 <rdieter> I don't mind it, reviewers have caught lots of oversights and mistakes
15:24:32 <Kevin_Kofler> If nobody beats me to it, I'll be doing the reviews ASAP, probably today or tomorrow. (But it's been ages since I last did a review, so my checklist is probably way out of date. :-( )
15:24:35 <rdieter> that said, I'd like to think reviewing my submissions would hopefully be easier
15:25:39 <Kevin_Kofler> I'll do qaccessibilityclient first (because kmag needs to be rebuilt and edited into the update).
15:25:58 <rdieter> ok, move on then?
15:26:07 <rdieter> any final comments?
15:26:14 <Kevin_Kofler> Log an #action to hold me responsible later? :-)
15:26:36 <rdieter> #action Kevin_Kofler commits to doing qaccessibilityclient pkg review, yay
15:26:56 <ltinkl> Kevin_Kofler: fedora-review is a nice tool for that ;)
15:27:03 <jreznik> action Kevin_Kofler to being responsible for everything from now to the end of the world :)
15:27:21 <rdieter> #topic kde 4.10 test day
15:27:28 <Kevin_Kofler> ltinkl: I at least used to never trust checklists I didn't write. ;-)
15:27:45 <ltinkl> Kevin_Kofler: this one is quite comprehensive :)
15:28:08 <rdieter> got test day coming up on thursday, https://fedoraproject.org/wiki/Test_Day:2013-03-14_KDE_4.10
15:28:49 <Martix> yep
15:28:50 <rdieter> let's make sure we have a good presence on hand to help steer testers around, and triage things
15:29:22 * rdieter will definitely be around most of thursday
15:29:42 * ltinkl too
15:29:45 * jgrulich as well
15:30:05 <rdieter> and, any additional test-cases you can think of
15:30:08 <ltinkl> let's hope we get some real testers as well xD
15:30:09 * dvratil will be available later afternoon
15:30:17 <mbriza> i'm not sure yet, depends on the weather :)
15:30:22 <ltinkl> haha
15:31:01 * rdieter seens no kscreen related test cases yet
15:31:12 <Martix> last week I was busy, I'll update test cases today and tomorrow, but feel free to help
15:31:13 <rdieter> and https://fedoraproject.org/wiki/QA:Testcase_KDE4_Printer  still refers to deprecated stuff
15:31:37 <rdieter> anyone able to help update that for kde-print-manager?
15:32:11 <Martix> we have another problem - F19 images, nightly builds are failing due to MySQL to MariaDB migration
15:32:15 <rdieter> (if not, probably best to just remove that test-case)
15:32:16 * dvratil will add kscreen testcases
15:32:25 <Kevin_Kofler> mbriza: The weather will be bad, you'll have plenty of time. :-)
15:32:29 <mbriza> literally, if it's freezing, I'll be present in the afternoon and if it's not, in the morning...
15:32:37 <Martix> I'll try to disable mysql in kickstart and build own images
15:32:39 <rdieter> Martix: that too. :(  We *hope* the compose will go better tonight
15:32:46 <Martix> rdieter: great
15:33:20 <rdieter> MySQL maintainer changed library sonames to help, but the latest image compose didn't pick up the new MySQL build yet
15:33:38 <mbriza> Kevin_Kofler: uhm... i hope it will be, i'm going home for the weekend, finally, hopefully will spend rest of the week skiing :)
15:33:45 <rdieter> dvratil: thanks!
15:33:54 <Kevin_Kofler> Martix: -MySQL* in the kickstart does not help because it's not dragged in by the kickstart, but by deps.
15:33:58 <rdieter> #action dvratil will add kscreen test cases
15:34:07 <Kevin_Kofler> It would need a yum-level --exclude.
15:34:17 <Martix> my availability on Thurday is 13-19 UTC at least
15:34:19 <Martix> Kevin_Kofler: ok
15:34:23 <Kevin_Kofler> But if Amarok is not rebuilt against mariadb-embedded yet, it'll also fail with the --exclude.
15:34:35 <rdieter> Kevin_Kofler: it is, I confirmed
15:34:41 <Kevin_Kofler> (-embedded has a new soname in MariaDB.)
15:34:52 <Martix> I'm going to ask other QE to help cover whole day
15:35:17 <Martix> dvratil: thanks for covering KScreen
15:35:38 <dvratil> np
15:38:19 <Martix> note about printing: there is planned 2013-04-04 	Printing Test Day, but it's run by baseOS QE for CUPS
15:39:08 <rdieter> cool, might be nice to coordinate and participate there too
15:40:26 <Martix> right, I can ask jpopelka and move printer desktop test cases here
15:40:41 <jpopelka> Martix: sure
15:40:53 <Martix> jpopelka: great :-)
15:41:53 <Kevin_Kofler> But it can't hurt to test kde-print-manager in the 4.10 test day either.
15:42:00 <Martix> jpopelka: both KDE and Gnome, it think it can attract more users to your test day
15:42:15 <Kevin_Kofler> It's new in upstream 4.10, we've been shipping it already in F18, but in F17, it'll be new for us too.
15:42:39 <Kevin_Kofler> Of course it makes sense to test it also on the printing test day.
15:42:40 <Martix> Kevin_Kofler: sound reasonable because of updates
15:43:38 <rdieter> Martix: I can't find it on https://fedoraproject.org/wiki/Category:Test_Days , is there a wiki page for the printing test day yet?  If so, where?
15:44:04 <Martix> rdieter: here https://fedoraproject.org/wiki/QA/Fedora_19_test_days
15:44:22 <jpopelka> I think not yet
15:44:23 <Martix> not in category yet, only for F18
15:44:36 <rdieter> ok
15:45:00 * rdieter is going to ping dannti (upstream dev for kde-print-manager if he'd be interested in being around then too)
15:45:14 <Martix> one last think for KDE Test Day - marketing
15:45:31 <Martix> we need news, announcement (I take this) and blogs
15:45:47 <Martix> I mean announcement on fedora-test and fedora-devel
15:45:47 <rdieter> cool, I spammed facebook already, https://www.facebook.com/events/410409435717523/
15:46:11 <dvratil> do we have G+ event? it's easier to invite more people there
15:46:12 <Martix> something on kde.org would be very helpful
15:46:29 <rdieter> dvratil: not yet, would be nice though, yes
15:47:08 <Martix> and I'm going to poke Phoronix
15:47:10 * rdieter will blog today about it
15:47:35 * Kevin_Kofler is scared of the flood of bug reports from the test day, wonders whether we have the resources to fix all the bugs that will be coming in, especially if you're going to advertise it on all the news sites. :-(
15:48:27 <Martix> Kevin_Kofler: thats why we do this, right? :-)
15:48:45 <dvratil> Kevin_Kofler, we can always upstream something ;-)
15:49:20 * dvratil wonders why G+ works so bad in Firefox
15:49:26 <jreznik> well I'd really like to see more fixes as direct outcome, not just upstreaming
15:49:33 <Martix> I prefer reporting bugs to upstream (kde.org) bugzilla
15:49:50 <jreznik> and with bigger KDE team, it could be more feasible :)
15:50:11 <rdieter> well, step 1 to fixing problems, is to become aware of them.
15:50:30 <rdieter> Kevin_Kofler: would you rather not know?  :)
15:51:01 <rdieter> but yeah, bug report floods are... sometimes daunting
15:51:09 <Kevin_Kofler> Yes, because then if users complain, I tell them, I didn't know, it's not my fault. ;-p
15:51:30 <Martix> :-D
15:51:37 <rdieter> cover your ears, and say loudly "la la la"... works for me.
15:52:32 <Kevin_Kofler> But yes, getting bug reports is good if we're actually fixing them.
15:52:56 <Kevin_Kofler> If they only get lost, it won't help anybody, just waste the testers' time. :-(
15:53:07 <Kevin_Kofler> So I hope we won't be overwhelmed.
15:53:36 <rdieter> true.  part of our "triaging" job is to help identify big/important issues, and indeed, make sure they don't get lost
15:54:41 <rdieter> and, everything else has to resort to a best effort.
15:54:51 <Martix> as long as I send reports from Test Day to various lists, no bug should get "lost"
15:55:01 <Kevin_Kofler> Speaking of being overwhelmed, yet another incoming ABRT report of an Akonadi crash.
15:55:28 <Kevin_Kofler> Those ABRT reports generally go nowhere. I find ABRT to cause more problems than it solves, sadly. :-(
15:55:51 <rmarko> Kevin_Kofler: why?
15:56:36 <Kevin_Kofler> Because 1. the reports end up in our Bugzilla, not upstream's, 2. they often have insufficient data and 3. their reporters tend to be totally unhelpful and uncooperative (fire&forget reporting).
15:57:01 <Kevin_Kofler> At least in KDE land most crashes get caught by KCrash/DrKonqi which reports them directly upstream.
15:57:12 <Martix> because I can and others can look at these reports later, for example adamw publish statistics of closed bugs from previous X Test Week with report from current X Test Week
15:57:41 <Kevin_Kofler> But we still get ABRT reports from non-GUI stuff like Akonadi or Nepomuk, from users who went out of their way to disable DrKonqi (yes, I've seen a couple reports like that) or from DrKonqi itself crashing (ouch!).
15:57:48 <Martix> I'm thinking about same statistics for more Test Days, inc. KDE
15:57:55 <Kevin_Kofler> And even those are too many for us to handle. :-(
15:58:32 <rdieter> Kevin_Kofler: nod, it's a matter of prioritizing.
15:58:44 <Kevin_Kofler> For other packages which are not using DrKonqi, it was much worse. I gave up trying to maintain Gnash because it got dozens of ABRT reports per month!
15:58:51 <rmarko> Kevin_Kofler: we are trying hard to handle reports on our server which should help maintainers to prioritize
15:58:54 <rmarko> .. https://retrace.fedoraproject.org/faf/
15:58:58 <rdieter> bz doesn't necessarily make it easy to wade through/ignore abrt-generated items though
15:59:16 <rdieter> rmarko: that is nice, indeed
15:59:35 <Kevin_Kofler> rmarko: Unfortunately, even the frequency of reporting is not always a good indicator of the true priority. See e.g.:
15:59:38 <Kevin_Kofler> .bug 711719
15:59:44 <zodbot> Kevin_Kofler: Bug 711719 [abrt] kdeutils-printer-applet-4.6.3-1.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.47" is not allowed to own the service "com.redhat.NewPrinterNotification" due to security policies in the c - https://bugzilla.redhat.com/show_bug.cgi?id=711719
16:00:04 <Kevin_Kofler> (my favorite one, which fill finally be fixed by F17 also moving to kde-print-manager from kde-printer-applet).
16:00:08 <Kevin_Kofler> *will
16:00:37 <mbriza> btw, i'd like to discuss switching to lightdm but it seems we ran out of time
16:00:45 <Kevin_Kofler> That's a completely harmless Python exception being thrown when you try to run kde-printer-applet without having access to the printer (e.g. over VNC).
16:00:50 <Kevin_Kofler> It got bazillions of duplicates.
16:01:08 <Kevin_Kofler> It's still IMHO not a bug at all, and surely not something worth a high priority.
16:01:25 <rmarko> Kevin_Kofler: when something like this happens send us that bug so we can check why duplicate detection is failing
16:01:46 <Kevin_Kofler> rmarko: Duplicate detection fails on that one because the D-Bus connection has a different number each time.
16:02:00 <Kevin_Kofler> But new bugs or new comments, it'd be annoying either way. :-)
16:02:03 <rmarko> I see
16:02:05 <rdieter> mbriza: ok, onlist or next week perhaps?
16:02:20 * rdieter would prefer discussing on mailing list initially
16:02:44 <Kevin_Kofler> mbriza: -1, what's wrong with KDM?
16:03:36 <rdieter> let's not discuss it here/now, we're out of time
16:03:44 <rdieter> thanks everyone!
16:03:50 <rdieter> #endmeeting