15:01:27 <adamw> #startmeeting Fedora QA meeting
15:01:27 <zodbot> Meeting started Mon Mar 18 15:01:27 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:31 <adamw> #meetingname fedora-qa
15:01:31 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:34 <adamw> #topic roll call
15:01:45 <adamw> roll up, roll up, for the qa meeting
15:01:46 * jreznik is still here, from meeting, to meeting
15:01:58 * tflink is here
15:02:11 * mkrizek is here
15:02:14 * pschindl is here
15:03:24 * spoore is lurking
15:03:52 * nirik is lurking as well
15:03:53 * kparal joins
15:04:20 <adamw> morning everyone
15:04:37 * adamw wonders what happened to our favourite viking lately
15:04:45 <adamw> longboat got raided?
15:04:51 <tflink> pillaging, most likely :-D
15:05:27 * Martix is here
15:06:00 <adamw> hehe
15:06:01 <Martix> adamw: lol
15:06:03 <adamw> okey dokey
15:06:09 <adamw> #topic previous meeting follow-up
15:06:22 <adamw> so just one item this week
15:06:33 <adamw> "jreznik to ink in the proposed image schedule, and add a Test Day entry"
15:06:48 * satellit_e joins late -listening
15:07:02 <jreznik> Test Day entry is added, schedule updated
15:07:13 <jreznik> #link http://fedorapeople.org/groups/schedule/f-19/f-19-quality-tasks.html
15:07:20 <jreznik> #link http://fedorapeople.org/groups/schedule/f-19/f-19-releng-tasks.html
15:07:36 <jreznik> ambassadors also asked for Test Days Reminder
15:07:46 <jreznik> (week before test days starts)
15:08:20 <adamw> thanks!
15:08:24 <adamw> #info this was done, see links above
15:08:31 <jreznik> please review the changes, in schedule, everything depends on everything and especially cutting out release candidates was... like rewriting it from scratch :)
15:08:50 <adamw> we'll make sure it just says 'vacation' for six months
15:09:06 * jreznik is going to update schedule with vacations :)
15:09:22 <adamw> #topic Fedora 19 Alpha status
15:09:37 <adamw> so...we were supposed to do RATS last week, that didn't happen because the tree's still too ropey
15:09:46 <adamw> i went to build a test image and could not get one that worked
15:10:15 <adamw> there have been some fixes for various things since friday and i'll keep bashing, but f19 tree doesn't appear to be in particularly great shape right now
15:10:22 <jreznik> do you know what everything is broken and makes it impossible to compose it?
15:10:24 <kparal> I'm trying to build an image too. no success
15:10:26 <adamw> anyone else have experience trying to build images?
15:10:35 <kparal> but still struggling
15:10:46 <adamw> kparal: cool
15:10:53 <adamw> so I think just about everything on the blocker list is affecting us - http://qa.fedoraproject.org/blockerbugs/milestone/19/alpha/buglist
15:10:53 * satellit_e mine  with live cd tools have not worked
15:10:54 * tflink hasn't tried yet
15:11:25 <jreznik> btw first TC is planned for tmrw, maybe asking for it officialy (as it's TC) could lead to more push on fixing stuff
15:12:00 <adamw> well, I know harald and bcl are already kinda focused on it
15:12:16 <adamw> actually let's see if we can pull them in
15:13:59 <jreznik> should we go through the list one by one? yes, it will be mini blocker review... :(
15:14:19 <tflink> jreznik: we said no blocker reviews during QA meetings for 19
15:14:43 <tflink> it makes them harder to keep track of and makes the QA meetings longer
15:14:47 <adamw> hmm, looks like they're not around
15:14:55 <adamw> right, we'll do the blocker review proper on wednesday
15:15:07 <adamw> i just wanted to note it as it hits a lot of the issues affecting composes
15:15:20 <Martix> it also affects Gnome Test Day
15:15:26 <jreznik> tflink: I know, we said no - but we should move with composes...
15:15:30 <Martix> Wednesday is late
15:15:41 <adamw> that's next in the schedule.
15:15:46 <adamw> er, later in the schedule.
15:15:52 <adamw> agenda.
15:15:53 <Martix> I know
15:15:55 <adamw> MEETING LIST THINGY
15:16:22 <Martix> my point is, we need to talk to them today
15:16:25 <adamw> yes
15:16:28 <adamw> i'll do that
15:16:33 <Martix> here or elsewhere :-)
15:16:34 <Martix> ok
15:16:37 <adamw> kparal: so where are you stuck on image compose?
15:17:30 <kparal> adamw: livecd-creator throws lots of errors when you run it on F18. I talked to bcl and he told me I have to use the same Fedora release, otherwise the result is not guaranteed
15:17:41 <adamw> kparal: right, that's how i've always done it
15:17:56 <kparal> so I installed F19 today, but I wasted an hour fighting with NFS, it seems to be completely broken
15:17:57 <adamw> i actually just set up a VM to use for image builds
15:18:05 <kparal> so now I'll be running livecd-creator on F19
15:18:25 <tflink> yeah, I usually have VMs set up for the smoke builds
15:18:31 <adamw> okay, so you don't have any further data on borkage issues
15:18:39 <kparal> no, sorry
15:18:47 <adamw> okay
15:18:50 <kparal> but we know that gdm is broken, even if we succeed in composing it
15:18:52 <adamw> i guess i'm in pole position on that one
15:19:13 <adamw> that seems to have been reported by multiple people for fresh images/installs, yeah
15:19:21 <adamw> my 'live' f19 system doesn't have gdm problems, though...
15:19:44 <adamw> so i guess i'll be working on this this week!
15:19:58 <adamw> does anyone else have useful data on the f19 state that hasn't been brought up yet?
15:20:00 <kparal> I used F18 anaconda to install F19 gnome, and it is broken. I even updated to latest Rawhide, still broken
15:20:06 <kparal> (gdm)
15:20:32 <kparal> but I haven't reported it yet, or looked for it
15:20:48 <kparal> Martix: have you succeeded in finding the gdm bug?
15:20:52 * satellit_e I got lucky with KDE test day instructions and got f20 KDE....?
15:21:20 <Martix> kparal: that was clutter
15:21:25 <Martix> its already fixed
15:21:42 <adamw> Martix: https://bugzilla.redhat.com/show_bug.cgi?id=917246 doesn't seem to have that info
15:22:08 <adamw> is there another bug?
15:22:25 <kparal> Martix: is it already pushed to F19?
15:22:28 <Martix> that another bug
15:22:46 <Martix> kparal: yes, I verified it on Friday on my F19 machine
15:23:16 <kparal> so we have multiple bugs here
15:23:34 <Martix> kparal: try disable gnome-initial-setup or remove it as in #6 comment
15:23:46 <jreznik> Martix: isn't the clutter one related to wayland support?
15:23:56 <Martix> jreznik: it was
15:24:40 <Martix> jreznik: well, on Friday I have distro-synced form Rawhide (F20) to F19 and verified that GDM/Gnome works
15:25:00 <Martix> #917246  seems to be related to gnome-initial-setup
15:25:28 <adamw> Martix: what was the bug # for the other one?
15:26:02 <Martix> adamw: no #, I wasn't able to reproduce it on synced F19
15:26:14 <jreznik> I'd say it was combination of all issues and people were/are hitting all of them/or part of them
15:26:16 <adamw> okay.
15:26:28 <jreznik> the wayland one was discussed on ml
15:27:42 <Martix> kparal: try to remove gnome-initial-setup and reboot
15:27:50 <adamw> #action adamw to work with developers on getting F19 images to bootable state
15:28:07 <kparal> Martix: thanks, I will, just not right now
15:28:31 <Martix> kparal: ok, if it'll work, we have at least workaround
15:28:56 * jreznik will try to help adamw
15:29:15 <Martix> but also we lose one critical path Gnome compent for Test Day
15:29:16 <jreznik> so do we want to request TC tmrw? to raise it "officially"?
15:29:19 <adamw> #info we have possible issues in image compose, dracut, selinux and gnome-initial-setup
15:29:40 <adamw> jreznik: wait and see. i don't think we need to play that kind of game and i'd rather not waste releng's time unless it's really necessary.
15:30:23 <adamw> #info TC1 supposed to be tomorrow, GNOME test day on Thursday: we need images
15:31:18 <jreznik> ok
15:31:25 * jskladan hates the snow calamity...
15:31:42 <kparal> jskladan: welcome the spring
15:31:44 <tflink> snow calamity?
15:31:48 <Martix> same here
15:32:06 <kparal> it's a snow blizzard out here :)
15:32:15 <tflink> it's  I see palm trees outside - no snow
15:32:39 <Martix> tflink: that was 14 days ago
15:32:46 <adamw> #topic criteria re-design
15:33:01 <adamw> so sorry to throw this on the list again, but I did put the beta draft out this week
15:33:21 <adamw> and i figure now is a good time for an go/no-go on whether to use the rewritten criteria for F19
15:33:55 <adamw> we've only done one blocker review so far with like two bugs in it, but if we want to switch we should probably do it before the next review meeting and tc1
15:34:08 <tflink> yeah, that makes sense
15:34:17 * jreznik likes generally likes it - see my latest comment, not sure about contingency part wording
15:34:51 <jreznik> and if we go with it now, it does not mean it will be set in stone
15:35:00 <jreznik> let's see how it works earlier than later
15:35:03 <kparal> adamw: are you referring to the new format or the new wording right now?
15:35:28 <adamw> kparal: as a practical matter, both, though we can tweak the layout as we go along
15:35:45 <adamw> note i went with the header style from your proposals that most people liked
15:35:45 <kparal> I like the new layout and I haven't studied the wording changes in much detail
15:36:13 <adamw> did people get a chance to look over the beta partitioning stuff? that's probably the most significant practical wording change
15:36:28 <adamw> all the other wording means pretty much what it did before, there's no big _practical_ change
15:36:40 * jreznik was more looking on the layout more than wording too
15:37:23 <adamw> well review on the wording is welcome to catch anywhere i messed up :)
15:37:51 <kparal> that means we all trust adamw and will burn him at a stake later, if we discover a problem
15:38:53 <tflink> kparal: if you ever wondered why people don't usually volunteer to submit criteria revisions ...
15:39:27 <jreznik> it's hard to review it "theoretically" - would be better to see it in action - especially when the revamp is quite big
15:40:01 <adamw> jreznik: sure, it's always nice to catch whatever you can ahead of time though
15:40:08 <adamw> okay, sounds like we're in favour of giving the new layout a shot?
15:40:12 <tflink> jreznik: it would be nice to minimize the changes during freeze, though
15:40:14 <tflink> yep
15:40:46 <jreznik> tflink: we still have some time before freeze
15:41:09 <tflink> jreznik: true, but the criteria wording seem to get the most active workout during freeze
15:41:20 <jreznik> also true
15:41:54 <adamw> welp, everyone take a look at it.
15:42:00 * jreznik will take a more closer look
15:42:09 <adamw> #agreed general agreement to give the new criteria a shot for Alpha
15:42:16 <jreznik> but overally - I'm in favor of the new layout
15:42:28 <tflink> adamw: I dunno, the idea of burning someone at the stake if there are mistakes is kind of tempting ... :-P
15:42:32 <jreznik> and I really like that diff section against alpha
15:42:34 <adamw> grr
15:44:06 <adamw> jreznik: thanks
15:44:20 <adamw> okay, anything else on criteria before moving on?
15:45:32 * jreznik has nothing to add right now
15:46:35 <adamw> #topic Test Days
15:46:45 <adamw> so, we more or less got the KDE test day off, though it was a bit chaotic
15:46:52 <adamw> and we had to use F18+KDE 4.10 images, not F19 images
15:47:05 <adamw> any thoughts on the kde test day martix?
15:47:14 <Martix> some people managed to upgrade to F19
15:47:38 <Martix> adamw: we need upstream announcement on kde.org next time
15:47:56 <adamw> yeah, it's good to get wider press for the big test days
15:48:08 <adamw> though actually if it's going to be a gong show like the kde one maybe not :)
15:48:10 <jreznik> Martix: at least it was on planetkde.org
15:48:17 <Martix> I asked pkovar to push some annoucements on gnome.org and worldofgnome.org for next Test Day
15:48:31 <adamw> i usually poke phoronix and a few other general news sources as well
15:48:50 <jreznik> for the freebsd kernel test day?
15:48:59 <Martix> I poke Phoronix on every Test Day I organize
15:49:05 <adamw> cool
15:49:06 <Martix> jreznik: except that, of course :-D
15:49:14 <tflink> jreznik: ooh, was that an accepted feature?
15:49:41 <jreznik> tflink: FeatureAcceptedJoke - my new category :)
15:50:09 <Martix> tflink: it's going to be reproposed in future
15:50:19 <Martix> as a real feature!
15:51:26 <Martix> waiting for Debian's kfreebsd move and ArchBSD, then pull systemd changes to upstream (Fedora)
15:51:34 <Martix> back to Gnome
15:51:37 <adamw> good grief.
15:51:54 <adamw> so i think i need to sync up with the gnome team today and have a fallback plan if we can't get working images
15:52:02 <adamw> but we'll hope to have images working tomorrow
15:52:06 <adamw> gnome itself seems pretty solid to me
15:52:21 <Martix> adamw: please use this ticket: https://fedorahosted.org/fedora-qa/ticket/339
15:52:22 <adamw> fallback plan might be to build f18-based images if feasible, or else to delay
15:52:24 <adamw> will do
15:52:31 <adamw> but i'll chat in irc first, it's faster
15:52:37 <Martix> ok
15:52:59 <jreznik> for the next time - we should plan these big test days a little bit later - not right after branch
15:53:31 <Martix> jreznik: Gnome explicitly asked for TD before their final release
15:54:03 <Martix> close to upstream philosophy :-)
15:54:06 <jreznik> Martix: I'm not saying too late, but later after branch to have some buffer to make sure it will compose
15:54:26 <jreznik> and history says - it takes some time every release
15:54:28 <adamw> jreznik: we're somewhat out of sync with both gnome and kde cycles after than f18 delay
15:54:29 <adamw> that's the problem
15:54:34 <Martix> jreznik: yeah, I was expecting some problems
15:54:43 <Martix> adamw: +1
15:55:13 <jreznik> adamw: even the question is, if we can get in sync anymore - with the way how fesco wants to schedule releases...
15:55:26 <adamw> not my problem!
15:55:41 <adamw> looks like hard freeze for 3.8 is in a week, so we really didn't have much flexibility in scheduling the test day.
15:55:49 <Martix> jreznik: I'd like to see F20 final on 10th years anniversary
15:56:29 <jreznik> adamw: fair enough - just saying, we know we usually hit problems right after branch...
15:56:43 <adamw> heh.
15:56:46 <jreznik> does not make sense to change it now
15:57:04 <adamw> #action adamw to work out a fallback plan with desktop team if we cannot get working images by wednesday
15:57:14 <jreznik> thanks adamw
15:57:23 <adamw> #topic Open floor
15:57:27 <adamw> anything for open floor, folks?
15:58:08 <tflink> not sure if it's hugeley important but I'm going to be mostly AFK this week at the pycon sprints
16:02:01 <adamw> tflink: roger
16:02:13 <adamw> #info tflink will be AFK much of the time at pycon this week
16:03:44 <adamw> anything else?
16:04:43 <jreznik> nothing from me
16:05:09 <adamw> alrightly
16:05:12 <adamw> thanks for coming everyone!
16:05:21 <adamw> same time same place next week, if f19 hasn't consumed us all
16:05:31 <tflink> RUN AWAY!!!!
16:05:36 <tflink> :)
16:06:03 * kparal hides
16:12:09 <kparal> adamw: endmeeting?
16:12:43 <adamw> doh
16:12:45 <adamw> #endmeeting