06:03:03 <tagoh_> #startmeeting i18n
06:03:03 <zodbot> Meeting started Thu Mar 21 06:03:03 2013 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:03:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:03:03 <tagoh_> #meetingname i18n
06:03:03 <zodbot> The meeting name has been set to 'i18n'
06:03:04 <tagoh_> #topic agenda and roll call
06:03:04 <tagoh_> #link https://fedoraproject.org/wiki/I18N/Meetings/2013-03-21
06:03:08 <epico> hi
06:03:10 <tagoh_> okay, shall we have i18n meeting
06:03:14 <mfabian> Hi!
06:04:39 <juhp> hi
06:05:13 <paragan> hi
06:07:27 <fujiwarat> hi
06:07:28 <pravins> hi
06:07:58 <tagoh_> okay, let's get started.
06:08:10 <tagoh_> #topic Upcoming schedule
06:08:10 <tagoh_> #info 0213-03-21        [[Test_Day:2013-03-21_Gnome_3.8]]
06:08:10 <tagoh_> #info 2013-04-02        Branch Freeze
06:08:10 <tagoh_> #info 2013-04-02        Software String Freeze
06:08:11 <tagoh_> #info 2013-04-02        Alpha Change Deadline
06:08:11 <tagoh_> #info 2013-04-11        [[Test_Day:2013-04-11_Translation_(l10n)]]
06:08:13 <tagoh_> #info 2013-04-16        Alpha Release
06:08:30 <tagoh_> gnome 3.8 test day is ongoing
06:08:49 <tagoh_> good to join to test, particularly improved ibus integration
06:09:05 <tagoh_> and other i18n related things
06:11:01 <tagoh_> okay, move on
06:11:07 <tagoh_> #topic Outstanding topics
06:11:08 <tagoh_> #info #16: Improving testcases/matrix for i18n test day (tagoh)
06:11:08 <tagoh_> #link https://fedorahosted.org/i18n/ticket/16
06:11:18 <tagoh_> https://fedoraproject.org/wiki/Test_Day:2013-05-02_Localization_(i18n)
06:11:44 <tagoh_> just proposed page renaming btw. so it still have this name but anyway
06:12:14 <tagoh_> mfabian: any chance to update desired languages for i-t-b testing?
06:12:31 <juhp> Gnome testday is supposed to be today (tonight) I guess
06:12:42 <juhp> ah already mentioned yes
06:13:00 <mfabian> I edited a bit last week, I think.
06:13:46 <tagoh_> you mean inscript2 perhaps?
06:13:55 <mfabian> Ah, now I see it, not https://fedoraproject.org/wiki/QA:Testcase_ibus-typing-booster ...
06:14:21 <tagoh_> yep :)
06:14:54 <tagoh_> well, I was about to ask for some volunteers to update test cases themselves though
06:15:14 <juhp> (also https://fedoraproject.org/wiki/Test_Day:2013-03-14_KDE_4.10 )
06:16:39 <tagoh_> so does current coverage of test cases work enough to check i18n features and regressions?
06:16:51 <dramsey> +1 for ibus
06:16:59 <paragan> I have added languages for inscript2 already during last meeting
06:17:23 <tagoh_> also need to check through all of test cases if steps to test is workable on f19.
06:18:35 * juhp finally has working f19 installs...
06:18:50 <paragan> cool
06:18:53 <juhp> (via f18 netinst.iso)
06:18:53 <tagoh_> any volunteers for checking?
06:19:51 <tagoh_> for ibus?
06:20:08 <juhp> how about owners checking their respective testcases?
06:20:19 <tagoh_> fujiwarat: guess you are best person to do?
06:20:36 <tagoh_> juhp: yes, that would be better
06:21:03 <juhp> when do we need to have them ready by?
06:21:34 <juhp> does l10n testday have any i18n tests?
06:21:42 <juhp> or need any updates for that?
06:22:33 <tagoh_> juhp: no, it should be only for translations. though if there are any issues in functionality, it may affects for their testing
06:23:35 <juhp> ok right
06:23:53 <tagoh_> juhp: well, may be good to finish by one week before the test day
06:24:03 <juhp> yes
06:25:46 <tagoh_> let's set due date to April 24, so we can check it in the meeting at April 25.
06:26:02 <pravins> yes
06:26:18 <juhp> +1
06:27:42 <tagoh_> #action all to check/update respective test cases which you are responsible
06:27:47 <tagoh_> okay
06:28:32 <tagoh_> if you think it would be better integrating/splitting up test cases, feel free to do. I'll leave it to you.
06:29:09 <tagoh_> in any cases, please do not forget to update the test day page for their links.
06:29:42 <tagoh_> any questions?
06:30:58 <tagoh_> #agreed update test cases by April 24
06:31:26 <tagoh_> if not, let's move on
06:32:01 <tagoh_> #info #18: F19 i18n docbeats (tagoh)
06:32:02 <tagoh_> #link https://fedorahosted.org/i18n/ticket/18
06:32:43 <pravins> tagoh_: i added couple of entries for fonts
06:32:58 <tagoh_> pravins: thanks
06:34:05 <pravins> welcome :)
06:34:42 <tagoh_> pravins: for lohit, maybe good to mention more specific and not too technical? what's enhanced and what that helps for users?
06:35:10 <tagoh_> and no need to write versions. that would be covered by technical notes.
06:36:00 <pravins> tagoh_: do you means, we can add string we fixed?
06:36:01 <tagoh_> so for culmus, kind of "new family has been added" would be good I think.
06:36:25 <tagoh_> pravins: sort of that
06:36:40 <pravins> tagoh_: good idea, i will improve that in notes.
06:36:46 <tagoh_> cool
06:37:28 <tagoh_> how about input methods?
06:37:35 <tagoh_> except kkc?
06:39:55 <juhp> what about fonts-tweak-tool?
06:41:13 <tagoh_> well, just added for reservation and remind me.. - UI improvement, font substitution support etc
06:42:47 <tagoh_> juhp: ah, suggesting that? yeah, I did it just now :)
06:43:18 <tagoh_> will update more details later.
06:43:50 <juhp> tagoh_, okay that is what I was wondering about
06:44:00 <juhp> I think any terse notes would be helpful
06:44:20 <juhp> ok
06:44:35 <tagoh_> yep
06:44:42 <tagoh_> anything else?
06:46:25 <juhp> epico, any new libpinyin related news/features?
06:47:24 <tagoh_> anything from ibus and i-t-b?
06:47:53 <epico> I am writing libpinyin 0.10.x series, no new features from user side. mostly re-factors.
06:47:54 <mfabian> ibus-typing-booster has some new features, yes.
06:48:17 <tagoh_> mfabian: do you want to add them into relnotes?
06:48:40 <mfabian> Most of them were available as updates for f18 already ..
06:48:40 <epico> for F19, ibus-libpinyin 1.6.x and libpinyin 0.9.x are built.
06:48:46 <juhp> what is "tw"?
06:48:52 <tagoh_> aha
06:49:28 <juhp> may still be good to mention new features since f18 in general
06:49:34 <juhp> but ok
06:49:35 <tagoh_> juhp: it was suggested in the meeting when I was away.
06:49:43 <juhp> pravins, ?
06:50:56 <epico> sorry, there are some new features in libpinyin 0.9.x series for F19.
06:51:13 <epico> guess I can add some for libpinyin 0.9.x series.
06:51:15 <pravins> juhp: not understood your question :)
06:51:55 <juhp> well dunno just trying to find out what "Other: tw" is referring to
06:52:03 <juhp> so who added it?
06:52:23 <pravins> its tagoh_
06:52:28 <tagoh_> I did according to the comment in the ticket
06:53:01 <juhp> no details?
06:53:09 <juhp> pravins, right
06:53:09 <tagoh_> if it's not worth mentioning in relnotes, let's drop it.
06:53:37 <juhp> ah ok it is a package!
06:53:48 <pravins> mfabian: i agree with juhp, good to mention feature implemented after Fedora 18 release.
06:54:03 <tagoh_> or please improve if one who suggested that like.
06:54:23 <mfabian> what is "tw"?
06:54:50 <dan408> taiwan?
06:54:50 <mfabian> pravins: I’ll try to write a bit about ibus-typing-booster.
06:55:00 <mfabian> Doesn't seem to be  taiwan.
06:55:06 <dan408> .tw the tld?
06:55:19 <dan408> epico: wait is someone talking about fedora 19 in here?
06:55:19 <pravins> mfabian: great !!
06:55:27 <dan408> oops
06:55:35 <dan408> wrong channel
06:55:44 <dan408> hehe
06:55:55 <tagoh_> https://admin.fedoraproject.org/pkgdb/acls/name/tw
06:55:57 <tagoh_> seems like this one
06:56:07 <epico> dan408, ?
06:56:16 <dan408> dont mind me
06:56:22 <epico> np
06:56:28 <tagoh_> but anyway
06:56:35 <juhp> yes - just had no idea what it was.....
06:56:38 <dan408> https://bugzilla.redhat.com/show_bug.cgi?id=885833
06:56:48 * dan408 tries to save face
06:58:09 <juhp> dan408, thx
06:58:56 <dan408> np
06:59:41 <tagoh_> anyway would be nice to have more notes if there are any and you think your new features is worth adding them.
06:59:53 <dan408> you guys know about the ö not showing up in the terminal for f19 right?
07:00:35 * juhp expanded the kkc and tw ones a bit...
07:00:46 <juhp> dan408, it does actually
07:01:12 <juhp> but not the closing quote
07:01:20 <mfabian> dan408: how do you get a problem with ö?
07:01:27 <tagoh_> anything else?
07:01:30 <dan408> ctrl+alt+f2
07:01:31 <juhp> well I am not expert on console fonts
07:01:43 <juhp> mfabian, it is from the f19 release name
07:01:49 <dan408> http://i.imgur.com/JdQemp6.png
07:01:59 <mfabian> Ah, the Schrödinger’s cat.
07:02:04 <dan408> http://www.irongeek.com/alt-numpad-ascii-key-combos-and-chart.html
07:02:18 <juhp> dan408, it was not showing for me either but after rebooting with latest fedora-release it renders ok for me
07:02:21 <dan408> terminal uses IBM AKA OEM PC extended ASCII
07:02:31 <dan408> i just composed a live cd
07:02:33 <dan408> and found that
07:02:47 <dan408> quite frankly
07:03:16 <dan408> the charachter should be in IBM/OEM instead of trying to make the terminal emulate UTF-8
07:03:25 <dan408> just for 1 charachter
07:03:43 <juhp> dan408, which version of fedora-release do you have?
07:03:49 <dan408> 19
07:03:55 <dan408> i just composed a live cd
07:04:02 <juhp> okay which release? ;)
07:04:07 <dan408> while dgilmore was composing tc1
07:04:10 <dan408> http://www.sput.nl/software/console-utf.html
07:04:15 <juhp> oh
07:04:20 <dan408> using the latest latest 19
07:04:33 <paragan> fedora-release-19-0.5 is the latest release for f19
07:04:37 <dan408> just trying to give y'all a heads up
07:04:42 <juhp> anyway "o is working for me now
07:04:48 <juhp> but not the '
07:04:50 <dan408> in a terminal?
07:04:58 <dan408> in a non X real terminal?
07:04:59 <juhp> in a console yes
07:05:03 <juhp> nod
07:05:04 <dan408> odd
07:05:08 <dan408> i just composed
07:05:15 <juhp> after install a new kernel
07:05:18 <dan408> and used the koji mash
07:05:20 <dan408> oh
07:05:23 <juhp> hmm ok interesting
07:05:23 <dan408> figures.
07:05:28 <dan408> i thought kernel needed to be patched
07:05:35 <dan408> looks like it was
07:05:52 <juhp> so might still be some edge case left perhaps dunno
07:06:04 <juhp> I just did a fresh install...
07:06:11 <juhp> let's see
07:06:16 <juhp> anyway...
07:06:19 <tagoh_> shall we move on? :)
07:06:19 <dan408> i booted live cd
07:06:24 <dan408> and did ctrl+alt+f2
07:06:32 <dan408> go on ;)
07:06:39 <tagoh_> #topic Outstanding task
07:06:39 <tagoh_> #info #15: F19 Feature: libkkc (ueno)
07:06:40 <tagoh_> #link https://fedorahosted.org/i18n/ticket/15
07:07:08 <tagoh_> well, feature is now 100% complete so I think we can close this ticket.
07:07:22 <juhp> great
07:07:28 <juhp> working well for me
07:07:30 <tagoh_> there may be some tasks to fix bugs etc, so need to test it carefully
07:08:00 <juhp> probably we need some testcases or convert them from anthy?
07:09:01 <tagoh_> juhp: maybe. though ueno-san opened https://fedoraproject.org/wiki/QA:Libkkc
07:09:06 <juhp> dan408, well of qemu wasn't crashing via gnome-boxes ;o)
07:09:08 <tagoh_> we can improve it as needed
07:09:10 <juhp> of = if
07:09:15 <juhp> ah okay
07:09:35 <tagoh_> which is linked from test day page
07:09:47 <juhp> aha
07:10:04 <dan408> juhp: i already mentioned my distate for qemu earlier tonight
07:10:13 <tagoh_> #topic Open Floor
07:10:17 <juhp> tagoh_, draft page?
07:10:42 <tagoh_> juhp: no, it's there in language-specific testing
07:10:58 <tagoh_> for ja
07:12:18 <tagoh_> anything else before closing this meeting?
07:12:43 <juhp> ah right thanks
07:14:28 <tagoh_> if not, let's stop here then.
07:14:51 <tagoh_> thanks everyone for the meeting!
07:15:02 <tagoh_> #endmeeting