15:00:06 <adamw> #startmeeting Fedora QA meeting
15:00:06 <zodbot> Meeting started Mon Mar 25 15:00:06 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:10 <adamw> #meetingname fedora-qa
15:00:10 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:17 <adamw> #topic roll call
15:00:23 * kparal wheeee
15:00:27 <adamw> morning folks, who's around?
15:00:43 * tflink is here
15:00:46 * mkrizek is here
15:00:50 * j_dulaney waves
15:01:06 * nirik is lurking around
15:01:17 * spoore is lurking
15:01:19 * pschindl is here
15:01:21 <jwb> i am present if needed.  i hope to not be needed.
15:01:39 <j_dulaney> .moar "kernel bugs" jwb
15:01:39 <zodbot> here jwb, have some more kernel bugs
15:02:07 <adamw> thankw jwb
15:02:22 <adamw> i don't think we have any particular fires in the kernel right now? anyhow.
15:02:25 * jskladan lurks
15:02:26 * pwhalen also lurks
15:04:00 <adamw> #topic Previous meeting follow-up
15:04:01 <adamw> alrightly
15:04:13 <adamw> "adamw to work with developers on getting F19 images to bootable state" - well...they boot!
15:04:16 <adamw> shipit
15:04:29 <j_dulaney> Heh
15:04:30 <tflink> wfm
15:07:33 <adamw> #info adamw to work with developers on getting F19 images to bootable state - this was done...TC1 boots, at least
15:07:48 <adamw> "adamw to work out a fallback plan with desktop team if we cannot get working images by Wednesday" - we got f19 images, in the end
15:07:57 <adamw> #info adamw to work out a fallback plan with desktop team if we cannot get working images by Wednesday - F19 images were used for the Test Day
15:08:04 <adamw> anything else from last week?
15:09:01 <tflink> blocker tracking app? that might be more open floor, though
15:09:12 <adamw> yeah
15:09:24 <adamw> so let's hit up the biggy
15:09:31 <adamw> #topic Fedora 19 Alpha status
15:10:09 <j_dulaney> live desktop works after dding to USB
15:10:43 * j_dulaney was able to get into gnome shell, fire up Firefox, hop online, etc
15:10:52 <adamw> yeah, me too.
15:10:55 <j_dulaney> Install failed, however
15:11:02 <adamw> works fine for me.
15:11:15 <j_dulaney> Of course, what I was trying to do is a Beta requirement, not Alpha
15:11:21 <adamw> so looking at https://fedoraproject.org/wiki/Test_Results:Fedora_19_Alpha_TC1_Install and http://qa.fedoraproject.org/blockerbugs/milestone/19/alpha/buglist , we obviously have various problems
15:11:36 <adamw> satellit seems to be hitting stuff i'm not seeing, but he didn't link his feedback to bugs...
15:11:53 * j_dulaney also seems to have hit something you didn't
15:13:26 <adamw> how did install fail for you?
15:13:37 <j_dulaney> Custom partitioning
15:14:11 <adamw> oh right.
15:14:14 <j_dulaney> When I clicked on the Custom Parition button, the dialog closed, but Anaconda would not allow me to continue from there
15:14:23 <adamw> tflink: did we want to do blocker review after the meeting btw?
15:14:37 <j_dulaney> But, that's a beta blocker
15:15:44 <kparal> adamw: I don't see it announced
15:16:03 <tflink> adamw: do you think we need it before wednesday since we're not in freeze yet?
15:17:15 * j_dulaney can see how it may be useful to knock out a few
15:17:16 <adamw> tflink: hm, good point
15:17:24 <adamw> okay, so we have various potential and actual blockers
15:17:54 <adamw> but the real big roadblock is https://bugzilla.redhat.com/show_bug.cgi?id=923951 , which is killing netinstall and bcl is pretty stuck on it
15:19:06 <adamw> #info https://bugzilla.redhat.com/show_bug.cgi?id=923951 is a major development/testing roadblock
15:19:11 * jreznik is late today, sorry, pto :)
15:19:15 <j_dulaney> BTW, not a show stopper, but the current F19 kernel is eating some major cycles and ram
15:19:24 <j_dulaney> 3/4 GB ram
15:19:27 <kparal> j_dulaney: it's a debug kernel
15:19:28 <adamw> so we might want to try and direct some high-level resources at that one; we also should make sure we test around it
15:19:39 <adamw> j_dulaney: it's a debug kernel. try 'slub_debug=-' parameter.
15:19:45 <j_dulaney> Roger
15:19:49 <kparal> adamw: what does it do?
15:20:49 * j_dulaney also noticed that f19 yum is not always showing progress
15:20:56 <j_dulaney> Especially on downloads
15:21:53 <adamw> kparal: breaks net install entirely
15:22:12 <kparal> adamw: no, I mean slub_debug=-
15:22:25 * kparal googles
15:22:27 <adamw> i haven't tried tc1 DVD install yet; can someone report if it's viable, or does it get eaten by dependency problems?
15:22:35 <brunowolff> Turns off slub debugging.
15:22:45 <adamw> kparal: oh, disables a specific subset of debugging options which appear to be responsible for most of the slowdown in debug kernels, for most people
15:23:09 <j_dulaney> adamw:  It gets eaten alive
15:23:11 <kparal> sounds great, I'll add it to our wiki
15:23:26 <adamw> j_dulaney: ah. so, ideally we need to do a tc2 soon, with no dep problems if possible
15:23:41 <j_dulaney> Indeed
15:23:48 <adamw> #info TC1 DVD install fails on dependency issues, so we need a TC2 soon without those
15:25:56 <adamw> any other thoughts on f19/tc1?
15:26:09 <j_dulaney> Can tc2 be slightly less broken?
15:26:13 <adamw> anyone hitting any big issues that haven't been reported as bugs? if so report them!
15:26:21 <adamw> j_dulaney: well that would be nice, certainly...:)
15:29:29 <adamw> #action adamw to request a TC2 as soon as it's clear we can compose one without critical dep issues
15:29:45 <adamw> #info we need to ensure we do all the tests that don't require network install at least, on TC2
15:30:15 <adamw> this is the 'don't just give up when we hit a showstopper' thing - let's make sure we get through all the validation tests on the DVD / live images even when we know netinst is busted
15:30:23 <adamw> that way we don't get surprised by something else
15:30:54 <tflink> adamw: that would never happen (the getting surprised by something else part) :-D
15:30:57 <adamw> =)
15:31:11 <adamw> #topic Test Days
15:31:25 <adamw> doesn't look like martix is around
15:31:29 <adamw> brno guys?
15:31:56 <kparal> he's not
15:32:01 <adamw> ok
15:32:03 <adamw> I can say that we managed to get the GNOME Test Day to fire, and even had a decently-working live image, but attendance was thinner than i was expecting
15:32:30 <adamw> 18 people filing results, inc. a lot of RHers
15:32:37 <adamw> i think we didn't get enough outside publicity done
15:33:21 <adamw> also partly my fault for not getting the test images up fast enough
15:33:44 <adamw> #info GNOME 3.8 Test Day went ahead with working F19-based images, but attendance was thin: insufficient publicity?
15:33:49 * j_dulaney had school in the way
15:33:57 * j_dulaney had a recital that night
15:34:14 <adamw> j_dulaney: not blaming the attendees :) individuals can always be busy, but looked at overall, IIRC we had like 50+ at the last gnome/kde test days
15:34:33 <kparal> actually I think the scope was too large and it put some people off
15:34:33 * jreznik thinks it's a problem of a too early desktop TDs but I understand why Martix scheduled them so early (upstream releases)
15:34:54 <kparal> and of course, yes, it was too early - everything is too broken
15:35:01 <adamw> hm, no, i must be remembering an older one
15:35:07 <adamw> attendance was somewhat up on 3.6 and 3.4 in fact
15:35:12 <adamw> #undo
15:35:12 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2a4940d0>
15:35:35 <adamw> #info GNOME 3.8 Test Day went ahead with working F19-based images, attendance was better than 3.4 and 3.6 but still below where it could be: try to improve outside publicity for future events
15:35:53 <adamw> comparing https://fedoraproject.org/wiki/Test_Day:2012-03-15_Gnome_Shell_and_Extensions and https://fedoraproject.org/wiki/Test_Day:2012-11-08_GNOME_3.6
15:36:17 <kparal> the first one was much more focused
15:36:26 <adamw> kparal: yeah, it has spread out a little
15:36:52 <adamw> partly just because G3 actually has applications now :)
15:37:14 <adamw> #info kparal suggests that the scope of the GNOME Test Day has gotten wider than a single day can really cover, suggests splitting future events into multiple days
15:37:28 * kparal nods
15:37:30 <j_dulaney> +1
15:39:00 <adamw> this week's test day is https://fedoraproject.org/wiki/Test_Day:2013-03-28_System_Certificates - shared system certificates
15:39:22 <adamw> the idea being we just have one database of trusted ssl/tls certs, not, like, 50. seems a good plan.
15:39:40 <adamw> the test day page still looks very template-y
15:40:06 <adamw> kparal: if I #action martix to talk to the organizers and make sure they're on track or delay the event, can you pass that on?
15:40:39 <kparal> adamw: I guess martix is one of the organizers, so you can #action me to talk to him
15:40:49 <adamw> sounds good
15:41:03 * Viking-Ice wonders if we just change the meeting time to 15:00 utc
15:41:11 <adamw> #action kparal to talk to martix and ensure https://fedoraproject.org/wiki/Test_Day:2013-03-28_System_Certificates will be in shape and ready to go ahead for Thursday, or delay the event
15:41:20 <adamw> Viking-Ice: my head says 'hell, no'
15:41:25 <adamw> :P
15:41:37 <kparal> Viking-Ice: two weeks ago
15:42:42 <Viking-Ice> ok
15:42:45 <kparal> as for upcoming test day, I already talked to alich and I'll try to create a livecd for them tomorrow
15:43:24 <Viking-Ice> well any *DE testing should not be done until after alpha
15:43:34 <adamw> Viking-Ice: the problem is that we're off-cycle with the DEs now
15:43:34 <Viking-Ice> which could explain bad attendance
15:43:55 <adamw> Viking-Ice: we had to schedule them both early or else they'd already have been released
15:44:03 <Viking-Ice> adamw, sorry not following how that has anything to do with us ( as in upstream relese cycle )
15:44:27 <jreznik> Viking-Ice: I talked to Martix and he was forced by upstreams to schedule it in this way
15:44:33 <Viking-Ice> we dont have and should not tie our test days to their release schedule
15:44:59 <jreznik> Viking-Ice: there's bigger chance to get a feedback and fixes in upstream...
15:45:10 <adamw> Viking-Ice: it's harder to get stuff fixed after the upstream final release
15:45:26 <jreznik> but still I think it was too early and it hit as more than upstream final releases (as we still have time for dot ones)
15:45:29 <Viking-Ice> history has taught us never to schedule DE test until after alpha regardless of upstream schedule
15:45:51 <adamw> that's an assertion, not an argument.
15:46:23 <Viking-Ice> well it's a bigger problem if bugs that get filed during out development cycle wont get fixed because it does not fit upstream schedule
15:46:51 <adamw> that's not what we said, exactly.
15:46:51 <Viking-Ice> with regards to Gnome testing given recent thread they dont even bother with our bugs anyway
15:47:11 <Viking-Ice> ( unless they get filed upstream )
15:47:11 <jreznik> so yep, for the next time I'd prefer no fix in upstreams (actually it was probably too late for GNOME too) and do the desktops tests with something more stable - as we want more users on TDs... for more advanced stuff, we can expect people will be able to workaround problems
15:47:37 <jreznik> but for both KDE and GNOME TD I heard a lot of complaints - I couldn't get it ready, so I gave it
15:48:30 <jreznik> Viking-Ice: well, this time I think they responded quite well in TD ("our" upstream devs) - so if they are changing theirs attitude - great
15:48:55 <adamw> desktop's team always been strongly involved with the test days.
15:49:09 <adamw> viking is referring to a thread on the desktop ML.
15:49:31 <Viking-Ice> yup which clearly shows their attitude against rh bz
15:49:49 <kparal> what's the thread name?
15:49:52 <adamw> buried ion https://lists.fedoraproject.org/pipermail/desktop/2013-March/007895.html
15:50:16 <kparal> personally I'm not sure why even RH employees refuse to follow their packages in RHBZ
15:50:27 <kparal> but it's not the best approach
15:50:55 <Viking-Ice> well I think this is only limited to RH Gnome developers not outside that group
15:51:29 <kparal> yes, I'm referring to the GNOME TD
15:51:47 <jreznik> adamw: wow, that's a small logo...
15:51:51 <adamw> oh god
15:51:54 <adamw> MOVING ON
15:51:58 <adamw> :P
15:52:40 <Viking-Ice> yeah not need to drag into this meeting how the Gnome devs are systematically killing the fedora brand
15:52:44 <Viking-Ice> so let's move on
15:52:46 * kparal moves on
15:53:42 <j_dulaney> Yeah, GDM sucks in that way
15:53:44 <j_dulaney> But
15:53:55 <j_dulaney> lightdm doesn't even show the logo, if I recall
15:54:04 <adamw> #topic Open floor
15:54:04 <rdieter> j_dulaney: yes it does
15:54:11 <rdieter> (or should, if not, it's a bug)
15:54:11 <j_dulaney> Hmm
15:54:25 <adamw> so what do we have besides toxic arguments? :)
15:54:37 <Viking-Ice> so is the new keyboard being displayed *always* in GDM considered a bug or a feature ?
15:54:41 * jreznik waits for lightdm default one for KDE and all that QML beaty :)
15:54:56 <Viking-Ice> lightdm that's canonical stuff right?
15:55:01 <rdieter> Viking-Ice: yeah
15:55:10 <tflink> still working to get the blocker bug tracker into production
15:55:37 <tflink> into staging now, not quite working but should get that figured out today hopefully
15:56:10 <tflink> there will be a sever name change at some point but hopefully, that change will be transparent to users
15:56:28 <j_dulaney> tflink:  Is it publically facing?
15:56:43 <adamw> Viking-Ice: i'm guessing 'feature' - this is commonly used on MMOs as a security measure
15:56:49 <j_dulaney> tflink:  As in, Linky?
15:56:51 <tflink> j_dulaney: the staging instance? yes
15:56:56 <adamw> Viking-Ice: the idea is that you can type your password partly using the keys and partly using the real keyboard
15:57:00 <adamw> in case someone's logging keypresses
15:57:09 <adamw> but imbw :)
15:57:20 <tflink> it isn't working ATM, though and I'd rather not have the extra hits until it's setup properly
15:57:30 <j_dulaney> Roger
15:57:37 <j_dulaney> BUT
15:57:38 <adamw> #info tflink still working on getting the blocker proposal webapp into production, it's on staging now but still a couple of bugs to fix
15:58:01 <j_dulaney> now would be the time to try to make it explode, rather than in the middle of the release cycle
15:58:33 * j_dulaney just had a mental image of Chuck Norris busting out of a RH datacenter
15:58:46 <Viking-Ice> adamw, really all it seems to do is ruin the user experience in GDM I personally thought it was table thingie
15:59:10 <halfline> no the keyboard isn't supposed to be there by default
15:59:16 <adamw> oh, so i guess i'm wrong :)
15:59:19 <halfline> just a bug in g-s-d
15:59:27 <adamw> halfline: feel free to use my explanation, though. CC license!
15:59:30 <halfline> fixed in 3.7.92 i think
16:01:06 <Viking-Ice> halfline, any reason the session chooser is there as opposed to somewhere in system settings ?
16:01:32 <adamw> because you...want to choose a session when you log in?
16:02:11 <halfline> an argument could be made for putting it in system settings
16:02:20 <halfline> we do for locale
16:02:32 * j_dulaney is glad it isn't
16:02:41 <halfline> not sure if it's a good idea or not
16:02:53 <j_dulaney> Sometimes, I break a DE, but don't want to fix it right away
16:02:56 <Viking-Ice> adamw, ? I would think they always would want users to use new gnome as first experience but have to manually configure it to the old mode ( which the natural place for that would be system settings )
16:03:09 <adamw> Viking-Ice: oh, you mean specifically for classic mode? right.
16:03:13 * j_dulaney had gnome broken the entire time f18 was on his laptop
16:03:15 <Viking-Ice> adamw, yeah
16:03:29 <adamw> welp, anyway
16:03:31 <halfline> it sort of makes sense
16:03:35 <j_dulaney> s/laptop/x86 laptop
16:03:35 <adamw> do we have any other *QA-related topics*? :)
16:03:39 <halfline> i mean we used to have "fallback" mode in system settings
16:03:41 <Viking-Ice> it's my experience any drop down menu/options in gdm has just confused users
16:04:02 <halfline> also the session list is really ugly
16:04:32 <adamw> halfline: right, i know where viking is coming from now.
16:04:33 * j_dulaney doesn't mind ugly if it means easy to find
16:05:03 <Viking-Ice> everything is easy to find once you have explain users where to find them ;)
16:05:16 <halfline> i can see both sides of the argument
16:05:22 <halfline> probably worth talking to aday/mccann about
16:07:29 <halfline> could also integrate with the talked about "Reboot into Windows" thing or whatever
16:07:37 <j_dulaney> Ew
16:07:38 <halfline> that we're going to have to do for EFI systems
16:08:03 <j_dulaney> halfline:  I hope that doesn't show up if you don't have Wincrap installed
16:08:19 <halfline> yea that would be a bug
16:08:21 <halfline> if it did
16:08:49 <halfline> of course the feature isn't implemented yet
16:09:40 <adamw> OK, GNOME design discussion to...wherever the appropriate channel for that is
16:09:40 <j_dulaney> Feature I'll never use
16:09:43 <halfline> another thing we should do is support login screen extensions, so people who want quick access to change their locale (or session if we end up moving that) can
16:09:43 <adamw> thanks for coming, everyone
16:09:49 <adamw> #endmeeting