15:11:04 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:11:04 <zodbot> Meeting started Tue Apr  9 15:11:04 2013 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:11:08 <Kevin_Kofler> #meetingname kde-sig
15:11:08 <zodbot> The meeting name has been set to 'kde-sig'
15:11:14 <Kevin_Kofler> #topic Role call
15:11:20 * Kevin_Kofler is present, of course.
15:11:25 <Kevin_Kofler> Who else? :-)
15:11:30 * mbriza is here
15:11:47 * jreznik_z10 is semi present
15:11:53 <than> present
15:12:04 <rdieter> hello
15:13:43 <jgrulich> present
15:15:22 <Kevin_Kofler> #info Kevin_Kofler, mbriza, than, rdieter, jgrulich present, jreznik_z10 semi-present.
15:15:33 <Kevin_Kofler> #chair mbriza jreznik_z10 than rdieter jgrulich
15:15:33 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik_z10 mbriza rdieter than
15:15:38 <Kevin_Kofler> #topic Agenda
15:15:45 <Kevin_Kofler> What to discuss?
15:16:08 <mbriza> i'd like to ask you if you agree with including my multi-seat patch into fedora kdm
15:16:22 <Kevin_Kofler> I'd suggest (potential and actual) F19Alpha blockers.
15:17:41 <jreznik_z10> Alpha yep
15:17:45 <Kevin_Kofler> Anything else? If not, let's finally start.
15:18:29 <Kevin_Kofler> OK, let's start with the hopefully short one.
15:18:40 <Kevin_Kofler> #topic mbriza's multi-seat patch for KDM
15:18:52 <Kevin_Kofler> So the question is: Do we want that patch?
15:19:04 <Kevin_Kofler> And my immediate followup is: Can we see the patch? :-)
15:19:04 <mbriza> so, the patch looks like this: http://paste.fedoraproject.org/6993/65520257/
15:19:13 * Kevin_Kofler has a look.
15:19:20 <rdieter> I can't think of any reason why not
15:19:26 <mbriza> basically it's a very hacky solution that eats the reserve displays
15:19:43 <mbriza> i was thinking about creating new displays but kdm doesn't provide any facilities for that
15:20:52 <Kevin_Kofler> So, first question, can't we automatically enable KDM_WITH_SYSTEMD if systemd libraries are found? Upstream will prefer it that way, if they accept your patch at all.
15:21:00 <mbriza> the problem here of course is, upstream won't accept this solution for the problem, and as i suggested multiple times, i'm really looking forward to the moment we switch from kdm to something newer
15:21:29 <Kevin_Kofler> (From our standpoint, both your and the automagic solution suck, I'd want it default enabled AND REQUIRED. :-) )
15:21:39 <rdieter> i agree with mbriza, if anything, we can worry about making it upstreamable later
15:23:00 <Kevin_Kofler> So the patch looks fine, but I don't see at a first glance how hackish it really is.
15:23:13 <mbriza> Kevin_Kofler: the hackish thing is using the reserve displays
15:23:25 <Kevin_Kofler> But if it doesn't have nasty side effects, let's apply it.
15:23:29 <mbriza> Kevin_Kofler: which is a hackish way of managing X displays anyway
15:24:10 <Kevin_Kofler> So, any objections to applying the patch in Fedora or can I file an #agreed?
15:24:12 <mbriza> the side-effect is, you have to add the reserve displays to /etc/kde/kdm/kdmrc to be able to have more than 4 sessions/systemd automatic seats at once
15:24:37 <mbriza> but that's normal, you have to do it even if you want to have more than four sessions without this patch
15:25:15 <Kevin_Kofler> And I guess the reserve displays eat a small amount of resources. Ugh, on demand would be much better, but I don't think teaching KDM that is doable reasonably, grrr…
15:25:31 <Kevin_Kofler> So +1 to applying the patch as is from me.
15:25:38 <rdieter> +1 agreed
15:25:54 <Kevin_Kofler> Last chance to object…
15:26:04 <mbriza> i'd have to rewrite half of the backend to do it reasonably... that's why i like sddm, too... it's basically what would i have done
15:26:19 <Kevin_Kofler> #agreed We will apply mbriza's patch in Fedora.
15:26:29 <Kevin_Kofler> So, next topic:
15:26:31 <than> the patch looks fine to me, +1 to apply the pacth
15:26:40 <Kevin_Kofler> Good.
15:26:42 <Kevin_Kofler> #topic F19 Alpha Blockers
15:26:54 <Kevin_Kofler> So, what's the situation there?
15:27:15 <Kevin_Kofler> The kde-settings/kdmrc issue sounds REALLY bad, I filed it as a blocker immediately.
15:27:57 <mbriza> it does, ironically enough, it is fine in tc4 where there is a newer version of the package
15:28:02 <Kevin_Kofler> .bug 949831
15:28:05 <zodbot> Kevin_Kofler: Bug 949831 Fedora 19 RC1 - Cannot open theme file /usr/share/kde4/apps/kdm/themes/SphericalCow - Wrong default theme - https://bugzilla.redhat.com/show_bug.cgi?id=949831
15:28:25 <Kevin_Kofler> Yeah, I suspect the package was pulled from a side tag in the TCs and it's still not stable and so it got lost?
15:29:42 <Kevin_Kofler> Then we have the obscure crash saga… Folks are not willing to wait for a GCC that fixes the real problem in Firefox and we don't have sufficient evidence that it's really causing problems for us (heck, we don't have sufficient evidence that the crashes we're seeing are even caused by the same GCC bug).
15:29:53 <Kevin_Kofler> The only thing which looks remotely like a blocker is this one:
15:29:55 <Kevin_Kofler> .bug 923828
15:30:00 <zodbot> Kevin_Kofler: Bug 923828 kactivitymanagerd crashed on KDE start, running debug kernel - https://bugzilla.redhat.com/show_bug.cgi?id=923828
15:30:19 <Kevin_Kofler> but it's poorly reproducible and even if it weren't I'm not sure it's a blocker for Alpha.
15:31:13 <rdieter> yeah, not a blocker (yet)
15:31:43 <jreznik_z10> Not a blocker, please vote
15:31:48 <rdieter> esp when nucleo mentioned having to disable random kde services to make it happen (apparently)
15:31:56 <rdieter> +1 not blocker
15:31:57 <than> without reproducer here-> not a blocker
15:32:09 <than> +1 not blocker
15:32:14 <jreznik_z10> For theme, it's just oversight I'd say
15:32:20 <Kevin_Kofler> So we're shipping code which is very likely miscompiled (see also the Qupzilla crash, which SHOULD in principle also be affecting Konqueror/kwebkitpart, but couldn't be reproduced with it for some obscure reason), but we don't have a concrete crash report of anything critical enough to be a blocker. :-(
15:32:49 <Kevin_Kofler> I think this really sucks, but I also can't demand we hold up the release for a bug which doesn't seem to matter.
15:33:43 <Kevin_Kofler> (I'd have felt much better if the resolution for the Firefox issue had been to actually fix the GCC bug and then rebuild everything possibly affected by it (worst case, ALL of F19) rather than hacking around it in Firefox only, with a workaround nobody even understands why it appears to work.)
15:34:19 <Kevin_Kofler> (Papering over bugs is really really nasty.)
15:34:27 <rdieter> do you recall what the workaround was?
15:34:42 <rdieter> (the firefox one)
15:34:42 <Kevin_Kofler> s/-O3/-Os/ in some makefiles.
15:34:59 <Kevin_Kofler> (I think -O2 didn't help, then they tried -Os and that did.)
15:35:26 <rdieter> scary
15:35:59 <Kevin_Kofler> (Now I think all of Fedora should be compiled with -Os anyway (saves both RAM and disk space and can even speed things up due to less swapping and less loading time), but that's not the point. ;-) )
15:36:03 <jreznik_z10> Not an ideal solution
15:36:18 <Kevin_Kofler> jreznik_z10: Yeah, I think it's not a solution at all. :-/
15:37:30 <Kevin_Kofler> I could live with -fno-(some specific optimization) as a workaround if that optimization were clearly identified and also all other possibly affected packages got the same workaround. But changing -O3 to -Os in xulrunner without understanding why this even works? Yuck!
15:37:52 <Kevin_Kofler> Who knows what other stuff is being miscompiled, just in less obvious ways than the xulrunner JIT?
15:38:26 <rdieter> I guess... the only options include: 1.  someone investigate deeper  2. not worry about it, until when/if more evidence surfaces that some problem still exists
15:38:53 <rdieter> I'm tempted to go with 2, unless anyone has better ideas?
15:39:37 <Kevin_Kofler> I'd also go with 2., I'm REALLY not in a mood to investigate a xulrunner JIT crash and we don't have any reproducer that's easier to debug. :-(
15:40:27 <Kevin_Kofler> I do have some experience with debugging GCC optimizations, but it takes a day even on a simple testcase. Here it looks like we possibly have GCC-produced machine code which generates other code which then crashes, argh!
15:43:02 <rdieter> ok "head in the sand" plan, +1 :)
15:43:50 <Kevin_Kofler> The only thing we can really do for 1 is more testing in the hope to get a reproducible KDE crash that's actually a blocker and that we hopefully can find a fix for.
15:44:11 <Kevin_Kofler> (but the WebKit JIT probably isn't any easier to debug than the xulrunner JIT :-( )
15:45:12 <Kevin_Kofler> Do we have any other issues that qualify for blocker status?
15:46:39 * rdieter knows of none
15:46:58 <Kevin_Kofler> #agreed #949831 is a clear blocker, #923828 is not a blocker.
15:47:08 <Kevin_Kofler> #info We don't know any other KDE-related issues that qualify for blockers.
15:47:42 <jreznik_z10> As I said, please vote in bug
15:48:13 <jreznik_z10> And of course any help on test matrices appreciated
15:49:04 <Kevin_Kofler> I posted https://bugzilla.redhat.com/show_bug.cgi?id=923828#c8
15:49:14 <rdieter> so, I take it the lastest f19 live image is busted? (the kdm theme thing?)
15:49:19 <Kevin_Kofler> The other one I think is a no brainer. :-)
15:49:36 <Kevin_Kofler> rdieter: Yeah, RC1 KDE is busted, they pulled in an old buggy kde-settings into the compose.
15:49:40 * rdieter will try to do f19 install today to help start testing
15:49:50 <rdieter> I suppose that bug is easy enough to workaround
15:50:26 <jreznik_z10> Live should work with autologin
15:50:44 <rdieter> oh right, the kdm theme never shows in that case. :)
15:50:53 <jreznik_z10> But I have problems with virt manager...
15:50:57 <Kevin_Kofler> Not sure, doesn't KDM fail to load if it doesn't like the theme?
15:51:07 <rdieter> Kevin_Kofler: i'll find out
15:51:15 <Kevin_Kofler> In any case, it's definitely busted once you install to HD.
15:51:46 <Kevin_Kofler> (unless they put different packages on the live image than on the DVD, which would also be a compose error)
15:52:06 <rdieter> seems i have a tc3 iso here too, maybe I can try that
15:52:28 <jreznik_z10> It was fixed in tc4
15:52:39 <jreznik_z10> Regressed in rc1
15:52:41 <Kevin_Kofler> Ouch, so TC3 is busted too, argh.
15:53:56 <Kevin_Kofler> So if TC4 can't be found anymore, I guess you'll have to wait for RC2 to have a working image. But yes, it should be possibly to work around it (boot in text mode, fix kdmrc with nano, switch to graphical.target).
15:54:30 <rdieter> yeah
15:57:08 <Kevin_Kofler> FWIW, there is another open blocker affecting the KDE spin, but it's not our fault:
15:57:11 <Kevin_Kofler> .bug 929403
15:57:15 <zodbot> Kevin_Kofler: Bug 929403 initial-setup-graphical.service is not enabled by default, so initial-setup does not run after install (KDE, LXDE, Xfce...) - https://bugzilla.redhat.com/show_bug.cgi?id=929403
15:57:58 <jreznik_z10> It's supposed to be fixed
15:59:52 <Kevin_Kofler> Yeah, looks like that one already works in RC1.
16:02:15 <Kevin_Kofler> #topic Open Discussion
16:02:25 <Kevin_Kofler> Anything else? Otherwise let's close here, we're already over time.
16:03:12 <Kevin_Kofler> OK, thanks for coming!
16:03:14 <Kevin_Kofler> #endmeeting