15:00:44 <adamw> #startmeeting Fedora QA meeting
15:00:44 <zodbot> Meeting started Mon Apr 15 15:00:44 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:46 <adamw> #meetingname fedora-qa
15:00:46 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:50 <adamw> #topic Roll call
15:00:52 <adamw> morning folks, who's a roll?
15:00:56 * tflink is here
15:01:14 * mkrizek is here
15:01:16 * randomuser` is lurking around, why not
15:01:26 * satellit listening
15:01:34 * jskladan lurks
15:01:36 * brunowolff is here
15:03:11 <adamw> but are you rolls?!
15:03:41 <tflink> rofl?
15:04:02 * jreznik is roll
15:05:28 <adamw> ahem
15:05:32 <adamw> morning everyone
15:05:38 <adamw> #topic fedora 19 alpha status
15:06:04 <adamw> soo, we're not looking too bad
15:06:38 <adamw> TC6 testing looks pretty solid (or am I missing anything)? and we just have the remaining EFI bug to zap, really
15:07:01 <adamw> there's a few more proposed blockers we'll deal with at the review meeting right after this meeting
15:07:15 * satellit_e adamw: https://bugzilla.redhat.com/show_bug.cgi?id=949761#c22  EFI install worked on MacBookPro i7 with litd USB
15:07:19 <adamw> anyone have any issues/concerns for alpha?
15:07:21 <adamw> satellit: thanks
15:08:33 <brunowolff> Is there a warning about using very old graphics cards and gnome?
15:09:02 <adamw> not really
15:09:07 <brunowolff> That doesn't look like it is going to work for alpha and those people should be steered to something like XFCE.
15:09:18 <adamw> how do you mean, "isn't going to work"?
15:09:26 <adamw> llvmpipe is working fine so far as I know. do you mean blacklisted cards?
15:09:41 <randomuser`> brunowolff, I'm intending to make such a statement in the the release notes and/or install guide, fwiw
15:09:47 * Viking-Ice lurks
15:09:54 <brunowolff> llvmpipe doesn't work on at least one of my old machines.
15:10:28 <brunowolff> The second old machine also doesn't get into gnome, but that might be due to something other than llvmpipe.
15:10:33 <jreznik> for that one outstanding bug we need some evidence that clearing efivars could help as looking on LKML, fix is still under review... mjg59 should know more, I hope, pls
15:10:53 <Viking-Ice> is the size of the efi partition being checked along with proper configuration and removal of files on kernel updates?
15:11:46 <Viking-Ice> and the correct mount path or is just people checking installing with uefi and if they can boot ?
15:11:49 <brunowolff> Now my machines are really old and don't have sse2 instructions, which may only be a small subset of machines with old graphics cards.
15:12:09 <adamw> jreznik: tc6 already has the fix that cleans out pstore - https://bugzilla.redhat.com/show_bug.cgi?id=950709
15:13:12 <jreznik> adamw: yes, I know - but it could be still tricky - as it could require up to two reboots...
15:13:14 <adamw> brunowolff: oh, right, the sse2 bug.
15:13:28 <adamw> so you're more talking 'old CPU and blacklisted gfx card'.
15:14:02 <jreznik> Viking-Ice: the idea is - abrt will report dumped crashes and reports them + anaconda will clean it up at install time
15:14:32 <brunowolff> Yes.
15:14:36 <jreznik> now the question is why some people see empty pstore and dumps in efivars I'd say reading the latest comments in the bug
15:14:45 <adamw> Viking-Ice: this isn't about the EFI system partition where kernels live
15:15:20 <Viking-Ice> ok did not know to what extend we where testing efi
15:15:51 <adamw> Viking-Ice: it's about some space in the NVRAM, which the OS can actually write stuff to
15:16:18 <jreznik> and combination of several conditions...
15:16:27 <adamw> jreznik: well, because of 947142. which is where we came in.
15:18:42 <adamw> #info TC6 is out and testing so far looks reasonably positive, we are mostly waiting on a fix for 947142 now
15:19:07 <adamw> #info randomuser is planning to include a note about problems running Shell on blacklisted graphics cards and old CPUs in the release notes
15:19:40 <randomuser`> ah
15:19:57 <randomuser`> help me out on the blacklisted cards bit
15:20:00 <jreznik> that's the question - if we really need a fix for 947142 or not - if it really makes that difference for most of the systems, there are reports just wiping out dumps from efi are enough :)
15:20:24 <randomuser`> adamw, i was thinking more of a generic 'if you have a less powerful machine, use a lighter DE'
15:20:58 <adamw> jreznik: oh, i see. good question, i guess we can send out a call for more uefi testing again
15:21:07 <adamw> #action adamw to send out another call for UEFI testing with TC6
15:21:57 <adamw> anything else for alpha? last call for alpha.
15:23:06 <pjones> yes, we really need a fix for 947142.
15:23:52 <pjones> If for no other reason than it basically means on many machines you can't re-test more than once.
15:24:18 * pschindl is here (I stuck in the treffic jam)
15:24:32 <adamw> pjones: even with the fix that wipes efivars at install time?
15:24:56 <pjones> that may sometimes help, but it's not a 100% sort of thing
15:25:25 <sn_op> secure boot is great for people with alzeimers
15:25:29 <jreznik> it's a fix that should make the reported size more "correct" as far as I understand it so you can end with the same problem
15:26:38 <sn_op> you cant get enough of peoples faces once they realixe they forgot the encription password
15:27:22 <adamw> ...okay.
15:27:29 <adamw> pjones: alright, thanks. we'll keep waiting for the fix then
15:28:43 <jreznik> adamw: I can't pretend I understand the problem, but still I'd go with that - please retest and to collect results as see my comment above...
15:28:51 <adamw> sure.
15:29:43 <adamw> pjones: do you have any news on the status of the fix, btw? or better apply to mjg59?
15:29:57 <jreznik> I think it's this one https://lkml.org/lkml/2013/4/9/828
15:30:04 <pjones> you'll have to ask the kernel team about the fedora kernels, but he has posted something
15:30:35 <jwb> jreznik, that's stale.
15:31:37 <adamw> so aiui as soon as the patch is acceptable to upstream, we can pull it into our kernel and rebuild, right jwb?
15:31:43 <pjones> http://paste.fedoraproject.org/7458 was the thing he was saying worked earlier
15:31:53 <pjones> but, again, jwb's answer trumps mine ;)
15:31:57 <jwb> adamw, basically, yes
15:32:01 <adamw> okay.
15:32:06 <adamw> pjones: thanks much
15:32:10 <jwb> afaik, we won't even have to carry it long
15:32:39 <adamw> #info mjg59 is still refining the 947142 fix, as soon as it's acceptable upstream we can pull it into F19 kernel and rebuild
15:33:15 <jreznik> jwb: would it be possible to carry it only for now even it's not completely accepted by upstream but it will turn out to help us now?
15:33:19 <jwb> no
15:35:07 <jreznik> ok
15:35:30 <adamw> alrighty, moving on
15:35:33 <adamw> #topic Test Days
15:36:25 <adamw> it doesn't look like much happened for https://fedoraproject.org/wiki/Test_Day:2013-04-11_Translation_%28l10n%29 . I missed that one, I was probably panicking about alpha.
15:36:31 <adamw> anyone have any info there?
15:37:58 <adamw> (crickets)
15:39:22 <adamw> so I guess that's a "no" :)
15:39:28 <adamw> anyone want an action item to follow up on it?
15:40:13 <jreznik> I can do it
15:40:42 <adamw> #info we're unsure whether Translations (l10n) test day happened, and whether it needs to be re-scheduled / re-organized
15:40:50 <adamw> #action jreznik to follow up on status of Translations (l10n) test day
15:40:52 <adamw> thanks jaro
15:41:15 <adamw> two other test days are scheduled this week - https://fedoraproject.org/wiki/Test_Day:2013-04-17_Power_Management and https://fedoraproject.org/wiki/Test_Day:2013-04-18 (freeipa)
15:41:23 <adamw> I guess I'd better try and check up on those
15:41:32 <adamw> and send out some publicity etc
15:42:10 <jskladan> adamw: i know that pm testday will happen :) IMHO we'll have the usual 'public' testday during openhouse
15:42:38 <adamw> what's this shiny new feedback tool?
15:42:49 <adamw> #info power management test day looks well set up, we just need to send out announcements
15:43:21 <adamw> #info freeipa page is mostly ready, looks to be a cut/paste dump from last year, so check for errors
15:45:10 <adamw> i guess that's all for test days
15:45:15 <adamw> anything else?
15:45:40 <jreznik> adamw: maybe restart discussion about TCs after RCs as we hit it now...
15:45:57 <adamw> i'm not sure we have time for that talkfest before blocker review
15:46:14 <adamw> but if someone wants to bring it up in open floor, sure
15:46:15 <jreznik> at least to poke it on ml...
15:46:28 <adamw> i meant 'anything else about test days', though, while we're still on the test day topic.
15:46:36 <jreznik> ok, sorry
15:47:16 <adamw> sounds like that's a negatory
15:47:18 <adamw> #topic open floor
15:47:27 <adamw> anything for open floor? anyone keen for a talkfest? :)
15:47:59 * jreznik would like to avoid talkfest :) maybe mailing list is now better option
15:48:52 <adamw> sure
15:50:07 <adamw> someone tell us a jokje
15:50:09 <adamw> also a joke
15:51:17 <jskladan> You know that one about canadian lumberjack? ;)
15:51:39 <adamw> heh
15:52:12 <adamw> welp, if that's all we got, everyone go get a beefy miracle and join us again in #fedora-blocker-review at the top of the hour for some AWESOME BLOCKER REVIEW FUN
15:52:41 * adamw sets quantum fuse
15:53:04 <jskladan> Canadian lumberjack's favourite sushi? The long roll...
15:53:23 <jskladan> Damg autocorrect *log roll
15:53:29 <adamw> ba-dum tish
15:53:45 <adamw> jskladan will be here all week or until the customers throw him out, tip your server!
15:54:06 * jskladan quits in shame!
15:54:12 <mjg59> adamw: Patches appear to look good to upstream now
15:54:17 <adamw> mjg59: yay!
15:54:20 <mjg59> Just posted them for further review
15:54:22 <adamw> so we can maybe get a kernel today?
15:54:36 <mjg59> Maybe!
15:54:55 <adamw> yay
15:55:20 <adamw> and on that positive note...thanks for coming, all
15:55:22 <adamw> #endmeeting