15:02:40 <rdieter> #startmeeting kde-sig
15:02:40 <zodbot> Meeting started Tue Apr 16 15:02:40 2013 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:42 <rdieter> #meetingname kde-sig
15:02:42 <zodbot> The meeting name has been set to 'kde-sig'
15:02:48 <rdieter> #topic roll call
15:03:01 <rdieter> hi everyone, who's around for a friendly kde-sig meeting today?
15:04:39 <rdieter> than, jreznik, Kevin_Kofler, mbriza : ping
15:04:50 <mbriza> sorry, i'm here, hi everybody
15:06:13 <rdieter> might be a quick meeting :)
15:06:18 <mbriza> should i poke dvratil?
15:06:45 <rdieter> mbriza: probably, if he want to partake of the fun
15:06:47 <Kevin_Kofler> Present.
15:07:02 * dvratil is here
15:07:17 <rdieter> #info rdieter mbriza Kevin_Kofler dvratil present
15:07:22 <rdieter> #chair mbriza Kevin_Kofler dvratil
15:07:22 <zodbot> Current chairs: Kevin_Kofler dvratil mbriza rdieter
15:07:41 <rdieter> k, ... on to agenda
15:07:42 <rdieter> #topic agenda
15:07:47 <rdieter> what to discuss today?
15:08:07 <Kevin_Kofler> 4.10.2
15:08:27 <than> present
15:08:31 <rdieter> #info than present
15:08:35 <rdieter> #chair than
15:08:35 <zodbot> Current chairs: Kevin_Kofler dvratil mbriza rdieter than
15:08:40 <rdieter> than: hi
15:08:47 <than> hi all
15:09:06 <jreznik> hey
15:09:14 <rdieter> #info jreznik
15:09:16 <rdieter> #chair jreznik
15:09:16 <zodbot> Current chairs: Kevin_Kofler dvratil jreznik mbriza rdieter than
15:09:24 <rdieter> #info jreznik present even
15:10:08 <rdieter> .bug 911295
15:10:12 <zodbot> rdieter: Bug 911295 Wrong numerals in slovak locale - https://bugzilla.redhat.com/show_bug.cgi?id=911295
15:10:46 <rdieter> ok, let's get started.
15:10:49 <Kevin_Kofler> Yeah, that's a nasty bug, I thought we'd have already fixed it, but somehow it fell through the cracks, ouch!
15:10:53 <rdieter> #topic kde-4.10.2 status
15:11:16 <rdieter> so one blocker'ish item for 4.10.2 is the kdelibs/icon-inheritance thing
15:11:31 <Kevin_Kofler> Well, that one we can fix later too.
15:11:41 <Kevin_Kofler> It's been there since 4.10.0.
15:12:14 <rdieter> i'd agreed to revert the upstream commit that caused this, will do so here shortly after meeting
15:12:28 * than is taking a look at 911295
15:12:51 <rdieter> Oh, and f17/kde-4.10.2 bodhi update needs karma/testing
15:12:54 <than> rdieter:will reverting cause any issue?
15:13:20 <rdieter> than: will just go back to the prior behavior, which we've had for a *long* time
15:14:02 <rdieter> that (revertable) commit fixes one other related bug, and actually brings kde into strict compliance with the icon spec, but... I'd like more time to review it in the meantime
15:14:15 <than> ah ok
15:14:57 <rdieter> *personally*, I'd prefer to leave the commit in, but others, including Kevin_Kofler felt strongly that the fixing the regression was more important in the short-term
15:15:13 <rdieter> (which I can't argue with much, regressions do suck)
15:17:49 <rdieter> there was a kmail/multipart issue mention in bodhi, and an upstream commit/fix has already been identified, may be worth pulling that into our packaging soon too (ie, prior to 4.10.3 landing)
15:18:18 <Kevin_Kofler> I'd like to have this in before we push 4.10.2.
15:18:35 <rdieter> Kevin_Kofler: this = what exactly?
15:18:47 <Kevin_Kofler> The kdepim/kmail/multipart one.
15:18:48 <Kevin_Kofler> It seems to be a regression in 4.10.2, apparently even compared to 4.10.1, though I haven't confirmed that.
15:19:14 <rdieter> sigh, I hate holding the 4.10.2 hostage.  Imo, this is not a blocker-worthy bug
15:19:16 <Kevin_Kofler> I haven't noticed that bug on 4.10.1 though and I use KMail a lot, so I guess it's a regression.
15:19:30 <rdieter> any volunteers to pull in the upstream fix?
15:19:44 <rdieter> (I probably won't have time today, todo list growing too big as it is)
15:20:26 <rdieter> kmail/multipart issue reference, fyi, http://bugs.kde.org/318182
15:20:31 <mbriza> i can't do it today either
15:20:46 <Kevin_Kofler> Then there was also the security issue with ESC not clearing the password, dvratil imported the fix into dist-git yesterday.
15:20:50 <Kevin_Kofler> (in kde-workspace)
15:20:57 <rdieter> ah, right, noted
15:21:06 <Kevin_Kofler> I think if we're editing the updates for kdepim, we'll want to add that in too.
15:21:08 <dvratil> I'll import the kdepim patch as well tonight
15:21:16 <than> dvratil: could you please take care of this?
15:21:22 <Kevin_Kofler> It's not a regression compared to 4.10.1, but it is compared to 4.9.5 and it's a security issue.
15:21:37 <Kevin_Kofler> (the kde-workspace one) So it should get out ASAP.
15:22:12 <rdieter> imo, it's a rare enough case, I don't consider it worth worrying too much about
15:22:25 <rdieter> but as we have a fixed build in hand, indeed we'll included it asap
15:22:25 <dvratil> Kevin_Kofler, I added the patch, but the Koji build failed because kdelibs4-devel>=4.10.2 was not found (???)
15:22:42 <rdieter> dvratil: use f19-kde f18-kde f17-kde koji build targets
15:22:53 <dvratil> rdieter, aah, thanks :-)
15:22:55 <rdieter> for example, fedpkg build --target f19-kde
15:23:51 <rdieter> ok, with those 3 fixes in hand, we're agreed 4.10.2 is a go for stable updates?
15:24:09 <rdieter> consider me +1 obviously
15:24:12 <than> rdieter: yes, fine with me
15:24:57 <Kevin_Kofler> +1
15:26:29 <rdieter> #agreed with these 3 fixes (kdelibs/icon-inheritance, kdepim/kmail-multipart, kde-workspace/screenlocker-esc), kde-4.10.2 will be queue'd for stable updates at earliest opportunity
15:26:35 <rdieter> anything else wrt 4.10.2 ?
15:27:03 <Kevin_Kofler> Not from me.
15:29:28 <Kevin_Kofler> Looks like it's time to move on, or close the meeting if there's nothing else to discuss.
15:31:24 <than> none from my side
15:33:16 <rdieter> one last bug, the Qt/slovack thing
15:33:26 <rdieter> #topic https://bugzilla.redhat.com/show_bug.cgi?id=911295
15:33:41 <rdieter> .bug 911295
15:33:44 <zodbot> rdieter: Bug 911295 Wrong numerals in slovak locale - https://bugzilla.redhat.com/show_bug.cgi?id=911295
15:33:49 <than> rdieter: i will take care of it
15:33:56 <rdieter> than: thanks
15:33:59 <than> np
15:34:02 <rdieter> well, yay, that was easy.
15:34:32 <rdieter> #action than will pull in upstream patch for bug #911295
15:34:40 <rdieter> #topic open discussion
15:34:49 <rdieter> anything else ?
15:34:56 <Kevin_Kofler> Not from me.
15:37:39 <rdieter> looks like nada, thanks everyone
15:37:42 <rdieter> #endmeeting