15:10:07 <rdieter> #startmeeting kde-sig
15:10:07 <zodbot> Meeting started Tue May  7 15:10:07 2013 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:10:13 <rdieter> #meetingname kde-sig
15:10:13 <zodbot> The meeting name has been set to 'kde-sig'
15:10:17 <rdieter> #topic roll call
15:10:34 <rdieter> hi all, who's present for a friendly kde-sig meeting today?
15:10:54 <rdieter> than, ltinkl, jgrulich, jreznik, Kevin_Kofler, dvratil_ , kde*foo: ping
15:11:00 <than> present
15:11:07 <jgrulich> present
15:11:22 <dvratil_> present
15:11:30 <ltinkl> here
15:11:38 <Kevin_Kofler> Present.
15:12:09 * than will leave the meeting earlier
15:12:29 <rdieter> #chair than jgrulich  dvratil_ ltinkl  Kevin_Kofler
15:12:29 <zodbot> Current chairs: Kevin_Kofler dvratil_ jgrulich ltinkl rdieter than
15:12:40 <rdieter> #info rdieter than jgrulich dvratil_ ltinkl Kevin_Kofler present
15:12:47 <rdieter> #topic agenda
15:12:59 <rdieter> kde-4.10.3 status is on the table, anything else?
15:13:30 <Kevin_Kofler> Anything to discuss about the Apper issue other than "it's still there"?
15:13:34 <than> blocker bug if we have some
15:14:43 <rdieter> the apper issue is a beta blocker I believe, so we can discuss that first
15:15:29 <rdieter> anything else?
15:16:41 <rdieter> ok, let's get started then
15:17:02 <rdieter> #topic apper always-checking-for-updates issue
15:17:12 <rdieter> .bug 948099
15:17:17 <zodbot> rdieter: Bug 948099 Apper ignores "never check for updates" option (also on the live image) - https://bugzilla.redhat.com/show_bug.cgi?id=948099
15:17:34 <rdieter> looks like my hacks to disable apper systray plasmoid on live image didn't work (according to nucleo)
15:18:02 <ltinkl> rdieter: did you just disable the plasmoid?
15:18:03 <rdieter> the apper thing could take someone looking into it more (I can, but I have about 4 things on my todo list before I'll have time for it).  any volunteers?
15:18:12 <rdieter> ltinkl: I tried (and failed apparently)
15:18:24 <ltinkl> rdieter: I mean, disabling the plasmoid is not enough
15:18:39 <ltinkl> rdieter: you also have to disable the kded module
15:18:44 <rdieter> I disabled (tried) both kded service and plasmoid
15:18:49 <rdieter> kded service disable worked
15:18:54 <rdieter> plasmoid not
15:19:21 <ltinkl> rdieter: disable as in make it not autostart?
15:19:34 <rdieter> it's a systray applet
15:19:40 <ltinkl> the kded module
15:19:44 <rdieter> see the spins-kickstarts commit in the aforementioned bug for my attemps
15:20:08 <Kevin_Kofler> You need to tweak the Plasma JavaScripts to disable the plasmoids.
15:20:50 <rdieter> kded module disable attempt: https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=19912d72a1b0751532980a03a9520a88174c1361
15:21:02 <rdieter> applet disable attempt: https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=95e68dc29e12c3777794fa27e1d2c7425418be7e
15:21:16 <rdieter> they both worked for me testing on my f18 box/session at least
15:23:26 <rdieter> anyway, if no one can look at it, I can later sometime
15:24:09 <ltinkl> hmm, I can't think of anything else
15:24:51 <rdieter> even testing to confirm/deny nucleo's findings would help
15:25:03 <Kevin_Kofler> I don't think X-KDE-PluginInfo-EnabledByDefault has any effect for plasmoids.
15:25:30 <Kevin_Kofler> What shows up in the systray is decided 1. by a hardcoded list of default stuff in kde-workspace and 2. by the init JavaScripts.
15:25:34 <rdieter> Kevin_Kofler: I'm not sure anymore.  like I said, it worked for me in my own testing
15:25:52 <Kevin_Kofler> I think there's a JavaScript which adds it, that JavaScript needs to be disabled on the live image.
15:26:09 <rdieter> (how else does the apper applet get enabled?)
15:26:10 <Kevin_Kofler> (maybe with a hack such as if (user != "liveuser") or something like that)
15:26:25 <ltinkl> yup, I also think the systray is a bit different, the X-KDE-PluginInfo-EnabledByDefault key might work for regular desktop plasmoids
15:26:50 <rdieter> I don't see any javascript code that exlicitly enables it, that's why I took this approach.
15:26:53 <Kevin_Kofler> http://pkgs.fedoraproject.org/cgit/apper.git/tree/01-fedora-apper-updater.js
15:27:00 <Kevin_Kofler> That's where it gets enabled.
15:27:16 <rdieter> damn, how did I miss that?
15:27:22 <Kevin_Kofler> ltinkl: I don't think X-KDE-PluginInfo-EnabledByDefault works for any plasmoids.
15:27:23 <rdieter> ok, that's why my own session test worked I guess
15:27:28 <rdieter> that script has already run
15:27:38 <Kevin_Kofler> Yes, it's an init only script.
15:27:51 <Kevin_Kofler> Or actually, update too, but as you say it's run only once.
15:27:54 <rdieter> grr, Kevin_Kofler can you followup in the bug
15:27:55 <rdieter> ?
15:28:15 <rdieter> with that detail explaining why it didn't work, so the next poor schmoe who tries doesn't fall into the same trap I did
15:28:19 <Kevin_Kofler> I think there's some API to get the user name, so we could compare it to "liveuser".
15:28:28 <Kevin_Kofler> (and not run the script for liveuser)
15:29:01 <Kevin_Kofler> I'll post a summary to the bug report.
15:29:48 <rdieter> thx
15:30:03 <rdieter> #action Kevin_Kofler will update bug with details/findings so far
15:30:13 <rdieter> #topic kde-4.10.3 status
15:30:14 <rdieter> moving on...
15:30:34 <rdieter> than's got git mostly updated, and builds are underway.
15:30:56 <rdieter> I think I'm up to kactivities/kdepimlibs/smokeqt so far
15:33:09 <rdieter> Kevin_Kofler was going to tweak iris (with kopete patches) so we can use system iris everwhere (not just f19+)
15:33:30 <rdieter> that will bump it's abi, so need to wait for that before doing any kdenetwork/ksirk builds (right?)
15:34:00 <Kevin_Kofler> Right.
15:34:12 <Kevin_Kofler> I'm on it.
15:34:37 <rdieter> anything else wrt 4.10.3 ?
15:34:43 <Kevin_Kofler> The VERSION entries are what needs to be bumped, I'm folding it into the sharedlib patch because otherwise we'll have fuzzed patches.
15:34:57 <Kevin_Kofler> (and setting the soname is a part of building a shared lib anyway)
15:35:15 <rdieter> Kevin_Kofler: eww, so... that'll bump the pkg-config --modversion too?
15:35:39 <rdieter> the packaging currently assumes Version: tag matches the pkd-config modversion I think
15:35:52 <rdieter> that's one reason why I was hesitant to change it
15:36:02 <Kevin_Kofler> Uhm, I have no idea what pkg-config --modversion is set from.
15:37:25 <rdieter> you'll find out the hard way if iris's %%check  stuff fails
15:37:29 <Kevin_Kofler> Probably also VERSION indeed.
15:39:05 <rdieter> ok, we'll see
15:39:15 <rdieter> moving on...
15:39:24 <rdieter> #topic open discussion
15:40:41 <rdieter> that's it for agenda items, anything else?
15:42:43 <rdieter> sounds like a no :)
15:42:47 <rdieter> thanks everyone!
15:42:52 <rdieter> #endmeeting