15:01:45 <adamw> #startmeeting Fedora QA meeting
15:01:45 <zodbot> Meeting started Mon May 20 15:01:45 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:51 <adamw> #meetingname fedora-qa
15:01:51 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:55 <adamw> #topic roll call
15:02:19 <adamw> *beep* No signal. Unable to call "roll".
15:02:30 <jreiser> here
15:02:33 * satellit_e listening
15:02:47 * Viking-Ice here
15:02:51 * pschindl is here
15:03:30 <adamw> morning folks
15:03:31 <adamw> anyone else?
15:03:55 * jreznik is here
15:04:02 <adamw> morning jreznik
15:04:09 <adamw> #chair jreznik viking-ice
15:04:09 <zodbot> Current chairs: adamw jreznik viking-ice
15:04:31 <adamw> #topic Previous meeting follow-up
15:05:01 <adamw> #info "martix or adamw to write a Graphics Test Week recap email" - yeah, failed that again. I'll just move it to a personal todo and stop boring the meeting with it
15:05:02 * mkrizek is here
15:06:05 <adamw> #info "tflink to write a list post announcing the blocker bug proposal webapp" - I don't believe he did this yet
15:06:18 <Martix> oh, that is my fault, but feel free to do it
15:06:19 <tflink> unfortunately, no
15:06:22 <adamw> #info "adamw to look into Test_Day:2013-04-30_MariaDB lack of participation and see if we should re-run it" - continuing the festival of fail: nope
15:06:37 <adamw> "brunowolff to re-test bug #909473 and re-open if it's still bad"
15:07:04 <adamw> i don't see any comments in there'
15:07:12 <adamw> wow, well we're clearly doing a bang-up job :)
15:07:27 <adamw> #info "brunowolff to re-test bug #909473 and re-open if it's still bad" - not sure if he did this yet
15:07:36 <tflink> well, festivals are fun
15:07:55 <adamw> and that's the important lesson, kids.
15:08:20 <adamw> anyhow, moving swiftly on!
15:08:21 <adamw> #topic Fedora 19 Beta status
15:08:38 <adamw> so, in "less sucky" news...beta looking pretty decent
15:09:07 <Guest15468> I did a quick retest with the games spin on the intel machine and things looked OK. I haven't retested on AMD/AMD machine yet.
15:09:19 <adamw> '#info Beta RC2 is currently in testing, some likely blocker bugs have been found but not too many
15:09:24 <adamw> Guest15468: aha, thanks
15:09:28 <adamw> #info Beta RC2 is currently in testing, some likely blocker bugs have been found but not too many
15:09:53 <adamw> #info Go/No-Go is scheduled for Thursday 2013-05-23
15:10:15 <adamw> anyone have anything to note/discuss on beta?
15:10:37 * satellit_e still trying to fix soas spin
15:10:55 <jreznik> thanks for mentioning go/no-go, adamw
15:11:03 <jreiser> corner cases still bad: 955779 no desktop on RV280; 962086 cannot skip bootloader; n-i-bz: grub2 requires LBA
15:11:27 <adamw> yeah, i've been trying to get bcl to fix the bootloader thing
15:12:15 * jskladan lurks
15:12:20 <adamw> jreiser: that rv280 one of yours look nutty
15:12:52 <jreiser> Yeah rv280 is nutty. I can run gdb, but need direction on effective debug
15:13:57 <adamw> jreiser: is it actually using the radeon driver?
15:14:12 <adamw> because I think RV280 should be blacklisted
15:14:17 <jreiser> it claims to be using ati.
15:15:00 <brunowolff> It should be using llvmpipe when using gnome-shell.
15:15:12 <adamw> jreiser: hmm. do you have it handy? can you fpaste 'glxinfo'?
15:15:13 <jreiser> yes, llvmpipe is ON.
15:15:16 <nirik> so, I have a thing at some point to mention... ;) The desktop updates tests are pretty gnome centric. ;) Would there be any interest in alternate tests for other desktops?
15:15:22 <nirik> or genericizing the existing one
15:15:23 <jreiser> I have seen the generated sse2 code.
15:15:47 <adamw> nirik: genericizing the existing one would be great, assuming you can play the balance between genericness and usefulness
15:15:53 <jreiser> The box is not up now;  will boot, then try for glxinfo.
15:16:07 <nirik> ok, I can try and take a stab at it.
15:16:10 <brunowolff> My machine is different in that I don't have SSE2 on my CPUs.
15:16:10 <nirik> propose to the list?
15:16:31 <adamw> nirik: if the changes are significant, sure
15:16:38 <adamw> brunowolff: that was one of the bugs that came up earlier
15:16:51 <adamw> right?
15:16:52 * nirik nods
15:16:57 <satellit_e> tests for sugar-desktop would be very different than for other DE's
15:17:10 <adamw> jreiser: well what we're saying is it should be using llvmpipe *not native acceleration*
15:17:24 <adamw> satellit: the update tests are greyed for SoaS on the basis it doesn't have a graphical updater
15:17:35 <satellit_e> ok
15:17:37 <adamw> satellit: is there a 'rule' about how you update sugar?
15:17:53 <satellit_e> yum update from root
15:18:00 <jreiser> g-i-s gets alpha-blended shadows.  after that, gnome-shell eats CPU for 5 minutes before timing out with no change in graphics display
15:18:13 <jreznik> nirik: well, all test cases are more gnome-centric - I'm trying to use some common sense :)
15:18:43 <nirik> jreznik: the updates ones are even more so tho. ;) For example, Xfce doesn't even ship PK...
15:18:50 <jreiser> adamw: 'glxinfo' requires access to display.  Cannot get display.  now what?
15:18:56 <satellit_e> adamw: actually there is a sugar control panel to update the activities in sugar
15:19:05 <adamw> satellit: oh, interesting
15:19:12 <adamw> so we could probably do with looking at that too...
15:19:31 <adamw> jreiser: you have to run glxinfo from within an x session, yeah...maybe try a KDE one :) but we can debug in the bug I guess.
15:20:08 <adamw> jreznik: nirik: in general, genericizing them is a good thing. i'm aiming to make revising a lot of the existing test cases my Big Project for post-f19 pre-f20
15:20:30 <adamw> there's quite a lot of other stuff needs doing, like writing some partitioning test cases, adding a yum test case, a buncha stuff.
15:20:36 <satellit_e> http://wiki.sugarlabs.org/images/thumb/e/e3/Screenshot_of_Software_Update.png/700px-Screenshot_of_Software_Update.png
15:20:45 <adamw> if anyone wants to work on any of that now, of course :)
15:20:48 * nirik nods again.
15:21:03 <adamw> satellit: does that only update sugar activities, though? not the base system?
15:21:47 <satellit_e> yes the update for sugar-desktop is in sugar-terminal root yum update
15:22:28 <satellit_e> FYI http://wiki.sugarlabs.org/go/Tutorials/Introduction_to_the_Sugar_Interface
15:23:49 <adamw> okay
15:24:00 <adamw> so adding a yum testcase to 'base' is indicated there as well.
15:24:27 <adamw> #info we could do with a 'update with yum' test case in the base matrix
15:24:37 <nirik> xfce (and I think lxde and possibly others) use yumex... it just has a update thing... but it doesn't do notifications, so none of the gui notify stuff applies.
15:24:39 <adamw> #action nirik to work on revising the 'desktop updates' test case to be more generic
15:24:57 <adamw> nirik: it's easy enough to just make that 'if your desktop provides...'
15:24:58 <satellit_e> mate uses yumex also
15:25:41 <nirik> yeah, ok. so, update that one and make a seperate non gui/yum one?
15:26:40 <jreiser> adamw: rv280 glxinfo is http://paste.fedoraproject.org/13201/90635761
15:26:54 <adamw> nirik: that's where i'd go with it, yeah
15:27:01 <adamw> nirik: the yum test would be in the Base matrix rather than the Desktop matrix
15:27:10 <nirik> will try and do so, if anyone else wants to first, feel free.
15:29:39 <adamw> alrighty
15:29:43 <adamw> anything else on Beta, folks?
15:32:04 <adamw> well then
15:32:05 <adamw> #topic Test Days
15:32:30 <adamw> so, frantic work appears to be underway on https://fedoraproject.org/wiki/Test_Day:2013-05-21_AnacondaNewUI_Followup
15:33:13 <adamw> speaking of partitioning test cases...there's some stuff to yoink
15:34:13 <adamw> so looks like 'mganisin', who is Marian Ganisin from RH in brno, is doing a lot of work on this one
15:34:30 <adamw> jreznik / pschindl, are you in touch with that?
15:35:57 * nirik is reminded to look at the feature page and try and help get it fully finished.
15:36:41 <jreznik> adamw: I talked to them when they started planning it, I'll try to get in touch to see what are the plans right now
15:36:44 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-21_AnacondaNewUI_Followup looks ready or close to ready
15:37:13 <adamw> #info NewUI_Followup test day also has some useful test cases for anaconda that we should adopt into the matrices (though we need to revise them into correct format)
15:38:08 <adamw> if people can try to spread the word a bit about the test day that'd be great
15:39:22 * jreznik is going to do some marketing over our asocial networks groups
15:39:38 <adamw> hehe
15:39:45 <adamw> i'll post in my usual places
15:41:18 <adamw> https://fedoraproject.org/wiki/Test_Day:2013-05-23_Thermostat looks to have a shell in place, but they haven't written most of their test cases yet
15:41:31 <adamw> has anyone been working with them on that?
15:42:08 <adamw> Martix: do you have time to check in and help them complete the page or delay the event, or are you busy?
15:44:14 <Martix> adamw: I can ask them in ticket on their status
15:44:51 <adamw> it might be best to try a bit more proactively to get in touch, at least if they don't respond there
15:45:16 <Martix> then poke them on IRC :-)
15:48:19 <adamw> yeah, he's not online atm
15:48:35 <adamw> #action martix to co-ordinate with Thermostat test day runners to make sure they'll be ready or postpone the event
15:49:23 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-23_Thermostat page shell is in place, but many test cases missing
15:49:29 <adamw> #topic Open floor
15:49:34 <adamw> anything for open floor, folks?
15:49:50 <tflink> we have a QA calendar
15:49:54 <tflink> https://apps.fedoraproject.org/calendar/QA/
15:50:04 <tflink> not much on it ATM
15:50:13 <nirik> so, there's a new bugzilla version.
15:50:58 <nirik> one change I thought I would mention because I bet lots of people will find out about it soon: needinfo bugs will now mail reminders to the suppy the info. ;)
15:51:08 <adamw> yep
15:51:11 <adamw> that'll be fun
15:51:44 <nirik> weekly.
15:51:55 <nirik> yeah
15:52:17 <adamw> #info Bugzilla has been updated to 4.4. Among the notable changes: longer alias names, and needinfo bugs will now email the 'needinfo'd party weekly
15:54:11 <adamw> on the up side, we can use the intended alias names for freeze exception bugs now
15:54:30 <adamw> (F19BetaFreezeException not F19BetaFreezeExcept for e.g.)
15:54:37 <adamw> so i'll change that
15:54:40 <Viking-Ice> can the calender app be hooked up to various mail clients and google calender etc or is this just completely standalone app?
15:54:55 <Viking-Ice> ( which makes it totally useless )
15:54:57 <adamw> Viking-Ice: it can export ICS at least, which you can import into anything else
15:55:01 <adamw> i don't know if it has caldav support
15:55:29 <Martix> adamw: just a note, I don't see any devels on Anaconda Test Day, only QA
15:55:42 <Viking-Ice> maybe we would be better of just to use google calender instead
15:55:53 <nirik> yes, you can hook it up to anything that uses ical... google calendar can just fine.
15:55:53 <Viking-Ice> which hooks up to tablets and phones
15:55:57 <adamw> Martix: yeah, i'll try and get bcl to come along
15:56:04 <Martix> I think mkolman would volunteer
15:56:25 <adamw> Martix: or, yeah, if there's gonna be a lot of testing in brno, someone from brno
15:56:41 <Martix> mkolman: feel free to write yourself as developer on this page: https://fedoraproject.org/wiki/Test_Day:2013-05-21_AnacondaNewUI_Followup
15:56:42 <adamw> Viking-Ice: and of course Skynet :)
15:57:11 <adamw> nirik: do we have a QA fedocal yet? tflink was working on it with you, right
15:57:23 <nirik> adamw: yes, as he noted above it's there now. ;)
15:57:34 <nirik> you can also subscribe to all calendars
15:57:48 <adamw> goddamnit, i'm not drunk enough yet.
15:58:11 <adamw> #info QA has a calendar in the fedocal system at https://apps.fedoraproject.org/calendar/QA/
15:58:23 <adamw> are we planning to migrate the schedule stuff to fedocal? F20? F21?
15:58:53 <adamw> jreznik: ^^^
16:00:29 <Viking-Ice> so what's up with version 20 being offered in bugzilla when we have not even branched yet?
16:00:35 <adamw> yeah, I dunno about that
16:00:38 <jreznik> adamw: it's uploaded there
16:00:40 <adamw> might be fallout from the 4.4 migration
16:00:59 <jreznik> adamw: in fedocal - not ideal right now, I have to take a loko
16:01:32 <adamw> oop, we're over time
16:01:49 <adamw> we're doing blocker review in #fedora-blocker-review next, though I forgot to announce it (sorry)
16:01:50 * nirik noticed the 20 as well, I didn't add it, perhaps we should remove it?
16:01:57 <adamw> nirik: probably
16:02:05 <brunowolff> I think that happened before the migration (at least the downtime), as I noticed that about 2 days ago.
16:02:05 <jreznik> nirik: yes please
16:02:36 <adamw> #action nirik to remove F20 from bugzilla for now
16:03:01 <Viking-Ice> wont removing it affect bugs if assigned to that?
16:03:16 <adamw> they should just get moved to rawhide, that shouldn't be hard
16:04:57 <jreznik> yep, rawhide and I have a script if it will be needed (not sure it still works with a new bz)
16:05:42 <adamw> i guess you'll find out :)
16:05:50 <adamw> ok, let's all head over to #fedora-blocker-review for some blocker review
16:05:53 <adamw> thanks for coming, folks
16:06:57 * nirik looks to see if there's actually any in it yet.
16:07:21 <adamw> #endmeeting