15:02:01 <adamw> #startmeeting Fedora QA meeting
15:02:01 <zodbot> Meeting started Mon May 27 15:02:01 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:05 <adamw> #meetingname fedora-qa
15:02:05 <zodbot> The meeting name has been set to 'fedora-qa'
15:02:08 <adamw> #topic roll call
15:02:12 <adamw> morning folks! how is everyone?
15:02:23 * j_dulaney slumps in, all tired
15:02:28 * satellit_e listening
15:02:42 * j_dulaney pulled an all night hacking run
15:03:22 * jreznik is partially here from bed - sick today :(
15:03:36 <pingou> take care jreznik
15:04:12 * Cerlyn watches
15:04:28 * jskladan tips his hat
15:04:39 * j_dulaney twitches
15:04:42 * kparal joins
15:05:59 * adamw sets up a coffee iv for j_dulaney
15:06:42 * j_dulaney gets high from the caffeine
15:07:09 <adamw> no tflink in the house?
15:07:17 * pschindl is here
15:07:41 <j_dulaney> Holiday in the US
15:07:52 <j_dulaney> Memorial Day
15:08:30 <adamw> pfeh
15:08:35 <adamw> .fire tflink
15:08:35 <zodbot> adamw fires tflink
15:08:51 <adamw> #chair kparal
15:08:51 <zodbot> Current chairs: adamw kparal
15:08:57 <adamw> #topic Previous meeting follow-up
15:09:10 <adamw> "nirik to work on revising the 'desktop updates' test case to be more generic" - did you get anywhere on that, nirik?
15:09:27 <nirik> nope. :)
15:09:36 <nirik> will try this week.
15:10:57 <adamw> alrighty.
15:11:15 <adamw> #info "nirik to work on revising the 'desktop updates' test case to be more generic" - not done yet, nirik will try to work on it this week
15:11:34 <adamw> #info "martix to co-ordinate with Thermostat test day runners to make sure they'll be ready or postpone the event" - martix checked in, and they were ready in time
15:11:44 <adamw> "nirik to remove F20 from bugzilla for now" - you again, nirik
15:12:14 <nirik> done.
15:12:27 <nirik> nuked. wiped.
15:12:42 <nirik> I moved all 10 bugs in it to rawhide.
15:13:29 <adamw> thanks.
15:13:38 <adamw> #info "nirik to remove F20 from bugzilla for now" - done, nuked, wiped, bugs moved to rawhide
15:13:49 <adamw> #topic Fedora 19 Beta review/wrap-up
15:14:12 <adamw> so, in case anyone missed it, we approved F19 Beta RC4 at go/no-go on thursday, it will be released tomorrow
15:14:19 <adamw> big thanks to everyone for validation testing
15:14:23 <j_dulaney> And there was much rejoicing
15:14:24 <kparal> I'll create some contributors stats, hopefully this week
15:14:31 <adamw> #info 19 Beta RC4 will be released as Beta tomorrow
15:14:43 <adamw> #info kparal will produce stats on contributors to testing
15:15:22 <adamw> the couple of things I have noted down are that we need to update https://fedoraproject.org/wiki/Common_F19_bugs and make sure the release notes cover the PackageKit/PolicyKit thing and maybe initial-setup
15:15:39 <adamw> anyone have anything else we need to do as part of beta wrap-up?
15:17:09 <tflink> this isn't so much wrap up for beta as prep for final but the iscsi test case needs some editing to work with newui
15:17:33 <kparal> I couldn't test the UEFI grub fix today, our mirrors were dead
15:18:07 <tflink> and there's a final prep section - should have waited 5 minutes
15:18:10 <adamw> tflink: :)
15:18:28 <adamw> kparal: ah, was wondering about that, i can try if i can get past the exhaustion issue somehow :/
15:18:47 <kparal> adamw: reflashing bios worked for us
15:19:07 <adamw> this is my production desktop so i'm a bit reluctant to do that. anyhow
15:19:07 <kparal> but the current uefi hw is really crap
15:19:39 <adamw> oh, while we're on the topic - if you can still flash yours, pjones is interested in what happens if you flash your firmware and then do nothing but install fedora over and over till it breaks
15:19:49 <adamw> if it really breaks after 10 tries, something's very wrong somewhere, he says
15:20:11 <kparal> adamw: I guess it will be around 15-20. I can definitely try it once our mirrors are back online
15:20:15 <adamw> ok
15:20:30 <adamw> he says the nvram ought to have space for hundreds or thousands of install attempts
15:20:37 <adamw> it should only really get filled up by stuff like coredumps
15:20:55 <tflink> there's that s-word :)
15:20:59 <adamw> so if it gets filled up by a few install attempts, either there's something wonky kernel-side or you have a really bad firmware
15:21:15 <j_dulaney> tflink:  Quiet!
15:21:21 <kparal> that depends. we did a 10 f19 installations, everything was fine. then we installed f18, upgraded, and the game was over
15:21:30 <kparal> *10x f19 installations
15:21:59 <kparal> damn, you get the meaning, ten installations :)
15:22:27 <kparal> but I think it was because f18 by default still uses coredump-to-nvram approach
15:22:33 <kparal> so it filled up
15:22:52 <adamw> kparal: right, that's why he wants you to just to f19 install attempts, as coredump storing is currently disabled so it shouldn't affect things
15:23:02 <adamw> but we're taking up meeting time here :)
15:23:21 <adamw> #action adamw and anyone else to work on updating https://fedoraproject.org/wiki/Common_F19_bugs
15:23:41 <adamw> #action adamw to talk to rbergeron and make sure packagekit/policykit issue makes it into the beta release notes
15:24:52 <adamw> if anyone wants to help out with commonbugs, that'd be great: see http://bit.ly/fedora-commonbugs-proposed for the list of bugs that may need to be added to the page
15:25:04 <adamw> #topic Fedora 19 Final planning
15:25:57 <adamw> so i had a couple of things noted down here
15:26:09 <adamw> #action adamw to complete 'new model' criteria revision by converting the final criteria
15:26:42 <adamw> #info Final TC1 scheduled for June 4th (2013-06-04)
15:27:09 <adamw> #info final freeze scheduled for 2013-06-18
15:27:34 <tflink> the iscsi installation test case needs updating for newui
15:27:42 <adamw> what else do we need to get ready for final?
15:27:44 <adamw> roger
15:27:58 <adamw> there's probably a few others too...i meant to do a comprehensive sweep through them between 19 and 20
15:28:10 <adamw> #action tflink to update the iscsi test case for newUI
15:28:13 <tflink> meant or want?
15:29:20 <adamw> whichever you prefer
15:29:49 <adamw> anyone have anything else to suggest?
15:29:52 <tflink> I assume you meant between 18 and 19, but them's details
15:31:31 <adamw> no, i meant 19 and 20
15:31:36 <adamw> but possibly 'mean' not 'meant;
15:34:35 <adamw> nothing else for 19 final prep?
15:35:12 <adamw> one note, then: we should probably cover the 'final' tests on beta and file blocker bugs for anything that fails
15:35:24 <adamw> help give us early warning of any final blockers
15:36:25 * kparal and vbocek have been already working on that
15:36:33 <tflink> and we might want to start blocker review meetings this week - the list was already pretty long when I last looked at it
15:37:05 <kparal> adamw: I just though we should fill in the empty test cases using Beta RC4 but wait for Final TC1
15:37:10 <kparal> *shouldn't
15:37:30 <adamw> kparal: it's fine to add them to the matrix, in fact it helps get a quick overview of the status
15:37:34 <adamw> thanks for working on it already
15:37:37 <adamw> tflink: that's a point
15:37:51 <kparal> at least for Desktop the packages changed a lot, since we've been unfrozen
15:38:22 <adamw> #action tflink to schedule first blocker review meeting for this week
15:38:35 <adamw> alright, we're running low on time so moving on
15:38:43 <adamw> #topic Taskbot
15:39:03 <adamw> #info http://tirfa.com/an-initial-idea-for-taskbot.html is Tim's idea for revising our approach to automated testing (and rebuilding autoqa)
15:39:15 <adamw> really just wanted to point it up and maybe have a quick q&a for anyone with questions :)
15:40:25 <jreznik> for taskbot - it would be great to coordinate with fedora revamp initiative - seems like a good fit
15:40:42 <tflink> jreznik: yeah, we've already been pinged about that
15:40:48 <kparal> tflink: so, the idea is to replace autotest, keep a half of the autoqa library. what about resultsdb?
15:41:08 <tflink> kparal: not 100% sure yet - need to talk to josef about it
15:41:20 <kparal> ok
15:41:31 <tflink> I didn't use it in the proof of concept for 2 reasons
15:41:47 <kparal> I like the architecture, at least in some points it will be a definite improvement
15:41:49 <tflink> 1 - I would rather everything use json over restful interfaces instead of xmlrpc
15:41:50 <jreznik> tflink: I'm aware of that and the whole revamp concept is all about automatic qa + processes around it
15:41:53 <kparal> if we can implement it
15:42:09 <tflink> 2 - I wanted to play with angular for the frontend instead of templating in the app
15:43:47 <tflink> yeah, human resources are going to be a bit of an issue, as always
15:44:05 <kparal> we can discuss the technical details in qa-devel. but what about some other details, like manpower. do you have some idea how many people we would need to work on it?
15:44:28 <adamw> and will the work be set up such that it's easy for people to contribute, or will that be difficult?
15:44:38 <tflink> depends on what we want done and how quickly
15:45:00 * j_dulaney is +1 public git repo
15:45:12 <tflink> it is all public
15:45:29 <kparal> the contribution should be easier
15:45:40 <tflink> than it is? yes
15:45:45 <kparal> no need to request patches approval
15:46:11 <tflink> I'd like to have code reviews for all core changes
15:46:19 <j_dulaney> +1 code reviews
15:46:30 <kparal> sure, I meant for third-party tests
15:46:37 <tflink> the task maintainers would be responsible for their own tests, though
15:47:28 <tflink> given our experience with autoqa, I assume that we're going to be hard pressed to find contributers to taskbot itself
15:47:31 <adamw> for third party tests great, but I meant the work of the actual conversion to taskbot
15:47:55 <jreznik> do you talk about contributions to the system or test cases? we would definitely need contributions from devels, mitr would like to sell it in the way - contribute test case and there would be smaller chance someone will break your stuff without knowing it (and that's the main idea behind revamp)
15:48:31 <tflink> jreznik: my initial target for taskbot is going to be no external tests
15:48:42 <tflink> once the core is solid, we can start talking about external tests
15:48:54 <j_dulaney> tflink:  Where can I start poking?
15:48:59 <kparal> I agree we will hardly find someone willing to contribute to the system core. for third-party tests I assume there should be enough interest
15:48:59 <tflink> my fear is that if we try to do everything right off the bat, this is going to implode
15:49:10 <tflink> j_dulaney: http://taskbot.tirfa.net for now
15:49:46 <tflink> it's like supporting arm - I'm planning on it and it's a requirement but the initial target is x86 to keep things kind of simpler
15:49:49 <j_dulaney> tflink:  Aye
15:49:56 <j_dulaney> Indeed
15:50:00 <jreznik> tflink: for the revamp - it's #1 feature we would like to have but I can image less gigantic first step (so the initial version with at least some integration testing prepared by QA)... just keep it in mind we would need such infrastructure
15:50:03 <adamw> j_dulaney: it'll move to https://fedorahosted.org/fedora-qa/ when it grows up I guess
15:50:35 <tflink> adamw: no, it won't - it'll be in a separate git repo and tracker
15:50:39 <adamw> ah okay
15:51:18 <tflink> jreznik: yeah, I'm still trying to figure out some of this - I'm not 100% sure what we're going to need for infra, if anything
15:51:54 <tflink> I was mostly interested in figuring out - a) is there interest in the idea? b) how soon do we want to go forward with this
15:52:34 <tflink> I'm not dumb/naive enough to assume that I've thought of everything, so useful input would be appreciated
15:52:56 <adamw> cool
15:53:14 <adamw> let's move on for now so we can wrap up in time
15:53:24 <tflink> one question is about the next steps - do we migrate the fedora cloud or replace autoqa-stg?
15:53:32 <tflink> but that can be on qa-devel@
15:53:59 <adamw> further discussion on #fedora-qa, tirfa.com, qa-devel@
15:54:07 <jreznik> tflink: I feel support especially from fesco, a lot of people stand behind it at fudcon but yeah, there's no clear direction now and it's definitely a good topic to talk abou before flock
15:54:40 <tflink> jreznik: one motivation for talking about it now was so that I can do a talk/hackfest @ flock
15:54:59 <adamw> right, that's an obvious thing we should do
15:55:02 <tflink> since the deadline for proposals is in a couple days
15:55:02 <adamw> #topic Test Days
15:55:20 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-21_AnacondaNewUI_Followup went off fine and produced some useful tests, including things we weren't covering in validation
15:55:21 <jreznik> tflink: "before flock" - it should be prepared by flock to be able to move with it there
15:55:32 * jreznik will contact mitr about it
15:56:04 <adamw> #action adamw to look at extracting some test cases from Test_Day:2013-05-21_AnacondaNewUI_Followup for use as optional test cases (or even enforceable partitioning test cases) for the validation matrices
15:56:28 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-23_Thermostat also went off well and looked like it was being useful for the developers
15:56:46 <kparal> although attended mainly by the developers themselves :)
15:57:19 <adamw> as long as they had fun :)
15:57:27 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-28_Virtualization looks to be ready
15:57:40 <adamw> are you doing a live image for that one?
15:58:04 <kparal> already provided
15:58:07 <adamw> great
15:58:15 <adamw> #info live image has been provided for virt test day
15:58:23 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-30_Spice is being worked on, but test cases not yet present
15:59:12 <adamw> Martix: are you in contact with the spice folks?
16:00:19 <Martix> adamw: I looked on test day page and I am going contact them
16:00:32 <adamw> great
16:00:39 <adamw> #action martix to ensure spice test day is ready on time
16:01:35 <adamw> #topic Open floor
16:01:42 <adamw> just wanted to say again great job everyone getting beta out on time
16:01:47 <adamw> thanks for that
16:01:54 <adamw> any other business for open floor?
16:02:21 <satellit_e> any test cases for sugar needed? or is it too specialized
16:03:48 <j_dulaney> satellit_e:  Test cases are always appreciated
16:03:52 <adamw> it would be nice if it had its own, sure
16:03:59 <adamw> we list the desktop cases for it but they're not entirely appropriate
16:04:10 <adamw> it might be good to have test cases for the most important elements
16:04:17 <satellit_e> let me draw up some simple tests
16:04:52 * satellit_e ideas for tests
16:05:06 <adamw> great, thanks
16:05:13 <adamw> #action satellit_e to work on some test cases for SoaS
16:05:19 <adamw> anything else, folks?
16:05:45 <j_dulaney> +1 to getting ready for flock; proposals close in a couple of days
16:06:19 <adamw> yup, good point
16:06:56 * j_dulaney has two proposed talks
16:07:02 <adamw> #info Flock session submission deadline is 2013-05-31, so if you have ideas for sessions, please submit them
16:07:29 <adamw> i've got one in and mean to submit another for taking another look at the release criteria
16:07:54 <adamw> which will just be me, on my own, wondering why no-one else spends all their time thinking about tweaking release criteria
16:08:38 <j_dulaney> adamw:  You're too good at it!  You drive away the compitition
16:08:43 <adamw> heh
16:08:57 <adamw> alrighty, thanks for coming everyone
16:09:15 * adamw sets the Patent Fuse for three chickens and a monkey
16:10:45 <adamw> #endmeeting