14:00:19 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:00:19 <zodbot> Meeting started Mon Jun 17 14:00:19 2013 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:19 <randomuser> #meetingname Fedora Docs
14:00:19 <zodbot> The meeting name has been set to 'fedora_docs'
14:00:19 <randomuser> #topic Roll Call
14:00:22 * Capesteve here
14:00:30 <randomuser> Hello everyone
14:00:36 <mahrud> hi!
14:01:21 * Sparks is here
14:02:25 * jjmcd 
14:02:26 * pkovar is here
14:04:10 <Sparks> Woot!  I hear that it's a bootloader
14:04:19 * Sparks is just now catching up on email
14:04:32 <randomuser> hehe
14:05:25 <randomuser> I had some grub content of my own planned, Sparks, we should coordinate in -docs sometime
14:06:04 <randomuser> #topic follow up on last weeks action items
14:06:20 <randomuser> no action items declared!
14:06:52 <Sparks> randomuser: Clearly we need more people to blame so that doesn't happen again.
14:07:04 <randomuser> I suppose I had an informal obligation to follow up up with rudi on the publishing thing, but he's updating the ticket
14:07:25 <randomuser> that reminds me
14:07:33 <randomuser> #info Participants are reminded to make liberal use of #info #link #help in order to make the minutes "more better"
14:07:44 <randomuser> #topic Release Notes - ready to start F20?
14:08:44 <randomuser> I think the release notes are pretty well done for f19
14:08:45 <mahrud> what kinds of things usually change in the Release Notes?
14:09:12 <randomuser> mahrud, everything except the boilerplate; the release notes are unique to each release by nature
14:09:13 <Sparks> randomuser: There will always be zero-day changes to the RN
14:09:47 <randomuser> Sparks, of course - and there are translations that will need publishing too
14:10:39 <randomuser> jjmcd proposed starting beats much earlier in the cycle, and now might be the time to start for F20
14:10:53 <randomuser> change proposals are already starting
14:11:27 <randomuser> jreznik has sent a handful of mails to devel, and will probably be assigning us bugs to track them soon
14:12:13 <randomuser> so, do we think it is too soon to clear master and the wiki and start prodding for writers, or just soon enough?
14:12:37 <Sparks> randomuser: Can we just branch for 19 and make 19 changes there as needed?
14:12:53 <randomuser> that's exactly what I had in mind, Sparks
14:14:12 <randomuser> mahrud, if you aren't familiar with the release notes process, we can give you a crash course sometime
14:15:49 <randomuser> ...looks like there's not a strong opinion against it
14:15:51 <mahrud> randomuser: I was just reading https://fedoraproject.org/wiki/Release_notes_process , seems like there is a page for EVERYTHING
14:15:56 <randomuser> heh
14:16:36 <randomuser> mahrud, there are quite a few, yes :)  The rpm building parts need updating, but the rest is good
14:16:51 <randomuser> #action randomuser to update rpm building docs for release notes
14:17:12 <randomuser> #topic Guide status
14:17:30 <randomuser> Capesteve, I added a topic for your thing next
14:17:41 <Capesteve> ta
14:18:29 <randomuser> so, How are we on guides?
14:18:54 <randomuser> anything the present guide owners need help with from the group, excluding sysadmin guide?
14:20:10 <mahrud> I'm still reading up on the Defensive Coding guide, but in the meanwhile added some details for the security guide
14:21:08 <randomuser> mahrud, how are you adding to it? bugs?
14:21:20 <mahrud> http://mahrud.fedorapeople.org/0001-Slight-updates-to-the-encryption-sections.patch
14:21:46 <randomuser> nice, that's a big chunk of patch!
14:22:06 <mahrud> a big part is actually just fixed tabbing I guess
14:22:37 <mahrud> I added a warning in the beginning and details on each algorithm
14:22:41 <randomuser> it's hard to hold back on that sometimes...
14:23:25 <randomuser> Ideally, mahrud , the patches are much easier to review without that
14:23:53 <mahrud> wait, this is old, date says may 29th, let me look around, there should be a newer one
14:24:19 <randomuser> is Sparks communicative and accommodating, mahrud ?
14:24:57 <Sparks> randomuser: I can be
14:25:19 <mahrud> I haven't finished up reading everything yet, but I ask questions often
14:26:17 <randomuser> mahrud, since he can't see your commit messages, I'd suggest submitting your patches to him in small logical chunks rather than all at once
14:27:52 <mahrud> sure, I didn't want to have a 100 commits with tiny changes, but I'll try to group them logically
14:28:27 <randomuser> as long as you're in communication with the guide owner, i think we'll be ok. That's the main point I wanted to make.
14:28:36 <randomuser> Anything else on guides?
14:29:26 <randomuser> ok, let's move on to guides then
14:29:33 <randomuser> #topic Proofreading Guides
14:29:38 <randomuser> #chair Capesteve
14:29:38 <zodbot> Current chairs: Capesteve randomuser
14:29:43 <randomuser> #chair jhradilek
14:29:43 <zodbot> Current chairs: Capesteve jhradilek randomuser
14:29:48 <Capesteve> We, the guide owner and myself mainly, have not had time to proof read the Sysadmin Guide for Fedora 18
14:30:01 <Capesteve> I thought it was better to publish as-is, so suggested this to jhradilek last Friday who agrees.
14:30:02 <Capesteve> The idea is to publish and see what sections need to fixed *and* are not trivial, i.e. that bother people enough to be reported.
14:30:02 <Capesteve> Then we keep trying to fix those things which are reported until Fed 19 is out.
14:30:48 <Capesteve> Some of the changes in NetworkManager section are trivial
14:31:13 <Capesteve> some other chapters not so
14:31:26 <Capesteve> Fed 19 Guide will be better as we are already working on that.
14:31:26 <Capesteve> Can you think of a way to get some volunteers to proof read a chapter or section for us?
14:31:26 <Capesteve> Maybe the best is to send an e-mail to the list with subject "Proof Readers needed".
14:31:59 <Sparks> Capesteve: I'd suggest a wiki page that people can use to sign up for sections
14:32:04 <Capesteve> The Sysadmin Guide guide owner,jhradilek, is on-leave but has joined the meeting I see.
14:32:06 <randomuser> Capesteve, the docs list, or did you have a wider audience in mind?
14:32:11 <randomuser> Sparks, +1
14:32:21 <Capesteve> I think you could e-mail the docs list
14:32:45 <Capesteve> we could ask some coleagues
14:32:50 <iambryan> Capesteve: I can help out with some proofing... is there a priority list?
14:33:27 <Capesteve> iambryan: Not from my point of view but that is a question best answered by jhradilek
14:33:46 <iambryan> Capesteve: ok
14:34:05 <Capesteve> jhradilek: Anything known to need more work than another?
14:35:05 <Capesteve> iambryan: Is there a section or subject you know better than others?
14:35:13 <randomuser> Capesteve, jhradilek - is the plan to publish as draft, review, then publish again? - or, do you have the time to update the guide for this release given guidance on what needs to change?
14:35:58 <jreznik> randomuser: ah, sorry - missed the beginning, /me is here, rereading backlog
14:36:33 <Capesteve> randomuser: I don't mind,
14:36:44 <Capesteve> randomuser: as long as its availble for proof reading
14:36:48 <iambryan> Capesteve: will have to review the doc to determine ;)
14:37:01 <randomuser> Capesteve, okay, thanks
14:37:28 <Capesteve> OK, see I will commit my chnages for NetworkManager, and some stuff on hostnamctl
14:37:44 <Capesteve> then we can ask fro an e-mail next Monday
14:37:50 <randomuser> so, we need someone to publish the doc, someone to make a wiki page to coordinate reviews, and someone to solicit reviews?
14:38:16 <Capesteve> an e-mail next Monday with a link to the Wiki page
14:38:30 <randomuser> ...and a week to prep
14:38:56 <Capesteve> I can try to make a wiki page
14:39:20 <Capesteve> and ask jhradilek to publish next Monday, as draft
14:39:38 <iambryan> Capesteve: I will reply to the group email once it goes out with what I can pick up
14:39:48 <Capesteve> iambryan: thank you
14:39:53 <iambryan> Capesteve: yw
14:40:20 <Capesteve> actually, Fed 18 Relase Notes might serve as a clue to what needs checking
14:40:39 <Capesteve> OK, enough, I am done
14:41:07 <randomuser> #info Capesteve needs input on System administrators guide
14:41:41 <Capesteve> #action me to try and make a wiki page
14:41:45 <randomuser> #info Capesteve will commit his work in progress and publish sysadmin guide for review
14:42:15 <randomuser> the more review time, the better, IMO
14:43:03 <randomuser> next topic, then?
14:43:34 <randomuser> #topic Outstanding BZ Tickets
14:43:41 <randomuser> #link http://tinyurl.com/lbrq84
14:45:09 <randomuser> so, there's some bugs
14:47:01 <randomuser> hmm... are we covering firewalld in the security guide or the sysadmin guide?
14:47:53 <Capesteve> Sec
14:48:01 <jhradilek> Should be in the Security Guide.
14:48:16 <Capesteve> Sparks in security guide
14:48:31 <mahrud> I think it should be in both actually
14:48:38 <randomuser> okay, thanks. I'm assigning you a bug, Sparks
14:49:00 <Capesteve> mahrud normallly we link to thinks
14:49:04 <iambryan> In sec guide with a pointer in sysadmin?
14:49:06 <Capesteve> rather than duplicate
14:49:24 <Capesteve> iambryan: exactamo
14:50:30 <randomuser> #action randomuser to look over open bugs for things obviously assigned to the wrong component
14:50:49 <randomuser> #topic open floor discussion
14:52:02 <mahrud> so I saw three docs-related workshops in the flock schedule
14:52:23 <randomuser> neat
14:52:41 <mahrud> I'm just curious who is managing those, etc.
14:52:41 <randomuser> Sparks, is that you?
14:52:54 * randomuser is attempting to plan attendance
14:53:09 <jreznik> it's hard to cooperate on talks at flock as you don't know with whom you should cooperate talk :(
14:54:41 <mahrud> edit: one of them is actually ARM documentation hackfest which I suppose is governed by ARM team
14:55:36 <mahrud> other than that there is a "Writing Technical Documentation for Fedora" workshop and a "Document your code" workshop
14:56:14 <randomuser> mahrud, we might have to attend them to find out who is running the shop !
14:56:21 <mahrud> :))
14:57:00 <suehle> We can check the list
14:57:15 <suehle> spot's working on the list, so if the schedule is tight, there may be some combining anyway
14:57:34 <randomuser> hey suehle
14:57:38 <suehle> hey!
14:58:02 <randomuser> I'm looking forward to the schedule update; in particular, i'm wondering if there's anything happening on monday
14:58:33 <suehle> Monday is going to be the mostly hackfesty day
14:58:44 <randomuser> fun, ok
14:59:55 <randomuser> our time is coming to a close, here's your last chance to get a word in
15:00:05 <suehle> docs hackfest submissions: Kushal Das, Jared Smith
15:00:14 <suehle> (Jared submitted two)
15:01:49 <randomuser> #endmeeting