15:25:18 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:25:18 <zodbot> Meeting started Tue Jul  2 15:25:18 2013 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:25:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:25:23 <Kevin_Kofler> #meetingname kde-sig
15:25:23 <zodbot> The meeting name has been set to 'kde-sig'
15:25:28 <Kevin_Kofler> #action Role call
15:25:37 <Kevin_Kofler> #undo
15:25:37 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x126ea550>
15:25:39 <rdieter> here
15:25:43 <Kevin_Kofler> #topic Role call
15:25:57 <Kevin_Kofler> So, rdieter and I are present, who else?
15:26:00 <jgrulich> present
15:26:15 <than> here
15:26:37 <rdieter> ltinkl, mbriza|home : ping
15:26:44 <ltinkl> here
15:27:22 * jreznik is not here, he is here
15:27:36 <Kevin_Kofler> #chair rdieter jgrulich than ltinkl jreznik
15:27:36 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik ltinkl rdieter than
15:28:01 <Kevin_Kofler> jreznik: ;-)
15:28:04 <Kevin_Kofler> #info Kevin_Kofler, rdieter, jgrulich, than, ltinkl, jreznik present.
15:28:30 <Kevin_Kofler> #topic KDE 4.10.5 status
15:28:42 <Kevin_Kofler> than: I think this one's yours. :-)
15:29:11 <than> KDE 4.10.5 import is done
15:29:38 <than> most of them are built in f19
15:29:59 <than> i hope to finish f10 build today or tomorow
15:30:06 <than> s/f10/f19
15:30:13 <Kevin_Kofler> f19-kde target?
15:30:32 <than> yes f19-kde
15:31:11 <Kevin_Kofler> #info 4.10.5 import done, most of it already built in f19-kde.
15:31:19 <than> do we plan 4.10.5 for f17?
15:31:31 <Kevin_Kofler> #action than to finish the F19 builds today or tomorrow.
15:31:43 <Kevin_Kofler> IMHO yes.
15:31:49 <Kevin_Kofler> There's a month left until EOL.
15:31:54 <Kevin_Kofler> We should be able to push this.
15:31:55 <rdieter> than: may as well, there's still ~1 month
15:32:01 <than> ok
15:32:22 <than> it's fine with me too
15:32:41 <Kevin_Kofler> Oh, I think we should remove that workaround for the KMix memory leak.
15:32:53 <Kevin_Kofler> (from Oxygen)
15:32:56 <Kevin_Kofler> It got reverted upstream.
15:33:13 <Kevin_Kofler> And changing a deleteLater to a delete is always scary, especially if upstream is no longer endorsing the change.
15:33:24 <than> Kevin_Kofler: i will take care of it
15:33:28 <Kevin_Kofler> This could cause crashes just about anywhere (and in any application, not just KMix).
15:33:38 <rdieter> there's a new kmix candidate fix worth testing too (but that can come later)
15:33:56 <Kevin_Kofler> #action than to drop the rejected KMix memory leak workaround from our Oxygen packaging.
15:34:27 <Kevin_Kofler> rdieter: Yeah.
15:34:32 <Kevin_Kofler> Anything else about 4.10.5?
15:35:52 <ltinkl> jgrulich reported the leak doesn't happen anymore with F19
15:36:04 <ltinkl> most probably because of a newer PA version
15:36:23 <Kevin_Kofler> ltinkl: But rdieter said that's not true.
15:36:40 <Kevin_Kofler> It's not clear what's going on there exactly.
15:36:41 <rdieter> ltinkl: jgrulich used the patched kde-workspace build
15:36:44 <ltinkl> aha
15:36:54 <Kevin_Kofler> Ah, that explains it.
15:36:55 <rdieter> so yeah, I would hope the leak was gone. :)
15:39:08 <jgrulich> is there some other different fix for that?
15:39:38 <Kevin_Kofler> rdieter said there's another proposed fix now.
15:39:48 <Kevin_Kofler> The one we were trying was rejected, in any case.
15:40:19 <rdieter> http://commits.kde.org/kmix/6edddf7c8e92bb499cb60fdee53622cab326f334
15:41:08 <Kevin_Kofler> OK, let's move on.
15:41:14 <Kevin_Kofler> #topic KDE 4.11 Beta 1
15:42:43 <rdieter> got most of 4.10.90 in rawhide, sans the new package spilts
15:43:11 <rdieter> worked on kdenetwork stuff, ready to submit for review:  http://rdieter.fedorapeople.org/rpms/kdenetwork/
15:44:17 <rdieter> unfortunately, some of these are bitten by the bundling bug (kopete/iris and krfb/libvncserver)
15:44:45 <Kevin_Kofler> #info most of 4.10.90 in Rawhide, sans the new package splits
15:44:52 <Kevin_Kofler> #info rdieter worked on the split kdenetwork
15:45:05 <Kevin_Kofler> #link http://rdieter.fedorapeople.org/rpms/kdenetwork/
15:45:49 <Kevin_Kofler> Well, we tried to unbundle iris, but it didn't seem to work properly. :-(
15:46:58 <rdieter> hopefully that will sastify any potential reviewer
15:47:13 <nucleo> 28 new packages in 4.11
15:47:21 <rdieter> ie, consider it a work-in-progress and not a review blocker
15:48:02 <Kevin_Kofler> We could have another try with 4.11 (IIRC, you said Kopete upgraded their bundled iris), but whether it'll work properly this time, I have no idea.
15:48:31 <rdieter> our iris packaging probably needs updating too
15:48:43 <rdieter> to roughly match/sync with what kopete has now
15:49:04 <Kevin_Kofler> Right.
15:49:32 <Kevin_Kofler> Maybe I did one of the rebases improperly, so replacing it with what upstream has now should improve things.
15:50:49 <Kevin_Kofler> Anything else about 4.11?
15:51:30 <rdieter> nucleo: do you still have that list of new packages handy?  if so, can you post it for the meeting log?
15:51:31 <Kevin_Kofler> Oh, actually, there's the Marble Python bindings FTBFS and the missing Marble BRs. I was going to look into them, but got distracted by other stuff.
15:51:46 <Kevin_Kofler> I'll try to get that done today.
15:51:53 <rdieter> I think additiona splits include: kdeadmin, kdesdk stuff
15:52:06 <Kevin_Kofler> #action Kevin_Kofler to take a look at Marble in 4.11 (Python bindings FTBFS, missing BRs)
15:52:24 <nucleo> amor cervisia dolphin-plugins kapptemplate kcachegrind kcron kde-dev-scripts kde-dev-utils kdenetwork-filesharing kdenetwork-strigi-analyzers kdesdk-kioslaves kdesdk-strigi-analyzers kdesdk-thumbnailers kdnssd kget kompare kopete kppp krdc krfb ksystemlog kteatime ktux kuser lokalize okteta poxml umbrello
15:52:39 <rdieter> nucleo: thx
15:52:57 <rdieter> #info new kde 4.11 packages include: amor cervisia dolphin-plugins kapptemplate kcachegrind kcron kde-dev-scripts kde-dev-utils kdenetwork-filesharing kdenetwork-strigi-analyzers kdesdk-kioslaves kdesdk-strigi-analyzers kdesdk-thumbnailers kdnssd kget kompare kopete kppp krdc krfb ksystemlog kteatime ktux kuser lokalize okteta poxml umbrello
15:55:46 <Kevin_Kofler> #topic Open discussion
15:55:55 <Kevin_Kofler> So, we have 5 minutes left, anything else to discuss?
15:56:54 <Kevin_Kofler> Looks like no, so thanks for coming and goodbye!
15:56:54 <jreznik> one things from me
15:56:58 <Kevin_Kofler> Oh.
15:57:03 <Kevin_Kofler> jreznik: Go ahead.
15:57:06 <jreznik> quick one :)
15:57:39 <jreznik> I'd like to thank you guys for F19! I did not have much time to contribute more but I'm running it, and I'm happy so far!
15:57:50 <Kevin_Kofler> Great!
15:58:32 <Kevin_Kofler> So I think that's all now. :-)
15:58:36 <Kevin_Kofler> #endmeeting