19:00:00 <nirik> #startmeeting Infrastructure (2013-08-15)
19:00:00 <zodbot> Meeting started Thu Aug 15 19:00:00 2013 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:01 <nirik> #meetingname infrastructure
19:00:01 <nirik> #topic welcome y'all
19:00:01 <nirik> #chair smooge relrod nirik abadger1999 lmacken dgilmore mdomsch threebean pingou puiterwijk
19:00:01 <zodbot> The meeting name has been set to 'infrastructure'
19:00:01 <zodbot> Current chairs: abadger1999 dgilmore lmacken mdomsch nirik pingou puiterwijk relrod smooge threebean
19:00:28 * cyberworm541 is here
19:00:33 * pingou here
19:00:34 <smooge> is here
19:00:39 * tflink is lurking
19:00:39 * oddshocks here
19:00:41 * adamw shows up, sure
19:00:47 * mdomsch 
19:00:53 * Smoother1rOgZ here
19:00:57 * number80 lurking 2
19:01:03 * bitlord here :-)
19:01:12 * smooge sits waiting for his airplane flight tomorrow and some semblance of a real work tomorrow night
19:01:36 <nirik> hey everyone. ;) Lets go ahead and get started I guess.
19:01:42 <nirik> #topic New folks introductions and Apprentice tasks
19:02:01 <nirik> Any new folks like to introduce themselves or apprentices have questions or comments?
19:02:25 <kushal> I want to do more work in future
19:02:37 <nirik> cool. ;)
19:02:42 <kushal> may be starting with setting up koji stages
19:02:46 <adamw> if anyone doesn't know who I am, i'm the crazy badge guy from flock.
19:02:50 <oddshocks> lol
19:03:02 <tflink> adamw: interesting way to introduce yourself
19:03:03 <nirik> adamw: everyone who looks at the leaderboard knows who you are at least. ;)
19:03:04 * relrod here (sorry, doing some other things too)
19:03:14 <nirik> #topic Applications status / discussion
19:03:17 <pingou> nirik: and the planet  ^^
19:03:19 <nirik> So, on to applications...
19:03:33 <nirik> badges launched right before flock and seems to be a hit. :)
19:03:36 <number80> hi, you met me at flock and i'd to help with apps: mostly hacking on fedocal and trying to patch things in fedmsg
19:03:48 <pingou> fedocal 2 quite ready but I don't really want to push the update before leaving, so it'll wait for September I think
19:03:56 <nirik> #info congrats on badges launch. kudos to oddshocks and threebean and many others.
19:04:03 <pingou> s/fedocal 2/fedocal 0.2.0/
19:04:07 <nirik> number80: welcome!
19:04:23 <nirik> pingou: ok.
19:04:30 <oddshocks> :D
19:04:38 <pingou> gg oddshocks and threebean :)
19:04:48 <adamw> thanks folks!
19:05:05 <nirik> pingou: tenatively we have alpha freeze from sept 3rd to 17th...
19:05:21 <pingou> nirik: arg, that's gonna clash :/
19:05:24 <nirik> yeah.
19:05:42 <pingou> well, we can do the stg instance and we'll have to wait alpha for prod
19:05:43 <nirik> we can always do a freeze break for it. ;)
19:05:51 <pingou> also an option :)
19:05:58 <mdomsch> sept 3?  that's coming up fast
19:06:06 <nirik> #info fedocal update waiting for sept
19:06:12 <nirik> mdomsch: yeah.
19:06:17 <nirik> mdomsch: branching is 20th
19:06:31 <smooge> I feel like we are always doing alphas
19:06:53 <Smoother1rOgZ> heh
19:06:58 <nirik> The great cycle. ;)
19:07:26 <nirik> any other application side news? Any places badges could use assistance in particular?
19:08:12 <adamw> in case anyone didn't see there's a bunch of query links on the front page of the new badge trac now: https://fedorahosted.org/fedora-badges/
19:08:23 <adamw> you can find badges that need definitions, need review, need artwork...
19:08:23 * pingou had not
19:09:11 <nirik> adamw: do you think it would be good to come up with a style guide for tagger ? since people are kind of free forming tags with no conventions...
19:09:16 <pingou> adamw: nice work
19:09:43 <oddshocks> nirik: +1 on some guidance on tagger
19:09:59 <oddshocks> big thanks to adamw for customizing the trac instance for us :)
19:10:17 <adamw> nirik: i'd leave that to oddshocks
19:10:31 * oddshocks is sort of taking a breather after Flock (was quite overwhelming) but is excited to see where badges goes
19:10:37 <adamw> i wasn't sure if the idea was to just collect a ton of tags and let natural selection sort them out - the UI seemed to be set up for that, intentionally minimal
19:10:47 <nirik> #info lots of links now on badges trac to show where help us needed: https://fedorahosted.org/fedora-badges/
19:10:53 <adamw> oddshocks: yw :) you know the overwhelming was an indication of huge success, right? :)
19:11:02 <nirik> adamw: yeah, to some extent... you can vote down tags that suck.
19:11:18 <oddshocks> adamw: It was cool but man I wasn't prepared. glad most people seem to dig it though
19:11:46 <adamw> nirik: some form of auto-complete or auto-correct might be nice; if you type a tag that's nearly like a voted-on existing on, suggest that one instead, should get some clumping
19:11:53 <oddshocks> As far as badges help, the frac instance linked above and the issue list https://github.com/fedora-infra/tahrir/issues are great places to look
19:11:56 <nirik> adamw: yeah.
19:11:56 <adamw> s/existing on/existing one/
19:12:09 <oddshocks> /s/frac/trac
19:12:59 <nirik> We hashed out a lot of other stuff at flock as well application wise... some great work on bodhi 2.0, figured out how we want our fedora-oauth to work, etc.
19:13:18 <pingou> I still have my notes if that can help
19:13:30 <pingou> (I guess we would like to put them somewhere on the wiki)
19:13:37 <nirik> pingou: yeah, could you post to the list? I got your paste, but I can't find it now. ;(
19:13:50 <nirik> yeah, wiki might be good too for the oauth stuff at very least.
19:13:58 <pingou> http://ur1.ca/f2fhw
19:14:21 <nirik> good. thanks.
19:14:22 <pingou> abadger1999 we didn't speak about python-fedora finally :/
19:14:23 <Smoother1rOgZ> yeah, I'm writing up a follow-up email for these
19:14:36 <nirik> oh, also, hyperkitty...
19:14:39 <Smoother1rOgZ> pingou: your note might be helpful
19:14:51 <pingou> Smoother1rOgZ: cool
19:14:59 <abadger1999> pingou: Yeah -- we didn't conclude that :-(
19:15:04 <nirik> I have now a mailman01.stg instance setup. Next steps are: setup packages/playbooks for it, setup db, test a bunch.
19:15:40 <nirik> once we have the stg one solid we can make a prod one and migrate some select lists.
19:15:45 <Smoother1rOgZ> nirik: so, will send the email in a few.
19:15:52 <nirik> Smoother1rOgZ: great!
19:15:56 <nirik> thanks
19:16:44 <nirik> #topic Sysadmin status / discussion
19:16:52 <nirik> on the sysadmin side, lets see...
19:17:05 <pingou> a bit more ansible?
19:17:14 <nirik> #info thanks to smooge for reissuing all our puppet certs when they expired tuesday morning.
19:17:26 <nirik> yeah, we have a ton of ansible stuff to do.
19:17:37 <nirik> #action nirik to move our stuff to using roles.
19:18:16 <nirik> #info added a bunch more hosts to rdiff-backup today as well.
19:19:39 <nirik> #info we have 2 new bvirthosts to add in soon.
19:19:49 <nirik> #info we have the new blade server to add in soon
19:19:59 <smooge> I still need to do some hosts
19:20:43 <smooge> my internet link is rather tenuous so I may need help doing them
19:20:50 <nirik> I can assist
19:21:08 <nirik> Oh, if someone wants a task, we have 2 scripts still using func that need porting to ansible.
19:21:37 <nirik> once they are moved we can nuke func
19:21:51 <nirik> #topic Upcoming Tasks/Items
19:21:52 <nirik> https://apps.fedoraproject.org/calendar/list/infrastructure/
19:22:00 <nirik> any upcoming tasks people would like to note or schedule?
19:22:41 <nirik> I need to add the f20 stuff in that affects us. Will do that soon.
19:23:12 <nirik> #topic Open Floor
19:23:13 <smooge> which tasks are those?
19:23:28 <nirik> smooge: like our freezes...
19:23:30 <smooge> typing through dial-up is slow
19:23:40 <smooge> sorry I meant which func tasks need to be done
19:23:42 <nirik> any items for open floor? questions? comments?
19:23:49 <nirik> smooge: it's 2 scripts... let me see:
19:23:56 <mdomsch> I need to get an MM bugfix release out
19:24:08 <mdomsch> not sure when I'll have time for it; not urgent, mostly removes hotfixes
19:24:25 <mdomsch> bapp02 hasn't OOMd since we reduced the number of crawlers last week
19:24:42 <nirik> modules/puppet/files/check_puppet_run.py (checks that puppet has checked in in X hours and sends to nagios)
19:25:05 <nirik> modules/puppet/files/make_puppet_reports.py (checks machines that have cronic puppet issues and sends a note about that)
19:25:17 <nirik> so, both also go away when puppet does, but that will be a bit longer.
19:25:19 <mdomsch> smooge: archive has releases/15/15/ for some reason, and perms are such that I can't see what's in there
19:25:22 <adamw> oh, another note on fedora-badges - if people can help triage that'd be great. right now i still haven't written up any policy or anything, but it should be pretty obvious what things should be set to what when. if you add proposed art to a bug, set artwork status to Proposed, if you write a yaml file, set definition status to Partial or Complete, Needs Review, etc...
19:25:51 <mdomsch> which server has /pub/ mounted rw ?
19:25:53 <adamw> design team members can set artwork to 'approved' and people with commit rights can set definitions to 'approved' (this isn't enforced in any way for now, hard to do in trac)
19:27:37 <nirik> mdomsch: let me think... releng04 probibly...
19:28:10 <nirik> #info triage welcome on badges ideas
19:29:19 <nirik> mdomsch: might have to be ftpsync too. ;)
19:30:20 <nirik> Oh, one other item: do we want to start discussing (possibly on list) doing a FAD later this year? or early next year...
19:30:44 * pingou is in :]
19:31:09 <pingou> Ansible, Fas3, HyperKitty
19:31:15 <Smoother1rOgZ> sure
19:31:24 <smooge> mdomsch, 15/15 is a copy of 15
19:31:36 <smooge> it is now gone
19:31:57 <smooge> mdomsch, I think I did a cp -avl and did it twice
19:31:59 <nirik> all good ones. database stuff, bodhi 2.0, 2fa'ing things.
19:32:01 <oddshocks> define FAD?
19:32:10 <nirik> oddshocks: Fedora Activity Day
19:32:11 <pingou> Fedora Activity Day
19:32:15 <pingou> too slow :)
19:32:25 <pingou> oddshocks: hackfest ;-)
19:32:25 <oddshocks> sounds cool
19:32:29 <oddshocks> hackfests++
19:32:41 <nirik> basically it's a targeted gathering... a small group gathers physically somewhere and works on one task thats harder to do ad-hock
19:33:40 <nirik> so, lets narrow down ideas and make that happen on the list.
19:33:49 <relrod> +1
19:33:56 <Smoother1rOgZ> +1
19:34:24 <pingou> I was wondering if we want to make 2 tasks one more sysadmin, the other more dev app
19:34:40 <pingou> or is it easier if we have only 1 task?
19:34:49 <nirik> pingou: possible. Usually they want FAD's to have one single goal, but we could look at some kind of 2 goal thing.
19:35:04 <nirik> That might allow us to move people between the two goals and get further on both
19:35:28 <pingou> or not, but at least we'll know :)
19:35:30 <nirik> The thing to avoid is something that we can't get done, or scattering off and trying to do too many things.
19:36:32 <nirik> ok, if nothing else will close out the meeting in a minute here.
19:37:03 <oddshocks> It was good meeting many of you in person this weekend.
19:37:13 <oddshocks> Cool group of people
19:37:26 <nirik> yeah! was very nice to meet up with everyone.
19:37:29 <pingou> oddshocks: +1, was nice :)
19:37:30 <relrod> indeed, had a great time
19:37:52 <puiterwijk> +1 from the Netherlands as well :)
19:37:59 <number80> oddshocks: the same, it helped me breaking the shyness barrier ;-)
19:38:05 <smooge> I want to say hi to eveyrone I met also and I had a good time
19:38:43 <oddshocks> puiterwijk: good to see you made it home well
19:38:58 <puiterwijk> oddshocks: yeah, I did :)  same to you ;)
19:39:00 <nirik> looking forward to next year. ;)
19:39:19 <puiterwijk> nirik: +1 on that one
19:39:23 <nirik> anyhow, do continue over on #fedora-admin, #fedora-apps and #fedora-noc
19:39:27 <nirik> thanks for coming everyone!
19:39:29 <nirik> #endmeeting