15:00:55 <handsome_pirate> #startmeeting Fedora QA meeting
15:00:55 <zodbot> Meeting started Mon Aug 19 15:00:55 2013 UTC.  The chair is handsome_pirate. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:06 <adamw> well now it's not :P
15:01:11 <handsome_pirate> #chair adamw
15:01:11 <zodbot> Current chairs: adamw handsome_pirate
15:01:13 <randomuser> ha!
15:01:15 <adamw> thansk
15:01:16 <handsome_pirate> #chair tflink
15:01:16 <zodbot> Current chairs: adamw handsome_pirate tflink
15:01:20 <adamw> #meetingname fedora-qa
15:01:20 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:24 <adamw> #topic Roll call
15:01:27 * threebean is here!
15:01:27 <handsome_pirate> #chair randomuser
15:01:27 <zodbot> Current chairs: adamw handsome_pirate randomuser tflink
15:01:37 * pwhalen is here
15:01:38 <adamw> ahoyhoy folks, who's around to A some Q?
15:01:40 * jskladan lurks
15:01:43 * mkrizek is here
15:01:48 <handsome_pirate> #topic roll call
15:01:56 <randomuser> handsome_pirate, I'm not staying :(
15:01:58 * handsome_pirate waves from his crows nest
15:02:07 * pschindl is here
15:02:08 * Cerlyn is here
15:02:14 * threebean is still here
15:02:19 * nirik is lurking
15:03:26 <adamw> threebean: i'm afraid I *probably* won't be able to derail this meeting onto the topic of badges
15:03:30 <adamw> though i will of course try my hardest
15:03:39 <handsome_pirate> adamw:  LOL
15:03:47 * threebean is here to help ;)
15:04:12 <adamw> speaking of, if you haven't seen badges yet, go to https://badges.fedoraproject.org !
15:05:41 <adamw> alrighty, looks like that's everyone
15:05:54 <adamw> #topic ARM and Visible Cloud validation process change review
15:06:32 <adamw> so if you check the meeting page at https://fedoraproject.org/wiki/QA/Meetings/20130819 i've included more detail on this
15:06:51 <adamw> as we're scheduled to do TC1 tomorrow (though...we may not get there...but that's for later) it'd be good to get the process changes for ARM and Cloud in ASAP
15:07:12 <adamw> so i thought i'd throw a spot on the schedule for anyone to air any concerns over the general approach or implementation in 'real time'
15:07:28 <adamw> did people manage to take a look at the proposals when I sent them in? or not had time yet?
15:07:30 <handsome_pirate> adamw:  Shall I spew about what I'm working on?
15:07:41 <adamw> handsome_pirate: not for now, let's focus on f20
15:07:48 <handsome_pirate> adamw:  You saw my concerns
15:07:50 <adamw> this is all about gettin' to tc1
15:07:52 <handsome_pirate> adamw:  Roger
15:08:42 <nirik> I have one thing to note...
15:09:31 <adamw> note ahead
15:09:31 <nirik> the cloud validation mentions the fedora infra private cloud. I'm not sure I fully like that, as it means we need to freeze it and always keep it production ready for testing. ;)
15:09:46 <nirik> could we make it more general 'openstack cloud' or something/
15:10:06 <nirik> in case people want to test it in their own clouds or in case ours is busted
15:10:30 <adamw> nirik: the downside to doing that is we wind up with a problem if it doesn't run in one openstack instance but does in another, or something
15:10:35 <adamw> we wind up having to make hand-wavy judgement calls
15:10:38 <adamw> is that at all likely?
15:10:58 <nirik> true. It also brings up: should version matter?
15:11:13 <nirik> ie, our cloud is openstack folsom, but thats no longer current...
15:11:20 <nirik> I mean it should work in any of them, but...
15:11:59 <nirik> perhaps ask cloud sig folks for their thoughts on what should be used to test/block?
15:12:29 <adamw> that sounds like a reasonable plan
15:12:38 <adamw> mattdm: do you happen to be around?
15:13:05 <adamw> for initial Alpha purposes we can just say 'an OpenStack cloud' and refine the definition later, maybe?
15:13:14 <nirik> wfm
15:13:19 <handsome_pirate> +1
15:13:25 <handsome_pirate> However
15:13:45 <handsome_pirate> It may be good to have a benchmark
15:14:06 <handsome_pirate> ie, "We know it works under this setup"
15:15:19 * handsome_pirate wonders by the crickets if he is making sense
15:15:28 <adamw> handsome_pirate: that would be the fedora cloud most likely, which was what we discussed at the meeting last week i think
15:15:49 * nirik really needs to upgrade our cloud.
15:16:02 * nirik really also needs an extra 12 hours in each day
15:16:23 <adamw> =) don't we all
15:16:37 <handsome_pirate> heh
15:16:46 <adamw> any other notes on the proposals as currently designed/written?
15:17:13 <handsome_pirate> None here
15:17:46 <handsome_pirate> First day of calculus
15:17:55 <handsome_pirate> Calc 2
15:19:14 <adamw> everyone else still reading, no problems, or bored? :)
15:21:01 <pwhalen> adamw, I think the arm changes look good. Do we need to make any changes on the initial-setup test case, I think you like the unified version
15:21:02 * jskladan is bored, since he has not seen a problem to brag about...
15:21:36 <adamw> pwhalen: i thought the i-s combined case looked good, nice work
15:21:44 <adamw> was just planning to go ahead and pull that in
15:21:58 <handsome_pirate> +1
15:22:05 <pwhalen> adamw, I have yet to go over the matrix in detail to look at what doesnt apply, I can do that today
15:22:14 <adamw> that'd be a great help
15:22:24 <adamw> i think base and desktop should apply, only install needs review
15:22:30 <pwhalen> right, will do
15:22:50 <adamw> ok, so it sounds like we're almost done for a first cut for ARM
15:23:30 <adamw> we still need to catch up a bit for cloud. i guess we need an 'initial deployment' test case for cloud with a little matrix like the arm one (it'll be smaller, though - just EC2 and OpenStack) and the base matrix would also apply, install and desktop would not
15:23:32 <adamw> sound sane?
15:27:03 * adamw talks to himself some more
15:27:32 * nirik nods. sounds good to me.
15:27:43 * adamw bursts with gratitude
15:28:00 <adamw> sigh, where's a viking when you need one
15:28:48 <adamw> alright then, let's move it along
15:28:59 <adamw> #action adamw to draft the final Cloud changes today
15:29:35 <adamw> proposed #agreed changes proposed so far for Cloud and ARM are accepted with the change to just mentioning OpenStack rather than the specific Fedora OS instance, and will be pushed out
15:29:45 <adamw> ack/nack/WHATTHEHELLAREYOUTHINKING
15:30:17 <pwhalen> ack
15:30:26 <jskladan> ack
15:30:30 <mkrizek> ack
15:30:36 <drago01> WHATTHEHELLAREYOUTHINKING
15:30:40 <adamw> :P hi drago
15:30:44 <drago01> ;)
15:31:37 <adamw> alrighty, thanks folks - let's pull the giant lever
15:31:41 <adamw> #agreed changes proposed so far for Cloud and ARM are accepted with the change to just mentioning OpenStack rather than the specific Fedora OS instance, and will be pushed out
15:32:57 <adamw> #topic Fedora 20 Planning
15:33:08 <adamw> sooo, here's where we are with F20: not looking great
15:33:09 * handsome_pirate comes in with a late ack
15:33:19 * handsome_pirate was distracted by class
15:33:31 <adamw> thanks pirate
15:34:01 <adamw> if sirs and madams would care to examine the current blocker list at https://qa.fedoraproject.org/blockerbugs/milestone/20/alpha/buglist , you will notice a heaping pile of showstoppers
15:34:18 <adamw> well, at least two of them, 983319 and 997690
15:34:32 <adamw> #info there are two anaconda showstoppers for F20 Alpha at present
15:34:38 <adamw> of course, we could still roll ARM and cloud images, I guess :P
15:34:45 <handsome_pirate> Aye
15:35:14 <adamw> but no, seriously, i'd plan to hold alpha tc1 until we can get those fixed and at least get through anaconda somehow in a smoke test - sound sane?
15:35:27 <handsome_pirate> Indeed
15:35:48 * jskladan is +1 for the idea of somewhat-working-anaconda-to-start-with
15:36:07 <handsome_pirate> Sane idea, indeed
15:36:26 <adamw> #agreed we'll hold off on doing Alpha TC1 until the known anaconda showstoppers are fixed
15:36:34 <adamw> #action adamw and pschindl to work with anaconda team on that
15:36:50 <adamw> is anyone aware of any other screaming issues for Alpha that aren't being tracked on the blocker list?
15:37:02 <adamw> the Bluez stuff sounds fun but should at least not be preventing any images from composing, i think
15:37:24 * handsome_pirate doesn't see how it would
15:37:39 <handsome_pirate> Are lives booting right now?
15:37:46 * handsome_pirate doesn't have a way to test 'em
15:37:51 <nirik> I can try and look at that livecd thing... but if someone else can before me that would be lovely.
15:38:07 <adamw> last live I composed booted fine, even with enforcing on
15:38:16 <adamw> that was friday iirc
15:38:23 <handsome_pirate> nirik:  Livecd thing?
15:38:30 <adamw> nirik: same question?
15:38:34 * nirik almost ignored that bug due to unrelated commentary
15:38:40 <nirik> the initial setup running on lives.
15:38:46 <nirik> 998083
15:38:48 <adamw> oh, that
15:38:53 <adamw> it should be an easyfix in spin-kickstarts
15:39:09 <adamw> i just didn't get around to it over the weekend. when you move that bit, make sure it stays within the bounds of the livesys script :P
15:39:11 <nirik> yeah, just needs someone to look at where to move the config done thing to correctly
15:39:15 <nirik> yep.
15:41:22 <adamw> #action nirik or adamw to fix spin-kickstarts user creation bug
15:41:44 <adamw> alrighty
15:41:48 <adamw> sounds like we have some plans
15:42:37 * handsome_pirate wonders if Viking is still recovering from Flock
15:43:20 <adamw> possibly :)
15:43:25 <adamw> or he's out shooting something
15:43:35 <adamw> welp, in that case, let's move on to:
15:43:38 <adamw> #topic Open Floor
15:43:42 <adamw> anyone got anything to discuss?
15:43:48 <threebean> oh!
15:43:49 <Southern_Gentlem> WOW viking came to FLOCK damn
15:44:16 <threebean> we talked at flock about measuring fedmsg reliability by checking the number of taskbot tasks run against the number of koji builds completed.
15:44:27 <handsome_pirate> adamw:  RE:  Tracker app, I opened a thread on design, EOF
15:44:37 <adamw> yeah i saw it, thanks
15:44:50 <threebean> I was wondering if someone could point me at taskbot, especially some place where I could query the number of tasks run (and the list of all tasks too, if possible).
15:44:54 <adamw> Southern_Gentlem: yeah, we met him at last! he's very nice in person
15:45:03 <handsome_pirate> threebean:  Hold one
15:45:08 <adamw> is there a tflink or a kparal in the house?
15:45:40 <handsome_pirate> threebean:  It's on tflink's personal boxen, so I don't know if you can query from your end
15:45:47 <adamw> i'm not sure taskbot is actually at the point of running tasks yet. so far the link i've been pointing to is simply tflink's blog: http://tirfa.com/an-initial-idea-for-taskbot.html
15:45:50 <jskladan> adamw: kparal is on PTO, AFAIK
15:45:54 <adamw> oh yeah, i forgot
15:46:02 <adamw> oh and tflink told me he'd be out today
15:46:24 <adamw> threebean: i'm afraid you're stuck with the monkey :) if you want to test out your idea and it's not too much work you could do it against autoqa, which is the system we actually have in production
15:46:29 <jskladan> threebean: adamw: once again AFAIK - taskbot is not running, it's in a proof-of-concept design state
15:46:32 <adamw> taskbot is the proposed replacement for/rewrite of autoqa
15:46:38 <threebean> ok.. i guess I'll correspond with tflink later when he's around :)
15:46:41 <adamw> jskladan: yeah, that's my understanding too
15:46:43 <jskladan> threebean: and tflink has some code running on his private machines
15:46:45 <threebean> maybe he and I can cook up a script to run on his end.
15:46:51 <adamw> threebean: for autoqa, see http://autoqa.fedoraproject.org/
15:47:10 <threebean> cool, cool.  thanks all :)
15:47:11 <adamw> threebean: autoqa should be running at least one test on every koji build, afaik
15:47:19 <handsome_pirate> threebean:  http://taskbot.tirfa.net/
15:47:20 <adamw> some it only runs on bodhi submissions
15:47:26 <adamw> handsome_pirate: aha, nice.
15:47:38 * handsome_pirate had to take a moment to find it
15:47:55 <handsome_pirate> threebean:  I also have a local instance I can get going
15:48:25 <handsome_pirate> threebean:  So, ping me this afternoon, say three hours from now, and we'll chat
15:48:33 * threebean nods
15:48:34 <adamw> and tflink should be in tomorrow or later today
15:48:38 * threebean will be around
15:48:39 <handsome_pirate> threebean:  I will be AFK for an hour or so
15:49:11 <adamw> oh, hey, one thing I should note for anyone who hasn't heard of it somehow or other:
15:49:20 <adamw> #info adamw will be on vacation from August 25 to September 16
15:49:32 <jskladan> prepare for the dark days!
15:49:33 <adamw> i'll be checking in via laptop every so often but i really will aim to be not working most of that time
15:50:07 <adamw> currently the plan is for pschindl to try and handle the compose requests, i'm sure he'd welcome any help in keeping up to date with those and in touch with anaconda team and fpl and fpm (which is what i usually do)
15:50:24 <adamw> er, fpm=program manager=jreznik
15:50:48 <adamw> i'm sure andre will be on top of sending out announces and setting up matrices as usual
15:51:11 <adamw> everything else should grind along just as/more smoothly without me in the way :P
15:51:17 <jskladan> I guess we'll be able to handle some of the anaconda devs in Brno - hopefully they won't be able to catch and strangle us before we tame them :)
15:51:21 <adamw> hehe
15:51:29 <pwhalen> for f20 we do have a bug on arm that may be considered a blocker, it only affects tegra2(trimslice) from our supported list
15:51:39 <pwhalen> https://bugzilla.redhat.com/show_bug.cgi?id=985342
15:51:44 <adamw> pwhalen: i believe that's going to be one of our blocking platforms, isn't it? if so, throw it on the list
15:51:49 <adamw> be good to have a test case
15:52:03 <adamw> oh right, that one. someone warned me not to run rawhide on my trimslice indeed.
15:52:17 <pwhalen> adamw, we have yet to finalize that list
15:52:31 <adamw> looks like it's in needinfo atm waiting for something from the reporters' side
15:52:55 <adamw> #info https://bugzilla.redhat.com/show_bug.cgi?id=985342 may be our first ARM release blocking bug
15:53:04 <pwhalen> I pinged Kyle about it, he hasnt had a chance yet
15:53:06 <adamw> pwhalen: you know how to put it on the alpha blocker list, right?
15:53:38 <pwhalen> I think so, I'll figure it out
15:54:58 <pwhalen> added
15:55:05 <adamw> awesome
15:55:15 * adamw sad there is no fedmsg event
15:55:24 * adamw sneaks an entry on tflink's todo
15:55:49 <adamw> we should definitely run blocker review this week, if only to put the obvious ones on the accepted list
15:58:37 <pwhalen> adamw, sure, when would that be held?
15:58:40 <adamw> wednesday
15:58:53 <pwhalen> time?
15:59:53 <adamw> er
16:00:23 <adamw> 16:00 UTC
16:01:04 <pwhalen> adamw, wfm
16:01:16 <pwhalen> thanks
16:01:22 <adamw> alrighty then folks
16:01:31 <adamw> thanks everyone for coming! looks like our project needs us
16:02:49 <pwhalen> thanks adamw et al
16:03:28 * adamw sets Quantum Fuse
16:04:14 <belimsf> oh yeah, will there be a release name?
16:05:04 <adamw> http://devopsreactions.tumblr.com/post/47609397208/on-call-saturday-morning-phone-rings-situation
16:05:09 <adamw> belimsf: not our department!
16:05:17 <belimsf> got it
16:05:50 <adamw> alrighty
16:05:51 <belimsf> not a criterion ;-)
16:05:52 <adamw> #endmeeting