15:03:18 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:03:18 <zodbot> Meeting started Tue Sep  3 15:03:18 2013 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:25 <Kevin_Kofler> #meetingname kde-sig
15:03:25 <zodbot> The meeting name has been set to 'kde-sig'
15:03:28 <Kevin_Kofler> #topic Role call
15:03:33 <Kevin_Kofler> So, who's present?
15:03:36 <mbriza> hi
15:04:57 <rdieter> howdy, here.
15:09:12 <Kevin_Kofler> dvratil, jreznik, than: Ping?
15:09:20 <dvratil> hi
15:09:45 * jreznik is around
15:11:09 <Kevin_Kofler> #chair mbriza rdieter dvratil jreznik than
15:11:09 <zodbot> Current chairs: Kevin_Kofler dvratil jreznik mbriza rdieter than
15:11:24 <Kevin_Kofler> #info Kevin_Kofler, mbriza, rdieter, dvratil, jreznik present.
15:11:26 <Kevin_Kofler> #topic Agenda
15:11:43 <Kevin_Kofler> So, rdieter proposed Qt 5.1 status and KDE 4.11.1 status.
15:11:45 <Kevin_Kofler> Anything else?
15:12:38 <mbriza> also maybe an appeal to test sddm and talk about its future theme, not a big topic though
15:12:44 <Kevin_Kofler> OK
15:12:46 <Kevin_Kofler> #topic Qt 5.1 status
15:12:52 <Kevin_Kofler> rdieter: Your turn. :-)
15:13:14 <rdieter> alrighty, much progress made with qt5 reviews, *most* stuff submitted to updates-testing now
15:13:34 <rdieter> reviews left include: qt5-qtquick1
15:13:46 <rdieter> and, just noticed today qt-5.1 included a few more modules compared to 5.0
15:13:50 <rdieter> so Im working on those too
15:14:24 <rdieter> that's all I have on qt5, any questions, comments ?
15:14:39 <rdieter> it's all in kde-testing repos too
15:15:43 <Kevin_Kofler> #info much progress made with qt5 reviews, *most* stuff submitted to updates-testing now, reviews left include: qt5-qtquick1
15:15:53 <Kevin_Kofler> #action rdieter working on new modules in 5.1 (compared to 5.0)
15:16:31 <Kevin_Kofler> I guess that's all for this topic. Thanks for your work, keep going!
15:16:37 <Kevin_Kofler> #topic KDE 4.11.1 status
15:17:54 <rdieter> in short, anyone looking at 4.11.1 yet?  anyone want to start working on it? :)
15:17:57 <Kevin_Kofler> So upstream recently tagged 4.11.1, is it officially announced already?
15:18:07 <rdieter> yes
15:18:25 <rdieter> http://dot.kde.org/2013/09/03/kde-ships-september-updates-plasma-workspaces-applications-and-platform
15:18:56 <rdieter> http://kde.org/announcements/announce-4.11.1.php
15:19:31 <rdieter> I can start/help in a few hours, after I finish up some @dayjob stuff
15:21:51 <mbriza> i can do some tomorrow, too, i guess
15:22:33 <rdieter> fyi, alpha freeze is tomorrow
15:23:02 <rdieter> so, imo, do just rawhide at first, and we'll build stuff in side tags/targets, f20-kde, f19-kde ...
15:23:21 <Kevin_Kofler> +1
15:24:22 <rdieter> I assume we won't be doing f18
15:24:44 <Kevin_Kofler> Good question…
15:25:06 <Kevin_Kofler> On one hand, the kdepim optimizations in particular would be welcome.
15:25:07 <mbriza> ok, i'll look at it tomorrow and write which ones i take here so you know
15:25:16 <Kevin_Kofler> (I'm really frustrated with KMail's slowness here.)
15:25:26 <Kevin_Kofler> On the other hand, there are huge changes in Nepomuk land.
15:26:13 <Kevin_Kofler> It might make more sense to attempt backporting the most important kdepim optimizations (mixedmaildir stuff and whatever general improvements can be found), if it can be done without the new Nepomuk.
15:26:31 <Kevin_Kofler> Just trying to update only the kdepim stack probably won't work, due to Nepomuk.
15:27:37 <rdieter> I can do unofficial builds for kde repo too, if there's demand
15:29:18 <jreznik> rdieter: +1 for unofficial builds
15:29:24 <jreznik> (at least for now)
15:29:36 <rdieter> ok, I'll consider demand for it... as a given. :)
15:32:00 <Kevin_Kofler> #action rdieter to do some 4.11.1 builds
15:32:05 <Kevin_Kofler> #action mbriza to do some 4.11.1 builds
15:32:36 <Kevin_Kofler> #info building Rawhide at first, then F20 and F19 in f20-kde resp. f19-kde side tags
15:33:08 <Kevin_Kofler> So, are we talking about unofficial builds for F18? Or only F19+ (in preparation of the official push)?
15:33:28 <rdieter> f18
15:33:53 <rdieter> f19-kde/f20-kde tag/targets for the rest
15:33:54 <Kevin_Kofler> +1, I guess we can start with that and see how it goes (how much of a mess it is to support).
15:34:27 <Kevin_Kofler> #action rdieter will do unofficial builds for F18 (kde repo).
15:35:58 <Kevin_Kofler> (I hope it won't be such a mess that you have to give up doing the builds entirely. There are some version conflicts we may hit, like krdc wanting a newer freerdp than available in F18; I guess the patch to move away from rdesktop should be reverted in the upstream build.)
15:36:10 <Kevin_Kofler> *the upstream patch … reverted in the F18 build
15:37:10 <rdieter> ah, right, well, we'll figure something out
15:37:15 <Kevin_Kofler> (That or you backport freerdp also in the unofficial build.)
15:37:20 <rdieter> yeah
15:37:48 <rdieter> I'll be doing some el6 builds sooner or later too, with similar options
15:37:59 <Kevin_Kofler> Speaking of freerdp, we probably want to add the option to disable that feature that the servers are choking on. (I don't remember how it was called.)
15:38:19 <Kevin_Kofler> Because otherwise the bug we just "fixed" on F19 by switching back to rdesktop shows up again. :-(
15:38:41 <Kevin_Kofler> (and probably poke upstream about passing that flag by default)
15:40:30 <rdieter> depends... I think different people hit different problems
15:40:46 <rdieter> for *me*, it was the --no-nla option
15:41:15 <Kevin_Kofler> I guess we can try putting the stuff as shipped by upstream in testing and see what breaks.
15:42:11 <Kevin_Kofler> #topic SDDM status
15:42:16 <Kevin_Kofler> mbriza: Your turn. :-)
15:43:12 <mbriza> okay, so, as i said, the issues with PA (maybe others) in sddm are finally (wheh) resolved
15:43:37 <mbriza> so there's nothing in way of your testing of the package... i filed updates for f18 and 19 a while ago so it'll hit updates-testing about tomorrow
15:43:52 <Kevin_Kofler> I also applied your kickstart fix to set up liveuser autologin for SDDM rather than for KDM on F20+.
15:44:06 <Kevin_Kofler> I hope it works.
15:44:14 <mbriza> thank you, we'll see in the next compose
15:44:57 <mbriza> also, as we always shipped our own theme for kdm, i thought it'd also be nice to have something for sddm, too... my design skills are rather poor though
15:46:06 <Kevin_Kofler> My design skills are also poor and my QML skills are nonexistent.
15:46:08 <mbriza> despite that, while i was ripping my hair with the pam stuff, i quickly sketched (um, hacked) something like this: http://ma.rtinbriza.cz/s/esdedeem.png
15:46:24 <mbriza> which is by no means complete and really hacky in its source
15:46:48 <mbriza> but the main idea was to have a smooth transition between plymouth and the greeter (that's why the logo is in the middle)
15:47:13 <mbriza> anyway, i don't know, it's not really necessary to have
15:50:47 <mbriza> btw by "smooth" i mean something along the lines of "when sddm does handle plymouth quit... that somebody (cough, me) will have to implement first"
15:50:56 <rdieter> not bad
15:55:12 <mbriza> thanks
15:56:39 <jreznik> mbriza: for alpha, design team is delayed too... so let's skip it for now, but for beta, we will take a look
15:57:29 <mbriza> great! thank you
15:59:44 <Kevin_Kofler> #info issues with PA etc. in SDDM finally resolved
16:00:18 <Kevin_Kofler> So, I think that's all, except the usual: Test, test, test! :-)
16:00:24 <Kevin_Kofler> #topic Open discussion
16:00:33 <Kevin_Kofler> Anything else? We're out of time already…
16:05:58 <Kevin_Kofler> #endmeeting