15:01:25 <tflink> #startmeeting Fedora QA meeting
15:01:25 <zodbot> Meeting started Mon Sep 16 15:01:25 2013 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:25 <tflink> #meetingname fedora-qa
15:01:25 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:29 <tflink> #topic Roll Call
15:01:39 * satellit listening
15:01:41 * jskladan lurks
15:01:55 * tflink tries to figure out what he did with the agenda
15:02:36 * roshi here
15:02:45 * kparal is a bit late again, but that shouldn't surprise you
15:03:04 * jreznik is here, but will have to leave in a short for an hour
15:03:21 <tflink> ah, saved it on the wrong page
15:03:39 <tflink> #link https://fedoraproject.org/wiki/QA/Meetings/20130916
15:04:20 * pschindl is here
15:05:08 * tflink waits another minute or so for folks to show up
15:06:06 <tflink> ok, it's been 5 minutes - anyone not here yet will miss out on all the fun
15:06:11 * pwhalen is here
15:06:18 <tflink> #topic previous meeting followup
15:06:26 <tflink> the only thing I'm seeing is:
15:06:44 <tflink> #info
15:06:49 <tflink> #info tflink to pester handsome_pirate about cloud testing coordination and/or talk to cloud folks about testing and eventual location of images
15:06:52 <tflink> hrm
15:06:53 <tflink> #undo
15:06:53 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x29dfb3d0>
15:06:56 <tflink> #undo
15:06:56 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x28f4c950>
15:07:01 <tflink> #info tflink to pester handsome_pirate about cloud testing coordination and/or talk to cloud folks about testing and eventual location of images
15:07:16 * Viking-Ice joins in 50%
15:07:36 <tflink> I think I pestered him about it, but I can't remember the outcome
15:08:01 <kparal> well, repeat the procedure :)
15:08:41 <tflink> yeah, I just found my irc logs and am realizing that I didn't get quite all of the information
15:08:45 <tflink> but most of it :)
15:09:09 <tflink> not sure there's much else to say on this
15:09:10 <jreznik> what's missing? if you got most of it
15:09:24 <tflink> eventual location, but I think that's also been figured out
15:09:40 <tflink> theoretically, the cloud sig is helping to test the cloud images
15:09:43 <jreznik> and from email, mattdm: This still doesn't boot. (We're working on it.) - from Sep 13
15:10:02 <tflink> yeah, the i386 AMI hasn't been booting for a while
15:10:13 <tflink> like I said, theoretically
15:11:25 <tflink> location is determined by releng, I think - new Images dir
15:11:53 <tflink> testing ... need to ping rbergeron about possibly getting people access to a fedora amazon account
15:12:39 <tflink> but that's something to deal with outside the QA meeting
15:13:16 <tflink> #action tflink to make sure some cloud testing is getting done
15:13:22 <tflink> anything else here"
15:13:25 <tflink> ?
15:13:37 <jreznik> and also how to track i386 ami better
15:14:14 <Viking-Ice> well is that not best handled by the cloud sig
15:14:59 <tflink> Viking-Ice: if they were actually doing the testing, sure
15:14:59 <tflink> jreznik: not sure I understand?
15:15:00 <tflink> i386 ami was just never tested
15:15:22 <Viking-Ice> tflink, they are the ones that should be doing the testing
15:15:37 <Viking-Ice> we should just help them prepare for it
15:15:51 <tflink> ok, moving on
15:15:51 <jreznik> tflink: I mean, we know it does not work, it's potential blocker, you did not know where/how to report it and it's not on the blocker bugs list (so could be easily missed, hard to get udpates...)
15:16:37 <tflink> jreznik: good point. it's still not blocking release
15:16:51 <tflink> #action tflink to file blocker bug about DOA i386 AMI
15:17:12 <tflink> Viking-Ice: I'm not disagreeing with you but the other option is DOA cloud images
15:17:27 <tflink> #topic F20 Alpha RC2 Testing Status
15:17:34 <jreznik> tflink: yep and you know how I hate last minute surprises when someone brings it up :)
15:18:00 <tflink> jreznik: meh, it adds excitement. what good would a boring, predictable release be :-D
15:18:10 <jreznik> :D
15:18:31 <Viking-Ice> but back to topic where are we at with regards to the alpha blocker bugs and testing
15:18:31 <tflink> any huge issues from RC2 testing thus far?
15:18:37 <tflink> other than the current blocker issues
15:19:25 <satellit> I am having a problem using anaconda liveinst to install to an external USB HD....
15:19:37 <tflink> hopefully, we'll have a new anaconda build today for #1007387
15:19:44 <kparal> I reported just a few cosmetic issues, I haven't seen any other big issue
15:19:55 <Viking-Ice> what about 1006113
15:20:08 <jreznik> btw. for current blocking issues - anaconda guys did some mess in the list by cloning blocker bugs - fedora stuff should be cleaned from that bugs
15:20:08 <kparal> tflink: will we get RC3 once that happens?
15:20:09 <tflink> Viking-Ice: it needs to be closed
15:20:17 <Viking-Ice> ah yes
15:20:19 <tflink> I forgot to secretarialize after go/no-no
15:20:23 <tflink> kparal: yep
15:20:49 <tflink> jreznik: i thought that got cleaned up post-clone
15:20:49 <Viking-Ice> what's our karma status on the bugs and their fixes
15:21:14 <tflink> there are a few builds missing karma for stable
15:21:16 <jreznik> tflink: seems like it wasn't
15:22:06 <tflink> pschindl: were you planning to do a F20 alpha karma request?
15:22:28 <tflink> I see several updates that should be stable once they get enough karma
15:22:40 <pschindl> I was. But haven't done it yet.
15:23:11 <Viking-Ice> pschindl, lure in karma via badges "Earn your badges test and provide karma" yata yata
15:23:24 <tflink> #action pschindl to send out karma/testing request for not-yet-stable updates in RC2
15:23:26 <Viking-Ice> hm we actually should be monitoring if karma brings in more people
15:23:31 <Viking-Ice> mean badges
15:24:02 <pschindl> Viking-Ice: thanks for the idea for the mail :)
15:24:04 * tflink wonders if it would be worth requesting/making badges for providing karma on blockers
15:24:38 <kparal> tflink: would be hard to query for and maintain
15:24:52 <Viking-Ice> tflink, dont think so
15:25:00 <tflink> yeah, something for another day at least
15:25:11 <Viking-Ice> have filed for a zombie badges for testing in the test matrix
15:25:47 <tflink> ok, anything else on testing status?
15:26:18 <tflink> #topic ARM Status
15:26:23 <pwhalen> tflink, arm bugs look resolved, testing the new anaconda today which should clear up our initial-setup blocker
15:26:31 <satellit> soas will start if lightdm is added to .ks and -gdm is included in it
15:26:37 <tflink> it looks like things are working better than they were
15:26:46 <tflink> satellit: bug filed?
15:26:46 <pwhalen> vexpress not booting was resolved with an update to qemu
15:27:03 <satellit> pbrobinson is aware but away atm
15:27:20 <tflink> satellit: is there a bug filed?
15:27:29 <tflink> if there's no bug, it's not supposed to change
15:27:30 <Viking-Ice> no bug no fix ;)
15:27:47 <satellit> no I will do so
15:27:56 <tflink> cool, thanks
15:28:18 <tflink> I'm hoping RC3 will be the last for f20 alpha, so I'd suggest doing it soon
15:28:32 <satellit> I did a test remix with this fix here: http://wiki.sugarlabs.org/go/Fedora_20#SoaS_86_64-dm_.28remix.29
15:28:32 <tflink> pwhalen: sounds like arm is in good shape for f20 alpha, though?
15:28:34 <kparal> I'm not sure why there are white fields in the general tests in installation matrix for ARM, when the only test case available speaks about dd-ing images to a SD card
15:28:57 <pwhalen> tflink, I'll confirm anaconda, but yes it is. The fix was very small for our setup issue
15:29:27 <pwhalen> https://admin.fedoraproject.org/updates/FEDORA-2013-16735/anaconda-20.16-1.fc20
15:29:36 <tflink> kparal: not sure I understand your question
15:29:49 <pwhalen> looks like someone left karma but didnt test the right version, can that be removed or we just need to get additional karma
15:29:53 <tflink> the lack of arm-specific stuff in the test cases?
15:29:55 <kparal> tflink: how do you run anaconda on ARM? I don't see any test case covering that
15:30:07 <tflink> yeah, not sure on that one myself
15:30:13 <kparal> I simply don't see any instructions
15:30:17 <tflink> i didn't think anaconda actually ran on arm
15:30:23 <tflink> outside of initial-setup
15:30:33 <pwhalen> kparal, pxe boot on highbank
15:30:47 <kparal> pwhalen: does it work with qemu as well?
15:31:16 <pwhalen> kparal, not that I'm aware of
15:31:48 <kparal> hmm, ok. maybe we should provide this info somehow in the matrix
15:32:10 <kparal> I saw empty cells for ARM, but I didn't know how to fill them
15:32:26 <tflink> they look mostly filled for RC2
15:32:52 <kparal> as long as pwhalen takes care of it, I don't mind... :)
15:33:04 <pwhalen> kparal, which. I think i missed - QA:Testcase_Kickstart_Nfs_Server_Path_Ks_Cfg , but all else should be done
15:33:44 <kparal> pwhalen: for example https://fedoraproject.org/wiki/QA:Testcase_Anaconda_autopart_install has ARM field enabled
15:33:58 <kparal> but I guess we can't put ARM-specific instructions into every test case
15:34:10 <kparal> we need to have a general guide at the top of the matrix or something like that
15:34:11 * jreznik has to leave now for a short, will read the log
15:34:23 <tflink> but some more links to ARM info might  be useful?
15:34:42 <kparal> definitely, but I wouldn't duplicate it into every test case
15:34:59 <pwhalen> kparal, I dont see any adjustments needed, boot the installer by any means
15:35:00 <kparal> something like "ARM testing" info box at the top of the page, perhaps?
15:35:08 <tflink> #info concerns about a lack of links to arm documentation were raised
15:35:58 <pwhalen> tflink, lack of links to arm documentation? that testcase seems pretty straightforward
15:36:09 <kparal> pwhalen: well, simple people like me don't realize that it means pxeboot (as the only method) :) I was looking for some real installation images, and they are not there, of course
15:37:06 <tflink> kparal: can you think of a better way to phrase the #info above?
15:37:10 <tflink> #chair kparal
15:37:10 <zodbot> Current chairs: kparal tflink
15:38:20 <tflink> pwhalen: I've not run through it before, to be honest
15:38:22 <kparal> #info People with no or little experience with ARM might wonder where ARM installation images are. We might consider adding a brief info to the installation matrix wiki page.
15:39:48 <tflink> ok, anything else here?
15:40:03 * tflink assumes not
15:40:30 <tflink> #info from earlier discussion, there are no currently known major issues with F20 alpha
15:40:36 <tflink> which brings us to ...
15:40:40 <tflink> #topic Open Floor
15:40:53 <tflink> I have one thing for open floor if nobody else has anything?
15:41:17 <kparal> I think we should mention that thanks to jskladan we have a simple way of seeing which test cases haven't been tested for a long time
15:41:18 <kparal> http://testdays.qa.fedoraproject.org/testcase_stats/
15:41:31 <kparal> it's regenerated every hour or so
15:41:32 * jskladan blushes
15:41:36 <satellit_e> https://bugzilla.redhat.com/show_bug.cgi?id=1008569
15:41:54 <satellit_e> not sure how to mark it for FE
15:42:03 <tflink> #link http://testdays.qa.fedoraproject.org/testcase_stats/
15:42:28 <tflink> satellit: mark it as blocking 980650
15:42:32 <satellit_e> ok
15:42:45 <Viking-Ice> +1 FE
15:43:36 <tflink> #info test case run statistics are regenerated ~ every hour and available at the url above
15:43:36 <Viking-Ice> should not be any problem to the release blocking desktop adding those missing requirements to the soas ks file
15:43:54 <tflink> jskladan: I thought you were supposed to change those dns entries
15:44:06 <tflink> they were going to be changed, rather
15:44:30 <tflink> Viking-Ice: sure, but we still need to go through the motions
15:44:42 <jskladan> tflink: I'm not sure what do you mean right now, to be honest
15:45:11 <jskladan> to be honest, I just spawned the regular cronjob there, since it's easily accessible public machine :)
15:45:25 <tflink> jskladan: we can talk after the meeting, not sure what the resolution was
15:45:41 <Viking-Ice> tflink, those here can just vote on the bug now
15:46:02 <Viking-Ice> mean the fix for this should relatively straight forward and actually faster then us voting on it
15:46:30 <pwhalen> +1 FE
15:46:57 <tflink> satellit: you add AcceptedFreezeException after it's accepted, not at proposal time :)
15:47:12 <tflink> +1 FE
15:47:13 <satellit_e> oops  sorry
15:47:52 <tflink> #info 980650 accepted as FE for F20 alpha, +3 votes in meeting
15:48:13 <tflink> ok
15:48:14 * satellit_e wish there was a dropdown  with 980650 in bugzilla.....
15:48:20 <satellit_e> thanks
15:48:39 <tflink> satellit_e: you'll be able to propose through the blocker tracking app again once I get it updated after the meeting
15:49:03 <tflink> the other thing I wanted to bring up was optical media
15:49:20 <tflink> size limits are not blocker issues for alpha, but booting from optical media is
15:50:23 <Viking-Ice> yeah we should remove it
15:50:28 <tflink> how do we want to handle the fact that the DVD.iso won't fit on a DVD?
15:50:29 <kparal> Viking-Ice: remove what?
15:50:34 <tflink> Viking-Ice: not going to happen
15:50:41 <kparal> "Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with at least one of the officially supported methods."
15:51:01 <Viking-Ice> kparal, tflink why not
15:51:24 <Viking-Ice> with the exception of the releng DVD the SIG's themselfs control the target size
15:51:25 <tflink> Viking-Ice: people still use it
15:51:36 * satellit_e not possible to split DVD to #1 and #2 with command to switch to #2 in boot?
15:51:38 <tflink> but we're talking about the DVD, not the spins
15:51:42 <kparal> so if I wanted to be super sneaky, if you can't write the image to a medium, it doesn't violate the criterion
15:52:03 <tflink> kparal: yeah, I was thinking something similar but figured it was worth discussion
15:52:07 <Viking-Ice> tflink, people still have floppy drives and your point being
15:52:13 <kparal> on the other hand, I could say that the ability to write it is a pre-requisite to testing this criterion and therefore it is a test blocker
15:52:14 <dgilmore> tflink: we have to make it smaller
15:52:19 <tflink> Viking-Ice: still have and still use are not the same thing
15:52:36 <Viking-Ice> tflink, I'm pretty sure they try to use it once in a full moon ;)
15:52:43 <Viking-Ice> we should really just stop shipping the dvd
15:52:59 <kparal> we don't have the concept of TestBlocker in Fedora QA yet, but I think we should have it
15:53:03 <dgilmore> Viking-Ice: thats a discussion for another day
15:53:14 <tflink> kparal: i was thinking that booting from optical media could be moved to beta blocker, with the size limits
15:53:23 <dgilmore> for today we will need to remove things to mak ethe dvd small enough to fit
15:53:36 <dgilmore> tflink: always a option also
15:53:36 <Viking-Ice> dgilmore, we should not be hitting sizing issue every god dam release cycle
15:53:37 <tflink> or we move size limitations to alpha, but it's a little late to be mucking around with that
15:53:43 <kparal> tflink: I'm in favor of that. but they should continue to boot in VM from .iso
15:53:59 <tflink> yeah, I'm also OK with USB and iso in VM for alpha
15:54:04 <satellit_e> and dd USB
15:54:13 <dgilmore> Viking-Ice: blame the developers and packagers :)
15:54:28 <kparal> tflink: size limits are Beta or Final?
15:54:35 <tflink> #action tflink to propose moving 'boot from optical media' criterion from alpha to beta
15:54:36 <dgilmore> kparal: Beta
15:54:38 <tflink> beta
15:54:45 <Viking-Ice> dgilmore, is it not the comps crew that's to blame here ;)
15:54:54 <kparal> tflink: sounds good
15:54:55 <Viking-Ice> tflink, just put an either or clause in the criteria
15:55:02 <dgilmore> Viking-Ice: the comps maintainers are the packagers
15:55:06 <tflink> Viking-Ice: either or?
15:55:16 <Viking-Ice> dvd or usb
15:55:33 <dgilmore> Viking-Ice: and I really dont think its comps to blame. but i could be wrong. software seems to be constantly growing deps
15:55:34 <tflink> or just move the dvd criterion to beta
15:55:42 <Viking-Ice> we can add a hard beta criteria but it's fine to have the criteria for alpha
15:56:02 <Viking-Ice> ( it's going to be even worse hitting size-ing issues in beta )
15:56:21 <tflink> what is the point of having an optical media criterion for alpha if we have no size criterion?
15:56:36 <kparal> I wouldn't split optical criteria between Alpha and Beta just because of DVD. it adds complexity
15:56:36 <dgilmore> tflink: none
15:56:44 * satellit_e 2 DVD w/ different Desktops ?
15:56:48 <dgilmore> lets move optical media to Beta with size
15:56:53 <tflink> but we're running short on time, if there's nothing else, I propose we move conversation to #fedora-qa and/or test@
15:56:55 <Viking-Ice> yeah sure
15:57:04 <Viking-Ice> tflink, just move it
15:57:59 <tflink> if there's nothing else ...
15:58:07 * tflink sets the fuse for (0,2] minutes
15:58:35 <tflink> Thanks for coming, everyone!
15:58:38 <tflink> #endmeeting