19:01:42 <nirik> #startmeeting Infrastructure (2013-07-19)
19:01:42 <zodbot> Meeting started Thu Sep 19 19:01:42 2013 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:42 <nirik> #meetingname infrastructure
19:01:42 <zodbot> The meeting name has been set to 'infrastructure'
19:01:42 <nirik> #topic welcome y'all
19:01:42 <nirik> #chair smooge relrod nirik abadger1999 lmacken dgilmore mdomsch threebean pingou puiterwijk
19:01:42 <zodbot> Current chairs: abadger1999 dgilmore lmacken mdomsch nirik pingou puiterwijk relrod smooge threebean
19:01:52 <nirik> who all is around for a infrastructure meeting?
19:02:01 * adimania is here
19:02:02 <gholms> nirik: Sorry for making you all wait.
19:02:04 * anshprat waves
19:02:07 * croberts raises his hand
19:02:23 * threebean 
19:02:27 * msuchy is here
19:02:32 <frankieonuonga> nirik: as always I am in
19:02:33 <frankieonuonga> :-)
19:02:58 * ianweller is around
19:03:19 <loic_> Hello me
19:03:20 <frankieonuonga> msuchy: hi, excited to see you here
19:03:28 <smooge> here
19:03:31 <nirik> cool. Lots of folks today.
19:03:59 <nirik> #topic New folks introductions and Apprentice tasks
19:04:08 <nirik> any new folks like to give a short intro...
19:04:14 <nirik> or apprentices with questions or comments?
19:04:38 <loic_> Yes me I am new to the project, and I try to contribute
19:04:39 <msuchy> hi, my name is Mirek Suchy
19:04:42 <croberts> I just wanted to say hi and after talking to nirik and sending out my introduction, I am happy to be here, and excited to help with some easy fix items and anything to do with the wiki ;)
19:04:50 <msuchy> I am working on Copr
19:05:16 <nirik> welcome everyone!
19:05:18 <threebean> msuchy: welcome :)
19:05:44 * lmacken here
19:05:57 * anshprat read the copr mails and blog and it was a good one
19:06:16 <msuchy> :) it will be even better
19:06:23 <nirik> so, some general links for everyone: http://fedoraproject.org/easyfix/ and https://fedoraproject.org/wiki/Infrastructure/GettingStarted and http://fedoraproject.org/wiki/Infrastructure_Apprentice
19:07:05 <nirik> I'd be happy to help anyone after the meeting over in #fedora-admin get added to fi-apprentice or point you in the right direction for working on easyfixes. ;)
19:07:27 <loic_> nirik : Do we have some third project for infrastructure ?
19:07:28 <nirik> do feel free to chime in with questions or comments anytime, we are informal in meetings. ;)
19:07:39 <nirik> loic_: third project?
19:07:47 <msuchy> can I dare to request write access to machine where are stored playbooks
19:07:57 <msuchy> I would need to change copr playbooks
19:08:06 <nirik> msuchy: yep. I can see about how to get you that after the meeting. ;)
19:08:13 <msuchy> ok
19:08:52 <nirik> we have two general areas: sysadmin and related tasks and then application development for applications we develop.
19:08:55 <loic_> nirik : tier project sorry, a coding project for the infrastructure
19:09:21 <nirik> loic_: as I think I mentioned in email to you, most of our applications are in python using various frameworks...
19:09:21 <loic_> ok
19:09:43 <nirik> https://apps.fedoraproject.org/ has a nice overview of all the stuff we run.
19:10:03 <nirik> some of those we just run instances of and some other place is development (for example, nagios, mediawiki)
19:10:20 <nirik> and some are things we develop/run (bodhi updates system, tagger, pkgdb, etc)
19:10:59 <nirik> makes me wonder... could we have some way to sort apps.fedoraproject.org based on that? might help people see what we develop...
19:10:59 <loic_> nirik : ok, thank you for the link
19:11:05 * anshprat I have another idea for apps.fp.o using another jit that can give more info. will set it up at someplace..
19:11:29 <nirik> anshprat: cool. look forward to seeing it.
19:11:41 * besser82 is another newcomer in here :)
19:12:00 <nirik> welcome besser82
19:12:08 <threebean> nirik: yeah, we can recategorize it however we like.. would take a puppet patch to do it.
19:12:11 <loic_> welcome besser82
19:12:21 <besser82> welcome nirik, loic_
19:12:35 <nirik> so, one thing I often ask new folks: are you more interested in application development/coding? or sysadmin tasks and tools?
19:12:45 <besser82> both
19:12:57 <nirik> perfectly valid. :)
19:13:09 <threebean> anshprat: btw, if you don't have any web space to put it up somewhere, we could create a temporary cloud instance for you to work on.
19:13:10 <msuchy> nirik: just development, i think copr will fill all my time :)
19:13:17 <croberts> for me most likely sysadmin tasks, because the wiki is in the sysadmin side i assume
19:13:36 <nirik> croberts: yep it is.
19:13:55 <besser82> I want to learn about setting up / maintaining HA-infra as well as contribute / improve fedora-homebrew-apps
19:14:02 <frankieonuonga> sorry guys.had a problem with my connection here. I am back though
19:14:54 <nirik> excellent.
19:14:55 <loic_> nirik : I have the boths but more by programming, with the functional langage like Haskell, Erlang or Lisp
19:14:57 <msuchy> or to be precise even sysadmin, but just around copr, maybe some trips to Fedora Cloud but I do not want to focus on too much things
19:15:09 <anshprat> threebean: thanks, that would be great! :)
19:15:58 <nirik> ok, great. So, anyone interested in the apprentice program see me in #fedora-admin after the meeting. If you're interested in app devel/coding, see #fedora-apps and we will try and point you the right way.
19:16:24 <nirik> any other general questions from new folks? or shall we move on...
19:16:37 <anshprat> nirik: am not sure all new folks are clear about sysadmin tasks tools  (even am a bit fuzzy I must say) :P
19:16:56 <loic_> nirik : for me it 's ok
19:17:00 <croberts> nirik: will do :)
19:17:10 <msuchy> move on
19:17:43 * anshprat was talking about general new folks and not specifically today's folks :P
19:17:48 <nirik> anshprat: well, by that I mean day to day management of servers and tools around them. This would include small scripts or cleaning up things, or installing new servers or ansible, or monitoring, etc.
19:17:51 * besser82 thinks he would join the apprentice first, devel would be the next run :)
19:18:52 <nirik> #topic Applications status / discussion
19:19:02 <anshprat> nirik: alright, so patching badges is coding but fixing the nodes running badges would be sysadmin..
19:19:05 <nirik> any application development news this week or upcoming?
19:19:11 <nirik> anshprat: yep.
19:19:16 <anshprat> alright
19:19:17 <nirik> there's of course sometimes overlap
19:19:27 <anshprat> (devops)
19:19:45 <nirik> sure.
19:20:01 <threebean> for news -> there's lots of pkgdb2 work going on offline.. nothing ready for deployment anywhere in the near future.
19:20:18 <ianweller> datagrepper 0.2.0 and datanommer 0.6.0 is in staging.
19:20:21 <nirik> #info lots of pkgdb2 work ongoing.
19:20:21 <threebean> much closer -> nuancier-lite is being put together in staging.. maybe done tomorrow?
19:20:23 * lmacken just did a bodhi1 masher bugfix release to releng04
19:20:31 <ianweller> mostly.
19:20:41 <ianweller> i need to nag someone to get a database set up in staging, and also figure out how to get access to a memcached instance
19:21:06 <nirik> #info nuancier-lite work ongoing, landing soon.
19:21:17 <frankieonuonga> ianweller: can i assist please?
19:21:19 <nirik> #info bodhi1 masher fix just rolled out.
19:21:34 <msuchy> I'm working full steam on Copr. I hope the by the end of the month will be ready to open it up, but there is still a lot of work ahead. There is open package review, need to finish selinux for backend, get HDD... but I expect then in 2 week I will submit RFR
19:22:09 <nirik> #info copr work ongoing, hopefully a end of the month release/opening.
19:22:11 <frankieonuonga> msuchy: I must say so far so good.doing an amazing job there.
19:22:14 <anshprat> msuchy: RFR==request for review?
19:22:18 <nirik> msuchy: I saw the review, I can try and do it soon...
19:22:20 <lmacken> anshprat: resources
19:22:21 <threebean> ianweller: so in staging, I'm pretty sure memcached is running on app01.stg but I bet there might be a firewall dance that needs to be done.  it should all be defined in our puppet repo somewhere.
19:22:30 <anshprat> lmacken: ok..
19:22:53 <ianweller> frankieonuonga: i need a sysadmin-db to create the database, and the memcached is just... finding it
19:23:01 <ianweller> frankieonuonga: so i'm not sure there's much to assist with
19:23:08 <abadger1999> I'm going to send a what's blocking python-fedora update to the infra list tomorrow -- try to get a new version of python-fedora out after we unfreeze.  (has had a draft half finished for a week but been occupied with FPC duties)
19:23:10 <msuchy> nirik: good, somebody done preliminary review, but seem to stuck right now, so I'm sure you can take over it
19:23:29 <frankieonuonga> ianweller: k so let me dm you after meeting in fedora-admin
19:23:36 <nirik> msuchy: yeah. I have it marked, it will try and work on it this weekend. ;)
19:23:57 <ianweller> threebean: aha it is.
19:24:17 <abadger1999> So  eveyrone interested, put your thinking caps on -- need to have some input about the proper course in finishing up the python-fedora auth w/ otp's model.
19:24:26 <nirik> #action nirik to try and work on copr package review soon.
19:24:37 <nirik> abadger1999: sounds fun. ;)
19:24:44 <abadger1999> always ;-)
19:24:57 * relrod_znc checks in late (and will have to check out early to run to a eyeglass appointment). Sorry my schedule is so hectic these past few weeks. :(
19:26:22 <nirik> So, we are a go on f20 alpha next tuesday. So we will be unfreezing next wed.
19:26:43 * adimania notes
19:26:58 <threebean> adimania: you have quite a queue for then :D
19:27:21 <adimania> yeah. It would be fun :)
19:27:22 <nirik> yeah, there's a bunch of stuff piling up. ;)
19:27:51 <nirik> also, we seem to be carrying a number of hotfixes... we should see if we can do any upstream releases and roll some of those up after freeze.
19:28:14 <anshprat> shouldn't the infra part which are not related to the packages (like bages etc) should not be part of freeze?
19:28:32 <threebean> anshprat: that's actually the way it is.
19:28:35 <adimania> badges is not frozen
19:28:37 <threebean> badges is not frozen right now.
19:28:39 <threebean> :)
19:28:41 * nirik nods.
19:28:47 <anshprat> oh ok
19:28:57 <adimania> there are things that are interdependent and are frozen.
19:29:03 <nirik> yeah.
19:29:16 <relrod_znc> If anyone is interested (I know dpsearch got mentioned a meeting or two ago) in comaintaining dpsearch, I'm looking for someone to do so - I've not been updating it as often as it should be.
19:29:17 <anshprat> ok, yeah agree to the dependencies being frozen
19:29:22 <nirik> so for example, many things use our proxy servers... and some of those things are frozen, so they are all frozen
19:29:43 <nirik> #info dpsearch co-maintainers welcomed
19:29:54 <nirik> ok, any more application/development side news?
19:30:29 <nirik> #topic Sysadmin status / discussion
19:30:31 <anshprat> relrod_znc: will ping you later to find out what all does it require..
19:30:36 <nirik> ok, on the sysadmin side now...
19:30:46 <nirik> #info release of f20 alpha is tuesday
19:31:01 <nirik> we have a bit of prep work for release, but shouldn't be too much.
19:31:35 <nirik> I'm happy to report that I was able to login to the management interface of our new blade server. ;)
19:31:37 <nirik> (finally)
19:31:52 <anshprat> yay
19:31:52 <frankieonuonga> nirik: jealous much
19:32:24 <nirik> I would like to look at scheduling some outages on oct 1st and 2nd for mass reboots and some other work thats pending, namely moving lookaside cache to new storage and some virtual instances around.
19:32:32 <smooge> yay
19:32:42 <nirik> frankieonuonga: we got this server many months ago and haven't been able to use it yet. ;)
19:32:45 <anshprat> nirik: ipmi /console ? or you were physically there?
19:33:01 <nirik> anshprat: java! :) (no, I'm not on site)
19:33:02 <smooge> it is in a vault inside a building in another state :)
19:33:20 <frankieonuonga> nirik: do we need to do outages  for that long?
19:33:23 <anshprat> java! phew! never seen one of those yet!
19:33:56 <nirik> frankieonuonga: not that long, but enough time to reboot things and move stuff. Just a few hours usually.
19:34:11 <nirik> and often only particular things are down at any given time.
19:34:27 <frankieonuonga> nirik: I see makes sense.
19:34:36 <nirik> #info new blade server is almost on line
19:34:53 <nirik> #info outages likely to be scheduled for oct 1st and/or 2nd
19:34:53 <anshprat> nirik: do we have anything like a cmr mentioning what all will be down and what all will be done? or just an FYI mail?
19:35:32 <msuchy> nirik: what is purpose of that blade server?
19:35:45 <nirik> anshprat: yep. a week or so before we need to formally schedule the outage. We make a trac ticket with what we are doing and what will be down and how long. Then we mail that also to announce or devel-announce depending on who it effects.
19:35:49 <msuchy> will it go to fedora cloud? or something different?
19:36:02 <nirik> msuchy: it's replacing our existing one... going to be builders for koji and releng stuff.
19:36:13 <msuchy> ok
19:36:14 <anshprat> nirik: alright, thanks
19:36:56 <adimania> I got some alerts on arm builders. Can I help with anything?
19:37:04 <nirik> msuchy: right now out cloud has 6 machines in it... but we have 2 more there. The idea was to use those 2 to install the newer cloud software and play with it, then migrate things over to it and upgrade the other cloudlet, etc.
19:37:32 <nirik> adimania: we were upgrading firmware on them and had a card die. ;( working on getting replacement in it...
19:38:00 <nirik> adimania: reminds me, after freeze we need to repoint those emails to sysadmin-build or something so more people get the fun of having them. ;)
19:38:17 <adimania> sure, no problem :)
19:38:52 <nirik> so, lets see... any other sysadmin type questions or comments or issues?
19:39:23 <nirik> oh, another one:
19:39:40 <nirik> postgresql 9.3 is out... and it has some nice replication stuff in it.
19:40:00 <nirik> 'sub second failover' and doing replication without WAL files.
19:40:35 <nirik> I keep trying to find time to dig into it but don't get to it. If someone would like to play with it and report back to everyone else on it that would be great.
19:41:04 <nirik> #topic Upcoming Tasks/Items
19:41:05 <nirik> https://apps.fedoraproject.org/calendar/list/infrastructure/
19:41:15 <nirik> anyone have upcoming items they would like to note or schedule?
19:41:58 <nirik> I'll mention here that I am planning on being off on vacation from oct 4th to the 13th... (leave friday, out the next week and back the following monday)
19:42:13 <nirik> I'll likely check emails and say hi, but dont think I will be online much. ;)
19:42:48 <croberts> nirik: where are you going for vacation?
19:43:00 <threebean> I'll mention again too then that my family's expecting a baby any day now.. so I'll be out for a while after that happens.  ;)
19:43:07 <nirik> lodge just outside yosimite, ca. ;)
19:43:13 <lmacken> nirik: nice!
19:43:18 <croberts> very nice :)
19:43:20 <nirik> yeah, should be fun.
19:43:29 <frankieonuonga> threebean: congratulations
19:43:35 <frankieonuonga> nirik: have fun
19:43:37 <croberts> threebean: congratulations
19:43:43 <besser82> Greet Yogi Bear if you see him  :D
19:43:48 <besser82> and have fun
19:43:50 <nirik> heh. will do.
19:44:03 <lmacken> well, I'm finally back on the grid, so nirik and threebean feel free to throw some stuff on my plate before you go :)
19:44:31 <nirik> lmacken: can do. :) oh, did you get a chance to look at that application logging ticket?
19:44:39 <lmacken> nirik: not yet, will have a look today
19:44:45 <nirik> cool.
19:44:48 <croberts> nirik: I will install postgresql 9.3 and start tinkering with it in some freetime :)
19:45:33 <nirik> croberts: cool. Another thing that you could look into if you like (that aligns with your wiki goals) would be to see how well the postgresql backend for mediawiki is... and how we can migrate to it.
19:45:39 <lmacken> you can also play with postgres 9.2 on openshift
19:45:50 <adimania> threebean, congratulations :)
19:46:02 <croberts> nirik: sounds good ;)
19:46:06 <nirik> SmootherFrOgZ also made repmgr rpms at: http://laxathom.fedorapeople.org/infra-fp/repmgr/
19:46:16 <nirik> repmgr was also something we wanted to check out.
19:47:00 <nirik> #topic Open Floor
19:47:17 <nirik> anyone have anything for open floor? comments, questions, suggestions, ideas, etc
19:47:53 <frankieonuonga> just a question, from last meeting , or maybe before what heppen to the idea of the fedora -search being worked on
19:47:57 <frankieonuonga> did that take off?
19:48:10 * anshprat did a blogpost on badges last week.. will be doing more on my apprenticeship experience soon..
19:48:14 <frankieonuonga> a search system being built that is .
19:48:40 <nirik> frankieonuonga: we haven't gotten any further on it I don't think... but relrod_znc did mention looking for folks to help maintain the package...
19:49:00 <frankieonuonga> relrod_znc: are you here?
19:49:20 <frankieonuonga> nirik: thank you for the response
19:49:21 <anshprat> frankieonuonga: he left to get new glasses..
19:49:22 <nirik> he had to go to an eye appointment.
19:49:29 <frankieonuonga> aaah i see.
19:49:41 <frankieonuonga> as a joke maybe it is to search for things a little better
19:49:44 <frankieonuonga> ha ha
19:49:48 <anshprat> :P
19:50:20 <nirik> :) good one.
19:51:25 <frankieonuonga> sssh...don't tell him.
19:51:37 <nirik> ok, if nothing else, will close out in a minute.
19:52:14 <frankieonuonga> thank you so much for today guys
19:52:25 <nirik> no problem, thanks for coming. ;)
19:52:32 <nirik> #endmeeting