15:00:18 <adamw> #startmeeting Fedora QA meeting
15:00:18 <zodbot> Meeting started Mon Oct  7 15:00:18 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:26 <adamw> #meetingname fedora-qa
15:00:26 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:30 <adamw> #topic Roll call
15:00:46 * adamw wonders what's ahoyhoy in czech
15:00:55 <adamw> ahojhoj, right?
15:01:02 * pwhalen is here
15:01:05 * kparal arrives
15:01:15 * mkrizek is here
15:01:20 <mkrizek> adamw: right :)
15:01:29 <adamw> ahojhoj it is, then
15:01:43 <adamw> ahojhoj from praha
15:01:46 * jreznik says ahoj to everyone :)
15:02:02 <jreznik> better to say ahoj, ahoj :)
15:02:26 <adamw> but less burns-ian
15:03:17 * tflink is
15:03:21 <tflink> here
15:03:39 <jreznik> adamw: yep
15:03:47 <adamw> tflink: aha, was wondering where you lot had got to
15:03:57 <adamw> don't you just hate north americans who never seem to be around
15:04:37 <adamw> roshi around?
15:04:40 <tflink> interesting how that changes as you cross the pond
15:04:50 <roshi> yes
15:04:53 * roshi here
15:05:15 <adamw> tflink: i've got huge piles of stuff to do while i'm here, sadly
15:05:24 <adamw> but today i've mostly just been wandering around prague being a tourist
15:05:33 <adamw> i imagine viking will be showing up as we go along
15:05:51 <adamw> #topic Previous meeting follow-up
15:06:14 <adamw> "tflink or someone competent to talk to releng about where to file bugs in the cloud .ks and whether it needs to be packaged in the distro" - tflink, any news?
15:06:37 <tflink> yes, cloud kickstarts need to be merged into spin-kickstarts
15:07:19 <tflink> instead of forming a cloud-kickstarts package. IIRC, dgilmore was planning to do this
15:07:20 <adamw> ok, is someone in charge of that?
15:07:33 <adamw> welp, we need to make sure it happens by GA, i guess
15:07:56 <adamw> #info "tflink or someone competent to talk to releng about where to file bugs in the cloud .ks and whether it needs to be packaged in the distro" - dgilmore will be making sure cloud kickstarts get added to spin-kickstarts package
15:07:57 <tflink> so bugs like the i386 AMI one would be filed against spin-kickstarts
15:08:14 <adamw> #info bugs in cloud kickstarts should be filed against spin-kickstarts
15:08:18 * Viking-Ice here for a brief moment
15:08:27 <adamw> hi viking
15:08:36 <adamw> if you're only here briefly, anything in particular you wanted to bring up?
15:09:11 <Viking-Ice> well the schedule stuff but I'll probably miss that
15:09:37 <adamw> i threw that on as i understand from tflink that fesco wanted people to pitch them specific proposals for work that could be done in a longer cycle
15:09:37 <Viking-Ice> as well as I dont know how smart workflow it is to have Fedora bugs block RHEL bugs
15:09:58 <adamw> what bug is that?
15:10:13 <adamw> often, rhel qe clones bugs we find in fedora, for RHEL
15:10:20 <adamw> when you clone, the original blocks the clone by default
15:10:23 <adamw> and sometimes they don't remove that
15:10:29 <adamw> one reason i hate using clones, but eh
15:10:30 * handsome_pirate staggers in
15:10:33 <Viking-Ice> bug 947815 the blocker bug is open so it's fine ( for now )
15:10:48 <Viking-Ice> but this could have been classic ACCESS DENIED
15:10:56 <adamw> i usually figure the rhel folks know what they're doing there
15:11:03 <adamw> i think it's more of a problem when rhel bugs block fedora bugs
15:11:27 <adamw> if you come across any of those where the rhel bug is private, give one of the rh folks a yell and we'll try and get it opened up or remove the block or something
15:12:05 <adamw> shouldn't ever be a case where fedora bugs depend on bugs that are rh-private for rhel reasons, i don't think (though sometimes fedora security bugs are embargoed, which is ok)
15:12:36 <adamw> if the fedora bug *blocks* a rhel bug, that's not really our problem - that's up to rhel people to deal with, we can just deal with the fedora bug\
15:12:58 * handsome_pirate wonders why a RHEL bug would block a Fedora bug
15:13:29 <adamw> handsome_pirate: it's usually just a mistake or a cloning artifact or something when it happens
15:13:36 <adamw> so it can usually be fixed
15:14:02 <adamw> Viking-Ice: did you have any particular ideas or concerns about the schedule stuff?
15:16:38 <Viking-Ice> adamw, mostly that we need it to you know work on stuff
15:17:13 <Viking-Ice> but fesco seemed to only give crap about what tflink and dgilmore where working on from qa/releng perspective
15:17:14 <adamw> Viking-Ice: any particular 'stuff' you wanted to put on the list?
15:17:36 <handsome_pirate> Viking-Ice:  What do you mean?
15:17:37 <Viking-Ice> adamw, qa community member work stuff like
15:17:59 <handsome_pirate> Viking-Ice:  What are you talking about, FESCo giving tflink crap?  I wasn't there, so a summary would be cool
15:18:44 <Viking-Ice> handsome_pirate, fesco was only giving crap ( only interested in ) the work tim and dennis were doing
15:18:46 <jreznik> well, that was my concern - that we need something to back up delaying schedule, not to do it just for "we can" but to have a real stuff done
15:18:47 <sgallagh> handsome_pirate: "Give a crap" vs. "giving crap". I love English.
15:19:13 <sgallagh> Viking-Ice: And no, we just were expecting that those two would be representing their respective teams. It was not exclusive.
15:19:15 <adamw> right, the idea is to nail down specific proposals, not just 'we got stuffs to do'
15:19:36 <Viking-Ice> adamw, as well as we really need to push anaconda development cycle on a different timeline
15:19:51 <Viking-Ice> so it's more or less ready when we branch
15:20:10 <Viking-Ice> for the branched release
15:20:15 <adamw> sounds like a slightly different topic, we'd have to discuss that with anaconda team i guess
15:20:33 <Viking-Ice> yes but to be able to do so we need that delay
15:20:46 <Viking-Ice> ( to be able to sync that stuff properly )
15:20:46 <handsome_pirate> Viking-Ice:  Do you have a link to the logs?
15:20:54 * handsome_pirate wants to read up on this
15:21:08 <Viking-Ice> it's there in the meetbot page
15:21:23 <jreznik> or meeting minutes are sent to -devel
15:21:54 * handsome_pirate will look
15:22:04 <adamw> Viking-Ice: i see, yeah, that links up
15:22:28 <adamw> ok, i'll try and work that in when the topic comes up, and maybe you can write a post to test@ / anaconda-devel-list@
15:22:30 <Viking-Ice> adamw, if we are going to be able to handle 3 ( or more ) products we need to put anaconda to be on different schedule so we can free up time to focus on those products
15:23:02 <handsome_pirate> Oh, the whole Fedora as Three Products thing
15:23:15 <Viking-Ice> in relation to that ( or more ) products
15:23:17 * adamw feels like he's been on the moon for a week
15:24:15 <Viking-Ice> in anycase internal meeting so carry on I'll catch up when i get back
15:25:03 <adamw> alrighty
15:25:13 <adamw> getting back to follow-up...
15:25:33 * handsome_pirate notes that there still isn't a QA person on FESCo
15:25:40 * handsome_pirate will brb
15:25:54 <adamw> #info "adamw to talk to anaconda devs and get a build done for beta tc1 with live keyboard bug fixed" - there was actually already a build ready at the time, and that went into TC1. i did check if they were happy with the build going into TC1, and they were.
15:26:08 <adamw> handsome_pirate: i think no-one wants to stand. i know i don't. :P
15:26:33 <adamw> " spstarr to work on iSCSI install testing" - anyone heard from him?
15:26:42 * adamw checks the matrix
15:28:37 <tflink> he was talking about doing it, but I didn't hear anything more
15:28:46 <adamw> there's no result for beta tc1
15:29:04 <adamw> #info "spstarr to work on iSCSI install testing" - spstarr not around, looks like no result filed for tc1
15:29:30 <adamw> #info "adamw to look into nightly fail" - was already resolved when I got to it, I did a pre-TC1 live image test which worked fine
15:29:49 <adamw> #topic Fedora 20 Beta status
15:30:12 <adamw> we're missing quite a lot of tc1 tests
15:30:33 <adamw> would be nice if folks could get around to some of those (including me)
15:30:47 <adamw> #info quite a few required tests have not been run for TC1, we need to get to those
15:32:50 <adamw> looking at the blocker list, looks like we have some changes to anaconda to check out - could be about time for a TC2 with a new anaconda build, see if the DVD size is fixed
15:33:06 <jreznik> DVD size should be fixed, I hope
15:34:24 <jreznik> gimp-help langpacks were about 600 MB
15:34:25 <adamw> #action adamw to co-ordinate with anaconda team to get a new anaconda build done and roll TC2
15:34:40 <dgilmore> adamw: ill have to make some spins-kickstarts changes to work around a dracut bug on arm images
15:35:46 <handsome_pirate> adamw:  I've run for FESCo and didn't get it
15:36:20 <handsome_pirate> adamw:  I d/l the DVD iso and it was borked, need to redownload
15:36:30 <handsome_pirate> adamw:  Checksum didn't pan out
15:36:52 <pwhalen> I'll be completing the rest of the ARM matrices today. The images themselves are doa due to the issue dgilmore mentions . I've filed a bug, added to blockers
15:41:26 <adamw> sorry...looks like i lagged out there
15:41:31 <adamw> #chair kparal tflink
15:41:31 <zodbot> Current chairs: adamw kparal tflink
15:42:02 <adamw> #info TC1 ARM images are DOA, dgilmore and pwhalen are dealing with it
15:42:23 <adamw> dgilmore: are you ready to roll with the fix whenever we go for a TC2?
15:43:11 <dgilmore> adamw: well i think the fix is reverting some things in dracut
15:43:15 <dgilmore> i have a workaround
15:43:50 <dgilmore> need to add dracut-generic-config to the arm images
15:44:14 <adamw> ah, i see
15:46:10 <adamw> alrighty, sounds like that's about it for Beta
15:46:12 <adamw> moving on..
15:49:24 <adamw> #topic Test Day status and help wanted
15:49:26 <adamw> roshi: this was sort of for you, just to check in on where we stand with test days and see if you wanted to ask for people to help run some
15:49:43 <roshi> for sure
15:49:59 <roshi> tomorrow we have Virtualization test day - so if you can make it, that would be great
15:50:13 <kparal> gnome test day on thursday should be run by lbrabec and garretraziel
15:50:47 <tflink> what about NA timezones?
15:50:51 <adamw> #info tomorrow (2013-10-08) is virtualization test day, and thursday (2013-10-10) is GNOME test day; please come if you can
15:51:03 <adamw> isn't garretraziel NA?
15:51:09 <tflink> brno
15:51:31 <kparal> adamw: you'll meet him soon enough :)
15:51:32 <roshi> I'll be here for NA timezones on thursday
15:51:48 <kparal> roshi: thanks
15:51:56 <kparal> also the gnome developers promised their presence
15:52:55 <adamw> kparal: sigh, me getting confused again
15:53:05 <adamw> roshi: any more coming up later that need help?
15:53:23 <roshi> for the graphics test week, we need volunteers to run the scheduled days (requested here: https://fedorahosted.org/fedora-qa/ticket/406)
15:53:56 <roshi> we have test days throughout the coming weeks
15:54:02 <adamw> i can probably take gfx test week
15:54:09 <adamw> should be just after i get back to canada
15:54:15 <kparal> how about wayland? that one will need a ton of preparation and I haven't seen it in the request for help
15:54:39 <roshi> that's part of the gfx test week
15:54:58 <roshi> but yes, we need someone to run that - or we need to split it off and reschedule it
15:55:09 <roshi> until someone takes it
15:55:17 <handsome_pirate> roshi:  I'll get it
15:55:43 <roshi> ok, great
15:56:22 <kparal> handsome_pirate: there are no previous test cases I think, so they need to be written from scratch
15:56:30 <kparal> best to consult this with gnome devs
15:56:44 <handsome_pirate> kparal:  Roger
15:56:51 <handsome_pirate> kparal:  I'll start on that this afternoon
15:56:55 <handsome_pirate> Actually
15:57:01 <kparal> I think that wayland test day can't be done without a heavy participation of gnome devs
15:57:23 <handsome_pirate> kparal:  I've started poking at Gnome devs
15:57:28 <adamw> most likely, and x devs.
15:57:42 <adamw> ok, moving on, since time is tight...
15:57:52 <adamw> #topic Possible elongated schedule for Fedora 21
15:58:12 <tflink> #link https://fedorahosted.org/fesco/ticket/1178
15:58:19 <adamw> so as mentioned earlier, fesco is/was wanting specific proposals of work that could be done in a longer release schedule
15:59:01 <adamw> #info fesco is wanting specific proposals of work that could be done in a longer release schedule: see https://fedorahosted.org/fesco/ticket/1178
15:59:09 <handsome_pirate> roshi:  I want to make sure of the date for Wayland:  2013-10-25
15:59:15 <adamw> we can certainly add ideas/proposals to that ticket; is there anything we want to kick around?
15:59:48 <adamw> we have viking's proposal from earlier about using a longer release to try and shift anaconda development to stabilize earlier, but that'd really need anaconda dev buy-in obviously
16:00:00 <handsome_pirate> adamw:  I'm +1 for that one
16:00:11 <adamw> are there any other ideas? work on any of the tooling we have underway at the moment, blocker bug app etc?
16:00:16 <roshi> handsome_pirate: yep - it's already on the wiki and fedocal
16:00:21 <adamw> tcms stuff?
16:00:41 <tflink> adamw: that had been in the back of my mind
16:00:43 <handsome_pirate> adamw:  Yeah, time to work on tools would be really amazing
16:01:17 <tflink> i got reamed out a little at the last fesco meeting for not having a specific plan, so we'd need more specifics
16:01:30 <adamw> well, sounds like we need to come up with fairly realistic and specifically timed-out proposals
16:01:30 <adamw> rght
16:01:33 <tflink> I didn't realize they were expecting more than proposals for automation or I'd have mentioned it earlier
16:01:39 <adamw> and it'll help our credibility if we can realistically commit and stick to anything we propose
16:02:06 <handsome_pirate> The question becomes, what do we want to focus on?
16:02:11 <handsome_pirate> Also, assignments
16:02:24 <adamw> shall i give you two action items?
16:02:24 <adamw> yeah\
16:02:41 <handsome_pirate> adamw:  Might as well
16:03:02 <handsome_pirate> tflink:  I'll ping you this afternoon about it
16:03:11 <adamw> is there one specific thing you'd like to work on above others, and can commit realistically to getting something concrete done on in, say, 3 months?
16:03:14 <handsome_pirate> Well, it is afternoon now
16:03:26 <adamw> if so, write up a good solid proposal for it, post it to the list and link from the ticket, i'd say
16:03:28 <handsome_pirate> adamw:  Testtrack
16:04:28 <handsome_pirate> The test results tracking app
16:07:50 * Viking-Ice jumps back in
16:09:43 <adamw_webchat> sorry folks, i'm lagging super-bad
16:09:49 <adamw_webchat> someone else want to take over chair to close out the meeting?
16:09:55 <tflink> sure
16:10:09 <adamw> #action tflink and handsome_pirate to write up detailed proposals for projects to be worked on in a possible longer f21 schedule and post / link to them in the trac ticket
16:10:18 <adamw_webchat> there, got that through
16:10:42 <adamw_webchat> if anyone else has concrete and achievable ideas for work to be done in a longer schedule, please add them too, of course
16:11:06 <tflink> maybe we should collect them outside the trac ticket first
16:11:16 <Viking-Ice> I'll try to throw on paper the anaconda stuff and get that discussion going with the anaconda developers
16:11:20 <adamw_webchat> right, if it needs discussion and refinement, we can work on that on the list
16:11:25 <tflink> so we present a more coherant proposal to fesco
16:11:26 <adamw_webchat> but we only have two days till fesco meeting
16:11:32 <tflink> yep
16:11:38 * handsome_pirate will get on it after lunch
16:11:41 <adamw_webchat> vik: right, that one's going to need buy-in from them of course, it's a no-go if they don't want to do it
16:12:14 <Viking-Ice> I'm pretty sure we can floor any kind of product plans if they will not buy into it
16:12:25 <adamw_webchat> heh, true
16:12:31 <tflink> #chair adamw_webchat
16:12:31 <zodbot> Current chairs: adamw adamw_webchat kparal tflink
16:12:49 <tflink> is there anything else we'd like to cover? we're already over time
16:12:50 <Viking-Ice> we need to somehow find time for that and our largest time consumer is anaconda
16:13:18 <adamw> #topic open floor
16:13:34 <adamw> and as tflink said, make it snappy :)
16:13:54 <Viking-Ice> so the general Idea I have surrounding qa community member is to merge the role of tester and triager
16:14:17 <Viking-Ice> since the bottom line is that both skill sets are more or less required ( for proper reporting and triaging )
16:14:42 <adamw> the thing with triage is that it seems like no-one actually wants to do any...
16:14:57 <Viking-Ice> as things stand now yes
16:15:09 <Viking-Ice> there seems to be little interest in it
16:15:42 <Viking-Ice> but we should be able to change that
16:15:54 <Viking-Ice> by merged these roles ( hopefully )
16:16:03 <adamw> but sure, so far as the whole group membership thing goes, that's a sensible approach
16:16:05 <adamw> so what exactly is the idea in concrete terms? people who read through Join and post up self-introductions can get triagers group membership, or what?
16:16:32 <Viking-Ice> well we need to rotated qa community members between components
16:16:56 <Viking-Ice> so you know people wont just stick themselves to the most popular component
16:17:28 <adamw> it's a bit hard to tell people what to do
16:17:40 <adamw> but sure, i like the idea of trying to get qa folks to take on some triage work
16:18:00 <Viking-Ice> well people sign up to a community member role and he gets assigned a week task ( or something ) testing and triaging x component
16:18:08 <Viking-Ice> then next week he rotates to the next one
16:18:42 <roshi> who would manage all that?
16:18:49 <roshi> setting up roles, notifying people
16:18:51 <roshi> etc
16:18:52 <roshi> ?
16:19:05 <roshi> or are you thinking some form of automated tool?
16:19:10 <Viking-Ice> you mean creating the schedule
16:19:19 <roshi> yeah
16:19:20 <Viking-Ice> yeah we need to automate the schedule creation
16:19:22 <adamw> well, and then making sure any of it actually happens...
16:19:27 <roshi> getting new things added to the schedule and whatnot
16:19:30 <tflink> week-long rotations seem like they would be a bit on the fast side - might it be better to leave people in a place for longer to gain more experience?
16:19:46 <Viking-Ice> tflink, not sure that will work
16:19:56 <roshi> I would think 2 week min if that route was taken
16:20:07 <Viking-Ice> we need to cover components on full products
16:20:32 <roshi> can you define "components" and "full products?"
16:20:48 <Viking-Ice> group of components make up x product
16:20:55 <roshi> (just so I know exactly what you're meaning - me being a new guy)
16:21:43 <Viking-Ice> so for example I first task would be to cover the components that make up the core/baseOS then extend to the next level on top of that
16:21:49 <Viking-Ice> etc
16:21:58 <roshi> ok
16:22:02 <Viking-Ice> I mean our
16:22:09 <Viking-Ice> there is no I in team
16:22:16 <roshi> do we have a list of all that, or is that something that should be created?
16:22:28 <adamw> we have the critpath list
16:22:36 <Viking-Ice> yup we can start with that
16:22:48 * handsome_pirate wonders if anyone has considered how much extra work this is going to be
16:22:50 <adamw> we used to try and cover that with triage under bz
16:23:14 <adamw> well, it's not like we'd expect 100% coverage right away or anything, i do like the idea of trying to at least get some kind of systematic coverage of different components
16:23:19 <adamw> but we're a long way over time at this point
16:23:59 <adamw> Viking-Ice: it'd be nice if you'd give us a day's advance notice of big ideas so we can work them into the meeting schedules :P
16:24:44 <Viking-Ice> adamw, well perhaps we should just schedule a brain farting session on etherpad and take something to build upon from that
16:25:17 <adamw> blue sky thinking!
16:25:54 <handsome_pirate> Ponies!
16:25:57 <handsome_pirate> Unicorns!
16:25:58 <Viking-Ice> so let's close this meeting since the general idea is out there and try to hold a spesific qa member meeting to start working out the larger vision
16:26:01 <handsome_pirate> Rainbows!
16:26:03 <adamw> sure, we could do that sometime
16:26:24 <adamw> Viking-Ice: sounds like a plan
16:26:27 * adamw sets fuse
16:27:11 <adamw> thanks for comin, folks
16:27:14 <adamw> #endmeeting