15:03:39 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:03:39 <zodbot> Meeting started Tue Oct  8 15:03:39 2013 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:45 <Kevin_Kofler> #meetingname kde-sig
15:03:45 <zodbot> The meeting name has been set to 'kde-sig'
15:03:53 <Kevin_Kofler> #topic Role call
15:04:00 * Kevin_Kofler is present, obviously. :-)
15:04:02 <Kevin_Kofler> Who else?
15:04:07 <jgrulich> me
15:04:13 * mbriza 's present, too
15:04:23 <rdieter> here
15:04:35 <than_> present
15:08:21 <Kevin_Kofler> #chair jgrulich mbriza rdieter than
15:08:21 <zodbot> Current chairs: Kevin_Kofler jgrulich mbriza rdieter than
15:08:33 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, mbriza, rdieter, than present.
15:08:36 <Kevin_Kofler> #topic Agenda
15:08:50 <Kevin_Kofler> So, the wiki page is nonexistent, so what do we have to discuss?
15:10:02 <than> Kevin_Kofler:  perhaps, kde-4.11.2 status
15:10:11 <Kevin_Kofler> OK
15:10:16 <Kevin_Kofler> Anything else?
15:11:05 <Kevin_Kofler> I guess a status update on Qt 5 packaging (and maybe KF5 if there's anything to discuss for that already) would be nice too.
15:11:07 <than> and qt5 status
15:11:12 <Kevin_Kofler> Yeah.
15:11:37 <rdieter> considering a kde test day?  (I suck, I think I was supposed to start discussion onlist about that from last week, and didn't)
15:12:18 <Kevin_Kofler> OK, we'll come to that after the status updates.
15:12:26 <Kevin_Kofler> #topic KDE 4.11.2 status
15:12:41 <Kevin_Kofler> rdieter: So you were about to push this to stable? Is it queued now?
15:12:47 <rdieter> queue'd
15:12:55 <Kevin_Kofler> I'm not aware of any reasons not to push it.
15:13:30 <than> has someone already tested 4.11.2?
15:13:49 <mbriza> i have it running on two machines
15:13:49 * rdieter has a bunch, the f19 bodhi updates got a fair amount of positive karma
15:13:52 <than> i will update to 4.11.2 and test today
15:13:58 <Kevin_Kofler> #info KDE 4.11.2 queued for F19 stable updates / F20 stable "Branched".
15:14:04 <than> rdieter: great
15:15:03 <Kevin_Kofler> Nice to know it's gotten some testing.
15:15:14 <Kevin_Kofler> I guess we can move on.
15:15:25 <Kevin_Kofler> #topic Qt 5 status
15:15:36 <Kevin_Kofler> What are the news there?
15:15:46 <Kevin_Kofler> And has any work been done on packaging KF5?
15:16:34 <Kevin_Kofler> I know Lubomir Rintel has been doing some packaging of Hawaii which included snapshots of parts of KF5, but I think that is not how we want the packages to eventually look like.
15:17:07 <Kevin_Kofler> IMHO, the libraries should have some kf5- or kde-frameworks5- name prefix like the qt5- one.
15:17:32 <rdieter> +1 to standard prefix
15:18:44 <rdieter> anyway, as far as Qt5 status goes... 5.1.1 is all headed for f18/f19 stable updates
15:19:01 <Kevin_Kofler> Great.
15:19:06 <than> rdieter: great
15:19:25 <Kevin_Kofler> #info Qt 5.1.1 headed for F18/F19 stable updates.
15:19:35 <Kevin_Kofler> I see you've been doing 5.2.0 alpha builds for Rawhide, too.
15:19:38 <rdieter> and 5.2.0-alpha is in rawhide, yes
15:20:04 <rdieter> if time permits, I would like to do some kde-unstable 5.2.0-alpha builds too
15:20:19 <Kevin_Kofler> What's the plan with that? Rawhide/unstable only until 5.2.0 final?
15:20:37 <rdieter> yes
15:20:42 <Kevin_Kofler> Or are you going to push an alpha or beta to updates for KF5 developers?
15:20:52 <Kevin_Kofler> (or to get KF5 in, even)
15:21:08 <rdieter> good question, maybe we could do it prior to a stable release if there is demand
15:21:17 <Kevin_Kofler> My guess is that when 5.2.0 goes stable, KF5 will be requiring 5.3.0 pre-alpha. :-/
15:21:46 <rdieter> Qt5 on f18/f19 is in tech-preview status already
15:22:29 <rdieter> anyone else with an opinion ?
15:23:38 <Kevin_Kofler> I'd personally put it only into kde-unstable for now, that should be enough for developers, and consider pushing it to updates when/if we have KF5 ready too.
15:23:55 <rdieter> ok, that's probably safest
15:24:03 <Kevin_Kofler> Ship prerelease versions only if we have something in Fedora actually wanting to use them.
15:24:55 <Kevin_Kofler> #info Qt 5.2.0 alpha now in Rawhide.
15:25:08 <Kevin_Kofler> #action rdieter wants to do kde-unstable builds of Qt 5.2.0 alpha if time permits.
15:25:35 <Kevin_Kofler> I think that's all for this topic.
15:25:42 <Kevin_Kofler> #topic KDE Test Day
15:25:43 <rdieter> esp if there's demand for it, accompanied by appropriate bribes of course (did I just say that out loud?)
15:25:51 <Kevin_Kofler> :-)
15:27:18 <rdieter> https://fedoraproject.org/wiki/Category:Fedora_20_Test_Days  slots used so far
15:28:04 <rdieter> looks like most folks like to do them on thursdays
15:28:54 <rdieter> anyone able/interested in leading a test-day effort?  this involves reserving the day, advertising it, and ideally, being around for some/most of the day day to help herd the cats
15:29:06 <Kevin_Kofler> Yes, Thursday is Test Day, maybe because it sounds similar? ;-)
15:30:33 <rdieter> well, we can probably tentatively help narrow which day(s) to use
15:31:25 <rdieter> 10-15 is open, then the next is 10-31, 11-05, etc...
15:31:56 <rdieter> hrm 10-31 falls on holloween , but probably not a big deal, how about that day?
15:32:06 <rdieter> 10-15 is a little short-notice imo
15:32:19 <jgrulich> I would prefer 31.10, because we have to improve ModemManager 1.0 support in plasma-nm
15:32:25 <Kevin_Kofler> That will be a scary test day. ^^
15:32:29 <rdieter> indeed
15:32:33 <mbriza> depends on you, we don't really celebrate halloween
15:32:51 <mbriza> i'd prefer the thursday though
15:33:05 <Kevin_Kofler> Just FYI, Nov 1 is a public holiday in Austria.
15:33:21 <rdieter> 11-07 then?  that's the next thursday slot
15:33:29 <Kevin_Kofler> It's a Friday, so you can expect people to already leave for a long weekend on Thursday late afternoon.
15:33:59 <Kevin_Kofler> (which would negatively impact the returns from a 10-31 test day)
15:34:08 <jgrulich> 11-07 looks good
15:34:12 <Kevin_Kofler> 11-07 should be better, yes.
15:35:09 <mbriza> seems fine to me
15:38:35 <Kevin_Kofler> So, Nov 7 fine with everybody?
15:38:49 <rdieter> looks like a tentative plan
15:39:00 <jgrulich> yep
15:39:09 <Kevin_Kofler> #agreed KDE Test Day tentatively scheduled for 2013-11-07.
15:39:27 <Kevin_Kofler> #topic Open discussion
15:39:34 <Kevin_Kofler> So, we're through the agenda, anything else?
15:40:03 * rdieter had something, but forgets now... must not have been that important. :)
15:40:19 <rdieter> ah, mbriza , any progress on userlist-less sddm theme?
15:40:44 <mbriza> the theme! well, there is no progress yet but i'll put the source somewhere finally
15:40:46 <rdieter> in particular, best to have that in place prior to test-day
15:40:58 <rdieter> ok
15:41:14 <Kevin_Kofler> Yeah, we really need that in ASAP.
15:41:15 <mbriza> jreznik isn't here, i'll ask him how he meant it with the review or what he said earlier about it...
15:41:18 <rdieter> mbriza: we have svn/git repos on fedorahosted.org, do you hav access to those?
15:41:42 <mbriza> but to make Kevin_Kofler happy, i started working on the xdmcp server again: https://github.com/MartinBriza/sddm/commit/2756c36d88
15:41:46 <rdieter> if not, we can add you easy enough
15:41:54 <mbriza> rdieter: i have access to fedora-kde-artwork
15:42:04 <rdieter> ok, plop it in there
15:42:26 <mbriza> alright
15:42:43 <rdieter> and public safety notice, don't try running sddm directly as your normal user. :)
15:44:50 <mbriza> everything you typed passed through to the first VT from the second one?
15:45:25 <rdieter> something like that
15:45:38 <mbriza> weird...
15:45:47 <rdieter> mbriza: per the hilarity from earlier today in #fedora-kde
15:46:14 <mbriza> yeah, i couldn't understand what you said and then i noticed the usernames and passwords :)
15:46:59 <Kevin_Kofler> Oh, and if you want to make me really happy, make an SDDM version of the Solar theme!
15:48:10 <rdieter> now you're just talking crazy.
15:48:30 <mbriza> you'd like that better than xdmcp? because it seems about a zillion times easier considering i still didn't get it to work :)
15:50:27 <Kevin_Kofler> I think that XDMCP will be useful to more people in the end.
15:50:45 <Kevin_Kofler> But I don't personally need it, if that's what you're asking.
15:50:56 <mbriza> btw, Beta TC2 is out... i tested the 20131004 build and it worked in contrary to TC1 so I hope TC2 will be the same
15:51:20 <mbriza> ah, i thought you were using it when you were standing so strong for its implementation
15:51:32 <Kevin_Kofler> I'm just not happy about defaulting to a display manager which does not support all the things people expect from a display manager.
15:53:09 * Kevin_Kofler wonders how many other KDM features we were taking for granted (if any) are still missing from SDDM.
15:53:42 <Kevin_Kofler> (Features we don't even think about putting in a requirements list because we're so used to them we find them obvious.)
15:53:52 <Kevin_Kofler> I hope there aren't any of those, of course.
15:54:16 <rdieter> Kevin_Kofler: kdm is still available, it's not like the features are gone
15:54:46 <Kevin_Kofler> One thing I can think of is configuration. Is there a configuration UI for SDDM yet?
15:54:58 <Kevin_Kofler> Or are you stuck with the config file? :-(
15:54:59 <mbriza> the completely basic ones are already there... anyone advanced enough to use xdmcp can switch to kdm anyway
15:55:19 <mbriza> it is, not packaged yet though
15:56:03 <Kevin_Kofler> That's the kind of a feature that should really be a requirement for anything you want to ship to end users, yet when you see stuff like polkit-1…
15:56:19 <mbriza> i don't quite understand why it's not a part of the main package
15:56:44 <Kevin_Kofler> (Only configurable through config files in Fedora, a KDE configuration UI is in a partially-to-non-working state upstream, and there's no official configuration UI for it at all.)
15:56:46 <mbriza> what's with polkit?
15:56:55 <mbriza> oh
15:57:08 <Kevin_Kofler> You have to write XML or JavaScript files to configure it even.
15:57:17 <Kevin_Kofler> Not even plain config files like the SDDM one.
15:58:40 <mbriza> well i talked about the config ui with drf and we settled on leaving it as it is..
15:59:37 <mbriza> but you're right the config files are a mess
16:00:45 <Kevin_Kofler> I think the polkit-1 editor really needs to be finished/fixed upstream where needed and packaged in Fedora.
16:01:16 <Kevin_Kofler> It'd be useful even to non-KDE users seeing how there's no other polkit-1 editor (unlike the old version).
16:01:59 <Kevin_Kofler> There are plenty of polkit permissions I and many others would like to customize and it's a PITA to do so.
16:05:21 <Kevin_Kofler> Anything else? It's time to conclude…
16:06:06 <Kevin_Kofler> OK, thanks for coming!
16:06:09 <Kevin_Kofler> #endmeeting