15:06:06 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:06:06 <zodbot> Meeting started Tue Oct 15 15:06:06 2013 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:13 <Kevin_Kofler> #meetingname kde-sig
15:06:13 <zodbot> The meeting name has been set to 'kde-sig'
15:06:18 <Kevin_Kofler> #topic Role call
15:06:22 * Kevin_Kofler is present, who else?
15:06:28 * jgrulich is present
15:06:32 * mbriza too
15:06:40 <rdieter> hi
15:07:44 * ltinkl is here
15:08:28 <Kevin_Kofler> #chair jgrulich mbriza rdieter ltinkl
15:08:28 <zodbot> Current chairs: Kevin_Kofler jgrulich ltinkl mbriza rdieter
15:09:40 <mbriza> just before we start, sorry for not letting you know sooner: i'd like to discuss state of my change proposal for f20
15:09:54 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, mbriza, rdieter, ltinkl present.
15:10:04 <Kevin_Kofler> Yeah, change proposals are the main topic for today anyway. :-)
15:10:23 <Kevin_Kofler> #topic Agenda
15:10:32 <Kevin_Kofler> So change proposals, today is the deadline!
15:10:34 <Kevin_Kofler> Anything else?
15:11:02 <Kevin_Kofler> Should we go through the change proposals one by one? Which ones do we have? KDE 4.11, SDDM, plasma-nm, anything else?
15:11:29 <Kevin_Kofler> (I think those 3 are all we filed, right?)
15:11:44 <rdieter> one by one is probably best
15:12:11 <Kevin_Kofler> Do we have any other topics? Or can we use the whole 48 minutes remaining for the change proposals?
15:12:33 <mbriza> nothing else from my side
15:13:15 <Kevin_Kofler> OK, nothing else, so change proposals it is. :-)
15:13:31 <Kevin_Kofler> #topic Change proposal: KDE (Plasma Workspaces etc.) 4.11
15:13:47 <Kevin_Kofler> I think this one is good to go, right?
15:14:04 <Kevin_Kofler> IMHO, it can be marked completely done, even including testing.
15:14:10 <ltinkl> yup
15:14:11 <Kevin_Kofler> After all we've been shipping it even on F19.
15:14:56 <Kevin_Kofler> Though ON_QA until the Test Day is fine with me too.
15:15:16 <Kevin_Kofler> But it's definitely ready for the required ON_QA state today.
15:15:29 <rdieter> 4.11 is good to go
15:16:00 <Kevin_Kofler> So, what state do we put the tracker in? CLOSED? Or ON_QA?
15:16:30 <rdieter> close
15:16:54 <Kevin_Kofler> +1 CLOSED from me.
15:17:28 <jgrulich> +1 for CLOSED
15:18:08 <Kevin_Kofler> #agreed The KDE 4.11 feature is completely done, the tracker shall be put into CLOSED state.
15:18:16 <Kevin_Kofler> So that was a quick one. :-)
15:18:28 <Kevin_Kofler> #topic Change proposal: SDDM by default instead of KDM
15:18:37 <Kevin_Kofler> mbriza: Your turn. :-)
15:19:33 <mbriza> so, sddm - to have it feature complete, i focused to finally finish the xdmcp support, which i did yesterday - and will merge it into our sddm as a patch if you agree
15:19:57 <Kevin_Kofler> +1 to including the patch.
15:20:08 <mbriza> here's the pull request: https://github.com/sddm/sddm/pull/107
15:20:38 <mbriza> anyway, there are some bugs left, i'll fix them over the course of the next weeks (especially the super annoying relogging on live image, that's still present, right?)
15:20:47 <rdieter> as long as it is safe, ie, since xdmcp is not enabled by default and the new code won't significantly affect non-xdmcp operation or testing
15:21:16 <mbriza> it's disabled, the current code depends on it just by calling the XDMCP::Server constructor
15:21:28 <rdieter> ok, +1
15:21:42 <mbriza> and there are two added methods to the current code but they are called from the XDMCP code only
15:22:03 <Kevin_Kofler> I've seen the changes, I think they're safe.
15:22:39 <Kevin_Kofler> The KDM ConsoleKit patch I rushed into F7 in the last moment was much scarier. ;-)
15:26:11 <Kevin_Kofler> So, what's the conclusion here? Do we move to the next state (which is ON_QA, as I understand it)?
15:26:40 <Kevin_Kofler> The alternative would probably be the big red "contingency plan" button.
15:27:22 <mbriza> well, i don't think that's necessary
15:27:30 <mbriza> depends on you though
15:27:34 <Kevin_Kofler> I think we have already decided to push this through, and there's nothing I can see which would make me want to scream "contingency plan".
15:28:32 <Kevin_Kofler> I haven't been a big fan of this from the beginning, but still, the decision was to try this and so far it has done all that it has promised.
15:28:49 <rdieter> according to http://fedoraproject.org/wiki/Changes/Policy#FAQs , we're supposed to mark it ON_QA  I guess
15:28:54 <Kevin_Kofler> So I'm for putting this into ON_QA state.
15:28:58 <ltinkl> put it in ON_QA state
15:29:11 <rdieter> I guess we should have done that for the 4.11 feature too
15:30:54 <Kevin_Kofler> #agreed SDDM is "code complete", the tracker will be put into ON_QA state.
15:31:12 <mbriza> i'll prepare the patch and push it to f20 and rawhide
15:31:30 <Kevin_Kofler> I'll put the other one into ON_QA too and ask jreznik whether we can/should close it entirely.
15:31:56 <Kevin_Kofler> mbriza: One thing I'd like to see packaged is the configuration UI.
15:32:05 <Kevin_Kofler> Editing config files is not very nice for the average user.
15:32:16 <Kevin_Kofler> KDM had a nice KCM there.
15:32:52 <mbriza> Kevin_Kofler: yeah, you're right, i'll prepare a spec when i'll be bored in school in the evening .)
15:34:09 <Kevin_Kofler> OK. :-)
15:34:18 <Kevin_Kofler> #action mbriza will package the configuration UI.
15:34:35 <Kevin_Kofler> Anything else for SDDM?
15:35:13 <mbriza> over time i'll try to convince upstream to merge the two projects, there is no reason to keep these two things apart, anyway
15:35:40 <Kevin_Kofler> Well, there could be multiple versions of the configuration UI.
15:36:44 <Kevin_Kofler> One KCM, one Plasma Active configuration module and one standalone Qt-only app.
15:36:44 <Kevin_Kofler> (for example)
15:37:01 <mbriza> ah, yes, i see
15:38:26 <Kevin_Kofler> I presume right now it's standalone, right?
15:38:51 <mbriza> it just edits the config, so i guess it is
15:39:57 <Kevin_Kofler> #topic Change proposal: plasma-nm
15:40:03 <Kevin_Kofler> OK, this is the last one.
15:40:12 <Kevin_Kofler> jgrulich said he already put it into ON_QA state, right?
15:40:36 <jgrulich> Kevin_Kofler: yes
15:41:14 <Kevin_Kofler> I have no objections to that.
15:41:22 <Kevin_Kofler> Is everybody fine with this assessment?
15:41:28 <rdieter> ON_QA++, now that it properly Obsoletes kde-plasma-networkmanagement
15:41:58 <Kevin_Kofler> Is ModemManager 1.0 support included now?
15:42:22 <jgrulich> Kevin_Kofler: yes
15:42:26 <Kevin_Kofler> Great!
15:42:41 <jgrulich> Kevin_Kofler: but I have to make git snapshots of libmm-qt/libnm-qt
15:42:55 <jgrulich> * had to make
15:43:19 <Kevin_Kofler> (It wouldn't really have been a requirement for the change IMHO, because it wasn't there to begin with, it's more for a ModemManager change… BTW, have they filed one? They should have…)
15:43:41 <Kevin_Kofler> (But that it's included is great, of course.)
15:44:07 <ltinkl> it even works :)
15:44:18 <Kevin_Kofler> :-)
15:44:43 <ltinkl> jgrulich has been able to connect to the O2 mobile network using it
15:44:50 <Kevin_Kofler> You mean, unlike the hit-and-miss NM 0.9 "compat API" hack in early F15. ;-)
15:45:09 <ltinkl> ye, I didn't like the compat layer from the start
15:45:20 <mbriza> btw, what does control the android tethering? especially usb and bluetooth?
15:45:45 <ltinkl> NM + MM + bluez(5)
15:46:07 <ltinkl> in this order
15:46:21 <mbriza> all of them, heh, thanks
15:46:25 <jgrulich> mbriza: tethering via usb should work, it's not a problem of ModemManager
15:46:31 <Kevin_Kofler> Doesn't BlueDevil also come into play? I think I have read it has some support for Bluetooth networking, but whether it actually works, I don't know.
15:47:01 <ltinkl> Kevin_Kofler: nope, we use bluez directly... which reminds me we should port it to bluez5 too, heh
15:47:13 <ltinkl> so that part might not work perfectly in F20
15:47:37 <ltinkl> jgrulich: more work :) ^^
15:47:56 <ltinkl> but this wasn't part of the feature/change
15:48:20 <Kevin_Kofler> Yeah, that's really supposed to be the BlueZ 5 change's job…
15:48:42 <Kevin_Kofler> But I'm confident you can pull it off ASAP.
15:50:10 <jgrulich> and I think this is not much used
15:50:46 <Kevin_Kofler> #info This change is already in ON_QA state, no objections to that were raised.
15:50:53 <Kevin_Kofler> #topic Open discussion
15:50:58 <Kevin_Kofler> Anything else to discuss?
15:51:39 <ltinkl> just a heads up, on a related note, I updated the bluedevil snapshot from the current git
15:51:52 <jgrulich> do we have reserved day for KDE test day?
15:52:02 <mbriza> yes, the test day, thanks for reminding that
15:52:12 <ltinkl> which should have an "almost-working" implementation of the bluez5 apu
15:52:14 <ltinkl> api
15:53:02 <Kevin_Kofler> We wanted Nov 7, is this now official? If not, and if there are no conflicts, we should officialize it ASAP or there WILL be conflicts. ;-)
15:53:36 <ltinkl> that's Thursday for the record
15:54:08 <Kevin_Kofler> Yes, it's the Thursday 3 weeks (and 2 days) from now.
15:57:34 <Kevin_Kofler> So, who takes care of reserving and coordinating the Test Day?
15:57:53 <Kevin_Kofler> mbriza: Can you take care of this? You have been driving this, haven't you?
15:59:31 <mbriza> i have been driving what? :)
15:59:34 <mbriza> but i can
15:59:56 <Kevin_Kofler> Who do you think should own the KDE Test Day? :-)
16:00:07 <Kevin_Kofler> Most likely not me. ^^
16:00:12 <ltinkl> mbriza: got driving license? :p
16:00:20 <mbriza> no idea but i can't just throw it on anyone else just like that! :D
16:00:24 <mbriza> ltinkl: yeah, damn
16:00:50 <mbriza> well, alright, i'm on it :)
16:01:22 <Kevin_Kofler> Of course, if nobody feels responsible, we can just not hold a Test Day at all, I wouldn't be opposed to that. ;-)
16:04:42 <Kevin_Kofler> #action mbriza to reserve the KDE Test Day.
16:04:51 <Kevin_Kofler> I think that's all for today, thanks for coming!
16:04:55 <Kevin_Kofler> #endmeeting