15:00:09 <adamw> #startmeeting Fedora QA meeting
15:00:09 <zodbot> Meeting started Mon Oct 21 15:00:09 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:13 <adamw> #meetingname fedora-qa
15:00:13 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:16 <adamw> #topic Roll call
15:00:20 * roshi is here
15:00:28 * satellit listening
15:00:28 * cmurf here
15:00:54 * mkrizek is here
15:00:59 * jreznik is here, not sure he will be available for the whole meeting - needs to pickup prescription in the ambulance
15:01:04 * kparal here
15:01:06 * handsome_pirate perches in the Crows Nest
15:01:19 <adamw> jreznik: yikes, sounds worrisome
15:01:33 <handsome_pirate> jreznik:  What's up?
15:01:39 * pschindl is here
15:01:48 <roshi> that's not a normal place to pick up a rx
15:02:29 * handsome_pirate tosses a couple crows eggs at roshi
15:02:36 <cmurf> roshi: sounds convenient though
15:02:44 <roshi> lol
15:03:37 <jreznik> adamw, handsome_pirate: just running out of my medicine - chronic hypertension :)
15:05:18 <adamw> ah, not an emergency then...whew
15:05:31 <adamw> #topic Previous meeting follow-up
15:05:34 <adamw> just one thing here:
15:05:39 <adamw> "roshi will update the Test Day SOP as agreed (encourage use of webapp for tracking test day results)"
15:05:44 <adamw> roshi, has that been done?
15:05:52 <roshi> https://fedoraproject.org/wiki/QA/SOP_Test_Day_management#Set_up_the_TestDayApp
15:05:57 <roshi> yep, edits welcome
15:06:23 * pwhalen is here
15:06:24 <roshi> but I suppose the "edits welcome" part goes without saying...
15:08:53 <adamw> =)
15:08:54 <adamw> thanks!
15:09:11 <roshi> good enough then?
15:09:33 <adamw> #info "roshi will update the Test Day SOP as agreed (encourage use of webapp for tracking test day results)" - this was done, see https://fedoraproject.org/wiki/QA/SOP_Test_Day_management#Set_up_the_TestDayApp
15:09:46 <adamw> roshi: i don't think it's necessary to create the matrix before the event any more, in fact it might just be confusing
15:10:10 <adamw> i would've just said to create the metadata before the event, make sure the test day page explains where to go for the list of tests and to submit results, and copy the results in later
15:10:23 <adamw> but that's just me...
15:10:33 <roshi> yeah - but when you export the results it doesn't include the test names themselves
15:10:51 <roshi> it just formats the results with the user that did them
15:11:07 <adamw> ah, interesting
15:11:18 <adamw> so you'd still need to create the matrix to copy the results into
15:11:25 <roshi> yeah
15:11:26 <adamw> still, not sure it needs to exist before the event happens...
15:11:38 <adamw> maybe we should ask jskladan to tweak that if possible? probably make it easier
15:11:56 * roshi shrugs
15:12:19 <roshi> before of after doesn't matter to me
15:12:39 <roshi> I can ask jskaladan about the tweak
15:12:56 <roshi> if the app pushed those out, then there'd be no need to think before/after for the matrix
15:13:14 <adamw> right, exactly
15:13:22 <adamw> just a simple copy/paste from the app into the page would be nice
15:13:26 <roshi> yeah
15:13:41 <roshi> where does the source live for the app? out of curiousity
15:13:45 <adamw> #action roshi to talk to jskladan about improving testday app result table generation so no manual work is required to prime the table
15:14:30 <adamw> roshi: i don't actually know; i've filed a ticket related to that
15:14:33 <adamw> does anyone know?
15:15:07 <adamw> https://fedorahosted.org/fedora-qa/ticket/426
15:15:50 <roshi> it's flask-based, iirc right?
15:16:24 <kparal> adamw: I guess https://github.com/rajcze/testdays_frontend
15:16:26 * adamw doesn't recall, sounds right
15:16:40 <adamw> kparal: that looks like it
15:16:42 <kparal> hmm, that's outdated repo probably
15:16:51 <kparal> I guess Josef moved it somewhere else
15:16:52 <nirik> do you folks want to keep just running that in the cloud? or ?
15:17:10 <adamw> might be nice to move it to infra i guess
15:17:31 <nirik> yeah.
15:17:38 * nirik is happy to help with that process.
15:18:31 <kparal> best to start the discussion in qa-devel with jskladan in CC
15:18:32 <adamw> kparal: is it OK if I action jskladan in his absence?
15:18:41 <adamw> i could action nirik i guess
15:18:42 <kparal> adamw: feel free to do so :)
15:19:09 <adamw> #action jskladan and nirik to discuss moving testday result app to infrastructure, probably on qa-devel list
15:19:23 * nirik nods. I am already subscribed there.
15:19:28 <adamw> coolbeans
15:19:53 <adamw> anything else for follow-up?
15:20:37 <adamw> alrighty then
15:20:41 <adamw> #topic Fedora 20 Beta status
15:21:37 <kparal> we still have quite a few unresolved blockers
15:21:40 <adamw> so, we're not looking super awesome
15:21:41 <adamw> indeed
15:21:43 <kparal> mainly anaconda
15:21:43 <jreznik> yep :(
15:21:50 <adamw> #info https://qa.fedoraproject.org/blockerbugs/milestone/20/beta/buglist still shows several unresolved blockers
15:21:58 <kparal> mainly filesystems
15:22:11 <adamw> i sent a blocker status mail to test/devel last week, ccing all involved developers, so everyone should be aware
15:22:22 <adamw> not sure there's much more we can do from our side except make sure we have covered all testing bases
15:22:37 <adamw> #action adamw to put together an F20 stable push request
15:22:40 <adamw> (that needs doing)
15:22:59 <adamw> oh, we should probably have done a blocker review meeting after qa meeting :( sorry for not announcing one
15:23:21 <jreznik> kparal: yep, that leads to one developer...
15:23:27 * handsome_pirate stumbles in for a couple minutes
15:23:28 <adamw> do people want to do that?
15:23:30 <adamw> ahoy pirate
15:23:48 <handsome_pirate> Alas, I won't make the post meeting meeting
15:23:49 <kparal> adamw: I'm OK with that
15:23:51 <jreznik> adamw: if there's nothing else for qa meeting, let's do it now
15:24:03 * handsome_pirate is busy getting paid
15:24:04 <cmurf> adamw: crank it out
15:24:09 * roshi will be here
15:24:17 <kparal> jreznik: there are some more topics I guess, like Test Days
15:24:42 <jreznik> kparal: ok, so I'll follow it from phone
15:25:06 * sgallagh can represent FESCo at a blocker meeting if needed
15:25:39 <adamw> jreznik: we decided to stop doing blocker review inside qa meetings, it's not a great process
15:25:54 <adamw> #agreed we'll run a quick blocker review meeting in #fedora-blocker-review at the top of the hour
15:26:06 <adamw> OK
15:26:14 <adamw> how does test coverage look?
15:26:46 <adamw> looks like we need more USB and cloud testing
15:26:54 <adamw> any cloud-y folks around?
15:27:30 <adamw> #info TC5 testing still has gaps, please everyone work to fill out the matrices and make sure our coverage is complete
15:27:40 * nirik could try and toss a tc5 into the infra cloud.
15:27:48 <jreznik> ok
15:27:50 <adamw> i see missing usb, cloud, dvd install, repository and disk target tests
15:28:05 <pwhalen> adamw, will be filling in the missing portions for arm today
15:28:11 <adamw> awesome, thanks
15:28:16 * jreznik knows it's separate process just wanted to speed it up a bit :)
15:28:17 <kparal> most of the USB test cases were tried with TC2
15:28:20 <cmurf> adamw: a lot of those were done with tc4 or tc3 so they're not totally untested, just not tested with current TC
15:28:22 <satellit> did DVD as USB test
15:28:22 <kparal> that's not that far ago
15:28:25 <adamw> pwhalen: if you could be around for the blocker meeting it'd help, as there's an arm issue there we'll likely need info on
15:28:34 <satellit> dd
15:28:44 <adamw> cmurf: indeed, but best to be up to date, esp. as we have seen some breakage in partitioning stuff between TCs already
15:28:55 * roshi can do some USB testing
15:28:59 <pwhalen> adamw, for sure
15:29:09 <satellit> cannot do DVD to hrd metal from disk  no dual layer here
15:29:11 <cmurf> adamw: understood
15:29:25 <adamw> satellit: yeah, we're kinda stuck on that test for now :/
15:29:52 <cmurf> i don't recall seeing a fully complete matrix for actual CD/DVD media testing
15:29:58 <satellit> dd USB to hard metal works though
15:30:13 <adamw> cmurf: we can't do DVD physical media testing really until it's undersize
15:30:19 <adamw> unless someone goes and buys a dual layer disc :P
15:30:33 <roshi> +1 satellit, this box is dd usb to hard metal
15:30:35 <cmurf> ohduhoknevermind
15:31:52 <cmurf> i can vouch for livecd-tools and dd to usb sticks for live, dvd, and netinst on Mac EFI
15:32:13 <cmurf> so that's three of the USB stick entries in the matrix
15:32:15 <cmurf> with TC5
15:32:52 <satellit> virtualbox here cannot see network even though says it is connected for netinstall DVD and live...may be f20 3.10.1
15:33:05 <satellit> boxes is OK
15:33:09 <adamw> vbox isn't supported
15:33:10 <adamw> :P
15:33:26 * cmurf updates matrix
15:33:27 <satellit> worked in earlier TC's though
15:35:03 <adamw> OK, sounds like we know where we are
15:35:09 <adamw> anything else on f20 status?
15:35:14 <adamw> oh
15:35:32 <adamw> can people +1 https://admin.fedoraproject.org/updates/lorax-20.3-1.fc20 ?
15:35:44 <adamw> it was used for TC5, so as long as that compose didn't explode (which it didn't), we can +1 the update
15:35:55 <adamw> #info https://admin.fedoraproject.org/updates/lorax-20.3-1.fc20 can be up-karmaed on the basis of TC5 testing
15:37:08 <adamw> #topic Open floor
15:37:15 <adamw> so I have something for this which I forgot to put on the agenda...
15:37:35 <jreznik> just two reminders - readiness and go/no-go meetings are held this week
15:37:36 <adamw> #info this week is Graphics Test Week - please help out with prepping the test days and contributing results
15:37:59 <cmurf> wow the whole week
15:38:03 <adamw> #action adamw to finish setting up gfx test week
15:38:05 <adamw> cmurf: yeah, and we'
15:38:11 <adamw> we're CLEARLY HIGHLY PREPARED :P
15:38:13 <roshi> adamw: I can help you out with that
15:38:17 <adamw> thanks
15:38:22 <kparal> I'm a bit concerned about the wayland test day. still no wiki page and no test cases. the gfx test cases can be copied from the last time, but not wayland
15:38:24 <adamw> #roshi to help adamw with setting up gfx test week
15:38:36 <kparal> handsome_pirate: what's the wayland test day status?
15:38:37 <adamw> kparal: yeah, we need to sort that out, but the copy/paste monkey-work comes first
15:38:42 <adamw> worst comes to worst, we can re-schedule wayland
15:38:54 <adamw> #info wayland test day is currently completely un-prepared, may need to be re-scheduled
15:38:55 <satellit> note I did a rpm test of power for karma and now screen does not blank after 1 min etc stays on  not important though
15:39:26 <roshi> I pinged handsome_pirate on Friday about wayland test day
15:39:30 <roshi> he's aware at least
15:39:49 <kparal> the developers need to be aware and need to provide test cases :)
15:40:11 <cmurf> karpal exactly what i was going to ask, if he's getting the necessary input
15:40:35 <roshi> so we should ping the wayland devs for test cases?
15:40:46 <adamw> yeah, we should
15:40:48 <cmurf> and gnome
15:41:02 <cmurf> and kde
15:41:06 <adamw> #action handsome_pirate, adamw and roshi to co-ordinate with wayland and GNOME devs to arrange wayland test cases
15:43:39 <adamw> #info Go/No-Go and release readiness meetings for F20 Beta will both be held this Thursday
15:46:12 <adamw> anything else for open floor, folks?
15:46:26 <nirik> if anyone cares, rawhide composes were broken by createrepo
15:46:31 <nirik> hopefully we have a fix today.
15:47:17 <adamw> #info rawhide composes have been broken recently by createrepo, should be fixed today
15:49:12 <adamw> welp, looks like we can finish early for a change, only to leap straight into a blocker review meeting :)
15:49:18 * adamw sets the Quantum Fuse
15:50:12 * jreznik has to go, will try to follow blocker meeting on the phone
15:51:08 <adamw> thanks for coming, folks
15:51:11 <adamw> blocker review in 9 minutes
15:51:16 <adamw> over in #fedora-blocker-review
15:51:17 <adamw> #endmeeting