15:06:48 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:06:48 <zodbot> Meeting started Tue Oct 29 15:06:48 2013 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:52 <Kevin_Kofler> #meetingname kde-sig
15:06:52 <zodbot> The meeting name has been set to 'kde-sig'
15:07:08 <Kevin_Kofler> #topic Role call
15:07:13 <Kevin_Kofler> So, who's present?
15:07:21 <rdieter> here
15:07:22 <Kevin_Kofler> (other than me ;-) )
15:07:26 <jgrulich> present
15:08:18 <mbriza> me too
15:08:50 <than> here
15:10:04 <Kevin_Kofler> #chair rdieter jgrulich mbriza than ltinkl
15:10:04 <zodbot> Current chairs: Kevin_Kofler jgrulich ltinkl mbriza rdieter than
15:11:19 <Kevin_Kofler> ltinkl: So can I report you as present? :-)
15:12:27 * ltinkl is here
15:13:15 <Kevin_Kofler> #info Kevin_Kofler, rdieter, jgrulich, mbriza, than, ltinkl present.
15:13:24 <Kevin_Kofler> #topic Agenda
15:13:48 <mbriza> the test day, i guess
15:13:50 <Kevin_Kofler> So, what's on the agenda? Update on the Test Day, and maybe a report of the Workstation meeting before us, anything else?
15:14:32 * rdieter has nothing
15:14:46 <Kevin_Kofler> Are we on track for F20?
15:15:48 <Kevin_Kofler> Well, I guess we are. :-)
15:16:07 <Kevin_Kofler> And we'll know after the Test Day. ;-) So…
15:16:13 <Kevin_Kofler> #topic Test Day update
15:16:29 <mbriza> confirmed as per https://fedorahosted.org/fedora-qa/ticket/424#comment:1
15:16:36 <mbriza> do we have everything we need to run it? :)
15:17:14 <Kevin_Kofler> #info Test Day date confirmed as 2013-11-07 by Fedora QA.
15:17:34 <Kevin_Kofler> So, what we need is mainly 2 things: test cases and test images.
15:18:08 <Kevin_Kofler> The nightly images should work, if they're composing.
15:18:08 <Kevin_Kofler> We may want to save current successful images in case later composes start failing.
15:18:23 <Kevin_Kofler> Test cases are more interesting because Koji doesn't compose those for us. ;-)
15:19:56 <Kevin_Kofler> Of course, we have test cases from the previous iterations, but we need to see if those still make sense or if they need updating.
15:20:22 <Kevin_Kofler> Some stuff we focused on in the past doesn't really need focused testing anymore, it falls more under "should just work" routine now.
15:20:29 <jgrulich> Kevin_Kofler: I'll update test cases for plasma-nm
15:20:37 <mbriza> i'm just stealing contents from the kde 4.10 test day
15:20:37 <Kevin_Kofler> Other stuff might need more detailed testing, plasma-nm is a good example indeed.
15:20:57 <Kevin_Kofler> (and also updating if the UI to expect changed)
15:21:10 <Kevin_Kofler> #action jgrulich will update test cases for plasma-nm.
15:21:24 <rdieter> sddm testing would be nice too, doing so on a live image may be trickier though
15:21:28 <Kevin_Kofler> +1, SDDM could use test cases too.
15:21:39 <mbriza> yes, i'll write some (or copy them from the change proposal)
15:22:17 <Kevin_Kofler> Do we have existing KDM test cases? If so, they need to be updated (either changed to SDDM or they need to explain how to enable KDM).
15:23:40 <rdieter> doubt it
15:24:22 <Kevin_Kofler> Where are the test cases we have?
15:25:12 <mbriza> https://fedoraproject.org/wiki/Test_Day:2013-03-14_KDE_4.10
15:25:33 <rdieter> SDDM stuff from the feature/changes page, http://fedoraproject.org/wiki/Changes/SDDMinsteadOfKDM#Basic_testing
15:27:01 <Kevin_Kofler> So there were no tests for the default display manager last time, only one for integration with GDM.
15:27:19 <Kevin_Kofler> So yes, we should make test cases out of the SDDM feature page.
15:27:34 <Kevin_Kofler> mbriza said he'll do that, so +1, please do. :-)
15:27:52 <Kevin_Kofler> #action mbriza will take care of SDDM test cases.
15:28:40 <Kevin_Kofler> That leaves 4.11 as the remaining change, do we want to test any of the new stuff from upstream particularly?
15:28:52 <mbriza> i'm on it
15:28:54 <Kevin_Kofler> (Then again people are already "testing" it on F19 every day.)
15:30:19 <Kevin_Kofler> #link http://dot.kde.org/2013/08/14/411-release-plasma-workspaces-applications-and-development-platform
15:32:55 <Kevin_Kofler> For the desktop itself, I see: new task bar, new battery applet, and KWin technology updates (XCB use, OpenGL 3 effects).
15:33:17 <Kevin_Kofler> Then there's the new Nepomuk.
15:33:38 <Kevin_Kofler> And there are some application improvements, which the announcement probably doesn't even list all.
15:36:19 <Kevin_Kofler> E.g. Marble changes are not listed in the dot.kde.org announcement: http://nienhueser.de/blog/?p=565
15:36:47 <Kevin_Kofler> Which of those changes warrant particular testing, I don't know.
15:37:11 <Kevin_Kofler> The application improvements are probably too many to write test cases for each.
15:37:39 <Kevin_Kofler> The new plasmoids, KWin and Nepomuk are probably worth doing at least 1 test case for.
15:39:00 * Kevin_Kofler wonders if people are still reading…
15:40:01 <Kevin_Kofler> Let's move on.
15:40:11 <Kevin_Kofler> #topic KDE vs. "Workstation"
15:40:38 <ltinkl> hmm :)
15:40:47 <Kevin_Kofler> ltinkl: So you attended that Workstation meeting before us…
15:41:05 <Kevin_Kofler> It looks like we're back to the same old fights as always.
15:41:35 <ltinkl> not much to discuss yet imho, before the WG creates and approves its own charter and mission statement
15:41:36 * jreznik is rereading backlog...
15:42:16 <Kevin_Kofler> ltinkl: From what I gathered in the last few minutes of the meeting, it looks like there's a lot of discord and little agreement there yet, indeed.
15:42:18 <ltinkl> but it really looks like we're heading the direction of the "one true desktop" (presented as the consistent workstation experience)
15:42:50 <Kevin_Kofler> The gnomies want to deproductize us even more than we already are, this really sucks.
15:43:03 <Kevin_Kofler> I'm fed up of KDE always beeing a second-class citizen.
15:43:39 <jreznik> with products, it could be on the other hand easier to stand on our own legs even out of Fedora space
15:43:40 <Kevin_Kofler> The Products should have been based on the existing spins, making the popular spins into first-class citizens.
15:44:06 <ltinkl> imho, there should be no spins at all
15:44:34 <Kevin_Kofler> There should be several workstation products (GNOME, KDE, Xfce, LXDE/RazorQt (they're merging upstream), Cinnamon, MATE etc.).
15:44:43 <jreznik> and for me it looks like the idea of workstation is even in a direct opposite way where current gnome aims... just my feeling
15:44:45 <ltinkl> dividing Fedora into Workstation/Server/Cloud makes much more sense
15:45:00 <rdieter> let's let ltinkl finish talking before speculation steers us into the weeds
15:45:05 <Kevin_Kofler> ltinkl: Huh?
15:45:28 <Kevin_Kofler> You want to have only one GNOME-based product? Or do you really thing the one Workstation product would be based on KDE?
15:45:37 <Kevin_Kofler> *think
15:45:41 <ltinkl> Kevin_Kofler: there should imho be one workstation product, with a freedom of choice as what desktop the user wants to use
15:45:55 <Kevin_Kofler> At install time?
15:46:07 <ltinkl> Kevin_Kofler: yup, why not
15:46:12 <Kevin_Kofler> That means to have an installer DVD, not a live image.
15:46:25 <Kevin_Kofler> Or do you propose to have the product be a Multi DVD?
15:46:36 <ltinkl> yes, that's a technical detail, CD is an obsolete technlogy anyway
15:46:37 <Kevin_Kofler> That one's really multiple spins produced separately and aggregated.
15:46:37 <rdieter> those are details that can be worked out later
15:46:57 <ltinkl> definitely
15:47:16 <Kevin_Kofler> I'm not sure the Multi DVD is really a good unit for development.
15:47:17 <ltinkl> we should really drop the "live media=CD" equation
15:47:27 <Kevin_Kofler> We already dropped that, sadly.
15:47:45 <Kevin_Kofler> It still sucks to have to download 4 live images when you'll be booting only into 1.
15:47:51 <mbriza> current limit for the images is 1GB, isn't it?
15:47:52 <ltinkl> "burning" a live USB media is easier anyway
15:48:10 <rdieter> mbriza: kde images targets 1gb, but some are even bigger
15:48:13 <ltinkl> most netbooks these days even ship w/o an optical drive
15:48:21 <Kevin_Kofler> Or worse, having really 1 image with all the desktops on it, where you then have to struggle to get rid of the extra ones after installing.
15:48:28 <Kevin_Kofler> (plus the UI issues: duplicate apps etc.)
15:49:02 <ltinkl> Kevin_Kofler: a couple of checkboxes, that's feasible :)
15:49:07 <Kevin_Kofler> I think it makes much more sense to select the desktop at download time, unless you're giving out free media at events (which is what the Multi DVD is for).
15:49:37 <Kevin_Kofler> ltinkl: Such checkboxes only work in a non-live installer.
15:49:49 <Kevin_Kofler> The live install procedure does not allow selecting packages.
15:50:08 <satellit> allow basicx desktop with DE selection option on DVD and netinstall to install all of the selected DE's
15:50:26 <satellit> not a minor part of them
15:50:51 <Kevin_Kofler> So I think having only one Workstation download is a flawed idea.
15:51:09 <rdieter> i think this discussion is premature
15:51:14 <Kevin_Kofler> Sure, you could point the Download Now to a multi DVD if we really need a Download Now button.
15:51:25 <Kevin_Kofler> But there should be a way at getting at the actual live images.
15:51:44 <Kevin_Kofler> I don't want to download a huge dual-layer ISO when I only need < 1 GiB of KDE spin.
15:52:18 <satellit> I test for Soas (sugar on a stick) and lives are important for us
15:53:01 <Kevin_Kofler> satellit: +1, live images are important, and they really need to be per desktop.
15:53:27 <Kevin_Kofler> The only "one download" I could live with is the Multi DVD.
15:53:34 <satellit> also for repairs and testing for DE prior to install
15:53:38 <Kevin_Kofler> (the stuff we hand out at events, pressed)
15:53:58 <mbriza> with even having presto enabled by default, i doubt they'd force users with slow connection to download a 8 times bigger image just to install the OS
15:54:23 <ltinkl> Kevin_Kofler: agree, the biggest flaw I see is that somehow I get a feeling the whole workstation idea is a way towards Gnome OS
15:56:01 <Kevin_Kofler> That's why I complained right from the start about that (too) short list of Products.
15:56:42 <Kevin_Kofler> I'd rather have no Server and Cloud product and 3 desktop products (one of which is KDE, one I guess GNOME (yuck!) and one third one which would probably be Xfce or Cinnamon).
15:56:54 <Kevin_Kofler> But I guess that train has left the station. :-(
15:57:04 <sgallagh> Kevin_Kofler: Well, we *need* the Server and Cloud.
15:57:17 <Kevin_Kofler> Who actually uses those?
15:57:36 <sgallagh> In the former case, we need a place to build the product that Red Hat will eventually sell in order to keep funding us.
15:57:38 <Kevin_Kofler> I know ONE person using Fedora on (a) server(s).
15:57:46 <satellit> will server be LTS
15:58:11 <sgallagh> satellit: That's being discussed, but I hope it'll be closer
15:58:12 <Kevin_Kofler> Even Fedora Infra is using RHEL.
15:59:12 <sgallagh> Kevin_Kofler: In the case of the Cloud, Ubuntu is crushing us on the "tear it down and rebuild it" use-case for DevOps. We need an answer there.
15:59:52 <Kevin_Kofler> You can hardly get more effective than mock for "tear it down and rebuild it" chroots.
15:59:54 <mbriza> i have Fedora 20 on my VPS... which runs... well, just irssi, i guess
15:59:58 <Kevin_Kofler> And that doesn't need a spin at all.
16:00:05 <Kevin_Kofler> (or "product")
16:00:26 <rdieter> Kevin_Kofler needs his own product it seems
16:00:28 <sgallagh> Kevin_Kofler: Not useful in public clouds like Amazon.
16:00:50 * nirik runs fedora on all his home server, and fedora infrastructure DOES use fedora in some places.
16:01:29 <Kevin_Kofler> sgallagh: But very effective to build binaries on CentOS (thus compatible with old or "enterprise" distros) quickly.
16:01:31 <sgallagh> I've got a person on the Fedora Server WG who is running literally hundreds of Fedora boxes in production because RHEL/CentOS is too old
16:01:42 <Kevin_Kofler> I've done it, so I know what I'm talking about.
16:01:44 <sgallagh> Kevin_Kofler: Oh, absolutely.
16:02:15 <sgallagh> I didn't mean to slight mock. Just that it's not useful for rapidly bringing up and down cluster apps to dynamically manage load.
16:02:24 <Kevin_Kofler> But I guess we're digressing far far away from KDE SIG's scope. :-)
16:02:43 <Kevin_Kofler> (and we're out of time…)
16:02:46 <Kevin_Kofler> #topic Open discussion
16:02:52 <Kevin_Kofler> Anything else before I close the meeting?
16:03:02 <Kevin_Kofler> Is there anything important to do for F20?
16:03:15 <mbriza> just that i copied over the old testday page to https://fedoraproject.org/wiki/Test_Day:2013-11-07_KDE
16:03:24 <Kevin_Kofler> OK
16:03:40 <Kevin_Kofler> #link https://fedoraproject.org/wiki/Test_Day:2013-11-07_KDE
16:03:45 <mbriza> and changed a few things, especially the links, removed testing in older fedora releases because that'd have to be rewritten completely
16:03:52 <mbriza> and maybe some more
16:04:29 <mbriza> i'll remove the qa folks to let them add themselves... i suppose we all will be available though
16:05:30 <Kevin_Kofler> Great. I think that's all for today, we're 5 minutes over time already, thanks for coming!
16:05:34 <Kevin_Kofler> #endmeeting