15:00:55 <rdieter> #startmeeting kde-sig
15:00:55 <zodbot> Meeting started Tue Nov  5 15:00:55 2013 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:00 <rdieter> #meetingname kde-sig
15:01:00 <zodbot> The meeting name has been set to 'kde-sig'
15:01:14 <rdieter> #topic roll call
15:01:37 <rdieter> hi everyone, who's present for friendly (and hopefully quick) kde-sig meeting?
15:02:11 <rdieter> than, ltinkl, dvratil, mbriza, Kevin_Kofler: ping
15:02:18 * ltinkl is present
15:02:27 * than is here
15:02:39 <mbriza> present
15:02:57 <Kevin_Kofler> Present.
15:03:39 <rdieter> #chair ltinkl than mbriza Kevin_Kofler
15:03:39 <zodbot> Current chairs: Kevin_Kofler ltinkl mbriza rdieter than
15:03:48 <rdieter> #info rdieter ltinkl than mbriza Kevin_Kofler present
15:05:11 <rdieter> #topic agenda
15:05:30 <rdieter> topics to discuss?  kde test day (thu), anything else?
15:05:55 <Kevin_Kofler> 4.11.3, 4.12 Beta
15:06:17 <Kevin_Kofler> (The latter should get tagged tomorrow.)
15:07:47 <rdieter> k
15:08:00 <rdieter> let's get started then
15:08:05 <rdieter> #topic kde test day (thu)
15:08:34 <rdieter> kde test day, yay.  someone mentioned in #fedora-kde earlier, the wiki references an old/non-existent live image
15:09:40 <rdieter> can someone followup to get that updated/fixed?
15:09:54 <mbriza> going to do that tomorrow
15:11:29 <rdieter> #action mbriza to followup on getting current live image .iso for test day
15:11:31 <rdieter> thanks
15:12:09 <rdieter> anything else wrt test day?  other than, advertise it, see if we can get some warm bodies
15:14:22 <rdieter> sounds like not, moving on...
15:14:53 <rdieter> #topic kde-4.11.3, kde-4.12 beta
15:15:16 <rdieter> on the topic of kde-4.11.3 release, I imported/built stuff over the weekend,
15:15:39 <rdieter> submitted updates for f20, waiting to queue f19 updates for official release announcement
15:15:51 <rdieter> (it's all in kde-testing repos already though)
15:16:34 <rdieter> that sound ok?  any other 4.11-related comments?
15:17:52 <Kevin_Kofler> Sounds OK.
15:18:10 <than> rdieter:  fine with me, thanks for your great job :)
15:18:20 <Kevin_Kofler> Thanks +1. :-)
15:18:29 <rdieter> I suppose could be a wee bit aggressive, and queue f19 now, so it could be available closer to when release announcement hits
15:18:38 <rdieter> but meh
15:18:45 <rdieter> thanks
15:19:03 <rdieter> so... on to 4.12 beta goodness.  I guess we should have a plan for how to handle that
15:19:37 <rdieter> or... punt... wait till after this week, and focus efforts on f20 stabilization/testing
15:19:38 <than> rdieter: 4.12 for f21
15:20:16 <than> but it still has time for f21
15:20:33 <rdieter> agreed, i figured it being for rawhide/f21 was a given. :)
15:20:56 <rdieter> doesn't hurt to explicitly say so
15:21:32 <rdieter> in general, keep an eye out for any new dependencies, so we can get those packaged/reviewed asap
15:21:46 <Kevin_Kofler> Of course 4.12 won't be for F20 right now.
15:21:46 <Kevin_Kofler> It's still in beta.
15:21:46 <Kevin_Kofler> But of course, users will appreciate getting it for F19 and F20 through kde-unstable. :-)
15:22:06 <Kevin_Kofler> (hint hint ;-) )
15:22:09 <Kevin_Kofler> That said, with all our slipping, we're now fairly aligned to 4.12's schedule…
15:22:09 <Kevin_Kofler> So we may end up releasing with 4.11 after 4.12 is released. :-(
15:22:13 <Kevin_Kofler> But rushing 4.12 in now? Bad plan IMHO…
15:23:22 <jreznik> yep
15:23:26 <than> Kevin_Kofler: i think it's better we should take time to make f20 stable
15:23:27 <Kevin_Kofler> I do guess we'll probably release F20 before upstream releases 4.12 anyway.
15:23:59 <Kevin_Kofler> We're in "beta" which would be "RC" in KDE terms, KDE's "beta" is like our "alpha".
15:24:12 <jreznik> for schedule, it depends, we would have to use some magic to avoid christmas but even we would have to (in the worst, worst) scenario skip christmas, it would be too late
15:24:23 <rdieter> with 4.12 we may end up having to fix some packaging, version assumptions since kde-workspace is LTS on 4.11
15:24:51 <Kevin_Kofler> jreznik: What's wrong with releasing F20 on Dec 24 or 25 as a Christmas present? :-)
15:25:23 <rdieter> Kevin_Kofler: mirror admins would *love* that
15:25:35 <rdieter> for various definitions of love
15:25:40 <Kevin_Kofler> ^^
15:25:49 <Kevin_Kofler> Users would genuinely love it though.
15:25:52 <jreznik> Kevin_Kofler: well, well :)
15:26:10 <Kevin_Kofler> Especially users in Europe who'd have up to 2 weeks of free time to install it.
15:27:06 <Kevin_Kofler> But of course the mirror admins here would hate it all the more.
15:29:26 <Kevin_Kofler> <rdieter> with 4.12 we may end up having to fix some packaging, version assumptions since kde-workspace is LTS on 4.11
15:29:41 <Kevin_Kofler> kde-workspace-4.12.0-1.really4.11.6.fc21? ;-)
15:29:52 <Kevin_Kofler> (a.k.a. the Ubuntu version hack ^^)
15:31:06 <rdieter> let's wait and see..  I don't think we have that many versioned deps on kde-workspace stuff
15:31:19 <Kevin_Kofler> Of course, that'd be a blatant violation of our versioning guidelines.
15:31:41 <rdieter> nod, hopefully we can avoid resorting to such hacks
15:32:35 <Kevin_Kofler> I don't understand why upstream didn't treat it the same way as kdelibs (just continue the versioning scheme with frozen master).
15:33:12 <Kevin_Kofler> (or even branch KDE/4.12 from KDE/4.11, which is how kdelibs was initially handled back in SVN land)
15:33:42 * rdieter doesn't know the implementation details yet
15:33:55 <Kevin_Kofler> (That way they could develop the next version in master and still have a 4.12 branch.)
15:33:58 <rdieter> but we should be thinking about options to handle each contingency
15:34:15 <Kevin_Kofler> I think they rejected it for purely political reasons, to force us to get used to different versioning schemes from component to component.
15:34:33 <Kevin_Kofler> At least that's the messaging I got from the blog posts.
15:34:55 <Kevin_Kofler> That we should get used to the version numbers no longer being in sync because that will be the case all over the place with that KF5 mess.
15:35:59 <rdieter> I think that topic is about done... :)
15:36:02 <rdieter> #topic open discussion
15:36:06 <rdieter> anything else for today?
15:36:34 <rdieter> just fyi for posterity, I'm working on phonon-4.7.0 (and backend) packaging and adding Qt5 support
15:36:42 <mbriza> just letting you know i finally fixed the pam stuff around sddm... autologin, everything
15:36:48 <rdieter> mbriza: woo!
15:37:04 <Kevin_Kofler> All great news!
15:37:18 <mbriza> it's hacky as hell but i'll commit it anyway... David Edmundson wants to use parts of my work to build a kcheckpass substitute library
15:38:01 <mbriza> so that will be the clean version that will get upstream
15:41:23 <rdieter> wrt phonon, after some discussion earlier in #fedora-kde, decided to use phonon-qt5 prefix (for Qt5) stuff, rather than other options like phonon4qt5 or qt5-phonon
15:42:21 <rdieter> sounds like the phonon 4.6 branch is closed now, so we probably want to seriously consider phonon-4.7 stuff for f20 sooner rather than later
15:42:32 <Kevin_Kofler> Yeah.
15:42:51 <rdieter> assuming dvratil is ok with that idea
15:43:56 <Kevin_Kofler> One thing to discuss is whether we really want to ship phonon-vlc with highest priority. I think we'll want to decrease it to the old value…
15:44:18 <Kevin_Kofler> I don't like the idea of the backend from RPM Fusion making itself the default over the Fedora one.
15:44:19 <rdieter> yeah, I'm a bit torn on that
15:44:35 <rdieter> probably will opt to lower vlc priority
15:44:53 <rdieter> otoh, users are already opting-in to use it merely by installing it
15:46:18 <rdieter> can discuss that later
15:47:03 * rdieter will close meeting 2 min if there are no new topics to discuss
15:48:01 <Kevin_Kofler> I don't think there's any update on GStreamer 1.0 porting, is there?
15:48:27 <Kevin_Kofler> (Phonon-GStreamer and QtGStreamer both badly need to get ported, GStreamer 0.10 is a dead branch now.)
15:48:55 <d_ed> I have no idea why I'm lurking in this meeting, but QtGstreamer has had some activity recently.
15:49:13 <d_ed> Not in the main repo, but a new developer has picked things up in their own repo.
15:49:22 <rdieter> yay
15:50:08 <Kevin_Kofler> d_ed: Related to GStreamer 1.0? I know there has been a Qt 5 port and some other changes, but nothing for GStreamer 1.0 last I checked…
15:50:28 <rdieter> yes
15:50:46 <rdieter> (or at least so I heard too)
15:50:55 <d_ed> https://github.com/detrout/qt-gstreamer
15:50:55 <Kevin_Kofler> For Phonon, there's a branch with a GStreamer 1.0 port, but it isn't working yet, at least with Amarok.
15:52:03 <Kevin_Kofler> d_ed: Thanks, that's good news.
15:52:41 * rdieter resets 2 min clock
15:53:59 <Kevin_Kofler> Looks like dvratil managed to fix the Amarok issue!
15:54:03 <Kevin_Kofler> https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer/repository/revisions/61a1fd8babb913be638fdf9a4f9fcb7b9454e61e
15:54:09 <Kevin_Kofler> https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer/repository/show?rev=1.0-porting-for-merge
15:54:34 <Kevin_Kofler> Thanks dvratil! :-)
15:54:54 <Kevin_Kofler> So things are looking good, we may be able to ship all GStreamer 1.0 stuff in F21.
15:56:56 <rdieter> let's wrap up, now we're out of time. :)  thanks everyone!
15:56:59 <rdieter> #endmeeting