16:00:51 <adamw> #startmeeting Fedora QA meeting
16:00:51 <zodbot> Meeting started Mon Dec  9 16:00:51 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:56 <adamw> #meetingname fedora-qa
16:00:56 <zodbot> The meeting name has been set to 'fedora-qa'
16:01:01 <adamw> #topic Roll call
16:01:08 * roshi is here
16:01:13 <adamw> ahoyhoy, folks, who's on board the ship o' release validation fun?
16:01:20 * nirik is lurking around
16:01:24 * jreznik is here
16:01:29 * mkrizek is here
16:01:47 * cmurf is wearing is life vest, just in case.
16:01:54 <cmurf> ^h
16:01:56 * pwhalen is here
16:02:17 * greenlion looking in
16:02:26 * kparal late
16:04:18 <cmurf> have we lost the relay?
16:04:43 <adamw> hmm?
16:04:43 <kparal> has he #chaired someone else?
16:04:58 <adamw> yeesh, it's only been four minutes and you're already plotting the mutiny?
16:05:08 <adamw> #plank kparal cmurf
16:05:25 <adamw> what, meetbot, there is no "makes X walk the plank" macro? this is an UNACCEPTABLE OVERSIGHT
16:05:34 <adamw> fine, then
16:05:37 <adamw> #chair kparal cmurf
16:05:37 <zodbot> Current chairs: adamw cmurf kparal
16:05:42 <adamw> #topic Previous meeting follow-up
16:05:53 <adamw> time to rename this section 'adamw sucks corner', folks
16:06:16 <cmurf> i'm referring to the ping timouts, connection resets, host changes - people left and there was a pause
16:06:16 <adamw> #info "adamw to draft a new test case and matrix row for validating cloud image checksums" - still didn't get around to this one, though somehow I found time to write a completely different test case. sorry. one more try
16:06:41 <adamw> #action adamw to draft a new test case and matrix row for validating cloud image checksums
16:06:51 <adamw> anything for follow-up that i missed?
16:06:51 <cmurf> *shrug* one was obviously much more interesting than the other :-)
16:07:30 * pschindl is here
16:08:16 <adamw> guess not
16:08:20 <adamw> wb, tflink
16:09:04 <tflink> not sure what happened there,
16:09:09 <tflink> fun times :)
16:09:11 <adamw> #topic Fedora 20 Final status
16:09:28 <adamw> tflink: well, we used the opportunity to re-assign all release blockers to you.
16:09:52 <tflink> adamw: I thought that the idea was _not_ to slip more :-P
16:09:57 <adamw> =)
16:10:01 <cmurf> right
16:10:06 <adamw> so, we still have a couple of tests that haven't run since Beta: http://testdays.qa.fedoraproject.org/testcase_stats/Category_Installation_validation_testing.html
16:10:09 <jreznik> that's not nice from you adamw!
16:10:19 <adamw> hehe
16:10:20 <cmurf> no more release blockers short of injuries that cause scaring
16:10:24 <adamw> i really need to do the hw raid one
16:10:46 <adamw> if people can help get https://fedoraproject.org/wiki/QA:Testcase_Kickstart_Hd_Device_Path_Ks_Cfg and https://fedoraproject.org/wiki/QA:Testcase_Kickstart_File_Path_Ks_Cfg done that'd be great, yes I know they're a pita
16:10:47 <cmurf> short of a firmware bug it really oughta just work like installing to a single drive
16:11:19 <adamw> cmurf: yeah, we all know the theory ;)
16:11:46 <cmurf> right so not a big deal waiting until the last second to test it
16:11:54 <adamw> then we have a few from tc2, tc3 and tc4 to work through, but we'll probably have RC1 by then
16:12:39 <adamw> or at least tc6...
16:13:25 * roshi crosses his fingers for RC
16:13:50 <adamw> for RC, ignoring for now the proposed blocker list, we have https://bugzilla.redhat.com/show_bug.cgi?id=1027947 and https://bugzilla.redhat.com/show_bug.cgi?id=983110
16:15:10 <jreznik> The kde one looks like we have a hit
16:15:23 <adamw> well, not entirely
16:15:54 <adamw> just arbitrarily turning off glib2 mainloop integration for a chunk of kde startup is a pretty big change to throw in at this point
16:16:04 <adamw> and right now i think they're discovering some consequences of it in #fedora-kde...
16:16:36 <adamw> but yeah, it mostly looks like we've got a few tests to clean up while we wait on devs for an rc1
16:16:55 <cmurf> isn't it kinda late for such big changes?
16:17:22 <adamw> and folks, if you have blocker bugs in you, *please* get them out today if at all possible =) i know this is the time when we get some spare minutes to do freeform testing and spot things we missed before, but try and get it done asap
16:17:57 <kparal> can't create new bugs in bugzilla
16:18:00 <cmurf> i went through that phase for beta, i'm ready for this goose to lay its egg man
16:18:01 <adamw> cmurf: yes, but we gotta fix it _somehow_. the build was mostly meant as a debugging test rather than as the fix, but they floated the possibility of pushing it if it fixes the bug and they can't come up with a more specific fix
16:18:16 <kparal> I wanted to report some, but ...
16:18:33 * handsome_pirate stumbles in late
16:18:52 <nirik> kparal: I understand they are going to push a hotfix for that. not sure when tho
16:19:56 <cmurf> re: new BZ bugs, is this isolated or can no one create bugs?
16:20:19 <nirik> its the top level report a bug thing timing out...
16:21:01 <kparal> someone at #fedora-admin claimed it works for him
16:21:14 <kparal> doesn't for me
16:21:33 <adamw> oh good, looks like dlehman is on PTO today. just what we need for  blocker fixing.
16:21:48 <nirik> kparal: it loads here after 1-2minutes.
16:21:51 <adamw> kparal: i thought i left specific instructions for you to be bound and gagged outside the reach of a keyboard
16:22:08 * adamw knows a workaround but ain't telling kparal
16:22:18 <cmurf> no kidding
16:22:27 * cmurf snickers
16:22:41 <adamw> if you're called kparal, look away now
16:22:42 * kparal gets proxy error
16:23:02 <adamw> for everyone else, you can go to http://bugz.fedoraproject.org/(packagename) then use the 'report a new bug against this package' thing
16:23:12 <adamw> (or you could just, you know, memorize the parameters to enter_bug.cgi)
16:23:41 <handsome_pirate> Yay
16:23:46 <handsome_pirate> New workflow
16:23:49 <kparal> https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=anaconda doesn't work for me either
16:24:08 <roshi> kparal, I think adamw just turned your access off :p
16:24:18 <cmurf> doesn't work = doesn't load?
16:24:20 <kparal> probably
16:24:27 <kparal> cmurf: proxy error after several minutes
16:24:33 <cmurf> it's hanging for me atm
16:25:16 <cmurf> what are "DE tools"?
16:25:52 <cmurf> context is "Open created LUKS device using DE tools"
16:26:02 <greenlion> cmurf, dolphin in my case
16:26:28 <cmurf> is that included in live desktop?
16:26:28 <greenlion> probably works with nautilus too
16:26:34 <greenlion> yes, KDE Live
16:27:06 <adamw> okay, so is there anything else to discuss about f20 status?
16:27:24 <cmurf> kparal reproduced 1008732 with live desktop though, not live kde
16:27:40 <cmurf> adamw nothing other than the obvious
16:27:50 <adamw> oh, yes
16:27:53 <adamw> #agreed everybody panic
16:27:58 <cmurf> right
16:28:00 <adamw> =)
16:28:21 <tflink> adamw: EINSUFFICIENTCOFFEE
16:28:29 <handsome_pirate> adamw:  What if I'm already panicking?
16:28:30 <greenlion> why panic? just delay release to january, or february... :)
16:28:34 <jreznik> set panic mode
16:28:45 <adamw> handsome_pirate: panic harder
16:28:47 <cmurf> i have 1tbsp of soymilk left so yes coffee panic mode is about to happen, and it's like -10C outside
16:28:52 <handsome_pirate> adamw:  I'm trying!
16:29:15 <cmurf> -16C, yikes
16:29:16 <roshi> cmurf, you don't drink your coffee black?
16:29:29 <adamw> obviously he hasn't been working hard enough
16:29:40 <cmurf> nope, comes out of the press pot like syrup it needs to be cut
16:29:49 <roshi> lol
16:30:03 <cmurf> besides i drink it because i actually like coffee not because i need it
16:30:15 <cmurf> anyway!
16:31:08 * masta looks in
16:31:19 <cmurf> blockers?
16:31:30 <adamw> #topic open floor
16:31:37 <adamw> not that it hasn't been open floor for ten minutes...
16:31:40 <adamw> but do we have anything else?
16:32:01 <cmurf> i do not
16:32:39 <tflink> If anyone's interested in automation - comments and discussion appreciated: https://lists.fedoraproject.org/pipermail/qa-devel/2013-December/000556.html
16:33:09 <roshi> I'm looking for feedback on an idea if people haven't already seen it: http://roshi.fedorapeople.org/testing-efficiently.html
16:33:37 <roshi> I'll be sending an email out to test@ once I get it a bit more fleshed out
16:33:45 <adamw> #info tflink and roshi both looking for feedback on ideas: https://lists.fedoraproject.org/pipermail/qa-devel/2013-December/000556.html and http://roshi.fedorapeople.org/testing-efficiently.html
16:33:50 <adamw> thanks guys!
16:34:15 <cmurf> speaking of the test matrix
16:34:48 <cmurf> it seems that we get a TC and then a day later we get another anaconda
16:35:41 <cmurf> and it's like… ok we have this TCx' (that's a prime) derivative outside the matrix
16:35:55 <cmurf> and the potential for regressions this time of the process increases I think
16:35:59 <adamw> cmurf: i didn't do another build right away because it looked like we'd be able to do an rc quicker
16:36:22 <cmurf> yeah and i'm glad for that actually
16:36:58 <cmurf> what i'm wondering is if there's a way to inhibit builds of anaconda until more stuff is fixed
16:37:13 <cmurf> because with every new build it really means, esp with an RC, we need to retest the whole matrix
16:37:21 <cmurf> in addition to any affected blockers
16:37:48 <cmurf> so fix more bugs before rolling another anaconda?
16:38:36 <cmurf> i'm not even doing a 10th of the work some folks are and it's a bit much to see only 1/2 the matrix get filled up before another anaconda appears and i'm like …. crap
16:38:43 <adamw> well, it's kinda up to anaconda team's discretion when to build a new one
16:38:49 <kparal> that's the basic dilemma. I believe we should use tools like http://testdays.qa.fedoraproject.org/testcase_stats/ more and not just blindly do all the test case again and again and again
16:39:16 <cmurf> adamw: understood, but i think they might be under the imrpession they're doing us a favor to get bug fixes tested sooner
16:39:38 <adamw> still, i don't quite see the practical difference between building anaconda 20.1, 20.2, 20.3, 20.4, 20.5, 20.6, and 20.7 with one fix each and building 20.1, then building 20.7 with all the fixes
16:39:45 <cmurf> kparal good point
16:39:55 <kparal> anaconda builds should not be delayed. we can delay TCs if we want
16:40:05 <adamw> kparal: during TC phase that's already what we should be doing
16:40:10 <kparal> frequent anaconda builds are actually helpful for us
16:40:17 <adamw> kparal: it's only RCs where in theory we ought to run every test
16:40:24 <cmurf> ahh ok
16:40:43 <kparal> adamw: well, this approach is not really described anywhere, but it's good that you agree
16:40:50 <adamw> kparal: yeah, that's my perspective too, the important question is how often we build TCs, not how often anaconda pushes builds out
16:41:27 <cmurf> ok great so 2nd question is if there is a way now or could be in the future to support an overlay for the DVD ISO
16:41:30 <cmurf> and netinst
16:41:40 <cmurf> so that anaconda can be updated and remain resident
16:41:43 <cmurf> like the live
16:41:51 <kparal> cmurf: hardly. there's not even rpm
16:41:58 <adamw> um. i have no idea? be one to ask bcl, i guess.
16:42:15 * nirik isn't sure what that gets you... not having to download a new one?
16:42:29 <kparal> nirik: not waiting for a next compose
16:42:30 <cmurf> not having to wait for a TC build with that version of anaconda in it
16:42:39 <greenlion> updates.img?
16:42:46 <nirik> ah. I guess.
16:42:55 <kparal> updates.img is hard to create by users
16:43:03 <nirik> too many things like that tho and you end up not testing the thing we are shipping tho.
16:43:09 <cmurf> exactly
16:43:30 <cmurf> and life install is gnome/kde only which takes a ton longer than a minimal install
16:43:43 <cmurf> live, rather
16:43:57 <cmurf> that's all i've got, meanwhile i'm testing some of these newly proposed blockers
16:44:57 <cmurf> what's next? blockers?
16:45:27 * cmurf hears Jeopardy muzak in the background
16:46:55 <adamw> blocker meeting next
16:47:03 <adamw> top of the hour, in #fedora-blocker-review
16:47:06 <adamw> everyone go get coffee :)
16:47:07 <cmurf> OIC
16:47:17 * adamw sets quantum fuse, thanks for coming folks!
16:54:36 <tflink> that's one long quantum fuse
16:55:08 <adamw> #endmeeting