#fedora-meeting: FESCO (2013-12-11)

Meeting started by mattdm at 18:00:46 UTC (full logs).

Meeting summary

  1. init process (mattdm, 18:00:59)
  2. #1185 Enable "-Werror=format-security" by default (mattdm, 18:04:33)
    1. AGREED: We add -Werror=format-security by default. (A -1 indicates that we will add -Wformat-security instead) (+7,-2) (mattdm, 18:17:29)

  3. #1201 Enabling third party repositories (mattdm, 18:18:02)
    1. AGREED: Proposal: Copr repos may be searched for applications to install as long as the user is explicitly asked to enable the copr before installing packages from them (See https://fedorahosted.org/fesco/ticket/1201#comment:19 for details) (+6,-,0) (mattdm, 18:36:59)
    2. signing and unicorns for all (mattdm, 18:37:05)
    3. AGREED: FESCo is okay with pointing to free software repositories approved by Fedora Legal in the same way as COPR repos (+8/-0/1) (mattdm, 19:13:53)
    4. AGREED: For non-free sofware repositories, FESCo is not changing exisiting policy. If you think the policy should change, talk to the board. (+9,-0,0) (mattdm, 19:19:06)
    5. AGREED: Revised 1a (with proposal and t8m's feedback): FESCo is okay with pointing to free software repositories in the same way as COPR repos if they are approved by FESCo and Fedora Legal. They are not limited in the criteria that they can choose to apply. (+7,-0,1) (mattdm, 19:44:49)
    6. further discussion to ticket and lists if necessary (mattdm, 19:45:55)

  4. #1211 F21 System Wide Change: Headless Java (mattdm, 19:46:27)
    1. https://fedoraproject.org/wiki/Changes/HeadlessJava (mattdm, 19:46:47)
    2. AGREED: Headless Java system wide change is approved. Please update the change page to be consistent with comment#2 in the ticket and get updated packaging guidelines to FPC soon. (+8,0,0) (mattdm, 19:53:18)

  5. Next week's chair (mattdm, 19:53:41)
    1. abadger1999 to chair next week. (mattdm, 19:55:27)
    2. we're going to skip the next two meetings after next week due to the holidays (mattdm, 19:55:44)

  6. Open Floor (mattdm, 19:56:08)
    1. t8m to chair january 8th meetiing (mattdm, 19:59:45)


Meeting ended at 20:01:35 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. mattdm (145)
  2. abadger1999 (75)
  3. jwb (62)
  4. sgallagh (56)
  5. mitr (43)
  6. notting (40)
  7. pjones (33)
  8. t8m (31)
  9. nirik (25)
  10. mmaslano (17)
  11. zodbot (15)
  12. halfie (6)
  13. jreznik (2)
  14. pknirsch (1)


Generated by MeetBot 0.1.4.