19:00:02 <nirik> #startmeeting Infrastructure (2013-12-12)
19:00:03 <zodbot> Meeting started Thu Dec 12 19:00:02 2013 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:03 <nirik> #meetingname infrastructure
19:00:03 <zodbot> The meeting name has been set to 'infrastructure'
19:00:03 <nirik> #topic welcome y'all
19:00:03 <nirik> #chair smooge relrod nirik abadger1999 lmacken dgilmore mdomsch threebean pingou puiterwijk
19:00:03 <zodbot> Current chairs: abadger1999 dgilmore lmacken mdomsch nirik pingou puiterwijk relrod smooge threebean
19:00:14 * relrod here
19:00:21 * LoKoMurdoK here
19:00:37 * bitlord here (listening ...)
19:01:07 * nirik waits for folks to wander in
19:01:39 * pingou here
19:01:43 * oddshocks here
19:01:59 * tflink is lurking
19:02:31 * docent here
19:02:34 * threebean is here
19:02:39 <nirik> morning everyone
19:02:46 <nirik> #topic New folks introductions and Apprentice tasks
19:02:47 <masta> howdy
19:02:54 <nirik> any new folks or apprentices with questions or comments?
19:04:15 <nirik> ok then. ;)
19:04:21 <nirik> #topic Applications status / discussion
19:04:28 <nirik> any application news?
19:04:48 <threebean> I got fmn into staging earlier this week!  :)
19:04:50 <pingou> nuancier has full unit-tests coverage
19:04:56 <pingou> helped debugging some things out :)
19:05:02 <pingou> \ó/ for fmn!
19:05:13 <threebean> https://apps.stg.fedoraproject.org/notifications
19:05:22 <threebean> still waiting on some mockups to change up that front page
19:05:27 <nirik> #info fmn in staging now
19:05:39 <nirik> #info bunch of nuancier work
19:06:01 <nirik> pingou: does nuancier still have selinux issues? or thats not sure until we roll out the main/non-lite one?
19:06:17 <pingou> also killed a couple of bugs on pkgdb2 from the feedback I got
19:06:25 <pingou> nirik: I didn't test with selinux
19:06:42 <oddshocks> I haven't done much in Tahrir-land recently with school wrapping up, but I have successfully deployed an "RIT Badges" Tahrir with a custom theme, and we hope to get that going soon :) so that's cool http://badges.rit.edu/
19:06:52 <nirik> there's some tickets outstanding about selinux and the lite version we have deployed now...
19:07:01 <pingou> nirik: the new nuancier will need the shared storage place though
19:07:02 <nirik> oddshocks: awesome.
19:07:17 <nirik> #info some pkgdb2 bugfixing over the last week based on feedback from devel list
19:07:52 <threebean> hm -- cnucnuweb fedmsg integration is coming along today too.  :)
19:07:54 <nirik> pingou: ok, we could look at gluster I guess, or a netapp volume
19:07:56 <pingou> \ó/
19:08:11 <pingou> nirik: that's what we spoke about last time, I'm fine with both :)
19:08:19 <nirik> #info cnucnuweb fedmsg integration work coming soon.
19:08:31 * ianweller is here
19:08:52 <nirik> pingou: yeah, we might wait and see how packages does after rebuilding... if it's ok with gluster thats easier.
19:08:55 <pingou> we need to see where/how we want to deploy cnucnu, we mentionned have it under release-monitoring.org or so
19:09:45 <nirik> ok.
19:10:02 <nirik> should that be something we do like others behind our proxies? or stand alone somewhere?
19:10:45 <pingou> it needs to access fedmsg
19:10:46 <nirik> I guess we can discuss and see.
19:10:49 <pingou> sure
19:10:50 <nirik> ah true...
19:11:30 <nirik> anything else on the application front?
19:11:41 <nirik> I guess we will have a bunch of things ready to land after the holidays.
19:11:52 <nirik> hopefully hyperkitty too.
19:12:02 <pingou> that would be cool :)
19:12:09 <threebean> yes :)
19:12:15 <nirik> indeedy
19:12:43 <pingou> oh and we got a new contributor to fedora-news :)
19:12:47 <pingou> https://github.com/fedora-infra/fedora-news/pull/4
19:13:01 <nirik> theres: fmn, nuancer, hyperkitty, cnucnuweb, pkgdb2 at least
19:13:11 <threebean> woo
19:13:14 <threebean> yeah, that's a list.
19:13:20 <nirik> nice.
19:13:30 <threebean> I have an update for fedora-packages too and was hoping to have a badges one too (out in January)
19:13:53 <nirik> I'm likely to try and move forward with some ansible migration in january... try and get things further along
19:14:08 <pingou> sounds all good :)
19:14:09 <nirik> I guess I can mention that in the sysadmin section.
19:14:22 <nirik> #topic Sysadmin status / discussion
19:14:25 <nirik> I'm likely to try and move forward with some ansible migration in january... try and get things further along
19:14:26 <nirik> :)
19:14:30 <threebean> oh?
19:14:33 <threebean> :P
19:14:55 <nirik> there's also a number of easyfixes for after freeze that can land.
19:15:02 <threebean> do you have a high-level plan of attack for the ansible migration?
19:15:05 <nirik> including things like ansible cron.
19:15:20 <nirik> not really, I was going to try and come up with one, but have been so busy with f20...
19:15:25 <smooge> threebean, our plan was the first person to ask that would be given the task
19:15:31 <smooge> congratulations
19:15:36 <nirik> ha. :)
19:15:37 <pingou> good job!
19:15:46 <threebean> so lucky
19:15:52 <pingou> smooge: (is there a backup plan?)
19:16:14 <nirik> so on the sysadmin side...
19:16:42 <nirik> #info likely to get in some new hw in january... more blades for the blade server and a few new replacement virthosts to replace old ones.
19:16:50 <smooge> pingou, congratulations.. you have won the backup plan
19:16:53 <nirik> #info likely to do a on-site phx2 visit in jan/feb
19:16:58 <pingou> smooge: :-p
19:17:03 <nirik> smooge: were you going to go? or did you want me to?
19:17:13 <smooge> I was going to go
19:17:21 <smooge> I have Jan 13-16 penned in right now
19:17:21 <nirik> fine with me. ;)
19:17:28 <nirik> cool. Sounds good.
19:17:42 <nirik> I don't think we have too much pending, but always some things.
19:17:57 <smooge> will be putting in the POs this afternoon and then I will be putting in the time at site
19:18:08 <nirik> Oh, after freeze, I will likely look at reinstalling all our builders again... with f20
19:18:17 <nirik> smooge: thanks.
19:18:27 <nirik> #info builders will be redone with f20 after freeze
19:18:50 <nirik> Also, for those that didn't see it... rhel7beta is out now.
19:19:10 <tflink> nirik: would that visit be a good time to look at network isolation the the qa stuff (can talk about it outside meeting if that woks better)
19:19:18 <nirik> Nothing urgent there, but might look at it and keep it in mind... as soon as the final is out I expect we will move to it pretty quickly.
19:19:37 <nirik> tflink: sure, although we still need to get networking people to make any networking changes...
19:20:10 <pingou> nirik: I foresee FAS and mirrormanager might be the hardest to move
19:20:14 <smooge> I could see another switch in that rack with no outside connections. The eth1 would go to that
19:20:23 <tflink> ok, I thought there might be wiring changes as well but we can continue in #fedora-admin post meeting
19:20:35 <nirik> pingou: yeah, likely so
19:21:04 <smooge> so we will be rebuilding everything on RHEL7-beta say beginning of Feb :)
19:21:14 <nirik> tflink: yeah, or perhaps write up a plan and we can poke it back and forth until we have something workable?
19:21:44 <nirik> smooge: :)
19:22:21 <nirik> anything else sysadminy ?
19:22:33 <tflink> that's good to know - maybe I can avoid doing compat packages for twisted on el6 :)
19:22:50 <nirik> tflink: yeah, although it may be a while before theres a 7 final.
19:23:04 <pingou> would we consider 7 beta?
19:23:28 <nirik> for testing and looking at? sure. Anything else: no.
19:23:49 <nirik> it will not get updates, so it will fall behind on security pretty fast.
19:24:14 <nirik> also, there's not (yet) an epel7.
19:24:21 <nirik> so, very limited package set.
19:24:50 <nirik> it strangely reminds me of f19... wonder why.
19:25:07 <bitlord> :-)
19:25:18 <nirik> #topic Upcoming Tasks/Items
19:25:18 <nirik> https://apps.fedoraproject.org/calendar/list/infrastructure/
19:25:20 <smooge> I figure we would build a .dev. environment like last time and put all our products in there on rhel7b
19:25:39 <nirik> so, as we type, the go/no-go meeting is still going in #fedora-meeting-2
19:25:47 <nirik> but it's looking like we might be go for next week.
19:26:02 <smooge> what only 1 rc? unheard of
19:26:08 <nirik> shocking I know.
19:26:37 <nirik> anyhow, even if (or especially if) we ship f20 next week, right after that is the holidays.
19:26:44 <smooge> yep
19:26:55 <nirik> even if we are out of freeze, I'd like to remind folks to be careful making changes...
19:27:14 <nirik> alerts that bother people on vacation or having to drag someone in to fix something are not good.
19:27:33 <nirik> so if you want to work on things, keep that in mind and make sure you have alerts off/things under control.
19:27:53 * pingou turns off his cell
19:27:55 <smooge> nirik, I think in the past we have just put in a freeze until Jan came back
19:28:10 <smooge> with the 2 person sign off on changes
19:28:27 <smooge> but that might have been just when we were really understaffed
19:28:28 <nirik> yeah, we could do that again... I'd like to unfreeze a bit tho, since we have stuff piled up.
19:28:46 <nirik> we can decide next week perhaps.
19:28:55 <nirik> I will be here for a meeting next week (19th)
19:29:01 <smooge> well slushy like an alpha freeze
19:29:05 <smooge> I will to.
19:29:08 <nirik> but I will be vacationing the next two weeks...
19:29:22 <nirik> shall we cancel the 26th and 2nd?
19:29:23 <smooge> I will be mostly away from keyboard from Dec 20 -> Jan 04 or my wife will kill me
19:29:28 <threebean> +1 to cancel
19:29:34 <smooge> +1 to cancel
19:29:59 <pingou> +1 to cancel
19:30:08 <nirik> sounds good to me.
19:30:46 <nirik> #agreed: we will not meet on 2013-12-26 or 2014-01-02. Meetings will resume on 2014-01-09
19:30:49 <pingou> I won't be there next week for the meeting btw
19:30:52 <oddshocks> Got it.
19:30:57 <nirik> pingou: fair enough.
19:31:37 <nirik> so, if we ship on the 17th, perhaps we unfreeze on the 18th, and then go back into a holiday freeze on the 23rd or something.
19:31:42 <nirik> but we can decide next week
19:31:45 <pingou> but I'll still be there a bit before and on the Friday during the day
19:33:03 <nirik> ok.
19:33:12 <nirik> anything else anyone would like to schedule or note upcoming?
19:33:23 <pingou> Santa is coming
19:33:26 <threebean> \ő/
19:33:45 <pingou> https://isitchristmas.com/ but still says no :(
19:33:49 <smooge> Krampus visited us this week
19:33:52 <lmacken> threebean: do you have a kinesis macro for that now? :P
19:34:06 <threebean> lmacken: its my only one
19:34:11 <lmacken>19:35:07 <nirik> ha
19:35:11 <nirik> #topic Open Floor
19:35:28 <nirik> anyone have items for open floor? questions, comments, ideas, gift suggestions?
19:35:40 <lmacken> https://github.com/bochecha/koji-mash
19:36:01 <pingou> that's bo's christmas gift!
19:36:15 <threebean> :D
19:36:17 <lmacken> indeed :)
19:36:39 <lmacken> it could use more eyes, and i think we're still waiting on upstream to decide what to do with the repos after
19:37:01 <lmacken> but it'll take a lot of work away from the bodhi masher, which will be awesome.
19:37:12 <nirik> yeah!
19:37:18 <pingou> nirik: oh and I noticed that the planet isn't liking the feed from badges, threebean started to look into but I thought maybe we could run the planet w/o > /dev/null for one and see what it says :)
19:37:40 <nirik> sure, I'd be happy to do that and see...
19:38:44 <nirik> will do after meeting.
19:38:47 <pingou> cool :)
19:38:53 <nirik> Anything else, or shall we call it a meeting?
19:39:00 <janeznemanic> I was wondering do we use openstack or something similar
19:40:15 <nirik> janeznemanic: yes, it's openstack in our private cloud... folsom
19:40:54 <janeznemanic> so there is no possibility to see how it is set up, administered etc.
19:41:30 <nirik> it's pretty seperate from the rest of our infrastructure (deliberately so)
19:41:43 <nirik> I can try and answer questions on it...
19:41:52 <janeznemanic> ok I see, just asked
19:42:30 <janeznemanic> no nothing special I was hoping to have a look at config files nothing else
19:43:00 <nirik> we are hoping to install on some new machines a newer version with ansible and have it much neater.
19:43:01 <janeznemanic> but what about ticket #4121
19:43:31 <nirik> .ticket 4121
19:43:32 <zodbot> nirik: #4121 (IPv6 link local address allocation sometimes fails on fed-cloud2) – Fedora Infrastructure - https://fedorahosted.org/fedora-infrastructure/ticket/4121
19:43:47 <nirik> oh yeah, that... I meant to look into that. I suspect it's a folsom bug...
19:43:53 <nirik> we might be able to work around it for them
19:44:20 <janeznemanic> so basically I can't do much there
19:44:26 <nirik> yeah, sorry. ;(
19:44:31 <nirik> should have noted it...
19:44:34 <janeznemanic> ok no problem
19:44:51 <nirik> once we have the more sanely installed one config would be in ansible git repo, etc.
19:45:12 <janeznemanic> that would be great
19:45:35 <nirik> yeah. reminds me, we probibly should schedule an update/reboot cycle for the cloud... sometime.
19:45:52 <nirik> anyhow, lets go continue in #fedora-admin, #fedora-apps and #fedora-noc. ;)
19:45:58 <nirik> Thanks for coming everyone!
19:46:01 <nirik> #endmeeting