15:06:09 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:06:09 <zodbot> Meeting started Tue Jan 21 15:06:09 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:14 <Kevin_Kofler> #meetingname kde-sig
15:06:14 <zodbot> The meeting name has been set to 'kde-sig'
15:06:19 <Kevin_Kofler> #topic Role call
15:06:21 <mbriza> hello
15:06:31 <jgrulich> Hi
15:06:38 <Kevin_Kofler> The usual: Who's present?
15:08:39 <dvratil> hi
15:08:56 <rdieter> hi
15:10:02 * jreznik is back from kde 5 session
15:10:25 <Kevin_Kofler> #chair mbriza jgrulich dvratil rdieter jreznik
15:10:25 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik mbriza rdieter
15:10:40 <Kevin_Kofler> #info Kevin_Kofler, mbriza, jgrulich, dvratil, rdieter, jreznik present.
15:10:49 <Kevin_Kofler> #topic Agenda
15:11:02 <Kevin_Kofler> I'd like to have an update on F21 planning.
15:11:05 <dvratil> KF5, Part 2
15:11:19 <Kevin_Kofler> Yeah, KF5 is also always a good topic. :-)
15:11:24 <Kevin_Kofler> Anything else?
15:12:26 <Kevin_Kofler> I guess that's all.
15:12:39 <Kevin_Kofler> #topic F21 update
15:12:58 <Kevin_Kofler> So how are things going with respect to getting a spin for F21 approved?
15:13:23 <Kevin_Kofler> It seems obvious at this point that we cannot count on the "Workstation" product to accomodate us (can we?).
15:13:32 <Kevin_Kofler> We need to keep our spin!
15:14:27 * rdieter would've liked to hear from ltinkl about that, but not here today
15:14:37 <jreznik> seems like the agreement would be on two products levels - so something like spins, some release blocking, some not
15:15:04 <Kevin_Kofler> The thing is, it looks like we're going to get degraded to a second-class spin. :-(
15:15:17 <Kevin_Kofler> KDE should really be a Product!
15:15:30 <jreznik> there are that three initial top level products, other products could be raised to the top level if they show commitment into the product
15:15:37 <jreznik> it should not be a big deal for us
15:15:57 <jreznik> we would have to transform SIG to WG
15:16:29 <jreznik> with some org charter, create PRD and propose it to FESCO... exact process is not yet know, but these are prereqs
15:16:40 <Kevin_Kofler> And probably accept some FESCo appointees who don't have anything to do with KDE in the spin. :-(
15:16:41 <jreznik> that's my understanding so far
15:16:49 <Kevin_Kofler> In the workgroup, I mean.
15:17:08 <jreznik> Kevin_Kofler: these are more liasons - somebody who reports to FESCO, I'd say, we can appoint him too
15:17:21 <sgallagh> Kevin_Kofler: I can't see FESCo refusing to accept jreznik or rdieter as a liason, FWIW.
15:17:41 <jreznik> that FESCO appointment was to kick it off
15:17:52 <jreznik> for long time running SIG, it's not needed
15:17:54 <jreznik> I'd say
15:17:57 <Kevin_Kofler> I think more about those people that sit in the Server, Cloud and Workstation WG who are not server, cloud resp. desktop packagers.
15:18:09 <Kevin_Kofler> I don't want to make any names.
15:18:25 <sgallagh> Kevin_Kofler: Packaging isn't the only aspect of producing a product
15:18:29 <jreznik> so for KDE, it would be SIG to WG but defined in more formal way
15:18:38 <Kevin_Kofler> But if you look at the member lists, you'll see that there are only vaguely relevant people.
15:18:58 <jreznik> actually we had that FKDESCO long time ago :D
15:19:19 <jreznik> that failed as we weren't very formally organized :)))
15:19:44 <sgallagh> Kevin_Kofler: I can only speak for Server with any confidence, but I selected a few people intentionally to address converging needs like QA, Ambassadors and Design.
15:20:13 <Kevin_Kofler> sgallagh: But that's kind of my point, if those people aren't working on Fedora on a server, why did you appoint them to the Server WG?
15:20:27 <sgallagh> Because the point of the WG isn't solely to *develop* the server.
15:20:50 <jreznik> I hope I understand that discussion correctly, sgallagh can hopefully add more details... but these are prereqs we should fulfill - I'm pretty sure it's going to be formality to get our product approved even there's no formal process now after that, as we have long time continuity
15:20:57 <sgallagh> It's to manage the holistic process of releasing a product
15:21:39 <Kevin_Kofler> jreznik: Yeah. I think either you or rdieter should file the ticket, you guys get along with FESCo much better than me. ;-)
15:21:39 <sgallagh> jreznik: You covered the major points. Yes, there will be a (yet-to-be-defined) process to become a full Product.
15:21:48 <sgallagh> Yes, KDE is most likely to be the first to go through it.
15:22:12 <Kevin_Kofler> And as sgallagh said, you'd also be the most appropriate candidates for the FESCo←→WG liaison.
15:22:22 <jreznik> Kevin_Kofler: we are still far away from ticket - we should first come with WG and PRD
15:23:20 * jreznik has to move to enclave for a call...
15:23:23 <rdieter> pardon my ignorance, but what is PRD?
15:23:25 <Kevin_Kofler> sgallagh: Unfortunately, reading things like "manage the holistic process of" scares me. :-(
15:23:26 <jreznik> I'll send a note to the list
15:23:38 <jreznik> rdieter: product requirements document
15:23:44 <rdieter> danke
15:23:45 <Kevin_Kofler> sgallagh: (Too many buzzwords.)
15:24:02 <jreznik> rdieter: in czech, it means fart
15:24:04 <jreznik> :D
15:24:20 <sgallagh> Kevin_Kofler: As it should! It's the difference between providing a spin containing a managed set of packages vs. providing a defined solution with marketing materials, targeted testing and focused goals.
15:24:23 <jreznik> and there's another document - MRD, marketing one and don't ask me what does it mean in Czech :)))))
15:24:26 <Kevin_Kofler> jreznik: It was supposed to be German. ^^
15:24:40 <sgallagh> Much of that you already have, so that's why I suspect you guys will make the transition fairly easily
15:24:54 <sgallagh> Whereas the "Games" or "Electronics Lab" spin might have more trouble
15:25:02 <jreznik> Kevin_Kofler: I know :) just saying prd in czech is fart, mrd in czech is that f* word :D
15:25:38 <Kevin_Kofler> Electronics Lab actually had some quite nice advertising back in the days where Chitlesh was most enthousiastically active.
15:25:55 <sgallagh> jreznik: That's what you get for a language with too few vowels ;-)
15:26:23 <sgallagh> Kevin_Kofler: This wasn't meant to start a holy war, just to point out that a Product is not just a renamed Spin.
15:26:30 <Kevin_Kofler> E.g., they had a small folder/dépliant.
15:27:17 <Kevin_Kofler> Some of the stuff they did back in the day is actually a good example to follow. These days, FEL is mostly dead though.
15:27:43 <Kevin_Kofler> (at least it's perceived as such – no more marketing)
15:29:51 <Kevin_Kofler> Keeping a spin working is one thing (and may be a lot of work if you care about it working WELL, even more so if you aren't just basing it on another spin; FEL has always been based on one of the desktop spins), but keeping up the buzz behind it is even harder.
15:30:14 <sgallagh> Right, and keeping up the "buzz" is one aspect of being a Product
15:30:49 <sgallagh> It's also a means to focus the limited ambassadorial staff we have on particularly cool and targeted stuff.
15:32:02 <Kevin_Kofler> KDE definitely does have its following here in Europe, so even just by being KDE, we get users interested.
15:32:19 * sgallagh nods
15:32:36 <Kevin_Kofler> But there are nice KDE apps that could also be killer apps if promoted properly.
15:33:31 <Kevin_Kofler> I'm thinking of KDevelop, for example.
15:33:54 <Kevin_Kofler> But also Marble could qualify.
15:35:15 <Kevin_Kofler> Or for everyone working with Mathematics (also engineers in various domains), Cantor is very useful.
15:35:51 <Kevin_Kofler> The problem we have there is, to fit all of those, we need to ship an image of at least up to 2 GiB, maybe even more. :-(
15:36:04 <sgallagh> Kevin_Kofler: That will be entirely up to your WG to decide upon
15:36:27 <sgallagh> Anyway, I'm juggling two meetings at the same time, so let's leave this at: I at least support this effort. Go for it.
15:36:34 <Kevin_Kofler> Having them only in the repo is probably the better solution, but then advertising them as product features is a bit misleading. Tough decision…
15:36:52 <mbriza> well, i suppose it's not a problem to produce two different images in case we want to ship everything
15:37:40 <dvratil> "Insert disc 2" - like when installing Debian from 25 floppy disks in the old times :)
15:38:00 <mbriza> yeah i meant having one "minimal" image and second one with everything good kde provides
15:38:02 <Kevin_Kofler> So I think we should start writing up the required documents and then come back to this next week.
15:38:19 <Kevin_Kofler> Who will work on the documents?
15:38:25 <mbriza> hopefully it won't be as debian with 7 or how many dvds
15:40:34 <Kevin_Kofler> jreznik: You seem to be most familiar with the processes, do you think you can do the PRD? Or at least give one of us some ideas so we can write it up?
15:42:19 <Kevin_Kofler> Hmmm, I'll see on the chan if we can get this going, we need to move on now.
15:42:44 <Kevin_Kofler> #info PRD needs to be written, volunteer needed.
15:42:49 <jreznik> Kevin_Kofler: yep
15:43:06 <Kevin_Kofler> jreznik: "yep" to what?
15:43:58 <jreznik> for PRD
15:44:11 <Kevin_Kofler> #undo
15:44:11 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x3170c810>
15:44:34 <Kevin_Kofler> #action jreznik to coordinate writing the PRD
15:44:37 <Kevin_Kofler> Thanks!
15:44:43 <Kevin_Kofler> #topic KF5 update
15:45:15 <dvratil> so, KF5 are ready
15:45:42 <dvratil> Plasma 2 is sort-of working - login works, but there are crashes, sometimes applets won't load, etc - but it's a devel preview so I think it's fine
15:46:21 <Kevin_Kofler> From conflicts land, upstream says most renames are now pushed, there are 3 binaries whose renames were under review as of their last status update, and kwallet which recently got (re)introduced in KF5 land and needs to be renamed, too.
15:46:25 <dvratil> I spent last few days trying to make plasma-shell work properly but failed, so I guess I'll just announce it on ML/blog today and put there a big warning that "Plasma 2 is still in development and does not effectively work"
15:46:39 <dvratil> kwallet has been renamed too
15:46:55 <Kevin_Kofler> OK, good.
15:47:19 <dvratil> the thing is that we ship KF5 TP1, which is now about 4 weeks old
15:47:46 <dvratil> so it's not effectively coinstallable (hence still in /opt/kf5). I want to only ship TPs, RCs, Betas etc, no random git snapshots
15:47:54 <Kevin_Kofler> I guess we need to wait for the next TP.
15:48:13 <Kevin_Kofler> Hopefully that'll also make Plasma work.
15:48:35 <Kevin_Kofler> (but if it's like KDE 4.0, it'll take until the Final to have something that even partly works)
15:48:39 <dvratil> yeah, they have a deadline for PW2 for June I think, so they better start moving quickly :)
15:49:39 <Kevin_Kofler> I remember the broken Plasma in all the 3.9x.xx releases, and the semi-working one in 4.0.0, it took until 4.0.3 (well, 4.0.4 really, but we backported the fixes for 4.0.3 in the F9 release rush) to have something that could be defined as "working".
15:50:14 <dvratil> I think this time it will be much less painful :)
15:50:46 <mbriza> or you'll just be more used to using broken stuff than back then ^^
15:51:16 <Kevin_Kofler> 3.9x.xx in Rawhide was fun, I think these days we'd get a really angry adamw loudly yelling at us if we broke Rawhide that badly for ~3 months. ^^
15:51:33 <Kevin_Kofler> Back in the good old F9 days, one could actually do development in Rawhide.
15:52:06 <Kevin_Kofler> Even if it meant KDE sessions were not working at all.
15:52:35 <adamw> RARRRRRRRGHGGHGHHH
15:52:43 <Kevin_Kofler> ;-)
15:54:37 <Kevin_Kofler> Nowadays importing Plasma 2 to Rawhide is not going to happen in this state.
15:56:33 <Kevin_Kofler> So I'm going to sum the state up for the meeting summary:
15:57:19 <Kevin_Kofler> #info KF5 TP1 (about 4 weeks old) is now ready in COPR. Plasma 2 is sort-of working - login works, but there are crashes, sometimes applets won't load, etc.
15:57:56 <Kevin_Kofler> #info In the next TP, parallel installability in /usr should be working (we use /opt/kf5 for now), and we hope that plasma-shell will also work better.
15:58:09 <Kevin_Kofler> dvratil: I think that sums it up, right?
15:58:25 <dvratil> yup
15:58:37 <Kevin_Kofler> #topic Open discussion
15:59:23 * Kevin_Kofler pushed a new krazy2 snapshot to testing, with some support for Qt5/KF5 code and some other small improvements.
15:59:40 <Kevin_Kofler> Sadly, the project doesn't care at all about getting packaged, so they don't do releases.
16:00:06 <Kevin_Kofler> I have to remember doing snapshots regularly, otherwise it gets VERY outdated.
16:00:22 <Kevin_Kofler> (as it was before I pushed the previous update in November)
16:00:57 * Kevin_Kofler wonders if he's a bit… krazy ;-) for even trying to package krazy2. ;-)
16:01:13 <rdieter> yes
16:01:25 <rdieter> but that's ok
16:02:04 <Kevin_Kofler> Listing the improvements also requires going through the git commit log.
16:02:14 <Kevin_Kofler> There isn't even a human-readable changelog provided by upstream. :-(
16:03:50 <Kevin_Kofler> Anything else? Otherwise, closing the meeting in 60 seconds.
16:04:39 <Kevin_Kofler> #info Kevin_Kofler pushed a new krazy2 snapshot to testing, with some support for Qt5/KF5 code and some other small improvements.
16:04:50 <Kevin_Kofler> Well, thanks for attending, see you next week!
16:04:53 <Kevin_Kofler> #endmeeting