15:06:49 <rdieter> #startmeeting kde-sig
15:06:49 <zodbot> Meeting started Tue Jan 28 15:06:49 2014 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:53 <rdieter> #meetingname kde-sig
15:06:53 <zodbot> The meeting name has been set to 'kde-sig'
15:07:01 <rdieter> #topic roll call
15:07:05 <Kevin_Kofler> Present.
15:07:13 <rdieter> hi, who's present for kde-sig meeting today?
15:07:19 <jgrulich> hi
15:09:43 <rdieter> #info Kevin_Kofler  jgrulich present
15:09:47 <rdieter> #chair Kevin_Kofler  jgrulich
15:09:47 <zodbot> Current chairs: Kevin_Kofler jgrulich rdieter
15:09:59 <mbriza> hello
15:10:05 <ltinkl> hi
15:10:17 <rdieter> I knew my typing that would prompt more arrivals :)
15:10:24 <rdieter> #info mbriza ltinkl rdieter present
15:10:27 <rdieter> #chair mbriza ltinkl
15:10:27 <zodbot> Current chairs: Kevin_Kofler jgrulich ltinkl mbriza rdieter
15:10:30 <mbriza> yeah, i completely forgot about time :/
15:10:45 <rdieter> #topic agenda
15:10:47 <dvratil> hi
15:10:52 <rdieter> #info dvratil present
15:10:54 <rdieter> #chair dvratil
15:10:54 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich ltinkl mbriza rdieter
15:11:27 <rdieter> so, proposed topics already include: formally target kde-4.12.2 for f20, devconf stuff
15:11:29 <rdieter> anything else?
15:12:46 <Kevin_Kofler> Maybe an update on getting our spin approved for F21?
15:13:32 <rdieter> ok
15:13:37 <Kevin_Kofler> Or is there nothing new there?
15:13:45 <rdieter> #topic kde-4.12.2 for f20 proposal
15:14:13 <rdieter> I think we'd only half-chatted about this, but never formally discussed it, so here we are.
15:14:35 <rdieter> target kde-4.12.2 for f20, any comment/objection to that plan?
15:14:48 * mbriza was using 4.12 since about 4.11.97 i think and it was completely fine
15:15:37 <jgrulich> +1 for KDE 4.12 for F20
15:15:40 <rdieter> <nod> esp with kde-workspace 4.11.x lts, this should be really easy and stable
15:15:47 <ltinkl> ye, completely fine, 4.12.x is very stable
15:16:40 <rdieter> #agreed kde-sig will target kde-4.12.2 for official f20 update
15:16:41 <Kevin_Kofler> +1
15:17:11 <Kevin_Kofler> There has also been some talk about planning 4.13 too when it will be ready, I approve that one too.
15:17:23 <Kevin_Kofler> 4.13 will be out before F21, so it should definitely go out to F20 updates.
15:17:45 <dvratil> Kevin_Kofler, but 4.13 will replace Nepomuk with Baloo - not sure it's a good idea to do that on F20
15:18:20 <rdieter> yeah, the nepomuk churn makes that less appealing
15:18:29 <Kevin_Kofler> Huh? They're doing that kind of changes in 4.x, with frozen kdelibs and kde-workspace??? WTF???
15:18:53 <nucleo> I use 4.12.1 from kde-unstable, only two new small problems appeared in 4.12: konsole asks for running bash if profile was changed and no other processes running and in gwenview don't work area at right bottom where large images can be moved
15:19:00 <Kevin_Kofler> The way upstream is handling 4.x really sucks.
15:19:03 <rdieter> I think we'll have to wait and see wrt kde-4.13
15:19:05 <dvratil> yeah. We decided we don't want to live with Nepomuk anymore and waiting 2 more years for KDE 5 is not going to work
15:19:38 <Kevin_Kofler> On one hand we have the core components feature-frozen for years (not even allowing simple new features in), on the other hand, major rewrites get in.
15:19:42 <Kevin_Kofler> This makes no sense whatsoever.
15:19:57 <dvratil> there will be no rewrite in kdelibs
15:20:36 <dvratil> I guess the Nepomuk API will only be marked as deprecated, but it won't be removed, or changed. Applications that want to use Baloo must be ported to Baloo
15:20:41 <Kevin_Kofler> Of course not, you just use a library outside of kdelibs instead of the one in kdelibs, bypassing the freeze and turning it into a farce.
15:20:58 <dvratil> *tunring it into a Framework
15:21:01 <Kevin_Kofler> dvratil: You guys are on crack!
15:21:21 <dvratil> well, sorry for making your email search useful
15:21:35 <Kevin_Kofler> We just recently got Nepomuk 2, a lot of time was thrown into Nepomuk, and now it's being thrown out yet again.
15:22:46 <dvratil> Nepomuk2 is just an ABI change. Yes, lots of work is going to be thrown away. Lots of work that was needed becuase Virtuoso was crappy and because ontologies are crappy. We decided to throw away lots of work, so that we can replace it by something that actually works, performs well and is much more flexible and stable
15:22:52 <Kevin_Kofler> What stuff is expected to be ported to Baloo for 4.13? Everything in the SC that uses Nepomuk? Or only Akonadi (and maybe unknown other stuff)?
15:23:23 <Kevin_Kofler> And why don't you do that with Akonadi? That would actually be worth throwing away!
15:23:31 <dvratil> at this point, Baloo indexes 150k emails within minutes. Nepomuk takes hours and hours of 100% CPU usage. Baloo can do a full-text search in 50k emails under 2 seconds. Nepomuk can't do such big search at all.
15:23:54 <rdieter> I've only casually followed the mailing list discussion so far.  kdepim/akonadi is on board already, and other stuff is being identified and queued
15:24:25 <Kevin_Kofler> For Akonadi, I don't see many issues because the stuff that's indexed can just be reindexed.
15:24:27 <dvratil> most applications use NepomukWidgets, which we only modify internally to use Baloo, so no porting neede there. Only Dolphin will be ported and KDE PIM, which is almost done
15:24:31 <Kevin_Kofler> I'm more worried about file tags.
15:24:58 <rdieter> #topic kde-4.13 and nepomuk/baloo
15:24:58 <dvratil> file tags will primarilly use xattr
15:25:19 <Kevin_Kofler> And all existing tags from Nepomuk will just be trashed?
15:25:26 <rdieter> thats interesting (we
15:25:29 <dvratil> migrated.
15:25:42 <rdieter> discussed it a bit yesterday in #fedora-kde, I think)
15:25:46 <Kevin_Kofler> Well, if the migration works, I think that's not a blocker for pushing that thing.
15:26:00 <Kevin_Kofler> If the migration DOESN'T work, then we have a problem.
15:26:23 <rdieter> Kevin_Kofler: <nod>, I'd like to reserve judgement until we have a chance to see it in action, do some testing
15:26:25 <dvratil> it's still a major technological change. We HOPE and will do our best to make it seemless. but still. Things can go wrong.
15:26:34 <Kevin_Kofler> We pushed 4.11 (IIRC) with the Nepomuk migration too.
15:27:02 <Kevin_Kofler> How will the search work in Baloo?
15:27:11 <Kevin_Kofler> (surely not with xattrs)
15:27:26 <dvratil> Baloo uses Xapian for contacts/emails indexing
15:27:48 <dvratil> Tags <-> File mapping will be in SQLite IIRC
15:29:08 <Kevin_Kofler> Finally a decision that makes sense, Xapian is actually designed to do indexing as opposed to RDF software.
15:29:11 <rdieter> <reserved>yay</reserved>
15:29:44 <Kevin_Kofler> Not sure why the file part cannot also be indexed with Xapian.
15:30:21 <dvratil> for indexing of content Xapian is maybe used too, I haven't seen that part of code yet.
15:30:53 <Kevin_Kofler> So I guess we'll make a decision about what to do with 4.13 once 4.13 is ready.
15:31:27 <Kevin_Kofler> We could also attempt a selective 4.13 update, pushing only those apps to F20 that are not affected by the Baloo changes.
15:31:57 <than> present
15:32:00 <rdieter> ok, let's move on...
15:32:03 <Kevin_Kofler> That'd be something of a disservice to our users if Baloo is really as great as you claim, but it'd be better than nothing.
15:32:05 <rdieter> #info than present
15:32:07 <rdieter> #chair than
15:32:07 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich ltinkl mbriza rdieter than
15:32:10 <Kevin_Kofler> (and with split packaging, it's possible now)
15:32:13 <rdieter> #topic DevConf
15:32:45 <Kevin_Kofler> #info DevConf Brno next week Fri-Sun (Feb 7-9)
15:33:39 <dvratil> I'll have a KF5 talk with Siddhart on Friday
15:34:38 <Kevin_Kofler> Friday February 7, 2014 16:40 - 17:20 says http://www.devconf.cz/schedule
15:35:09 <dvratil> yup
15:35:24 <Kevin_Kofler> I'll be there.
15:36:03 <rdieter> nice, anyone else planning to attend?
15:36:19 <jgrulich> yep, me, mbriza and ltinkl
15:37:04 <dvratil> I will go maybe
15:37:12 <rdieter> ha
15:37:37 <Kevin_Kofler> LOL, "maybe"… ;-)
15:38:16 <rdieter> ok, moving on...
15:38:29 <rdieter> #topic f21, kde spin plans
15:38:44 <rdieter> I suspect there is no news here, yet.
15:38:56 <Kevin_Kofler> We should get something going there.
15:39:02 <rdieter> (not from me, particularly)
15:39:09 <Kevin_Kofler> It'd suck to have F21 without an official KDE spin.
15:39:29 <ltinkl> why's that?
15:39:54 <rdieter> ltinkl: largely about not knowing what to expect yet from fedora.next I guess
15:40:22 <Kevin_Kofler> ltinkl: As I understand it, there's a new spin approval process, we need at least confirmation that our spin is approved.
15:40:30 <ltinkl> rdieter: well judging from the Workstation WG discussions, it's not gonna materialize anytime soon
15:40:35 <Kevin_Kofler> We may have to re-run it past some committee.
15:41:00 <rdieter> ltinkl: <nod>, my impression as well.
15:41:07 <Kevin_Kofler> ltinkl: Well, everyone's set on having F21 being Fedora.Next.
15:41:23 <ltinkl> now if it DOES turn into something concrete, we can always make the KDE spin on top of that, this will be possible
15:42:03 <ltinkl> Kevin_Kofler: the plan to have F21=fedora.next might be feasible for other WGs, certainly not for the Workstation at this point
15:42:06 <Kevin_Kofler> My problem is not so much with what to base the spin on, but with having (continued) approval for publishing it.
15:42:07 <ltinkl> jgrulich: any more insight? :)
15:42:13 <ltinkl> jreznik_: erm ^^
15:42:36 <ltinkl> Kevin_Kofler: having the approval shouldn't change either
15:43:02 <jgrulich> ltinkl: I don't know much about Fedora.Next :)
15:43:03 <ltinkl> jreznik said something about preparing a tentative F21 schedule
15:43:12 <ltinkl> jgrulich: I know that was meant for jreznik :)
15:43:16 <Kevin_Kofler> I don't want to reach release day with "What? You wanted to do a spin? Why haven't you run it past XYZ to get approval? Try again for F22!"
15:43:34 <jreznik_> sorry guys, I was out/busy for a few days, so no move with wg/prd prep
15:43:44 <ltinkl> Kevin_Kofler: why should that change? did we have to get that approval for each release in the past?
15:44:09 <ltinkl> jreznik_: so the plan is? F21 or fedora.next?
15:44:10 <Kevin_Kofler> As long as the current permanent approval is valid, I'm fine with that, though in the new world we should really try to become a Product.
15:44:33 <jreznik_> ltinkl: f21 as fedora.next, at least it looks like this
15:45:19 <ltinkl> jreznik_: with the 3 distinct products? (workstation, server, cloud)?
15:45:39 <ltinkl> jreznik_: or the old fashioned release?
15:46:05 <jreznik_> ltinkl: new one, multiple products
15:46:38 <ltinkl> jreznik_: how and precisely when do you want to do that when the Workstation product isn't finalized yet
15:46:48 <ltinkl> jreznik_: and other ones not much either
15:47:11 <Kevin_Kofler> Isn't releasing unfinished junk always what Fedora does? :-(
15:47:12 <ltinkl> under the status quo, we could wait for F21 till xmas or even later
15:47:57 <Kevin_Kofler> Fedora.Next sucks!
15:48:03 <jreznik_> ltinkl: if we would have to wait, we will wait
15:48:35 <Kevin_Kofler> jreznik_: What happened to Fedora being First and following a time-based schedule, not a "when it's done" one?
15:48:36 <jreznik_> seems like most people want f21 as fedora.next, if you as WG member thinks it's too early - comment it@
15:49:03 <Kevin_Kofler> I don't see why we all need to be held hostage to that Fedora.Next nonsense that brings no practical improvements to our users.
15:49:08 <jreznik_> Kevin_Kofler: as restart, I don't have problem with not being time based
15:49:33 <jreznik_> Kevin_Kofler: I can't answer it, I'm not right person to ask
15:50:25 <ltinkl> I understand that with this change, the whole release planning will be different
15:50:39 <ltinkl> my main gripe is that nobody knows at this point when it will happen
15:51:08 <jreznik_> and so it does not make sense to set schedule
15:51:19 <ltinkl> and things are moving forward very slowly so delaying the next Fedora release might hurt the whole distro reputation I fear
15:51:31 <ltinkl> jreznik_: right, I understand that
15:51:38 <rdieter> yeah, there would be no shame (and less stress) to not rush this into f21, imho
15:51:50 <ltinkl> but not releasing anything for a long time is much worse imo
15:52:17 <jreznik_> I'd prefer f21 old way, on the other hand I don't have problem with slipping it
15:52:33 <Kevin_Kofler> I'd support planning a normal 6-month schedule for F21 (even if it means an Alpha very soon) and pushing Fedora.Next back to at least F22.
15:52:38 <ltinkl> jreznik_: now honest fundamental question, who said that F21 _must_ be based on the WGs concept?
15:52:44 <Kevin_Kofler> (For all I care, it can be in Fedora 99999. ^^)
15:53:03 <ltinkl> Kevin_Kofler: indeed, my thoughts
15:53:05 <jreznik_> ltinkl: it wasn't decided yet but feelings are it is going to be fedora.next
15:53:14 <ltinkl> feelings don't matter here
15:53:26 <ltinkl> seriously
15:53:36 <jreznik_> ltinkl: or better - for now, there seems to be support for fedora.next within fesco
15:53:47 <jreznik_> if anybody has objections, ticket is opened
15:53:58 <rdieter> knurd started a recent thread on -devel list, probably time to chime in there
15:54:00 <jreznik_> feel free to comment it
15:54:03 <ltinkl> I know FESCO supports it, I'd be surprised if it didn't
15:54:38 <Kevin_Kofler> I'd also be surprised if there were any bad idea FESCo did NOT support. ^^
15:54:43 <rdieter> (well, continued older thread, would be more accurate)
15:54:50 <ltinkl> my question remains tho, any deadline until which F21 can still be tied to fedora.next? or better, wouldn't make more sense to delay that decision for F22
15:54:57 <ltinkl> liefe doesn't end at F21
15:55:04 <rdieter> ltinkl: +1
15:55:26 <ltinkl> life even
15:55:38 <ltinkl> it could be F42, who knows :)
15:56:04 <jreznik_> I think we will have an idea once initial scoping is done
15:56:15 <Kevin_Kofler> Fedora Infinity ;-)
15:56:27 <jreznik_> without real data on what does fedora.next mean, it's not a wise move to throw idea away and say "it
15:56:30 <jreznik_> s impossible"
15:56:36 <ltinkl> agree
15:56:57 <jreznik_> and fesco set pretty early deadline for scoping
15:57:00 <Kevin_Kofler> But you also can't say it's possible without a plan for how to realize it!
15:57:07 <ltinkl> but I'd only repeat myself, without clear goals and schedules this isn't moving anywhere
15:57:12 <rdieter> no one is saying throw anything away, just to delay it's implementation because it seems not ready
15:57:22 <ltinkl> indeed
15:57:25 <jreznik_> Kevin_Kofler: and fesco asked for that plan to be ready in two/three weeks
15:57:55 <rdieter> (but here is likely not the best venue for any constructive conversation)
15:58:00 <Kevin_Kofler> +1
15:58:09 <Kevin_Kofler> So let's move on…
15:58:12 <jreznik_> I'm not defending it, just sayin - scoping happens right now, deadline is I think feb 14
15:58:24 <rdieter> short answer: we don't know yet
15:58:24 <jreznik_> by that time, I think we should know if it's possible or not
15:58:31 <rdieter> ok
15:58:34 <rdieter> jreznik_: thanks
15:58:35 <jreznik_> so wait two, three weeks
15:58:41 <ltinkl> ok, thanks, that clears it up at least a bit
15:58:48 <rdieter> #topic open discussion
15:59:05 <rdieter> we're close to end of of hour, any last thoughts before closing meeting?
15:59:10 <jreznik_> after that time, I'd start to scream to do old release if no plans would be available
15:59:24 <ltinkl> jreznik_: cool :)
15:59:37 <mbriza> i officially wrote my own DM... it's able to start lxdm now... :)
15:59:46 <ltinkl> haha
16:00:33 <ltinkl> another fine example of a stale mate (sddm vs lightdm vs kdm), write a new one! ;)
16:00:40 <mbriza> few more days and some review and i'll hack it into sddm - it's a whole library
16:00:51 <mbriza> well, i made it as a proof-of-concept :)
16:01:20 <mbriza> the whole source of the DM is about 90 LoC and can only start a precompiled binary and autologin a precompiled user :D
16:01:35 <Kevin_Kofler> ltinkl: http://xkcd.com/927/ ;-)
16:01:53 <ltinkl> yup
16:02:13 <ltinkl> I sincerely hope it will be sddm once all the quirks are resolved
16:02:27 <ltinkl> kdm is just a piece of obsolete crap and lightdm is a no-go due to the CLA
16:02:54 <mbriza> ltinkl: nobody will seriously use this as their main DM https://github.com/MartinBriza/QAuth/blob/master/example/MinimalDMApp.cpp :)
16:03:16 <mbriza> maybe my roommate but he's strange, he's using DWM and still blabbering about how it's better than KDE and whatnot
16:03:30 <sochotni> mmaslano: already here?
16:04:06 <mmaslano> sure
16:04:08 <jgrulich> mbriza: don't say that nobody won't use it, we started plasma-nm as an insane idea to rewrite everything from scratch, so you can definitely write your own DM :) heh
16:04:45 <Kevin_Kofler> I think we should vacate the chan now. :-)
16:04:53 <sochotni> Kevin_Kofler: yes :-P
16:05:22 <Kevin_Kofler> #endmeeting