15:07:15 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:07:15 <zodbot> Meeting started Tue Feb 11 15:07:15 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:21 <Kevin_Kofler> #meetingname kde-sig
15:07:21 <zodbot> The meeting name has been set to 'kde-sig'
15:07:27 <Kevin_Kofler> #topic Role call
15:07:33 * Kevin_Kofler is present, who else?
15:07:47 * jgrulich is present
15:07:48 <rdieter_work> here
15:08:24 <rdieter_work> sorry, may get pulled away (again), this slot happens to fall on my office hours @ work
15:09:43 * ltinkl is present
15:10:26 <Kevin_Kofler> #chair jgrulich rdieter_work ltinkl
15:10:26 <zodbot> Current chairs: Kevin_Kofler jgrulich ltinkl rdieter_work
15:10:39 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, ltinkl, rdieter present.
15:10:47 <Kevin_Kofler> #topic Agenda
15:11:08 <Kevin_Kofler> So, do we have anything to discuss? And also, do we want to discuss it with only 4 people present?
15:11:09 * jreznik is around but not feeling very well, so...
15:11:20 <Kevin_Kofler> #chair jreznik
15:11:20 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik ltinkl rdieter_work
15:11:31 <Kevin_Kofler> #info jreznik also present.
15:12:22 <Kevin_Kofler> So I'm going to wait a minute for anybody to propose agenda topics, and if not, adjourn the meeting right here.
15:12:53 <rdieter_work> ltinkl: will you be around after meeting, I'd like to pick your brain a little about the workstation WG PRD, otherwise we can do it during the meeting here/now
15:13:11 <jgrulich> I have one problem to solve https://bugzilla.redhat.com/show_bug.cgi?id=1063378
15:13:33 <Kevin_Kofler> .bug 1063378
15:13:37 <ltinkl> rdieter_work: yup i will, we need to discuss it a bit more, not here preferably
15:13:40 <zodbot> Kevin_Kofler: Bug 1063378 kde-plasma-nm base package should not require ModemManager - https://bugzilla.redhat.com/show_bug.cgi?id=1063378
15:13:44 <rdieter_work> ltinkl: ok, thanks
15:14:11 <Kevin_Kofler> jgrulich: Not sure what the best solution is here.
15:14:27 <Kevin_Kofler> Really, ModemManager needs some enabled=no configuration. :-/
15:14:29 <jgrulich> I think we already discuss it with rdieter_work before, but we didn't find any suitable solution
15:15:00 <jgrulich> kde-plasma-nm doesn't need ModemManager, but libmm-qt does
15:15:05 <rdieter_work> jgrulich: yeah, we had an old (cantfix?) bug, I think.  probably just dup it.  no need to rehash it again
15:15:10 <jgrulich> and without libmm-qt you can't have libnm-qt
15:16:02 <Kevin_Kofler> #topic #1063378
15:16:19 <Kevin_Kofler> #link https://bugzilla.redhat.com/show_bug.cgi?id=1063378
15:16:31 <Kevin_Kofler> #info Bug 1063378 kde-plasma-nm base package should not require ModemManager
15:16:34 <rdieter_work> I can look at it one more time after meeting, just in case
15:16:34 <jgrulich> when libnm-qt is compiled with libmm-qt support, it hardly depends on it
15:16:52 <Kevin_Kofler> I think there's indeed no good solution for that.
15:17:06 <Kevin_Kofler> So → CANTFIX.
15:17:25 <rdieter_work> jgrulich: could consider dropping Requires: ModemManager from libmm-qt
15:17:29 <ltinkl> ye, there's nothing linking (strictly speaking) libnm-qt to libmm-qt
15:17:58 <ltinkl> rdieter_work: can't, this thing really needs MM running
15:18:19 <rdieter_work> if kde-plasma-nm-mobile is it's only consumer, put the dep there instead
15:19:04 <Kevin_Kofler> But there's also a BR ModemManager-devel.
15:19:17 <Kevin_Kofler> If this links to ModemManager libraries, dropping the explicit Requires isn't going to help.
15:19:39 <rdieter_work> I didn't see MM having any libs
15:19:44 <rdieter_work> checked that first
15:19:57 <jgrulich> libmm-qt uses only MM headers
15:20:09 <jgrulich> for enums and macros
15:20:24 * rdieter_work repoqueries
15:20:49 <rdieter_work> k, kde-plasma-nm indeed is the only thing pulling in libmm-qt currently
15:21:08 <rdieter_work> so, what I proposed may be the only option (other than doing nothing)
15:21:46 <Kevin_Kofler> Yeah, it's ugly, but it's probably the best solution for the users.
15:22:07 <Kevin_Kofler> So +1 to moving the Requires.
15:22:11 <mbriza> i'm here too just for the record, not that i have anything to add
15:22:29 <rdieter_work> kde-plasma-nm-mobile already has the dep, so it's only a matter of removing from libmm-qt at this point.
15:22:43 <rdieter_work> #info mbriza present
15:22:45 <rdieter_work> #chair mbriza
15:22:45 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik ltinkl mbriza rdieter_work
15:23:12 <rdieter_work> jgrulich, ltinkl : assuming nothing blows up if MM is missing?
15:23:34 <rdieter_work> or is that an unknown yet?
15:23:49 <jgrulich> rdieter_work: I guess only dbus calls won't work
15:23:57 <ltinkl> rdieter_work: nah, it shouldn't blow up, it just won't work for modems if you insert one
15:24:07 <ltinkl> (hopefully)
15:24:46 <rdieter_work> I have no strong feelings either way... it's not like having ModemManager installed is hurting anyone
15:25:21 <rdieter_work> on my box, pulls in a whopping 326k package
15:25:29 <Kevin_Kofler> rdieter_work: The argument in the bug is that it does hurt because it claims all USB-serial adapters.
15:25:39 <Kevin_Kofler> And there's no way to disable that behavior.
15:25:43 <jgrulich> rdieter_work: maybe putting ModemManager as dependency for libmm-qt-devel if someone wants to hack on it?
15:26:04 <Kevin_Kofler> jgrulich: I'd just remove the dependency entirely.
15:26:06 <ltinkl> Kevin_Kofler: then there's a bug in MM itself, it's not like we are the ones eating the ports
15:26:18 <rdieter_work> jgrulich: <nod>, not a bad idea
15:26:28 <Kevin_Kofler> Runtime dependencies in -devel are not welcome, they only force more stuff into the buildroots.
15:26:47 <Kevin_Kofler> It just doesn't make any logical sense to have this dep in -devel.
15:26:52 <rdieter_work> (no strong feelings either way though, again)
15:29:04 <jgrulich> ok, then I'll remove MM as dependency from libmm-qt
15:30:07 <Kevin_Kofler> #agreed Remove ModemManager as a dependency from libmm-qt, a Requires remains in kde-plasma-nm-mobile, which should be sufficient in practice.
15:32:20 <Kevin_Kofler> #topic Open discussion
15:32:28 <Kevin_Kofler> So, anything else or can we close the meeting?
15:35:03 * jreznik has nothing to share now
15:36:25 <Kevin_Kofler> OK, waited more than enough. ;-)
15:36:30 <Kevin_Kofler> Thanks for coming!
15:36:32 <Kevin_Kofler> #endmeeting