16:00:25 <adamw> #startmeeting Fedora QA meeting
16:00:25 <zodbot> Meeting started Mon Feb 17 16:00:25 2014 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:29 <adamw> #meetingname fedora-qa
16:00:29 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:36 <adamw> #topic Roll call
16:00:37 <adamw> ahoyhoy, folks
16:01:24 * jskladan lurks
16:01:37 * pschindl is here
16:01:39 * adamw watches dustball roll by
16:01:50 * mkrizek is here
16:02:29 * handsome_pirate stumbles in
16:02:38 * nirik is lurking around as usual.
16:02:43 * cmurf is here
16:02:43 <adamw> handsome_pirate: tough day's pillaging?
16:02:57 <handsome_pirate> adamw:  Aye
16:03:07 <ignatenkobrain> heeey ;)
16:03:15 <ignatenkobrain> I'm here
16:03:18 <ignatenkobrain> again
16:03:27 <adamw> morning igor
16:03:32 <cmurf> It is "Washington's Birthday" in the U.S. today, do not let uninformed Americans call it President's Day. There is no such thing.
16:03:42 <adamw> .fire roshi
16:03:42 <zodbot> adamw fires roshi
16:03:47 <ignatenkobrain> .fire adamw
16:03:47 <zodbot> adamw fires adamw
16:03:51 <adamw> cmurf: not even Presidents' Day ?
16:03:51 <ignatenkobrain> .fire roshi
16:03:51 <zodbot> adamw fires roshi
16:03:59 <roshi> ?
16:04:00 <adamw> .fire zodbot
16:04:00 <zodbot> adamw fires zodbot
16:04:04 <adamw> OH HAI META
16:04:06 <roshi> I didn't even do anything
16:04:09 <cmurf> adamw: Certainly not. One is more than enough.
16:04:09 <adamw> roshi: you didn't indicate presence
16:04:14 * roshi is here
16:04:19 <ignatenkobrain> who's here?
16:04:21 <roshi> I was reading logs like a good person
16:04:39 <roshi> I said I was here two hours ago - never left the channel
16:04:40 <ignatenkobrain> jreznik: ?
16:04:41 <roshi> :p
16:05:00 <adamw> roshi: oh, a barracks room lawyer, eh?
16:05:01 <ignatenkobrain> tflink: ?
16:05:07 <adamw> ignatenkobrain: thanks
16:05:15 <roshi> haha
16:05:16 <adamw> #chair ignatenkobrain handsome_pirate
16:05:16 <zodbot> Current chairs: adamw handsome_pirate ignatenkobrain
16:05:21 <roshi> nah - docs meeting
16:05:47 <ignatenkobrain> hohoho!
16:06:01 <ignatenkobrain> let's go!
16:06:01 <cmurf> docs meetings are too early
16:06:13 <roshi> tell me about it cmurf
16:06:15 <roshi> lol
16:06:20 <adamw> #topic Fedora 20 status
16:06:21 <cmurf> I only get up that early to ski/board.
16:07:02 <adamw> cmurf: 127cm in the last seven days at whistler, 12cm more forecast tonight and i'm there tomorrow...wheee
16:07:17 <cmurf> that is abit of white
16:07:34 <adamw> OK, so, I wanted to throw this in to mention a couple of fairly significant bugs I'm trying to firefight at the moment, and see if anyone has any input or any other things we ought to be keeping an eye on
16:07:48 <cmurf> i think that might have been 2x your base up until 2 weeks ago!
16:07:57 <adamw> cmurf: about that
16:08:16 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1043212
16:08:33 <ignatenkobrain> .bug 1043212
16:08:44 <cmurf> curious i haven't run into that one at all
16:08:47 <adamw> hey, I think I really did fire zodbot.
16:08:51 <ignatenkobrain> zodbot: do work!!!
16:08:51 <zodbot> ignatenkobrain: Error: You don't have the do capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
16:08:53 <adamw> cmurf: it's a race condition, so not everyone will
16:08:55 <zodbot> ignatenkobrain: Bug 1043212 something creating /var/run/nologin - https://bugzilla.redhat.com/show_bug.cgi?id=1043212
16:09:07 <cmurf> yes but i'm a bug magnet
16:09:20 <adamw> #info there's a rather nasty bug in systemd which, for REASONS, causes it to sometimes create /var/run/nologin when you do stuff (it's typically triggered by a package update, but there are other vectors)
16:09:33 * nirik has also never seen it.
16:09:46 <ignatenkobrain> hi nirik
16:09:55 <nirik> hey ignatenkobrain
16:09:57 <adamw> a running system on which /var/run/nologin exists behaves...oddly. no-one's allowed to log in, or shut the system down. and there is apparently something of a corner case where the GNOME lock screen can be bypassed by hibernating the system (although only one person's indicated that).
16:09:59 <adamw> so...fun times.
16:10:37 <cmurf> sync && reboot -f doesn't work?
16:10:46 <adamw> no, you're not allowed to reboot the system.
16:10:50 <adamw> if you know what'
16:10:51 <cmurf> ha well that sucks
16:10:55 <ignatenkobrain> interesting..
16:10:59 <adamw> if you know what's going on it's trivial to just rm -f /var/run/nologin
16:11:02 <adamw> but if you don't, it's icky.
16:11:07 <danofsatx> I'm here....sorry, was fighting w/ libvirt bridging....
16:11:25 <adamw> so, be on the lookout. i spent some time poking into this on friday
16:11:35 * handsome_pirate has not seen this either
16:11:57 <adamw> it gets more fun, because we actually sent out a build that would've fixed it already, and everyone's best friend harald -1ed it out of existence because it triggered another bug (log spam on cronjobs)
16:12:32 <adamw> f20's systemd package is kind of messy. upstream systemd has had major major changes since 208 so there hasn't been a stable release for months, and we don't just want to bump to git master
16:12:47 <adamw> so f20 has 208 plus a huge chunk of backported patches, manually cherry picked by zbigniew
16:13:18 <adamw> that makes it rather tricky to work with the package or figure out exactly what to do about tricky bugs. but zbigniew's come up with something and sent out a new testing package this morning
16:13:23 <ignatenkobrain> is there plans to release 209 ?
16:13:33 <danofsatx> I haven't seen this one personally, but I know folks (on gnome) that have run into it.
16:13:34 * nirik notes rawhide is in the same state. Pity they commited a bunch of kdbus stuff.
16:13:50 <adamw> ignatenkobrain: i believe once the kdbus stuff is vaguely usable
16:14:15 <adamw> so really, i just wanted to note: a) if you do user support, be on the lookout for this one - if someone reports weirdness with not being able to login or shutdown or unlock their screen, it's likely this bug
16:14:17 <roshi> so this is GNOME specific?
16:14:26 <adamw> roshi: no, it affects any desktop and no desktop at all.
16:14:34 <adamw> it's PAM that denies things when the file exists.
16:14:39 <cmurf> so if kdbus is enabled in f21 kernels, does systemd know this and thus know not to launch dbus?
16:14:47 <roshi> I haven't seen it either
16:14:50 <adamw> cmurf: I dunno, haven't looked at that stuff much either.
16:15:11 <nirik> cmurf: kdbus is not merged in the kernel yet that I know of.
16:15:31 <adamw> and b), please do test the update - test it carefully as it adds like a whole dump of patches compared to 208-9 that we shipped with, but unless there are *really serious* regressions we want to ship it
16:15:35 <nirik> it's not _just_ kdbus stuff... "<zbyszek>       nirik: There's just too many bugs in current git. Even without kdbus
16:15:35 <nirik> enabled :)"
16:15:44 <adamw> nirik: yeah, there's other stuff too
16:15:59 * nirik nods.
16:17:11 <cmurf> nirik: ok yeah i see that it's not in mainline and requires compile time changes to both systemd and the kernel so it looks like some coordination is needed
16:17:16 <ignatenkobrain> well. have we fix/workaround in our wiki ?
16:17:38 <roshi> it's labeled as commonbugs on bz
16:17:42 <cmurf> implies that there could be some breakage when running Fxx with Fxx+1 kernels, hmm
16:17:53 <roshi> if it's not on the commonbugs wiki I'll add it
16:18:22 <ignatenkobrain> roshi: have nothing about that in wiki. add please if you can
16:18:31 <roshi> for sure
16:18:37 <adamw> yeah, i meant to add it to commonbugs but didn't get to it yet, thanks
16:18:43 <ignatenkobrain> https://fedoraproject.org/wiki/Common_F20_bugs
16:18:45 <cmurf> 208-11 was in u-t and then pulled wasn't it?
16:18:47 <ignatenkobrain> useful link
16:18:48 <adamw> #action roshi to add #1043212 to commonbugs
16:18:53 <adamw> cmurf: yes, that's the thing i mentioned about harald
16:19:27 <handsome_pirate> cmurf:  What are you talking about?
16:19:35 <handsome_pirate> cmurf:  /me is running 3.14rc2
16:19:35 <adamw> handsome_pirate: he's talking about kdbus
16:19:40 <handsome_pirate> adamw:  Ah
16:19:58 <adamw> once we turn it on for f21 it may cause the kernel not to work right with f20, but i don't know if he's right or not, i haven't looked into that.
16:20:11 <nirik> it's too early to say much about kdbus IMHO... it's not even merged yet.
16:20:19 <cmurf> handsome_pirate: I'm way too far ahead to the point of being utterly off topic
16:21:25 <masta> kdbus probably more thrash&churn than the udev firmware loading thing...
16:21:49 <masta> for people running mixed user space & kernel
16:21:52 <cmurf> just because it ends up in kernel mainline doesn't mean it gets enabled in f21/f22 kernels so… I think we're going to get some warning about all of this.
16:22:14 <adamw> yeah, i'd trust the kernel folks
16:22:15 <adamw> anyhow
16:22:23 <adamw> i think w covered this bug?
16:22:53 <cmurf> yessir
16:22:57 <adamw> the other big one I had on my plate is the crashing in GNOME shell
16:23:00 <ignatenkobrain> adamw: yup
16:23:04 <ignatenkobrain> oh yeah
16:23:09 <ignatenkobrain> gnome crashing ;)
16:23:12 <ignatenkobrain> js js js
16:23:31 <handsome_pirate> lol
16:23:42 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1028813 is the f20 report, but most of the action is happening in the f21 report, #1034467
16:23:48 <cmurf> 3.10.3-x or a particular Fedora subversion?
16:23:55 <handsome_pirate> adamw:  One of the advantages of not running Gnome is I don't have to experience the joys that go with it
16:23:59 <adamw> for some people (inc. me, unfortunately) Shell crashes quite frequently, somewhere in gjs
16:24:20 <adamw> this is apparently due to an underlying memory corruption so the backtraces per se aren't much use, which means debugging it is a complete bear
16:24:35 <adamw> i've been trying to provide the necessary info to the devs via valgrind, but it's proving a job.
16:24:40 <ignatenkobrain> adamw: is there way for properly debugging ?
16:25:02 <ignatenkobrain> I also have so much crashes there
16:25:09 <adamw> ignatenkobrain: right now, the mozjs devs are asking for a valgrind log capturing the crash, with mozjs24 built with --enable-debug
16:25:40 <adamw> you also have to build mozjs24 with --enable-valgrind and do a few other dance steps, i've mentioned most of them in the bug report and/or the mozilla bug report at https://bugzilla.mozilla.org/show_bug.cgi?id=972725
16:26:16 <adamw> i've managed to get a valgrind log of the crash with mozjs24 built without --enable-debug, but when I ran it for like a day with --enable-debug, it didn't crash, so this may be heisenbug-y to add to all its other wonderful properties
16:26:17 <cmurf> jeez
16:26:22 <ignatenkobrain> Heisenbug-ish
16:26:27 <ignatenkobrain> *dance*
16:26:27 <adamw> running Shell in valgrind for a day is not my idea of a good time, btw. :P
16:26:45 <ignatenkobrain> well
16:26:46 <adamw> i have the appropriate mozjs24 and gjs rebuilds for rawhide, if anyone else wants them. i should stick 'em up in a repo or something.
16:27:17 <ignatenkobrain> adamw: you mean that you will enable debug opts for rawhide temporary. so ?
16:27:20 <adamw> today i'm planning to just bug the gnome devs to look at the last valgrind log i got and see if it helps them figure anything out. if anyone else wants to help work on this, please, do pitch in...
16:27:25 <adamw> ignatenkobrain: no, i did a private side build.
16:28:22 <ignatenkobrain> adamw: ok. how about mini instruction what needed ?
16:28:53 <ignatenkobrain> 1. mozjs24 with --enable-debug
16:28:55 <ignatenkobrain> 2. ?
16:29:15 <adamw> ignatenkobrain: run gnome-shell through valgrind:
16:30:17 <adamw> env G_SLICE=always-malloc valgrind --tool=memcheck --leak-check=full --leak-resolution=high --num-callers=12 --vex-iropt-register-updates=allregs-at-mem-access --log-file=/home/adamw/gnome-shell_valgrind.log --smc-check=all-non-file gnome-shell --replace
16:30:36 <ignatenkobrain> yes. i wanted this
16:30:53 <ignatenkobrain> okay. I will try it after meeting
16:31:03 <ignatenkobrain> adamw: thanks
16:31:06 <adamw> they also wanted me to try running it through valgrind with --vgdb-error=0 and then attaching gdb to the process , but shell would never start up completely for me when I attempted that (see the mozilla report)
16:31:24 <adamw> ignatenkobrain: http://koji.fedoraproject.org/koji/taskinfo?taskID=6531078 is mozjs24 with the necessary rebuilds
16:31:29 <adamw> er, parameters
16:31:54 <ignatenkobrain> adamw: awawaw in release :D
16:32:01 * ignatenkobrain noted
16:32:27 <adamw> ignatenkobrain: then you have to rebuild gjs against *that*, which i did in mock, let me stick those packages up somewhere
16:32:51 <ignatenkobrain> adamw: I will prepare COPR repo for rawhide
16:32:55 <ignatenkobrain> for this
16:34:20 <adamw> https://www.happyassassin.net/temp/gjs-1.39.3-2.1.fc21.x86_64.rpm and https://www.happyassassin.net/temp/gjs-debuginfo-1.39.3-2.1.fc21.x86_64.rpm
16:35:07 <cmurf> prepare for 1/4 to 1/5 the normal performance
16:35:33 <ignatenkobrain> For me repo more better ;) it will be available here: http://copr.fedoraproject.org/coprs/ignatenkobrain/gnome-shell/
16:35:57 <ignatenkobrain> adamw: thank you again ;)
16:36:19 <danofsatx> 1/4 to 1/5 the "normal" performance of gnome? now I know why adamw doesn't think it's a good time... sheesh
16:36:37 <ignatenkobrain> adamw: note our links for meetbot
16:36:46 <roshi> read a book while you do it - it'll feel more productive :p
16:37:11 <cmurf> damn, apparently if you use valgrind with memcheck the program runs 20-30 times slower
16:37:26 <danofsatx> or try to get the networking setup fixed on a production xen server....
16:38:04 <adamw> ignatenkobrain: meetbot notes links automatically.
16:38:16 <ignatenkobrain> adamw: okay. good.
16:38:17 <adamw> cmurf: i call it molasses land :)
16:38:20 <ignatenkobrain> go next ?
16:38:38 <cmurf> molasses arctic circle land
16:39:00 <ignatenkobrain> #topic Fedora.next status and next steps
16:39:14 <handsome_pirate> Ahoy!
16:39:41 <adamw> yeah
16:39:47 * adamw looks around for vikings
16:40:23 <danofsatx> no vikings here, just us chickens
16:40:27 <ignatenkobrain> .fire jwb
16:40:27 <zodbot> adamw fires jwb
16:40:33 <adamw> why am I firing jwb?
16:40:54 <ignatenkobrain> adamw: because you fired zodbot
16:41:16 <adamw> okay?
16:41:25 <jwb> does this mean i can stop workign for the day?
16:41:28 <adamw> so, anyhow, this week is when the WGs should be moving on to specific implementations details
16:42:39 <ignatenkobrain> IIRC jwb leader in one of WG... He should know about this topic I think
16:42:44 <adamw> this is when we should be really on our game to make sure things don't get...excessively ambitious, i think
16:42:54 <adamw> ignatenkobrain: yes, he is. but why do you keep talking about him specifically?
16:43:47 <jreznik> adamw: my feelings now are that folks understand smaller steps are the way how to get to fedora.next but still it would be good for you to watch it more closely
16:43:48 <cmurf> adamw: so are the WGs deciding details this week? Or are they presenting already decided details?
16:43:49 <adamw> i'll be following the server WG, of course. handsome_pirate, are you still on...er, which WG was it again? i know you were on one of them.
16:44:11 <adamw> cmurf: working on detailed plans I believe. up to now they've been working on the PRDs, which were the Big Pictures.
16:44:52 <cmurf> Ok I thought the PRDs were pretty much done and accepted 2-3 weeks ago.
16:45:11 <handsome_pirate> adamw:  Envronment and Stacks
16:45:41 <roshi> they have some early meetings handsome_pirate
16:46:08 <handsome_pirate> adamw:  The biggest things that will hit qa right now are SCLs and a new repo for things that don't quite meet Fedora packaging guidelines but do meet licensing
16:46:25 <handsome_pirate> roshi:  Aye, it means I have to be up at the crack of dawn :)
16:46:52 <adamw> cmurf: yes, they were, but since then there's been devconf
16:47:04 <adamw> and fosdem
16:47:12 <roshi> is there a WG our presence is light in?
16:47:13 <cmurf> got it
16:47:14 <adamw> and fesco elections
16:47:25 <adamw> so basically things have been stalled
16:47:26 <adamw> roshi: cloud
16:47:30 <adamw> (afaik anyway)
16:47:34 <adamw> has anyone been watching the cloud wg?
16:47:41 <roshi> I can start following the cloud WG
16:49:19 <cmurf> Isn't the cloud product a set of VM images?
16:49:37 <adamw> deciding on deliverables is part of what we'll be doing in this phase, aiui.
16:49:59 <adamw> and that's obviously very significant for QA, as is deciding just how much of their planned stuff they'll actually be building and putting into f21.
16:50:18 <cmurf> If there's no installer… wow that's around 5E8 times easier to test
16:50:40 <adamw> cmurf: we're already shipping cloud images with no installer in f20.
16:50:54 <cmurf> i know and if that's the way going forward with the cloud product
16:51:10 <adamw> we'll find out, but it would seem to make sense - that's how cloud deployment works.
16:51:24 <adamw> #info roshi will follow cloud WG for us, thanks roshi!
16:51:40 <adamw> #info adamw is still on server WG and following desktop WG, and handsome_pirate is on env and stacks WG
16:52:14 <adamw> oh, i guess that also leaves the base WG
16:52:18 <adamw> has anyone been following that?
16:52:53 * ignatenkobrain on desktop WG
16:53:01 <roshi> Np
16:53:24 <ignatenkobrain> adamw: will follow desktop WG
16:53:41 <roshi> I
16:53:47 <jreznik> adamw: Base WGs is not going to have real deliverable
16:54:05 <adamw> jreznik: doesn't mean it doesn't have QA considerations
16:54:06 <roshi> Er, I thought Viking was following base
16:54:21 <adamw> roshi: i'm never sure where viking's at.
16:54:29 <jreznik> adamw: not saying that :)
16:54:30 <adamw> jreznik: netinst isn't considered a base deliverable, btw?
16:54:48 <cmurf> I thought base was a kind of glue for the other WGs to make sure at a basic level they're all somewhat anchored together
16:55:08 <jreznik> adamw: there was discussion about it last time but the meeting run out of time and I had to leave
16:55:18 <adamw> cmurf: more or less.
16:55:20 <nirik> adamw: there was talk about base doing a iso thats all the base (so self hosting)
16:56:36 <adamw> okay, we've got 5 minutes left
16:56:47 <adamw> so, quick open floor time - i think we're all up to speed regarding .next for now
16:56:58 <cmurf> Is there a flowchart of Fedora.next that shows the WGs, products, and their deliverables?
16:57:08 <adamw> if the WG representatives / followers can post to test@ and/or meetings about anything particularly significant that'd be great
16:57:21 <adamw> cmurf: not afaik, no. the deliverables have not been decided yet.
16:57:32 <cmurf> OK
16:57:49 <adamw> https://fedoraproject.org/wiki/Fedora.next is the 'main page', but it needs some love, really.
16:58:23 <adamw> #info we now have folks to keep an eye on each WG, they will report anything particularly significant back to the list / QA meetings for discussion
16:58:29 <cmurf> OK so I suspect that QAs concerns will have a mirror with Docs in that too many Fedora.next changes will obsolete a lot of documentation. So...
16:58:35 <adamw> #topic open floor
16:58:40 <jreznik> adamw: nicer page is what I'd like to take a look this week
16:59:26 <jreznik> for open floor, I've just talked to dgilmore - we have a few ideas how to make compose request ticket a bit better, I'll sum it up into the ticket tomorrow
17:00:13 <adamw> jreznik: as in, TC/RC?
17:00:25 <jreznik> adamw: yep
17:00:33 <adamw> hum, first i heard of it :)
17:00:35 <adamw> what's the ticket?
17:00:57 <jreznik> tickets
17:00:59 <jreznik> :)
17:01:09 <jreznik> for f21, so it's not urgent now
17:01:35 <jreznik> just to find the way how to make it less mess/better formating of builds to be included in the compose
17:01:38 <adamw> #info jreznik and dgilmore have some plans to improve compose request tickets
17:02:11 <adamw> i'd much rather we built the system to do the damn builds automatically than twiddle with the ticket layout, but whatever :)
17:02:54 <adamw> jreznik: you wrote "I'll sum it up into the ticket tomorrow"
17:03:03 <adamw> jreznik: that's 'the ticket' I was asking about
17:03:20 <dgilmore> adamw: me too
17:03:53 <jreznik> adamw: ah, sorry - I'll create it, so it's trackable
17:04:28 <adamw> OK, thanks
17:04:33 <jreznik> (and we don't forget it - still long road to the first f21 compose)
17:05:17 <adamw> anything else for open floor?
17:05:17 * jreznik has to run
17:05:43 * roshi has nothing
17:05:48 <handsome_pirate> adamw:  I vote that we use some of the QA budget to supply bacon to everyone
17:06:07 <adamw> wait, wait, wait, wait, wait, wait, wait. wait. wait.
17:06:08 <adamw> QA has a budget?
17:06:19 <roshi> Yeah, wha?
17:06:21 <adamw> thanks jreznik!
17:07:17 <handsome_pirate> adamw:  In all seriousness, though, we may want to look into getting some new h/w for taskotron
17:07:41 <tflink> handsome_pirate: why's that?
17:07:46 <adamw> i believe tflink is on top of our hardware needs
17:08:02 * tflink has been spending more time than he'd like to admit on that, actually
17:08:11 <tflink> tis' a waiting game at the moment
17:08:18 <handsome_pirate> tflink:  Do we have enough?  Also, what if we wind up having h/w specific tasks?
17:08:36 <handsome_pirate> tflink:  s/hw specific/needs to run on its own arch
17:08:53 <tflink> handsome_pirate: assuming that things go the way I think they will, we should be fine for the near future
17:09:05 <handsome_pirate> tflink:  Ah, okay
17:09:41 <tflink> the only thing that I haven't started on is any ARM hw but I think we can get some highbank boxes
17:11:09 <adamw> the arm guys always seem to have hardware to burn
17:11:45 <handsome_pirate> tflink:  In theory, there are four arm qa boxes in phx
17:12:12 <adamw> OK, we're over time, so...anything else super serious?
17:12:51 <handsome_pirate> Can we keep all the snow up adamw's way?
17:13:05 <handsome_pirate> Seriously, snow causes cars to blow up around here.
17:13:28 <adamw> +1
17:13:31 <adamw> i'll take it
17:13:47 <handsome_pirate> adamw:  https://scontent-b.xx.fbcdn.net/hphotos-ash3/t1/q77/s720x720/1920543_10152192564303431_259801825_n.jpg
17:13:57 <handsome_pirate> adamw:  That's what happens when it snows in Raleigh
17:14:07 <adamw> heh.
17:15:17 <adamw> my local ski hill's daily update reads "The snow conditions off-piste are best on the upper Mountain above the Humpty exit to Horizon", by which they mean *below* that altitude the alleged "snow" will swallow your board/skis and then congeal, custard-like, around them.
17:15:27 <adamw> OK, thanks for coming folks!
17:15:36 <adamw> #endmeeting