15:01:13 <pknirsch> #startmeeting Fedora Base Design Working Group (2014-03-14)
15:01:13 <zodbot> Meeting started Fri Mar 14 15:01:13 2014 UTC.  The chair is pknirsch. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:19 <pknirsch> #meetingname  Fedora Base Design Working Group
15:01:19 <zodbot> The meeting name has been set to 'fedora_base_design_working_group'
15:01:22 <pknirsch> there we go :)
15:01:45 <jreznik> where we go?
15:01:47 <pknirsch> Welcome everyone to another great Friday afternoon with spring weather in Germany :)
15:01:59 <pknirsch> to the beach, jreznik ? ;)
15:02:15 <pknirsch> #chair jreznik
15:02:15 <zodbot> Current chairs: jreznik pknirsch
15:02:37 * masta looks in
15:02:39 * notting is here
15:02:42 <jwb> hi
15:03:02 <pknirsch> Harald already notified me this morning he won't be able to join today, but the agenda isn't really packed with important decisions today anyway
15:03:52 <pknirsch> heya masta, notting and jwb !
15:04:01 <pknirsch> #chair masta notting jwb
15:04:01 <zodbot> Current chairs: jreznik jwb masta notting pknirsch
15:04:07 <pknirsch> so lets get rolling
15:04:23 <pknirsch> #topic Proposal to move meeting to summer time (14:00 UTC)
15:05:06 <pknirsch> That should (hopefully) be a quick and easy one. Due to the daylight savings time change i'd like to propose to move the meeting 1h earlier regarding UTC so it effectively will stay at the same time over the summer
15:05:20 <jwb> fine with me
15:05:25 * pknirsch hopes he did that correctly in his head
15:05:26 <notting> won't it still be two times for .eu people for a few weeks?
15:05:27 <masta> I kinda like the meeting where it is now
15:05:41 <jreznik> yep, let's wait until EU changes too
15:05:53 <pknirsch> good point notting and jreznik
15:05:56 <notting> i'm ok with either time at the moment
15:05:58 <jreznik> it moved one hour earlier for EU folks
15:06:20 <dgilmore> hola amigos
15:06:26 <pknirsch> heya dgilmore :)
15:06:26 <jreznik> I think it's March 30th
15:06:28 <masta> howdy dgilmore
15:06:32 <pknirsch> #chair dgilmore
15:06:32 <zodbot> Current chairs: dgilmore jreznik jwb masta notting pknirsch
15:06:35 <pknirsch> hm
15:06:36 <jreznik> hi dgilmore!
15:07:01 <jreznik> pknirsch: on the last Sunday of March
15:07:21 <pknirsch> hm, so would 1h earlier work for everyone then, too? then we could just also just keep it at 14:00 UTC
15:07:32 <pknirsch> 1h earlier for EU folks that is
15:07:33 <jreznik> http://en.wikipedia.org/wiki/Central_European_Summer_Time#Central_European_Summer_Time
15:07:37 <pknirsch> and for all the US folks ofc, too
15:08:32 <masta> so we are good with the current meeting time?
15:08:37 <pknirsch> i'd be fine with both as well, managed to not get my Friday afternoons packed with meetings so far :)
15:09:11 <pknirsch> That would be the alternative, masta: To keep it at 15:00 UTC which would effectively be erh, 1h later then?
15:09:17 * pknirsch scratches his head
15:09:49 <pknirsch> as it used to be compared to winter time
15:10:29 <pknirsch> effectively it would be 17:00 - 18:00 for EU folks, which might be "suboptimal" for a Friday.
15:10:39 * pknirsch doesn't care though
15:10:51 <masta> I'm in favor of the new setting, which is effectively one hour later than usual. but would be happy either way =)
15:11:05 <pknirsch> jreznik: how about you then?
15:11:58 <jreznik> I can do whatever you want unless it's late night on Friday :)
15:12:17 <pknirsch> hehe
15:13:29 <pknirsch> ok, lets see then if people here are more in favor of keeping the current time (15:00 UTC)
15:13:35 <jreznik> but even that would work for me
15:13:50 * pknirsch tries to remember how votings worked with the meetbot
15:14:20 * dgilmore is okay with either time
15:14:24 <jreznik> I'd say let's skip this topic until EU and US sync again
15:14:35 <jwb> for the love of whatever you love, just give me a time
15:15:16 <jreznik> :)
15:15:29 * jreznik really hates DST changes
15:16:14 <pknirsch> alright, then lets just keep it at 15:00 UTC for now, seems we got wild agreement that thats fine and we won't have to change anything then. I'll check with Harald if that works for him as well offline
15:16:58 <jreznik> +1
15:17:01 <masta> +1
15:17:08 <notting> +1
15:18:51 <pknirsch> #agreed Keep 15:00 UTC meeting time. pknirsch to check with harald if that works for him as well offline (+4, 0, 2)
15:18:55 <dgilmore> +1
15:19:17 <pknirsch> alright, lets move on then.
15:19:33 <pknirsch> #topic 2nd round of reviews of Tech Specs
15:20:00 <pknirsch> I just wanted to give that another go this week as the Server tech spec had quite a few edits and the Workstation one got refined.
15:20:04 <pknirsch> For reference again:
15:20:22 <pknirsch> #info Server tech spec https://fedoraproject.org/wiki/Server/Technical_Specification
15:20:40 <pknirsch> #info Workstation tech spec https://fedoraproject.org/wiki/Workstation/Technical_Specification
15:20:55 <pknirsch> I've taken some time to look at the Workstation one.
15:21:16 <pknirsch> There were mainly refinements in the packagelist and some clarifications regarding HW
15:21:24 <dgilmore> I need to follow up with workstation guys again
15:21:32 <dgilmore> about their deliverables.
15:21:47 <pknirsch> #action dgilmore to follow up with Workstation about deliverables
15:21:54 <pknirsch> ok, cool, thanks dgilmore !
15:22:03 <dgilmore> I accidently sidetracked them with supporting arm and my question on the deliverables seems to have been ignored except for one question
15:22:26 <pknirsch> hm, ok
15:23:19 <pknirsch> jwb: anything else that comes to your mind regarding Workstation? I haven't seen anything that would require actions from the Base team so far.
15:23:33 <jreznik> WS guys are now talking about fonts
15:24:17 <masta> Regarding workstation: hopefully ARM will be able to support kde (or whatever other DE) if gnome-shell support (read 3d support) continues to not work.
15:24:42 <pknirsch> Is KDE now part of the Workstation? I thought that was canceled?
15:24:59 <pknirsch> at least it's not listed in the packagelist
15:25:14 <jreznik> pknirsch: it wasn't cancelled (yet) and there's discussion about kde-rutime happening on the list
15:25:27 <pknirsch> jreznik: ok, thanks, thats good to know
15:25:34 <masta> KDE is sorta the primary DE for arm, at least the one QA tests
15:25:35 <jreznik> but also KDE SIG wants to propose Plasma Product
15:25:45 <pknirsch> right
15:26:00 <jreznik> I tried to use ARM as selling point but Kevin is not a big fan of ARM :(
15:26:12 <pknirsch> hrmpf
15:26:34 <jreznik> and KDE moves the same way as GNOME - OpenGL needed (expect it in one year, so...)
15:26:53 <dgilmore> jreznik: kevin is Kevin, he is definetly rude and unhelpful when it comes to ARM
15:26:54 <jreznik> but we're now a bit OT
15:26:54 <masta> indeed
15:26:55 <pknirsch> so we need a CDE product? :)
15:26:58 * pknirsch runs
15:27:07 <pknirsch> yea
15:27:17 * masta grabs pitch fork and torch
15:27:24 <pknirsch> so fonts. thats nothing that should affect us imho.
15:27:39 <dgilmore> pknirsch: well some fonts will fall into base
15:27:46 <jwb> pknirsch, sorry, distracted.  no, nothing at the moment
15:27:47 <dgilmore> but what they use is really up to them
15:27:48 <jreznik> dgilmore: you know I'm ARM fan but I have to agree with him in some degree
15:28:01 <pknirsch> dgilmore: right
15:28:07 <pknirsch> jwb:  thanks :)
15:28:10 <masta> I like that server and workstation decided to go libvirt
15:28:24 <notting> yeah, not seeing anything in the changes since end-of-feb in the tech specs that looks concerning
15:28:34 <masta> that seems to be now also a Base, libvirt
15:28:35 * pknirsch nods
15:28:41 <pknirsch> @notting
15:29:04 <jreznik> so, do we want to start workin on Base Tech Specs? it's the right time to do so
15:29:13 <pknirsch> jreznik: good idea!
15:29:28 * jreznik is not sure how far Cloud is but it's probably special case, as it's very minimal product
15:29:30 <dgilmore> jreznik: likely ys
15:29:36 <dgilmore> yes
15:30:03 <masta> yes, time to get started
15:30:08 <pknirsch> jreznik: from what i've seen they mainly keep working with their pretty detailed Product definition, which already resembles somewhat a tech spec :)
15:30:25 <pknirsch> ok, volunteers to put a wiki together? not sure i'll have time to do so.
15:30:38 <jreznik> and I expect Server/WS/other Tech Specs would just %include Base, right? unless in Tech Spec it's noted that it does not apply as exception?
15:30:50 <pknirsch> right, thats the point of Base, jreznik
15:30:51 <masta> the easy thing to do is diff the workstation and server, and all the same things become our foundation.
15:31:29 <jreznik> masta: I'd not call it "easy" but diff is definitely good starting point
15:31:55 <masta> I'll step forward and make the starting point wiki
15:32:01 <pknirsch> thanks masta !
15:32:03 <jreznik> thanks masta
15:32:18 <pknirsch> #actiom masta to start the Base Design  tech spec wiki
15:32:56 <pknirsch> erh
15:33:03 <pknirsch> #action masta to start the Base Design  tech spec wiki
15:33:41 * pknirsch is a keyboard dyslexic today
15:33:57 <jreznik> and for sure for the rest - feel free to edit it!
15:34:26 <masta> cool, I'll try to spend some hours on the initial tech spec this weekend, hopefully have draft quality by Monday, and next Friday we can formally review and tune things.
15:34:35 <pknirsch> good idea
15:34:52 <pknirsch> #info Agenda item for next week: Review masta's draft of the tech spec
15:36:00 <jreznik> wfm
15:36:44 <pknirsch> Anything else about the tech specs for today? I just checked the Cloud PRD and thats ofc frozen since Mid February, but masta, please make sure to include information or requirements from that one as well
15:36:54 <jreznik> one more thing
15:36:57 <pknirsch> https://fedoraproject.org/wiki/Cloud_PRD
15:37:40 <jreznik> once we have Base Tech Specs, I'd like to ask owners of items in Tech Specs (as we don't have PRD) to propose any changes as Change Proposal, deadline is Apr 8th
15:38:13 <masta> pknirsch: acknowledge - check clout spec too
15:38:49 <pknirsch> jreznik: good point. I've also seen a preliminary (not earlier than) release schedule is out for F21!
15:39:06 <pknirsch> (in case people missed it: https://fedoraproject.org/wiki/Releases/21/Schedule)
15:39:32 <dgilmore> woohoo
15:40:19 <pknirsch> and let me info jreznik's request
15:40:49 <pknirsch> #info jreznik: Once we have Base Tech Specs, I'd like to ask owners of items in Tech Specs (as we don't have PRD) to propose any changes as Change Proposal, deadline is Apr 8th
15:41:36 <pknirsch> Anything else for tech specs? If not i'll open the floor then for any other topics
15:42:08 <masta> [nothing]
15:42:28 <pknirsch> ok, then:
15:42:32 <pknirsch> #topic Open Floor
15:42:46 <pknirsch> any other topics we need to cover today then?
15:44:18 <pknirsch> ok, i take that as a no as well :)
15:44:43 * jsmith has nothing
15:44:50 <pknirsch> hehe jsmith :)
15:44:52 <dgilmore> i wonder if we need to require products to have an install tree/DVD
15:44:55 * pknirsch waves at jsmith
15:45:03 <jsmith> dgilmore: Great question
15:45:10 <pknirsch> good point, yes
15:45:19 <dgilmore> since its needed for upgrades, installer is part of base
15:45:21 <pknirsch> does Base have requirements for products
15:45:51 <dgilmore> i honestly think live only install of workstation is short sighted
15:46:12 <dgilmore> it means you can do automated network kickstart installs
15:46:24 <dgilmore> can't
15:46:42 <dgilmore> I think we need to require at the least that they have an install tree
15:46:53 <dgilmore> install DVD may be optional
15:47:27 <pknirsch> Is their plan to allow DVD burning of the live media insufficient then, dgilmore ?
15:47:45 <dgilmore> pknirsch: no
15:47:57 <dgilmore> pknirsch: fedup cant work with their plan
15:47:59 <masta> pxe installs is a functionality i'd like to preserve too
15:48:00 <notting> anaconda has installation from an image, iirc - so you culd kickstart the live
15:48:03 <notting> (can't upgrade, obvs)
15:48:15 <jwb> dgilmore, on that, i think nobody actually understood what you were asking.
15:48:21 <jwb> dgilmore, on the workstation thread
15:48:31 <dgilmore> pknirsch: and doing an automated network install is not an option in their plan,
15:48:49 <dgilmore> jwb: i guess ill follow up more
15:49:16 <dgilmore> notting: you cant pxe install
15:49:22 <jwb> dgilmore, that would be helpful.  even i'm a bit confused.  i would have thought pointing at the existing Fedora tree would be sufficient
15:49:28 <dgilmore> you need to have local media of some sort
15:49:57 <dgilmore> jwb: there will be no Fedora tree
15:50:12 <jwb> dgilmore, that's not been made clear to anyone i think?
15:50:31 <jwb> or at least i was unaware of that
15:50:33 <dgilmore> jwb: longer term there is plans to use anaconda to make live media, which means its needed for that
15:50:34 <pknirsch> the question though is if pxe installation is a must for the Workstation product. It definitely is for Server and Cloud obviously, but for a Workstation thats certainly debatable
15:50:49 <jwb> pknirsch, according to the WG, no
15:50:57 <pknirsch> right
15:50:59 <jwb> or according to current plans anyway
15:51:02 * pknirsch nods
15:51:17 <dgilmore> pknirsch: think developers inside Red Hat at the office, today they can boot, tell the bios to pxeboot and install fedora
15:51:36 <dgilmore> that functionality should be preserved and be a requirement from base
15:51:38 <jwb> they can still do that with server and cloud
15:51:53 <jwb> and we had previously discussed Base having a boot.iso
15:52:32 <notting> hm, wonder if you can tie a boot.iso to an image install.
15:52:36 <dgilmore> jwb: for testing that anaconda works, we discussed it in the context that it would not be a deliverable
15:52:46 <jreznik> jwb: yes but dgilmore said "developers" - so this would mean, you as developer can't PXE boot do Workstation tailored for developer use case, but you would have to start with Server Product, then install everything to match dev. WS
15:53:02 <dgilmore> jreznik: right
15:53:05 <jreznik> and indeed, everyone in the office uses PXE
15:53:05 <pknirsch> aye
15:53:21 * pknirsch can't remember using a DVD for several years
15:53:22 <dgilmore> I think its very short sighted of the workstation product
15:53:29 <jwb> dgilmore, push back! :)
15:53:39 <jwb> the one time i tried using PXE at the office, it didn't work
15:53:44 <jwb> for any release that was avaialble
15:53:59 <dgilmore> jwb: the way im proposing push back is for base to require an install tree fromt he product
15:54:07 <jwb> i'm happy it does now and if Base wants to make it a requirement, then ok
15:54:18 <dgilmore> jwb: i know the guys in Brisbane do it a lot
15:54:27 <dgilmore> ive no experience elsewhere
15:54:34 <jwb> but it might be beneficial to explain it in a bit more detail on the WS thread because i'm not sure everyone even understands
15:54:35 <pknirsch> we only do pxe installations here in STR
15:55:14 <dgilmore> jwb: i will folow up
15:55:20 <dgilmore> and try to make it clearer
15:55:24 <jwb> thanks
15:55:27 <pknirsch> thanks dgilmore :)
15:56:09 <jreznik> jwb: it works pretty well in Brno too, we even have two different networks, the lab one is populated even with TCs/RCs as far as I remember...
15:56:19 <pknirsch> same here, ye
15:56:27 <masta> I personally feel the workstation team will only have profit from preserving PXE functionality, is there any persuasive reason to not include that capability?
15:56:48 <jwb> test matrix explosion would be the only thing i can think of
15:57:25 <jreznik> but I think we have an agreement it's a good idea - do we want to set it us Base requirement or first talk to WS WG?
15:58:10 <pknirsch> lets clear it up first and see if there are any arguments against doing so
15:58:20 <masta> we should discuss with WS first
15:58:26 <jreznik> I think so
15:58:59 <pknirsch> ok, so action for dgilmore to discuss with WS WG about pxe and install trees
15:59:18 <jwb> please :)
15:59:30 <dgilmore> yep
15:59:31 <pknirsch> #action dgilmore to discuss with WS WG about pxe and install trees
16:00:19 <mjg59> The only thing I've seen WS actively express is that they don't want to distribute an actual DVD image
16:00:30 <pknirsch> And on topic: If anyone has other items they think might be a potential requirement for other products lets discuss those next Friday
16:00:49 <dgilmore> mjg59: that could be optional with some tooling work
16:01:01 <dgilmore> pknirsch: :) okay
16:01:09 <mjg59> And if that involves building an image and then immediately calling rm because that's easier, eh
16:01:33 <dgilmore> mjg59: no
16:02:25 <dgilmore> mjg59: we can teach pungi to have a --no-dvd flag or a config option. and just skip the mkisofs call that makes the DVD
16:02:53 <masta> It seems that a "live image" and a "dvd" are ambiguous. They are effectively the same, right?
16:02:58 <mjg59> Right, all I was saying is that it's an implementation detail
16:02:59 <jwb> no
16:03:00 <mjg59> masta: No
16:03:01 <jreznik> it was proposed in that thread, just discard DVD
16:03:07 <dgilmore> masta: completely different
16:03:17 * masta stands corrected
16:03:24 <mjg59> masta: The DVD contains an install tree and boots to Anaconda, not a desktop
16:04:03 <masta> mjg59: oh I meant "live dvd", I thought we just sort of DD those to usb media...
16:04:33 <mjg59> masta: Yeah. That's different to what we refer to as the live image.
16:04:36 <jreznik> Server guys call it "local installation media" but I'd say it's also vague (as live could be local installation media with anaconda included)
16:04:46 <mjg59> masta: You'll still be able to write the live image to a DVD and install from that
16:04:48 <dgilmore> the difference is live vs install media
16:06:11 <dgilmore> diffeence being live is an installed system that runs from media, and can be used to install. install media is just an installer
16:07:02 <masta> gotcha
16:09:20 <pknirsch> alright, sounds we have a plan at least :)
16:09:38 <pknirsch> and i think with some clarifications we should be able to resolve this one way or another
16:09:42 <dgilmore> pknirsch: i think so
16:09:43 <masta> ok - so the WS wg not having install dvd seems doable, hopefully they accept the install tree stuff.
16:10:10 <dgilmore> I have nothing else to bring up
16:10:58 <pknirsch> ok, lets close up for today then
16:11:14 <masta> thanks pknirsch
16:11:16 <pknirsch> thanks everyone for todays lively discussions and lets meet at 15:00 UTC next Friday again
16:11:17 <masta> bye bye all
16:11:25 <pknirsch> have a fantastic weekend everyone!
16:11:29 <pknirsch> o/
16:11:35 <jreznik> bye guys, see you next week
16:12:12 <pknirsch> #endmeeting