15:04:40 <rdieter> #startmeeting kde-sig
15:04:40 <zodbot> Meeting started Tue Apr 15 15:04:40 2014 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:45 <rdieter> #meetingname kde-sig
15:04:45 <zodbot> The meeting name has been set to 'kde-sig'
15:04:49 <rdieter> #topic roll call
15:04:53 <rdieter> ok, lets try this again
15:04:54 <rdieter> :)
15:04:55 <jgrulich> hi again
15:04:58 <Kevin_Kofler> Present.
15:04:59 <dvratil> hi
15:05:44 * rdieter waves at all the strangers he totally did not see just a minute ago in some other channel resembling this one
15:06:07 <rdieter> (dripping with sarcasm)
15:06:19 <rdieter> #info rdieter jgrulich Kevin_Kofler dvratil present
15:06:23 * pino|work turns rdieter upside down
15:06:24 <rdieter> #chair jgrulich Kevin_Kofler dvratil
15:06:24 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich rdieter
15:06:28 <pino|work> me
15:06:36 <rdieter> #info pino|work present
15:06:38 <tosky> hre
15:06:42 <tosky> here*
15:06:54 <rdieter> #info tosky present
15:07:01 <rdieter> #chair pino|work tosky
15:07:01 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich pino|work rdieter tosky
15:07:27 <rdieter> good enough for me, let's discuss agenda
15:07:29 <rdieter> #topic agenda
15:07:31 <mbriza> hi
15:07:38 <rdieter> #info mbriza present
15:07:41 <rdieter> #chair mbriza
15:07:41 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich mbriza pino|work rdieter tosky
15:07:48 <rdieter> what to discuss today?
15:08:01 <dvratil> KF5 reviews
15:08:11 * rdieter can do kde-4.13.0 status update
15:08:40 * jreznik is around, hope in a right channel :)
15:08:57 <Kevin_Kofler> jreznik: Yes. :-)
15:10:05 <rdieter> ok, let's get started...
15:10:11 <rdieter> #topic kf5 reviews
15:10:19 <rdieter> dvratil: the floor is yours
15:10:28 <dvratil> so, I started submitting our KF5 packages for review
15:10:38 <dvratil> .bug 1086148
15:10:42 <zodbot> dvratil: Bug 1086148 KDE Frameworks 5 - https://bugzilla.redhat.com/1086148
15:10:55 <dvratil> all reviews block the "Feature" bug
15:11:01 <dvratil> so if you are bored, feel free to pick one
15:11:14 <rdieter> yay, will do.
15:11:20 <dvratil> I submitted the base packages and kf5-attica as a first framework, based on review of that framework I'll adjust all others
15:11:26 <jgrulich> I'll take a look tomorrow :)
15:11:31 <dvratil> one question:
15:11:53 <dvratil> currently we have kf5-filesystem, which owns some of the paths, but also installs macro.kf5 for rpmbuild
15:12:20 <Kevin_Kofler> kde-filesystem also worked that way.
15:12:31 <dvratil> given that we will need to adjust some env variables via /etc/profile.d, does it make sense to create kf5-settings, or can it go to kf5-filesystem, too?
15:12:59 <Kevin_Kofler> I guess having the RPM macros separate would be cleaner, but for the few bytes they take…
15:13:22 <jgrulich> dvratil: wrong link → http://dvratil.fedorapeople.org/kf5/review/dbusmenu-qt5.spec
15:13:31 <jgrulich> dvratil: or you forgot to upload it
15:13:37 <dvratil> jgrulich, ok, will fix after the mtg
15:14:01 <dvratil> right now kf5-filesystem is in BR of all frameworks
15:14:16 <dvratil> so kf5-filesystem would have to be moved to Requires
15:14:41 <rdieter> dvratil: good question.  I'd say if I had to do it all over again, I'd say producing both -settings -filesystem from the same base pkg makes sense
15:15:35 <rdieter> otoh, doing it separate isnt *wrong* either.  whichever approach is most convenient I guess
15:15:40 <dvratil> hmm, that's a clever idea :-)
15:16:38 <than_> present
15:16:45 <dvratil> thanks rdieter :)
15:16:49 <rdieter> #info than present
15:16:51 <rdieter> #chair than
15:16:51 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich mbriza pino|work rdieter than tosky
15:17:11 <dvratil> except for that, that's all from me...add yourself to CC of the "Feature" bug, so that you get notifications about new reviews
15:17:22 <Kevin_Kofler> For complete cleanliness, there should be kf5-filesystem with only the paths and kf5-rpmmacros.
15:17:23 <dvratil> if you want to get the notifications of course :-)
15:17:33 <Kevin_Kofler> And the packages would BR kf5-rpmmacros and Require kf5-filesystem.
15:17:45 <dvratil> and kf5-settings
15:18:08 <Kevin_Kofler> dvratil: For the reviews, please also put them on the kde-reviews tracker, I'm mass-changing the existing ones for that.
15:18:10 * rdieter doesn't see the need for a separate -rpmmacros, but meh (bikeshed)
15:18:22 <dvratil> Kevin_Kofler, ok,  thanks
15:18:39 <Kevin_Kofler> rdieter: Conceptually, -rpmmacros is a build-time dep, -filesystem a runtime one.
15:18:46 <Kevin_Kofler> Spacewise, it's negligible of course.
15:19:15 <rdieter> I prefer to introduce subpkgs because it solves some need or problem.  I don't see either in this case
15:19:27 <jgrulich> dvratil: could you please add us when submitting SCM request? so we don't have to add yourself to all of KF5 packages later?
15:19:39 <dvratil> jgrulich, ok, I'll try not to forget that
15:20:50 <dvratil> does it make sense to have the basepkg (kf5) Require kf5-filesystem and kf5-settings, so that all frameworks can have just Requires: kf5 ?
15:20:56 <dvratil> then kf5-rpmmacros in BR
15:21:36 <rdieter> dvratil: +1, worksforme
15:22:01 <dvratil> ok, thanks for your input, I'll update the stuff accordingly after the mtg
15:22:32 <rdieter> dvratil: actually... I'd prefer only packages that *really* need -settings depend on it
15:22:50 <rdieter> (if possible)
15:22:55 <dvratil> that should be possible
15:23:11 <rdieter> for example, in kde4, only kdelibs Requires: kde-settings
15:23:23 <rdieter> not sure if that is analogous to kf5
15:23:32 <dvratil> hmm
15:23:41 <dvratil> I think the -settings only involves setting QML2_IMPORT_PATH
15:24:00 <Kevin_Kofler> In KDE 4, everything requires kdelibs, so basically everything requires kde-settings. ;-)
15:24:03 <dvratil> so it should be required only by frameworks that install any QML stuff
15:24:15 <Kevin_Kofler> dvratil: We'll definitely have more settings at some point.
15:24:19 <Kevin_Kofler> Something like the KDE 4 kde-settings.
15:24:21 <rdieter> (so far).   ok, consider me retracting my minor objection
15:24:36 <rdieter> I don't see any harm in it
15:24:41 <Kevin_Kofler> Given how KF5 uses different settings directories, we need a separate one, or to add the stuff to kde-settings.
15:25:03 <Kevin_Kofler> (I liked how KDE 4 shared the settings with KDE 3, IMHO it's a mistake from upstream to change that now.)
15:25:10 <dvratil> I'm trying to follow the KDE4 style, so that /usr/share/kf5, /usr/include/kf5/ ....
15:25:18 <rdieter> (just be mindful of the potential of adding needless extraneous deps all over)
15:25:19 <dvratil> so yes, maybe XDG_DATA_DIRS might need adjusting too
15:25:45 <Kevin_Kofler> dvratil: It's not just a matter of environment variables, but also of defaults.
15:25:53 <Kevin_Kofler> The upstream defaults are not always what we want.
15:26:03 <Kevin_Kofler> Look at our kde-settings package to see what we override for KDE 4.
15:26:06 <Kevin_Kofler> (and 3)
15:26:18 <dvratil> that mostly apps settings
15:26:36 <dvratil> that would be kde5-settings :-)
15:27:15 <tosky> dvratil: namespaced directories for libraries/frameworks?
15:27:25 <dvratil> but that's a not-that-distant-but-still-pretty-far-away future
15:27:31 <dvratil> tosky, as in...?
15:27:49 <dvratil> /usr/lib64/$FRAMEWORK/libKF5$FRAMEWORK.so ?
15:27:51 <tosky> dvratil: /usr/share/kf5, namespaced
15:27:55 <dvratil> oh
15:28:04 <dvratil> yes, that follows the KDE4 concept
15:28:13 <dvratil> everything KDE is in /usr/share/kde4
15:28:23 <dvratil> KDE5 will be in /usr/share/kde5
15:28:27 <tosky> uhm
15:28:31 <Kevin_Kofler> tosky: Prevents conflicts with KDE 4 and ancient KDE 3 stuff.
15:28:36 <dvratil> so it makes sense (IMO) to have FW in /usr/share/kf5
15:28:41 <rdieter> dvratil: /usr/share/kde4 was used only because it conflicted with kde3 stuff.
15:28:47 <tosky> Kevin_Kofler: packagers from other distributions worked to prevent this
15:29:00 <dvratil> that's not the case with KF5, so should we drop the prefix for KF5?
15:29:12 <rdieter> dvratil: do you think /usr/share/kf5 or /usr/share/kde5 is needed to avoid conflicts still?
15:29:30 <dvratil> there are no conflicts with KDE4 as far as I know
15:29:36 <Kevin_Kofler> We have kdelibs3 stuff in /usr/share (e.g. /usr/share/apps).
15:29:40 <tosky> rdieter: I think that for *libraries* (kf5), conflicts are bugs
15:29:45 <rdieter> <nod>, only use prefix if it's necessary (or if you think it useful thinking forward to the future)
15:29:46 <Kevin_Kofler> KDE 4 is in /usr/share/kde4/apps.
15:29:57 <dvratil> hmm, wait a sec
15:29:59 <tosky> applications are different
15:30:01 <Kevin_Kofler> One source of conflicts is KatePart syntax highlighting files.
15:30:11 <Kevin_Kofler> IIRC one of the reasons we did /usr/share/kde4/apps to begin with.
15:30:13 <Kevin_Kofler> That's a library.
15:30:26 <dvratil> there might be some confusion in /usr/libexec
15:30:30 <Kevin_Kofler> I don't think it's a good idea to use non-namespaced installdirs.
15:30:30 <rdieter> I recall something in kde3/kde4 libkhtml conflicting too
15:30:40 <Kevin_Kofler> libexecdir also definitely needs to be namespaced.
15:30:47 <dvratil> kf5-kinit install /usr/libexec/start_kdeinit, while kdelibs installs /usr/libexec/kde4/start_kdeinit
15:30:58 <dvratil> (there might be others, this is one I remember from top of my head)
15:31:10 <Kevin_Kofler> And if other distros checked coinstallation with KDE 4 in /usr/share/apps, that doesn't help us because our /usr/share/apps is KDE 3, not 4.
15:31:20 <Kevin_Kofler> Please keep the namespacing.
15:31:26 <tosky> Kevin_Kofler: maybe we can fix it in kf5
15:31:31 <dvratil> or we can just blow KDE3 away :P
15:31:33 <Kevin_Kofler> And the libexecdir stuff should go to /usr/libexec/kf5, not /usr/libexec.
15:31:35 <Kevin_Kofler> dvratil: -1
15:32:08 <dvratil> well, if we keep namespacing somewhere, we can as well keep it everywhere...
15:32:11 <dvratil> so...keep namespacing or remove it?
15:32:22 <Kevin_Kofler> keep +1
15:32:29 <Kevin_Kofler> (and make it complete, i.e. also for libexecdir)
15:32:30 <tosky> remove
15:32:31 <rdieter> namespacing would be the safest course (conflict-wise)
15:32:38 <Kevin_Kofler> In some places like includedir, it's definitely needed!
15:32:41 <tosky> remove for libraries, I mean
15:32:45 <dvratil> Kevin_Kofler, it's not
15:32:51 <rdieter> but it can also introduce other problems
15:33:10 <Kevin_Kofler> dvratil: Why not?
15:33:21 <jgrulich> I thought it shouldn't be a problem for libraries, they should be co-installable with kdelibs4
15:33:33 <dvratil> Kevin_Kofler, because the include folders are called /usr/include/$FrameWork
15:33:47 <dvratil> so they don't clash with kde4 or kde3
15:34:00 <Kevin_Kofler> jgrulich: /usr/lib/lib*.so* should not conflict, I'm not proposing to namespace that.
15:34:29 <rdieter> I think we have a semi-consensus, to namespace only stuff where it makes good sense.
15:34:40 <Kevin_Kofler> But /usr/include, /usr/libexec and the same places under /usr/share that were namespaced in KDE 4 should stay namespaced.
15:34:41 <rdieter> not sure what that includes exactly yet
15:35:10 <tosky> I don't agree with that (namespaced things in /usr/share if there is no conflict)
15:35:19 <jgrulich> /usr/include uses kf5 namespace
15:35:26 <rdieter> so lets start with easy stuff, is there anything that we know for sure conflicts without namespace?
15:36:08 <dvratil> nothing AFAIK
15:36:12 <Kevin_Kofler> Unlike namespacing /usr/lib (a bad idea because it requires messing with linker paths, the kdelibs 3&4 coexistence hack is ugly and should not be needed for KF5), namespacing the other stuff shouldn't hurt anything.
15:36:15 <dvratil> (thanks to KDE4 being namespaced)
15:36:42 <rdieter> dvratil: oh?  yay
15:37:00 <rdieter> then I'd be tempted to say lets try no namespacing, and see how it goes
15:37:17 <dvratil> there are *potential* conflicts, but all are solved thanks to KDE4 being namespaced (like the libexec thing with kf5-kinit)
15:37:28 <jgrulich> only kactivities is conflicting as I remember, there was conflict in solid, but this is already solved in upstream
15:37:34 <Kevin_Kofler> dvratil: Have you checked with kdelibs3 and kdebase3 though?
15:37:37 <Kevin_Kofler> Those are NOT namespaced.
15:38:03 <Kevin_Kofler> Again, all new stuff should be namespaced.
15:38:10 <tosky> again, I don't agree
15:38:17 <pino|work> time to drop kde3, really
15:38:21 <Kevin_Kofler> -1
15:38:27 <Kevin_Kofler> There are still unported apps.
15:38:34 <rdieter> sorry afk ~5 min
15:38:35 <dvratil> checking kdebase3:
15:38:45 <pino|work> which means nobody worked on them for years
15:38:48 <dvratil> no conflict in /usr/bin (all frameworks that install execs have 5 suffix)
15:38:55 <pino|work> which means they are effectively dead
15:39:00 <dvratil> no conflict in /usr/lib (kde3 namespace)
15:39:02 <Kevin_Kofler> I de-facto maintain kde*3, I can take primary maintainership if than wants me to, and I'm not going to give it up.
15:39:17 <Kevin_Kofler> dvratil: So far, that was expected.
15:39:24 <Kevin_Kofler> The problem is the /usr/share/apps stuff.
15:39:30 <dvratil> I have to check on /usr/share
15:39:30 <pino|work> being stubborn won't turn a dead body into a living dancer
15:39:51 <Kevin_Kofler> Also putting stuff directly into /usr/include is ugly and not necessary.
15:39:54 <tosky> as I said, apps are different, I was talking (for now) for kf5 (libraries), so no apps/
15:40:16 <tosky> so, I asked maintainers of the other distro doing the no-conflict work
15:40:29 <tosky> directly in /usr/share, but /usr/include/KF5
15:40:29 <Kevin_Kofler> Using a subdirectory in /usr/include for large frameworks is a standard practice, and KF5 is really a framework of frameworks. :-)
15:40:37 <tosky> following upstream
15:41:19 <Kevin_Kofler> tosky: KatePart no longer installs to apps/?
15:41:27 <Kevin_Kofler> There's also services/…
15:41:43 <Kevin_Kofler> Both those were under /usr/share/kde4/ for KDE 4, and IMHO should stay namespaced.
15:41:58 <jgrulich> services are installed to /usr/share/kde5/, at least what I tried with plasma-framework
15:42:10 <Kevin_Kofler> And that makes sense.
15:42:13 <dvratil> jgrulich, because I told it to do so
15:42:23 <Kevin_Kofler> apps/ should also be namespaced.
15:42:31 <jgrulich> dvratil: I compiled it myself
15:42:34 <tosky> dvratil: shouldn't it be kf5 instead of kde5?
15:42:48 <dvratil> tosky, that was a hack for kde5-workspace to find it's stuff :-)
15:42:56 * tosky facepalms
15:42:57 <dvratil> I agree kf5 would make more sense
15:43:16 <Kevin_Kofler> And includedir too, IMHO. There's already enough of a mess under /usr/include/.
15:44:10 <dvratil> includedir is namespaces by upstream by default, so I agree there
15:44:14 <dvratil> *namespaced
15:45:04 <tosky> include dir is namespaced upstream too
15:45:32 <tosky> I guess it's easier to check by installing with upstream default on a VM
15:45:36 <Kevin_Kofler> That leaves /usr/libexec and /usr/share/{apps,services} and I really don't see a good reason to not namespace them like in KDE 4.
15:45:57 <dvratil> I don't think any framework installs into apps
15:46:03 <Kevin_Kofler> i.e. /usr/libexec/kf5 and /usr/share/kf5/{apps,services}
15:46:06 <dvratil> because they are libraries, so they have nothing to do in apps
15:46:21 <Kevin_Kofler> If apps is not relevant, then the discussion is moot for apps.
15:48:21 <dvratil> and there seems to be no conflict with kdebase3 or kdelibs3 in /usr/share
15:49:12 <dvratil> each framework has it's own namespace (so /usr/share/kconfigwidgets, /usr/share/knewstuff, etc.)
15:50:07 <Kevin_Kofler> Ouch, directly under /usr/share, not even the /usr/share/apps that was at least SOME namespacing by default…
15:50:11 * Kevin_Kofler sees the conflicts come when there will be a KF6!
15:50:20 <dvratil> well, they are libraries
15:50:25 <Kevin_Kofler> Some stuff might even conflict with non-KDE apps.
15:50:49 <tosky> other K-applications?
15:50:51 <tosky> nah
15:50:57 <tosky> K-directories, I mean
15:51:10 <dvratil> no, because KDE4 application are namespaced and KDE5 will most probably be namespaced too
15:51:54 <tosky> dvratil: you mean kf5-based apps?
15:52:02 <dvratil> yes, KDE5 is shorter
15:52:15 <tosky> kf5apps :)
15:52:24 <tosky> ok, ok
15:52:51 <dvratil> so...
15:53:01 <dvratil> looking at it, we want namespacing in /usr/include and /usr/libexec
15:53:22 <dvratil> that we agree on
15:54:21 <dvratil> about /usr/share, I don't know....there is no conflict in /usr/share, but on the other hand we are namespacing all stuff in include and libexec, why not namespace share too?
15:54:45 <tosky> "closer to upstream" is my point
15:55:33 <dvratil> I understand it...but then if plasma-framework will insist on using /usr/share/kde5, it all gets messed up
15:55:57 <dvratil> I should probably send a mail about that upstream
15:56:01 <tosky> exactly
15:56:07 <tosky> this should be solved there too
15:56:32 <tosky> if it is a framework, it should (upstream) follow the same rule for the other libraries
15:56:39 <dvratil> yes
15:56:43 <tosky> if not, it's not a framework -> app, other rules
15:56:54 <dvratil> plasma-framework is tricky
15:56:56 <dvratil> it has both
15:57:28 <tosky> eh, it does not work this way for frameworks
15:57:33 <tosky> anyway, this is an upstream discussion
15:57:36 <dvratil> /usr/bin/dpitest
15:57:37 <dvratil> /usr/bin/plasma-shell
15:57:39 <dvratil> /usr/bin/plasmapkg2
15:57:39 <tosky> and the time is almost over
15:57:57 <dvratil> so quick vote: /usr/share/kf5 or /usr/share ?
15:58:04 <tosky> dvratil: please cc kde-frameworks-list, not only plasma-devel or whatever list
15:58:09 <dvratil> technically both is possible
15:58:21 <tosky> +1 /usr/share (follow upstream as it is possible)
15:58:28 <jgrulich> +1 /usr/share
15:58:36 <dvratil> I'll send mail directly to kf-list (there are more reasonable people than on plasma-devel) :D
15:58:58 <jgrulich> dvratil: also solid has /usr/bin/solidhardware5
15:59:11 <dvratil> that's slightly different IMO
15:59:21 * Kevin_Kofler thinks /usr/share/kf5 is more future-safe…
16:02:49 <Kevin_Kofler> Our hour is up…
16:03:46 <dvratil> ok, so summary: split kf5-filesystem to kf5-filesystem, kf5-rpmmacros and add kf5-settings
16:03:53 <dvratil> and install Frameworks to /usr/include/KF5, /usr/libexec/kf5, /usr/share
16:04:14 <dvratil> +contact upstream about the Plasma framework
16:07:58 <tosky> dvratil: I guess you need to add an #action
16:08:06 <tosky> dvratil: so that it's logged by the bot
16:08:17 <dvratil> #action contact upstream about Plasma framework installing to /usr/share/kde5
16:08:36 <tosky> dvratil: and #info for the rest :)
16:08:52 <dvratil> #info we will split kf5-filesystem to kf5-filesystem and kf5-rpmmacros and add kf5-settings
16:08:59 <tosky> dvratil: and #endmeeting if Kevin_Kofler is out, we are out of time
16:09:14 <dvratil> #info we will install into /usr/include/KF5, /usr/libexec/kf5 and /usr/share
16:09:15 <Kevin_Kofler> I'm here, rdieter was supposed to lead the meeting today though…
16:09:44 <dvratil> and that's all from me. I did not expect to take full hour with my KF5 update, sorry :-)
16:09:53 <Kevin_Kofler> #topic 4.13.0 status update
16:09:58 <Kevin_Kofler> rdieter: Anything from you on that?
16:09:59 <tosky> oh, right, sorry
16:11:06 <Kevin_Kofler> Whatever, let's skip that and close the meeting now, time's up…
16:11:08 <Kevin_Kofler> #undo
16:11:08 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x10fbe2d0>
16:11:13 <Kevin_Kofler> #endmeeting