14:08:17 <jzb> #startmeeting
14:08:17 <zodbot> Meeting started Thu Apr 24 14:08:17 2014 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:08:26 <jzb> #topic roll call
14:08:30 * roshi is here
14:08:37 <jzb> .fasinfo jzb
14:08:38 <zodbot> jzb: User: jzb, Name: Joe Brockmeier, email: jzb@zonker.net, Creation: 2010-04-20, IRC Nick: jzb, Timezone: America/Chicago, Locale: en, GPG key ID: A0207CD4, Status: active
14:08:40 <zodbot> jzb: Approved Groups: marketing cla_done cla_fpca cla_fedora
14:08:46 * geppetto is here
14:08:59 * number80 ahoj
14:09:02 * red_trela 
14:10:00 <jzb> OK, let's look at the agenda
14:10:06 <jzb> #topic Meeting tickets
14:10:12 <jzb> https://fedorahosted.org/cloud/query?keywords=~meeting&status=!closed
14:11:02 <jzb> Let's start with #16
14:11:14 <jzb> #topic rename cloud spin kickstart to distinguish the cloud base image
14:11:48 <jzb> #info https://fedorahosted.org/cloud/ticket/16
14:12:02 <jzb> discussion on that one?
14:12:10 <red_trela> +1 on the proposal
14:12:26 <jzb> I'm +1
14:12:41 <number80> +1
14:12:43 <jzb> I'm assuming mattdm is +1 since it's his idea
14:12:45 <roshi> +1 if I can vote on it
14:12:53 <geppetto> +1
14:13:29 <mattdm> +1
14:13:31 <mattdm> :)
14:13:48 <jzb> OK, I think we have that one settled.
14:13:59 <geppetto> mattdm: I thought you weren't going to be here :)
14:14:04 <red_trela> is it necessary to have cloud-base-base.ks and cloud-base.ks, though? i.e. what's going to be the difference?
14:16:14 <jzb> anybody?
14:16:52 <roshi> I'm not familiar enough with the image creation process :-/
14:17:18 <jzb> red_trela: I don't think we have the folks in attendance to discuss. Can we start a thread and try to solve this on the list?
14:18:01 <red_trela> if we only just agree on the image name, yes. the second part of the ticket is the ks naming, though so we shouldn't decide that yet.
14:18:32 <jzb> OK
14:18:37 <jzb> Moving on...
14:19:24 <jzb> #topic File F22 change: Re-factor cloud-init
14:19:31 <jzb> this is ticket #23
14:20:08 <jzb> though, reading through the ticket, this may be deferred
14:20:36 <jzb> #info https://fedorahosted.org/cloud/ticket/23
14:21:26 <jzb> we need someone to step up for refactoring cloud-init, provisionally
14:22:11 <jzb> anybody?
14:22:20 * jzb feels like he's talking to himself here.
14:22:21 <number80> I'm more in favor to improve min-metadata service
14:23:01 <jzb> number80: you want to update the ticket?
14:23:14 <red_trela> I'm in favor for any of the alternatives, over the legacy cloud-init
14:23:44 <red_trela> but if we stick with legacy, it must be refactored some
14:23:44 <number80> nope, because i'm not sure that it will be acceptable for open{stack,nebula} folks for instance
14:23:51 <jzb> red_trela: we're not concerned that we'll lose / fail to attract people who expect cloud-init?
14:24:43 <red_trela> jzb: that sure is a big question
14:25:18 <number80> jzb: do we have access to cloud instances ?
14:25:26 <red_trela> jzb: since we want to be "First", we might be ready to take that route
14:25:31 <jzb> red_trela: my general observation is that it's one of those "I expect this, and even if there are good reasons not to have it, I'm just going to pass it by b/c it's not hitting one of my checkboxes."
14:25:47 <red_trela> jzb: also, CoreOS is hugely popular and develops their own cloud-init
14:25:50 <number80> I could work on implementing some missing features, but it would be expensive if I did on my own EC2 account
14:26:08 <red_trela> https://github.com/coreos/coreos-cloudinit
14:26:14 <jzb> number80: I don't think we have an account as a group, no.
14:26:21 <jzb> number80: that's not to say it's something we couldn't come up with
14:26:28 <jzb> number80: define "expensive"
14:26:52 <number80> jzb: I was thinking about eucalyptus or openstack clouds hosted in fedora-infra
14:26:53 <red_trela> number80: open a ticket with fedora-infrastructure to get an account on their cloud
14:27:11 <red_trela> number80: i.e. the fedora infrastructure openstack cloud
14:27:20 <number80> red_trela: great
14:27:22 <jzb> https://fedorahosted.org/fedora-infrastructure/
14:27:34 <jzb> ^^ unnecessary googling, probably :-)
14:27:40 <number80> :)
14:28:02 <jzb> red_trela: CoreOS is getting a lot of attention, I'm not sure about "hugely popular"
14:28:14 <jzb> not sure how much, if any, real world adoption is going on there.
14:28:40 <red_trela> jzb: not sure how much, if any, real world adoption we are getting at the moment...
14:28:45 <red_trela> (in the cloud)
14:28:48 <jzb> red_trela: there's that
14:29:04 <jzb> OK, anything else on this ticket?
14:29:11 * roshi has nothing
14:29:26 <jzb> I take it we kind of need to leave this one for further discussion.
14:29:34 <number80> I'll add myself as CC, but I need to get more visibility
14:29:55 <jzb> number80: thanks
14:30:05 <jzb> number80: can I put you down as taking lead on that?
14:30:13 <jzb> I'm sure mattdm would appreciate it :-)
14:30:14 <number80> yes
14:30:45 <red_trela> number80: could you start a thread on the ml to discuss the various cloud-init alternatives?
14:30:52 <jzb> #action number80 to take lead on Ticket #23 (https://fedorahosted.org/cloud/ticket/23)
14:31:28 <jzb> #topic Ticket #45 need three packages added to the fedora21 cloud image
14:31:55 <jzb> sdake has requested that we add os-collect-config, os-apply-config, and os-refresh-config to the Fedora Cloud images.
14:32:59 <jzb> reading the thread, I'm not entirely sure this is needed -
14:33:04 <jzb> any thoughts, comments, etc.?
14:33:24 <jzb> have we established that these don't need to be in the image by default, and can be added later, or do we need to look at adding them?
14:33:26 <roshi> it looks like it's requested for one thing
14:33:41 <number80> I won't vote since i might be suspected of being partial here
14:33:41 <roshi> but wasn;'t a long term goal getting the python dep out of the image?
14:34:05 <geppetto> with the previous cloud-init ticket, yeh
14:34:13 <geppetto> now we add a second python :-o
14:34:15 <red_trela> at first it seemed he wanted the packages included for tripleO but as I raised concerns he dropped that use case and went with Heat instead. So right now we have heat-cfntools (109k according to yum info) and the new tools use 50MB (installed size)
14:35:12 <red_trela> that really goes against our efforts of minimizing the footprint and sdake has failed to come up with a (good) reason for it so far.
14:35:14 <geppetto> Does anyone know how possible it would be to have it use py2 until everything else is using py3?
14:35:31 <red_trela> roshi: only our of the docker image, which would not ship those tools
14:35:49 <red_trela> s/our/out/
14:36:00 <number80> geppetto: though I'm a pythonista, I'd look forward dropping interpreters in the base image
14:36:05 <red_trela> roshi: the other images ship yum, so they need python ;)
14:36:06 <roshi> depends on the lib and it's deps - py2 vs 3 is a giant PITA in my experience
14:36:24 <jzb> I'd also point out
14:36:24 <geppetto> number80: right … and I agree, but 1 python is still better than 2 :)
14:36:32 <jzb> that this is only aimed at one IaaS
14:36:38 <roshi> ah - that makes sense red_trela - finally getting my head wrapped around it
14:36:40 <jzb> AFAICT
14:36:57 <jzb> it only benefits use cases with Fedora on OpenStack, not Euca, AWS, GCE, or CloudStack
14:37:04 <jzb> (or am I wrong on that?)
14:37:16 <red_trela> jzb: right
14:37:28 <number80> geppetto: sure
14:37:37 <jzb> so we'd be looking at adding another runtime, and embiggening the image just for that use case.
14:37:38 <red_trela> jzb: and only when using Heat (i.e. Orchestration)
14:37:47 <roshi> embiggening
14:37:55 * roshi is going to use that word going forward
14:38:00 <number80> jzb: heat could be used with other cloud infrastructures too
14:38:06 <jzb> I think that we'd either want to look at having a separate spin for that or providing a Puppet recipe, etc. instead.
14:38:10 <number80> (I once used it with AWS)
14:38:18 <jzb> number80: ah, OK - would people do that?
14:38:26 <red_trela> number80: that's a serious edge case :)
14:38:34 <jzb> I think Heat is actually implementing a native AWS tool, right?
14:38:53 <red_trela> CloudFormation, yes
14:38:59 <number80> jzb: not sure but Heat has some compatibility with CloudFormation (its AWS equivalent)
14:39:21 <jzb> OK
14:39:22 <red_trela> but I think they're moving away from compatibility
14:39:31 <frankieonuonga> hi folk
14:39:35 <frankieonuonga> sorry i am late
14:39:37 <frankieonuonga> long story
14:40:16 <jzb> hi frankieonuonga
14:40:25 <jzb> let's put it to a vote here
14:40:27 <frankieonuonga> jzb: hi mate...
14:40:39 <frankieonuonga> can someone kindly get me up to speed on DM
14:40:39 <jzb> who's in favor of adding these packages?
14:40:58 <red_trela> -1 unless sdake can come up with new good arguments
14:41:10 <roshi> -1
14:41:39 <number80> frankieonuonga: we're voting on this ticket https://fedorahosted.org/cloud/ticket/45
14:41:50 <frankieonuonga> thanks
14:42:13 <jzb> -1 unless we get further info that provides a better rationale for adding them.
14:43:15 <jzb> number80? frankieonuonga?
14:43:33 <jzb> geppetto: ?
14:43:42 <frankieonuonga> I am voting agaist it cause there is not enough to to back it up
14:43:50 <number80> jzb: I'm abstaining to vote because it involves sdake and I won't be considered impartial
14:43:51 <frankieonuonga> one really needs to give a good argument
14:44:05 <frankieonuonga> here i feel at this moment  it is weak
14:45:02 <jzb> summoning mattdm
14:45:31 * mattdm reads back
14:46:25 <geppetto> jzb: I'm not sure … I guess -1 for including it in images for everyone (although that vote doesn't really matter :) … would be nice to get some more info. though, and why they can't just have their own image
14:46:58 <mattdm> I had some further conversation with sdake but can't remember it all :)
14:47:17 <jzb> I think we're currently at "needs more info, but probably not."
14:47:28 <mattdm> I can be +1 to that statement
14:47:37 <mattdm> which I guess joins everyone else's -1s
14:48:33 <mattdm> and we can maybe look at adding an openstack-optimized spin? I'm not exciting about going down that road, but when stuff starts getting loaded up with environment-specific agents it might be the best way.
14:48:35 <jzb> OK, I'm reassigning this one to myself to track
14:49:07 <jzb> mattdm: yeah
14:49:27 <jzb> #action jzb to follow up on Ticket 45, will herd cats until we come to a conclusion on it.
14:50:03 <jzb> #topic Project Atomic and Fedora Docker Host Image
14:50:03 <red_trela> jzb: I was actually just going to write it since I was already the in the discussion on the ticket
14:50:17 <number80> \o/
14:50:19 <jzb> red_trela: already done :-)
14:50:41 <jzb> https://fedorahosted.org/cloud/ticket/46
14:50:41 <red_trela> jzb: okay ;)
14:50:53 <jzb> so questions
14:51:02 <number80> I'm so +10000 for that
14:51:11 <jzb> 1) do we want the Fedora Docker host to be the Atomic host
14:51:16 <mattdm> mattdm is heavily +1 on an All-in-on-Atomic image
14:51:20 <jzb> apparently number80 likes it
14:51:35 <jzb> it should be pretty obvious where I am on that, but +1
14:51:53 <number80> I'm already annoying everyone with how awesome is atomic :)
14:51:53 <frankieonuonga> +1
14:52:05 * roshi doesn't vote because he only has a passing understanding of Docker/Atomic
14:52:28 <geppetto> Why didn't Colin open this?
14:52:54 <jzb> Not sure
14:53:38 <mattdm> atomic is grown bigger than just colin's baby :)
14:53:46 <geppetto> Anyway … do you have a plan other than to have the docker host be ostree/Atomic based?
14:53:59 <red_trela> so, what do we understand by this. Basically cp project-atomic.qcow2 fedora-21-atomic.qcow2?
14:54:18 <jzb> geppetto: define "other plan"?
14:54:35 <jzb> geppetto: Atomic also pulls in geard, cockpit, etc.
14:55:03 <mattdm> I want to get this under the fedora umbrella, _rather_ than the 'cp' approach
14:55:14 <number80> +1 with mattdm
14:55:43 <geppetto> jzb: I'm just not sure what the point of voting is … it seems like asking should we have the linux kernel in our docker host … AFAIK all the plans for a docker host are using atomic, so we'd have to be pretty crazy to not do so.
14:55:51 <number80> besides, the atomic host could also be the base for the openshift image
14:56:04 <mattdm> (not the _whole_ thing under fedora, of course, but I want to make sure that the part that _is_ under fedora is official and integrated)
14:56:13 <jzb> geppetto: we could have a non-Atomic docker host
14:56:43 <jzb> I don't see that as an advantage, but I suppose it'd be possible someone would be against the rpm-ostree stuff, for example.
14:56:45 <mattdm> geppetto let's vote for "we're not crazy", then :)
14:57:01 <jzb> mattdm: why do you keep excluding me?
14:57:09 <mattdm> jzb lol
14:57:20 <geppetto> mattdm: Yeh, I mean … for official counts, put me down on the not crazy side :)
14:57:33 <jzb> OK, I ... think we actually have majority there. Yay
14:57:39 <red_trela> mattdm: okay, let me ask that differently. is the question whether to use rpm-ostree or is it whether to do all the project atomic stuff (rpm-ostree, geard, cockpit, etc.) and ignore the alternatives (accepting the guys at project atomic choose the best stuff)
14:58:45 <mattdm> red_trela I think it is to use the project atomic patterns as a foundation (including all that stuff), and possibly do whatever else fits within that and makes sense
14:59:41 <number80> won't it be possible to get projectatomic.io as a co-owner of this feature ?
14:59:54 <mattdm> number80 that would be cool, yes.
15:00:17 <mattdm> for example, jzb :)
15:00:44 <jzb> I will do what I can, and push for other folks
15:00:47 <number80> :)
15:01:09 <number80> moarr collaboration
15:01:28 <jzb> so, do we want to open new tickets for specific items and consider this one a yes?
15:01:32 <jzb> or just use this as the tracker?
15:01:49 * mattdm has a lot of informal "yeah, I'd love to help in fedora" comments that we _should_ be able to turn into commitments. :)
15:02:08 <number80> jzb: tracker
15:02:22 <red_trela> sigh, I didn't have half the time I'd liked to dig into project atomic so I feel I'm making a somewhat unfounded decision...but throwing in a +1 as well
15:02:41 <red_trela> always having a hard time to resist the leading edge ;)
15:03:00 <frankieonuonga> red_trela: that makes two of us
15:03:00 <roshi> it's chronic :)
15:03:01 <jzb> red_trela: time seems to be our enemy
15:03:08 * mattdm is glad to have fedora near the leading edge in the cloud area for once :)
15:03:23 <jzb> or, more accurately, having to eat, sleep, pay bills, and scoop litter boxes.
15:03:43 <jzb> OK
15:03:45 <roshi> eating is that thing I always seem to forget to do during the workday
15:04:03 <jzb> roshi: yeah... that's definitely not my problem. Forgetting to eat would be a feature.
15:04:24 <red_trela> sleep is the thing I would like to go do since our 1h is over...so can we please wrap this and try having more regular meetings from now on? :)
15:04:40 <roshi> I have one thing
15:04:44 <jzb> red_trela: I like the way you think
15:04:53 <roshi> discussion can happen on list or wherever
15:04:54 <jzb> do we need to address any of the other tickets urgently today?
15:05:02 <roshi> https://fedorahosted.org/cloud/ticket/41
15:05:03 <jzb> or shall we table them for next week?
15:05:20 <mattdm> anyone here want to look at the gce effort?
15:05:21 <roshi> I created some draft stuff for testing I'd like feedback on :)
15:05:53 <jzb> mattdm: erjohnso spoke up about that at the beginning of the meeting.
15:06:00 <red_trela> roshi: they are fairly high up on my todo list :)
15:06:03 <erjohnso> yup, i'm here to assist :)
15:06:12 <mattdm> erjohnso is from google and wants someone here to connect with
15:06:30 <erjohnso> if you give me a pointer to your standard image creation tools, I can give them a try
15:06:35 <jzb> roshi: thanks for that, can you send a note to the list?
15:06:40 <roshi> yeah
15:06:59 <jzb> #action roshi to send note to the list for review of his QA draft
15:07:01 <number80> erjohnso: is it possible to get credentials for testing purposes ?
15:07:05 <jzb> roshi: thanks again!
15:07:06 <frankieonuonga> I would like to help but I can not promise to touch this until next week tuesday
15:07:15 <frankieonuonga> then my schedule is free again
15:07:27 <roshi> if I felt more qualified to call myself a cloud person I would volunteer mattdm
15:07:31 <frankieonuonga> erjohnso: if you need any help just ping me
15:07:45 <number80> and since we brought up GCE, has anyone an update on packaging GCE utilities progression ?
15:07:53 <frankieonuonga> roshi: Only one way to learn, through yourself into the dip end
15:08:17 <roshi> true enough, I suppose
15:08:18 <erjohnso> I can likely get a free project created and give folks access to it - I'll need to check on that though
15:08:24 <jzb> frankieonuonga: deep end?
15:08:30 <erjohnso> frankieonuonga: great!
15:08:49 <mattdm> erjohnso the tool that we're migrating to is imagefactory, fed with this kickstart file https://git.fedorahosted.org/cgit/spin-kickstarts.git/tree/fedora-x86_64-cloud.ks
15:08:53 <frankieonuonga> jzb: yeah...like just get yourself into the mix of things and find your way around :-)
15:08:56 <number80> erjohnso: I may contact you after you'll send a note to the list :)
15:09:03 <mattdm> zooz (Vaidas Jablonskis) has done some work on this
15:09:12 <mattdm> I'll try to dig up the mailing list posts
15:09:49 <number80> thanks
15:09:53 <red_trela> figure fedora legal would want to talk with google about such accounts just as they do with hp cloud...
15:10:00 <erjohnso> much appreciated.  sorry, new to the fedora community (old school redhat user though) - what list should I post to?
15:10:08 <mattdm> red_trela that is still in the black box state
15:10:31 <number80> red_trela: I thought that samkottler has sorted out this issue with legal
15:10:51 <mattdm> erjohnso https://lists.fedoraproject.org/pipermail/cloud/
15:11:06 <erjohnso> mattdm: thx
15:11:14 <red_trela> number80: not yet afaik. and it's taking forever already so don't expect to use gce like that soon :/
15:11:41 <number80> :(
15:11:59 <red_trela> remember when legal (or actual laws, even) had no idea about IT and everything was just great? ;)
15:12:40 <number80> I'm not bound to their whims :>
15:12:58 <red_trela> so, who got the wrapping paper for this one?
15:13:32 <jzb> red_trela: is that a call for adjourning?
15:13:49 <red_trela> jzb: please :)
15:13:55 <jzb> +1
15:13:58 <frankieonuonga> +1
15:14:01 <roshi> +1
15:14:03 <number80> +1
15:14:03 <red_trela> it's already Friday over here ;)
15:14:19 <jzb> I'm pretty sure I can count mattdm as +1 too
15:14:23 <jzb> so, meeting adjourned
15:14:27 <jzb> #endmeeting