15:00:36 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:00:36 <zodbot> Meeting started Tue Apr 29 15:00:36 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:41 <Kevin_Kofler> #meetingname kde-sig
15:00:41 <zodbot> The meeting name has been set to 'kde-sig'
15:00:44 <Kevin_Kofler> #topic Role call
15:00:50 * Kevin_Kofler is present, who else?
15:00:55 * jgrulich is present
15:01:20 <tosky> here
15:01:26 * dvratil present
15:01:33 * rkratky is here
15:01:53 <rdieter> hola
15:02:13 <pino|work> rdieter: -ELANG :p
15:03:04 <rdieter> pino|work: bonjour ?
15:03:22 <pino|work> hi ;)
15:03:49 <Kevin_Kofler> #chair jgrulich tosky dvratil rkratky rdieter pino|work
15:03:49 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich pino|work rdieter rkratky tosky
15:03:54 <rdieter> moin (ok I'm done :) )
15:04:25 * than is presen
15:04:32 <Kevin_Kofler> #chair than
15:04:32 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich pino|work rdieter rkratky than tosky
15:04:47 <Kevin_Kofler> mbriza: Ping?
15:05:17 <Kevin_Kofler> jreznik: Ping?
15:05:31 <tosky> I think jreznik is not going to attend
15:05:43 <Kevin_Kofler> He's quite busy these days.
15:06:02 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, tosky, dvratil, rkratky, rdieter, pino|work, than present.
15:06:10 <Kevin_Kofler> #topic Agenda
15:06:54 <Kevin_Kofler> Meeting chan registration/conflict.
15:07:15 <Kevin_Kofler> Anything else? Status updates on new upstream releases or stuff like that?
15:08:05 <rdieter> I can give status on 4.12.5, pam-kwallet
15:08:11 <Kevin_Kofler> OK.
15:08:28 <Kevin_Kofler> IMHO, moving to GStreamer 1.0 should be a priority, maybe we can also take that up.
15:08:39 <Kevin_Kofler> #topic Meeting chan registration/conflict
15:08:47 <Kevin_Kofler> Let's start with the administrative stuff.
15:09:13 <Kevin_Kofler> So I looked at the meeting chan situation: We are currently registered for 15:00 UTC on the wiki, but not in Fedocal.
15:09:49 <Kevin_Kofler> Env-and-Stacks is registered on both the wiki and in Fedocal as alternating between 13:00 and 16:00 UTC, but they apparently moved to 15:00 UTC with US DST, causing a channel conflict every other week.
15:10:40 <Kevin_Kofler> My proposal is: Also register our meeting on Fedocal to match the wiki, and show up on time next week so that Env-and-Stacks cannot steal our chan.
15:10:48 <Kevin_Kofler> We have always been at 15:00 UTC.
15:11:23 <tosky> but can you register on Fedocal if there is a conflict?
15:11:25 <rdieter> +1, though I don't mind being flexible and considering the use of another meeting channel
15:11:34 <rdieter> tosky: there is no conflict on fedocal
15:11:43 <tosky> oh, ok, I misunderstood
15:11:48 <Kevin_Kofler> Env-and-Stacks is listed at 16:00 UTC on both Fedocal and the wiki.
15:12:18 <Kevin_Kofler> They're actually meeting at 15:00 it seems, but this isn't documented anywhere.
15:12:27 <Kevin_Kofler> And they didn't bother checking that the chan is free to begin with.
15:12:55 <tosky> ok, so it's easy then
15:13:07 <tosky> if it's not documented, this channel is officially free
15:18:12 <Kevin_Kofler> #info KDE SIG Meeting now also registered on Fedocal.
15:18:47 <Kevin_Kofler> #link https://apps.fedoraproject.org/calendar/location/fedora-meeting@irc.freenode.net/
15:18:57 <tosky> good :)
15:19:01 <tosky> thanks
15:19:20 <Kevin_Kofler> IMHO, we should also drop a note to the Env-and-Stacks folks.
15:19:50 <Kevin_Kofler> We've been on the wiki for 15:00 UTC since forever.
15:19:59 <tosky> good idea
15:20:28 <Kevin_Kofler> Now I also added it on Fedocal for every Tuesday from 2013-01-01 to 2025-12-31. :-p
15:21:44 <Kevin_Kofler> #topic 4.12.5 releases
15:21:47 <Kevin_Kofler> rdieter: Your turn.
15:22:24 <rdieter> ok, 4.12.5 is in kde-testing, and ready to go in bodhi as soon as upstream announces it
15:22:58 <Kevin_Kofler> #info 4.12.5 is in kde-testing, and ready to go in bodhi as soon as upstream announces it.
15:23:03 <rdieter> 2 tarball respins to building now: kdelibs, kde-workspace
15:23:09 <Kevin_Kofler> Great.
15:23:22 <Kevin_Kofler> I guess it should be fairly uneventful, being a .5 release.
15:23:54 <Kevin_Kofler> #topic pam-kwallet
15:24:36 <rdieter> .bug 1091479
15:24:39 <zodbot> rdieter: Bug 1091479 Review Request: pam-kwallet - PAM module for KWallet - https://bugzilla.redhat.com/1091479
15:24:41 <rdieter> ^^ needs a reviewer
15:24:52 <Kevin_Kofler> #link https://bugzilla.redhat.com/1091479
15:25:03 <rdieter> its in kde-unstable too (since it needs 4.13.0), been testing it for about a week with good results (kdm)
15:25:23 <rdieter> posted on kde@fpo list for more testing/feedback
15:25:32 <jgrulich> I'll do it tomorrow if nobody do it today
15:26:11 <rdieter> jgrulich: thanks
15:26:53 <Kevin_Kofler> #action jgrulich will do the review tomorrow if nobody does it today.
15:27:33 <Kevin_Kofler> I suppose it needs 4.13.0 because the old KWallet can't talk to it? I guess the KWallet patches could be backported…
15:27:43 <Kevin_Kofler> I suppose they should have no effect if pam-kwallet isn't installed.
15:29:08 <rdieter> there was something in kde-runtime too I think
15:29:53 <Kevin_Kofler> That's where KWallet really lives, the other package is just the kwalletmanager.
15:30:14 <rdieter> ah, ok, maybe that's it then
15:30:40 <Kevin_Kofler> Anyway, we don't HAVE to support that, I just thought that it'd be nice to allow users to opt into it on F20 and even F19.
15:30:46 <rdieter> once in, will have to modify kde-settings to set kwallet defaults to not autoclose
15:31:12 <Kevin_Kofler> Though for F20, if we're pushing 4.13 anyway, we don't need to backport. :-)
15:31:26 <Kevin_Kofler> (and that's another open question there)
15:33:36 <rdieter> ok, so that's all I have on pam-kwallet
15:34:00 <rdieter> anyone else try it yet?  (if not, I'd encourage you to do so)
15:35:14 <Kevin_Kofler> #halp Testing wanted for pam-kwallet.
15:35:41 <Kevin_Kofler> I guess none of us did. :-)
15:35:47 <Kevin_Kofler> #topic GStreamer 1.0 migration
15:36:05 <Kevin_Kofler> So, let's take up the GStreamer thing again.
15:36:27 <Kevin_Kofler> KDE is kinda late at catching up there, a lot of stuff is still stuck on 0.10.
15:36:34 <Kevin_Kofler> It'd be nice to get everything moved to 1.0 for F21.
15:36:42 <Kevin_Kofler> (It was supposed to happen for F20 already.)
15:37:26 <Kevin_Kofler> rdieter split the qt-mobility packaging, which should at least help avoid the … → qt-mobility → GStreamer 0.10 depchain.
15:37:37 <rdieter> theres a lot of packages that would require patches/snapshots , probably good idea to create a tracker bug
15:37:57 <Kevin_Kofler> There isn't anything important using the multimedia parts of qt-mobility (anymore), AFAIK.
15:38:01 <rdieter> <nod>, qt-mobilities libQtMultiMediaKit (which nothing in the distro currently uses, afaict)
15:38:18 <Kevin_Kofler> QtWebKit used to use them long ago, but moved to using GStreamer directly.
15:38:27 <Kevin_Kofler> (using the code that WebKit had for webkitgtk anyway)
15:38:58 <Kevin_Kofler> And KGranatier used the stuff for a moment, but then switched to OpenAL.
15:39:25 <Kevin_Kofler> The other stuff that uses GStreamer 0.10 in KDE:
15:39:29 <rdieter> so biggies include: qtwebkit, phonon-gstreamer
15:39:50 <rdieter> qt-gstreamer (used in telepathy stack)
15:39:52 <Kevin_Kofler> Hmmm, actually, the topic is bad, let me fix it…
15:39:53 <Kevin_Kofler> #undo
15:39:53 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0xba6a450>
15:40:02 <Kevin_Kofler> #topic GStreamer 1 migration
15:40:07 <Kevin_Kofler> We're at 1.2 already. :-)
15:40:14 <rdieter> close enough
15:40:19 <Kevin_Kofler> So I was saying: The other stuff that uses GStreamer 0.10 in KDE:
15:40:47 <Kevin_Kofler> * QtWebKit – WebKit already supports GStreamer 1, and openSUSE has a small patch to backport the support in the Qt parts
15:40:54 <Kevin_Kofler> (The Qt 5 version already supports it, I think.)
15:41:23 <rdieter> correct
15:41:25 <Kevin_Kofler> * Phonon-GStreamer – There's a branch that supports GStreamer 1, it should be working.
15:41:28 <rdieter> (about qt5)
15:42:00 <rdieter> ironic that qt5-qtmultimedia still uses gst-0.10
15:42:39 <Kevin_Kofler> * QtGStreamer – There too, there's a branch with GStreamer 1 support, and also patches for kde-telepathy (that also port it to the current version of farstream, that uses 1.x instead of 0.10 too) and Kamoso to work with the new version.
15:42:51 <Kevin_Kofler> So in principle, everything should be there to ship.
15:42:59 <Kevin_Kofler> It should be just a matter of importing it into Rawhide.
15:43:20 <rdieter> last we checked, the rumors of a kamoso patch were exagerated, we couldnt find one
15:43:34 <Kevin_Kofler> I could eventually find it.
15:44:00 <Kevin_Kofler> IIRC, it was in a git clone on the github project where the QtGStreamer port is being developed.
15:44:02 <rdieter> ok, so back to my original suggestion, tracking bug, then bugs against all the affected packages...
15:44:03 <pino|work> kamoso has not had a release in years
15:44:34 <Kevin_Kofler> pino|work: But it works. :-)
15:44:40 <Kevin_Kofler> We should keep it that way.
15:45:19 <pino|work> well, sure, if you carry your own patches to eg fix kipi stuff (like new api, file conflicts with kde-workspace), ...
15:45:50 <Kevin_Kofler> The advantages from moving to GStreamer 1: more features, fewer bugs, less user confusion (no more requirement for 2 different sets of patent-encumbered plugins depending on the app), less wasted space on the live images.
15:46:17 <Kevin_Kofler> And also, automatic plugin installation will keep working. (It got switched from being built against 0.10 to being built against 1.x in F21.)
15:46:42 <rdieter> <nod>, gst upstream has no support for 0.10 too
15:48:30 <Kevin_Kofler> So, what's the plan? Do we start the import of the updated/changed bits into Rawhide now?
15:48:47 <rdieter> <rdieter> ok, so back to my original suggestion, tracking bug, then bugs against all the affected packages...
15:49:10 <rdieter> once we have everything ready, then start importing
15:49:35 <Kevin_Kofler> -1, unnecessary bureaucracy…
15:50:00 * Kevin_Kofler dislikes the latest trend to try to track every silly thing on Bugzilla.
15:50:16 <Kevin_Kofler> It just generates lots of useless e-mail traffic and wastes everyone's time.
15:50:26 <rdieter> Kevin_Kofler: no one knows all the necessarily details except you.
15:50:33 <Kevin_Kofler> We already know exactly what needs to be done, just do it.
15:50:36 <rdieter> unless you want to do all the work to implement this
15:50:39 <Kevin_Kofler> I listed the necessary details above.
15:50:42 <pino|work> well, if for some reason you cannot finish it off soon, you don't forget it later nor lose track of it
15:50:48 <rdieter> I've no idea where all the patches can be found
15:51:05 <rdieter> if you want help, please *document* it
15:52:19 <Kevin_Kofler> Whatever… I'm filing the terabazillion bugs that you ask for now… ;-)
15:52:30 <Kevin_Kofler> (Well, actually, it should be only 5 or 6.)
15:52:43 <Kevin_Kofler> #action Kevin_Kofler to file tracking bugs.
15:52:59 <Kevin_Kofler> #topic Open discussion
15:53:02 <Kevin_Kofler> Anything else?
15:55:03 <Kevin_Kofler> Closing the meeting in 60 seconds…
15:55:25 <tosky> dvratil: you did have some answers for the co-installability issue, right?
15:55:36 <dvratil> yes
15:55:41 <tosky> (maybe for next week, no much time left?)
15:55:46 <tosky> as you wish :)
15:55:51 <Kevin_Kofler> We can discuss it now.
15:55:52 <dvratil> talked to dfaure, he they decided to use kf5 prefix for some stuff
15:55:54 <rdieter> co-install of kf5 ?
15:55:56 <dvratil> *they :)
15:56:16 <dvratil> and the generic stuff will have "5" suffix, so /usr/share/kservices5
15:56:19 <dvratil> for instance
15:56:48 <rdieter> good
15:56:49 <dvratil> it will be already in 4.99.0 next week(-ish?)
15:57:44 <dvratil> and there's some pressure on upstreamto make workspace co-installable too, but that's not decided yet
16:00:26 <Kevin_Kofler> That could help us, it'd allow us to ship it in F21 as a non-default option, avoiding the 4.0 flamewar from F9…
16:00:59 <Kevin_Kofler> Upstream keeps blaming the distros for the way 4.0 was introduced, but are not willing to make the changes to let us do it better. :-/
16:01:32 <rdieter> yeah, though having copr and playground repos may make that easier in the long-run too, we'll have to see
16:03:29 <tosky> anyway, no conflicts for libraries (and if there are, it's an upstream bug)
16:05:04 <Kevin_Kofler> FYI:
16:05:09 <Kevin_Kofler> .bug 1092641
16:05:13 <zodbot> Kevin_Kofler: Bug 1092641 KDE GStreamer 1 migration tracking bug - https://bugzilla.redhat.com/1092641
16:05:26 <Kevin_Kofler> I'm filing the bugs against the affected components now.
16:11:06 <Kevin_Kofler> Looks like we're really out of topics to discuss now, and also out of time, so thanks everyone for attending, see you next week!
16:11:12 <Kevin_Kofler> #endmeeting