15:00:06 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:00:07 <zodbot> Meeting started Tue May 20 15:00:06 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:11 <Kevin_Kofler> #meetingname kde-sig
15:00:11 <zodbot> The meeting name has been set to 'kde-sig'
15:00:30 <Kevin_Kofler> #topic Role call
15:00:32 * jgrulich is present
15:00:34 * Kevin_Kofler is present, who else?
15:00:39 <rdieter> yo
15:00:41 <pino|work> moo
15:01:01 * rkratky is here
15:02:08 <mmaslano> conflict, um env people please to #fedora-meeting-2, thanks
15:02:56 * danofsatx-work is here too
15:05:40 <dvratil> here
15:05:45 <than> present
15:06:11 <ltinkl> hi
15:06:27 <Kevin_Kofler> #chair jgrulich rdieter pino|work rkratky danofsatx-work dvratil than ltinkl
15:06:27 <zodbot> Current chairs: Kevin_Kofler danofsatx-work dvratil jgrulich ltinkl pino|work rdieter rkratky than
15:06:45 <Kevin_Kofler> #info jgrulich, Kevin_Kofler, rdieter, pino|work, rkratky, danofsatx-work, dvratil, than, ltinkl present.
15:06:49 <Kevin_Kofler> #topic Agenda
15:07:10 <Kevin_Kofler> I guess there isn't a prepared agenda, as usual these days…
15:08:17 <dvratil> I have a live ISO with Plasma Next
15:08:27 <rdieter> yay
15:08:33 <Kevin_Kofler> Yay +1!
15:08:39 <danofsatx-work> fedora based?
15:08:41 <Kevin_Kofler> Any status updates? Any items to discuss?
15:09:13 <danofsatx-work> nevermind, stupid question
15:09:35 * danofsatx-work typed before he thought
15:10:08 <dvratil> danofsatx-work, hehe, I wouldn't be bragging about it here otherwise :)
15:10:26 <danofsatx-work> ;)
15:10:37 <Kevin_Kofler> #info dvratil has a Fedora Remix live ISO with Plasma Next.
15:10:57 <jgrulich> danofsatx-work: dvratil just downloaded project Neon iso and renamed Kubuntu to Fedora :)
15:11:03 <Kevin_Kofler> (I'm not writing "Fedora-based" because I don't want the trademark police chasing after me. ;-) )
15:11:18 <Kevin_Kofler> jgrulich: LOL
15:11:32 <dvratil> well, I managed to package and compile all frameworks and KDE 5 apps
15:11:51 <dvratil> managed to make a working ISO from kickstart
15:12:06 <dvratil> and I'm only suffering from SDDM being crap and taking 30 seconds to start
15:12:27 <dvratil> which makes it the most broken part of the entire live image :D
15:12:29 <Kevin_Kofler> #undo
15:12:29 <zodbot> Removing item from minutes: INFO by Kevin_Kofler at 15:10:37 : dvratil has a Fedora Remix live ISO with Plasma Next.
15:12:35 <Kevin_Kofler> #topic Live ISO with Plasma Next
15:12:38 <Kevin_Kofler> #info dvratil has a Fedora Remix live ISO with Plasma Next.
15:12:46 <Kevin_Kofler> Let's officially make this a topic. :-)
15:12:48 <rdieter> sddm not working in rawhide is a problem
15:12:49 <dvratil> (sorry, I thought you already set it)
15:12:57 <dvratil> it's F20 based
15:13:07 <rdieter> oh
15:13:13 <rdieter> dvratil: use kdm :)
15:13:28 <rdieter> (only half serious)
15:13:31 <Kevin_Kofler> Have you tried the latest SDDM (the one with QAuth) from mbriza?
15:13:44 <dvratil> no, I use the one shipped in F20
15:14:06 <dvratil> I'll try that
15:14:08 <Kevin_Kofler> The one shipped in F20 is known broken, there's a reason we pushed the "SDDM by default" feature back.
15:14:23 <Kevin_Kofler> The one in Rawhide is probably worse though.
15:14:32 <Kevin_Kofler> The QAuth one is not in Rawhide yet.
15:14:55 <dvratil> except for that, it pretty much works (surprisingly well), so once this is solved, I'll upload it smwhere, write a blog post and be done with packaging for next couple months :D
15:15:23 <Kevin_Kofler> I don't know what the state there is, and I don't know where mbriza went (he's connected to IRC, but didn't report present).
15:15:27 <jgrulich> dvratil: we still have to finish KF5 package reviews :)
15:15:48 <dvratil> yeah, I wanted to bother him to fix it for me, but he didn't show up today...like if he knew...:)
15:15:59 <Kevin_Kofler> ;-)
15:16:39 <Kevin_Kofler> dvratil: Did you start from the official Fedora KDE kickstart? From my Kannolo one? From something else? Or even from scratch?
15:16:57 <dvratil> I started with the KS script that Siddhart originally made
15:17:17 <dvratil> btw I even created SDDM theme: http://pub.progdan.cz/sddm-theme.png :-)
15:17:30 <dvratil> by taking mbriza's default and chaging wallpaper :-)
15:17:30 <jgrulich> dvratil: the latest sucessful build of sddm for F20 is quite old, so maybe you can try to rebuild the rawhide build
15:18:23 <jgrulich> dvratil: but probably better to ask mbriza about that
15:18:31 <Kevin_Kofler> jgrulich: Except rdieter says it's even more broken.
15:18:53 <Kevin_Kofler> I remember that we pulled several SDDM updates/freeze overrides for F20 because they made things worse.
15:19:23 <dvratil> KDM requires kdelibs(4), right?
15:19:32 <jgrulich> Kevin_Kofler: it could be broken in rawhide only :)
15:19:46 <rdieter> dvratil: yes
15:20:18 <jgrulich> it's worth to check that with mbriza
15:20:34 <danofsatx-work> what does neon use?
15:20:35 <rdieter> dvratil: another possible alternative, lightdm (and lightdm-gtk greeter), should only depend on gtk2.  but otherwise, making sddm work is probably the way to go
15:20:54 <rdieter> danofsatx-work: lightdm probably
15:21:03 <dvratil> yeah. it works when I start it manually, but it behaves funny when started via systemctl
15:21:21 <danofsatx-work> now that I think on my brief, horrible experience with it, I think you're correct
15:21:47 <Kevin_Kofler> How about startx? ;-)
15:21:54 <Kevin_Kofler> (not really serious…)
15:22:07 <dvratil> that would work too - sddm is set to autologin anyways, so you don't really see it
15:23:26 <mbriza> the qauth sddm works on all my computers
15:23:53 <mbriza> and my roommate who always breaks everything has it too and didn't report anything
15:24:14 <dvratil> mbriza, where can I get it?
15:24:19 <mbriza> my copr
15:24:23 <mbriza> sddm repo i think
15:24:28 <dvratil> ok, I'll try
15:24:35 <mbriza> thx
15:24:40 <Kevin_Kofler> Yeah, the link was posted in #fedora-kde the other day, let me dig it up.
15:24:55 <Kevin_Kofler> #link https://copr.fedoraproject.org/coprs/mbriza/sddm/
15:25:10 <rdieter> mbriza: great, let's get it into rawhide asap :)
15:25:12 <Kevin_Kofler> #info Copr repo for SDDM using the new QAuth library.
15:27:13 <Kevin_Kofler> #topic Open discussion
15:27:20 <Kevin_Kofler> So, is there anything else to discuss?
15:27:44 <jgrulich> Qt 5.3 was released today, does anyone working on update?
15:28:09 <rdieter> I was going to start in a few hours (after lunch), but any help would be welcome
15:28:40 <jgrulich> I can help or do it tomorrow as I'm leaving after the meeting
15:28:48 <rdieter> ok
15:29:48 <mbriza> rdieter: tomorrow or they after, i'll open a request
15:30:04 <Kevin_Kofler> #action rdieter to work on the Qt 5.3 update.
15:30:09 <Kevin_Kofler> #action jgrulich to also work on the Qt 5.3 update.
15:30:23 <Kevin_Kofler> #action mbriza to open a review request for QAuth.
15:32:01 <Kevin_Kofler> So, if there's nothing else, I'll close the meeting in 60 seconds.
15:32:15 <jgrulich> rdieter: expect a lot of acl requests
15:33:30 <Kevin_Kofler> Thank you all for coming, see you (hopefully) next week!
15:33:33 <Kevin_Kofler> #endmeeting