15:15:01 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:15:01 <zodbot> Meeting started Tue Jun  3 15:15:01 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:15:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:15:06 <Kevin_Kofler> #meetingname kde-sig
15:15:06 <zodbot> The meeting name has been set to 'kde-sig'
15:15:10 <Kevin_Kofler> #topic Role call
15:15:15 * Kevin_Kofler is present, who else?
15:15:17 * jgrulich is present
15:15:37 * danofsatx-work is here
15:17:15 <Kevin_Kofler> dvratil, jreznik, rdieter, than, tosky: Ping?
15:17:26 <dvratil> present
15:17:51 <tosky> here
15:18:16 <mbriza> hi, sorry, preparing for exams
15:18:49 <Kevin_Kofler> mbriza: Tell us how SDDM is going and we let you leave. :-)
15:19:38 <mbriza> i opened a review for qauth last week (?)
15:19:45 <Kevin_Kofler> Great!
15:19:57 <mbriza> other than that, it's going quite well, the upstream is very lively lately
15:20:20 <Kevin_Kofler> I hope we can get it working well for F21.
15:20:29 <mbriza> i just need to get the other maintainers to look at the pull request to use qauth by default upstream, too
15:20:33 * rkratky is here
15:20:48 <Kevin_Kofler> #chair jgrulich danofsatx-work dvratil tosky mbriza rkratky rdieter
15:20:48 <zodbot> Current chairs: Kevin_Kofler danofsatx-work dvratil jgrulich mbriza rdieter rkratky tosky
15:21:44 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, danofsatx-work, dvratil, tosky, rkratky present, mbriza semi-present (preparing for exams), rdieter probably late (as announced on #fedora-kde).
15:22:05 <Kevin_Kofler> mbriza: Good luck for your exams, by the way! :-)
15:22:17 <mbriza> but from this point, everything points to working sddm in the autumn
15:22:20 <mbriza> Kevin_Kofler: thank you :)
15:23:43 <Kevin_Kofler> #topic Agenda
15:24:04 <danofsatx-work> yeah, god luck mbriza - I finished mine the first week of May.
15:24:45 <mbriza> i'm graduating in two weeks, so precisely speaking it's just one exam... but a large one :
15:24:54 <mbriza> congratulations, danofsatx-work :)
15:25:29 <Kevin_Kofler> So, what's up to discuss this week? Maybe the Plasma Product? (Last week, we deferred it because ltinkl wasn't present.)
15:25:38 <ltinkl> hi
15:25:47 <Kevin_Kofler> #chair ltinkl
15:25:47 <zodbot> Current chairs: Kevin_Kofler danofsatx-work dvratil jgrulich ltinkl mbriza rdieter rkratky tosky
15:25:52 <Kevin_Kofler> #info ltinkl also present.
15:26:18 * Kevin_Kofler hopes rdieter will show up too.
15:26:42 <ltinkl> the current status is to prepare and push the Fedora Plasma for F22
15:26:43 <Kevin_Kofler> I guess how (and whether) to proceed with the Plasma Product is going the main agenda item today, or is there anything else?
15:26:58 <ltinkl> (as it's late anyway for F21)
15:27:22 <Kevin_Kofler> #topic Plasma Product
15:27:33 <Kevin_Kofler> ltinkl: FESCo already rejected it for F21 anyway.
15:27:51 <ltinkl> Kevin_Kofler: yes
15:28:06 <Kevin_Kofler> The question is whether it makes still sense to pursue at all after the feedback we got.
15:28:06 <rdieter> here, finally, sorry
15:28:08 <ltinkl> so we will resume the process with F21 at full speed
15:28:32 <rdieter> you mean f22?
15:28:54 <ltinkl> rdieter: yes, targetting F22
15:29:08 <rdieter> fwiw, we're currently blocking on feedback from the board on the topic anyway
15:29:34 <Kevin_Kofler> See also the thread started by the maintainer of the current Scientific spin:
15:29:39 <Kevin_Kofler> #link https://lists.fedoraproject.org/pipermail/kde/2014-May/013585.html
15:29:41 <ltinkl> rdieter: is there a set date when the board should decide on the topic?
15:29:53 <rdieter> ltinkl: none I'm aware of
15:30:09 <rdieter> though we can ask for one
15:30:18 <rdieter> which wouldnt be unreasonable
15:30:27 <Kevin_Kofler> IMHO, being forced to target a user base disjoint from Workstation's is a non-starter.
15:30:30 * mattdm is having a busy day today, but -- I'm going to put this as pretty urgent on the board's agenda
15:31:03 <mattdm> there are some big, legitmate questions to decide, including what kevin just said
15:31:03 <Kevin_Kofler> And the double goal of being a KDE spin and a scientific spin also still doesn't make me happy (I had my reservations about that from the beginning).
15:31:04 <ltinkl> mattdm: thanks matt
15:31:07 * mattdm runs off again :)
15:31:09 <rdieter> mattdm: muchas gracias, mr. new leader sir
15:31:29 <Kevin_Kofler> See also my reply in that mailing list thread.
15:31:43 <rdieter> Kevin_Kofler: I agree with your sentiments there
15:31:50 <ltinkl> right, that's still up to us to decide imo
15:32:02 <ltinkl> where we want our product to go
15:32:11 <Kevin_Kofler> The fact that some people think we shouldn't be allowed to target developers just because GNOME claimed them first is entirely unacceptable.
15:32:58 * ltinkl likes how you started thinking strategically instead of pinpointing the details :)
15:33:02 <Kevin_Kofler> For every new niche that pops up, is this going to be a race at who manages to target them first, and everyone else should not be allowed to target them (even if it means removing features from upstream desktop environments to make them intentionally useless for that user base)?
15:33:02 <rdieter> Kevin_Kofler: +1, you cant have it both ways... either we use the Workstation umbrella completely/properly, of if we're excluded from there, have the freedom to make as we see fit.  essentially
15:33:28 <ltinkl> rdieter: definitely
15:33:54 <rdieter> I still think the best overall fit is under Workstation, but there may be too many political hurdles
15:33:57 <Kevin_Kofler> ltinkl: Is that comment supposed to be serious or sarcastic?
15:33:58 <ltinkl> so, having a proper Plasma Product is the way we should go imo, including devel stuff
15:34:05 <ltinkl> Kevin_Kofler: no, very serious
15:34:33 <ltinkl> but I had another idea, how would a Plasma product with a "Scientific Addon" sound like?
15:34:47 <rdieter> ltinkl: sounds nice
15:35:00 <rdieter> similar to how workstation + kde addon is being pitched now
15:35:07 <ltinkl> yes
15:35:13 <Kevin_Kofler> That would make a lot of sense.
15:35:44 <ltinkl> we (the KDE SIG) would take care of the product while the addon would be maintained (or fully converted) by the Sci SIG
15:36:26 <ltinkl> dvratil, tosky, jgrulich, kdefoo: what do the others think?
15:36:44 <Kevin_Kofler> There is still going to be some friction on what should be in that addon, of course. I'd want to feature all the KDE scientific stuff (see also the list of programs we added to the PRD (that was not well-received, by the way)), but the Scientific SIG is currently also shipping stuff like Eclipse.
15:36:50 <tosky> it makes sense, and it bring more manpower, with a correct splitting of roles
15:37:04 <Kevin_Kofler> But then again, if we leave the addon to the Scientific SIG, it's not really our problem. :-p
15:37:20 <ltinkl> Kevin_Kofler: not at all imho, as the scientific stuff would be managed by the Sci SIG
15:37:21 <dvratil> sounds like a good idea
15:37:31 <ltinkl> Kevin_Kofler: completely under their gestion
15:38:04 <ltinkl> the Plasma product itself would therefore include no scientific apps
15:38:06 <Kevin_Kofler> So "not our problem", as I said; they'll just add whatever they're adding now in their "Scientific KDE" images.
15:38:41 <ltinkl> ye, that way we get rid of the double target schizophrenia
15:39:49 <ltinkl> but we're basically changing the PRD and the Mission, so I assume we'd have to run thru Fesco again?
15:40:20 * jreznik is here, had another meeting
15:40:22 <Kevin_Kofler> BTW, I also really don't understand the complaints about concrete apps being listed in the PRD. Those were just there to prove that there are flagship KDE apps for those purposes.
15:40:23 <rdieter> ltinkl: yeah
15:40:45 <Kevin_Kofler> Sure, Workstation didn't write any program names into their PRD, but they had very clear ideas about those products from the beginning.
15:40:49 <rdieter> the current prd/mission is a bit of a farce anyway, concocted to satisfy artificial constraints
15:40:52 <Kevin_Kofler> (GNOME and GNOME apps.)
15:41:00 <Kevin_Kofler> They just didn't write it.
15:41:03 <ltinkl> rdieter: sort of yes
15:41:33 <Kevin_Kofler> But it's very clear that they had decided on the implementation before even writing a word of the PRD.
15:41:44 <ltinkl> that's true as well
15:42:14 <Kevin_Kofler> #chair jreznik
15:42:14 <zodbot> Current chairs: Kevin_Kofler danofsatx-work dvratil jgrulich jreznik ltinkl mbriza rdieter rkratky tosky
15:42:59 <ltinkl> ok so, let's vote on the Mission/PRD change :)
15:43:16 * ltinkl looks up the list of the WG members
15:43:24 <Kevin_Kofler> See also the farce at the beginning, where it was supposedly "not decided yet" that the desktop environment on Workstation would be GNOME, but "everyone" knew it and it was assumed throughout…
15:44:05 <ltinkl> umm, the Workstation WG members voted on that
15:44:15 * danofsatx-work is just SIG, so can't vote.
15:44:27 <Kevin_Kofler> ltinkl: I mean before they voted it.
15:44:39 <ltinkl> but with the majority of Gnome ppl there the outcome had been set from the start
15:44:53 <Kevin_Kofler> That farce was ongoing for months until the vote.
15:45:05 <Kevin_Kofler> But let's focus on our stuff now. :-)
15:45:12 <Kevin_Kofler> ltinkl: What exactly are we voting for? Changing from one Plasma/scientific Product to a Plasma Product with optional Scientific Addon, right?
15:45:29 <ltinkl> Kevin_Kofler: yes, with the mission clarification
15:45:45 <Kevin_Kofler> +1 to that.
15:46:02 <ltinkl> the current mission says:
15:46:03 <ltinkl> The WG aims to create a reliable, user-friendly and powerful operating system for laptops and PC hardware, leveraging the KDE Plasma Workspaces technologies. The system will be primarily aimed at providing educational and scientific software but should be attractive to a range of power users and content creators - people who build our community.
15:46:15 <tosky> ltinkl: just to be totally clear: is this going to raise the probability of being accepted?
15:46:33 <Kevin_Kofler> List of voting members: https://fedoraproject.org/wiki/Fedora_Plasma_Product#Why_Fedora_Plasma
15:46:41 <rdieter> tosky: unknown
15:46:47 <ltinkl> tosky: dunno but I think the concensus is that we don't want to go that way
15:46:58 <rdieter> ltinkl: +1, agreed
15:47:10 <tosky> I'm a bit lost, we don't want to go which way?
15:47:22 <tosky> the Plasma scientific product?
15:47:22 <rdieter> tosky: what's in the current product proposal
15:47:26 <ltinkl> the way of a bullshit compromise
15:47:32 <tosky> oh, ok
15:47:41 <ltinkl> (mildly put)
15:47:56 <tosky> come on, this is just a publicly recorded meeting :)
15:48:15 <ltinkl> zodbot has a filter I hope ;)
15:48:16 <rdieter> you mean the censors didn't bleep that out? :)
15:48:18 <Kevin_Kofler> Re acceptance, it's a 2-edged sword I think: The change will stop the objections that we are unclear or even dishonest on the goals of the Product, but it will also not make the "disjoint user bases" hardliners happy.
15:48:38 <rdieter> Kevin_Kofler: true
15:48:46 <jwb> question: this is all still for f22, correct?
15:48:52 <ltinkl> jwb: yes
15:48:56 <jwb> ok, thanks
15:49:00 <Kevin_Kofler> Still, I think the attempted compromise just doesn't work out and the proposed change is definitely an improvement.
15:49:03 <rdieter> jwb:  *something* post-f21, yes
15:49:17 <Kevin_Kofler> Thus my +1 to ltinkl's proposal.
15:49:35 <ltinkl> re-reading that mission statement, I think it's fine - what will change though is the implementation
15:49:50 <ltinkl> so the scientific stuff won't be part of the core but provided as an addon
15:50:01 <rdieter> ltinkl: agree, I like the mission
15:50:16 <tosky> but then " The system will be primarily aimed" is not true anymore
15:50:18 <tosky> it's an addon
15:50:21 <ltinkl> the mission continues with: And also as a platform for development of modern KDE and Qt applications - even in mobile space. The product will be built upon the foundations of the Fedora Base product and closely cooperating with the Workstation WG on the technical aspects and (inter)compatibility.
15:50:49 <rdieter> *could* consider emphasizing different stuff (than edu/scientific) or not mention it specifically at all anymore
15:50:50 <Kevin_Kofler> ltinkl: I'd change that "The system will be primarily aimed at providing educational and scientific software but should be attractive to a range of power users and content creators - people who build our community." sentence that was also criticized as a contradiction by some.
15:50:51 * ltinkl striking primarily
15:51:22 <ltinkl> and putting the developers on par with the rest, is that fine?
15:51:37 <rdieter> fine++ with me
15:51:52 <rdieter> (a step in the right direction anyway)
15:51:56 <jreznik> what about that "workstation" only way? aka there will be only workstation, both gnome and kde installed by default together, with gnome default in dm?
15:52:00 <Kevin_Kofler> Something like "The system should be attractive to a range of power users and content creators - people who build our community. There will be add-ons delivered based on our platform; the first such add-on will contain quality educational and scientific software."
15:52:29 <tosky> jreznik: is this a real possibility (two DE installed at the same time by default)?
15:52:47 <ltinkl> Kevin_Kofler: adding that
15:53:03 <Kevin_Kofler> ltinkl: That goes iInstead of the original sentence
15:53:06 <jreznik> tosky: I don't see any reason why not as Qt/KDE stack is going to be part of workstation too
15:53:11 <Kevin_Kofler> ltinkl: That goes instead of the original sentence or you repeat yourself.
15:53:19 <rdieter> jreznik: ok with me too, I assume the separate product plans here are assuming acceptable integration into workstation product does not happen
15:53:29 <ltinkl> jreznik: nope, only Qt
15:53:31 <jreznik> rdieter: yep
15:53:37 <Kevin_Kofler> tosky: IMHO, only if the primary deliverable is an installer rather than a live image (which would IMHO be a bad idea).
15:53:39 <ltinkl> only Qt will be part of the workstation
15:53:42 <jwb> rdieter, why wouldn't it happen?
15:53:43 <jreznik> ltinkl: the intitial idea was to have both
15:54:04 <tosky> ltinkl: not even in the future Frameworks world, or it has not been discussed?
15:54:04 <rdieter> jwb: ie, its just a fallback plan (to me)
15:54:07 <jwb> ltinkl, qt is the only thing installed by default at the moment.  we haven't really discussed the KDE aspects
15:54:17 <ltinkl> jreznik: but we don't want to (have the manpower) to maintain the KDE stack at 3 places
15:54:22 <Kevin_Kofler> tosky: With 2 desktops on a single live image (really one image, not a multi-boot hack like what the EMEA Ambassadors have at the moment), you're in for a gigantic mess in the menus.
15:54:34 <jreznik> ltinkl: there would be only 1 in the end - win for everyone
15:54:36 <rdieter> jwb: fwiw, I asked about kde-runtime on -desktop list... didnt get much (any?) response
15:54:55 <ltinkl> ye the response for KDE in workstation was none
15:54:56 <jwb> rdieter, yeah, i saw that.  the wg needs some refocusing
15:54:58 <jreznik> rdieter: then we should move it forward
15:55:01 <ltinkl> plus what I said
15:55:09 <Kevin_Kofler> (That, or massive OnlyShowIn/NotShowIn abuse that would be a step backwards IMHO, I like having the option of running apps that happen to use the "wrong" toolkit when I need them!)
15:55:31 <ltinkl> maintaining (currently) KDE in the KDE spin, preparing for Plasma product and taking care of Workstation is unrealistic
15:55:43 <Kevin_Kofler> To sum up:
15:55:44 <rdieter> Kevin_Kofler: its worth improving regardless, imho
15:55:45 <jwb> ltinkl, even you didn't chime in on the thread and you're in the WG...
15:56:08 <Kevin_Kofler> 1. 2 desktops on one live image is unrealistic (unless it's really a multi-boot image).
15:56:15 <jreznik> Kevin_Kofler: there would be nothing like gnome/kde apps, just possibility to have two different DEs... otherwise app selection would be better apps from both world which fit the right use case... with possibility to install full gnome/kde stacks
15:56:20 <rdieter> Kevin_Kofler: I disagree
15:56:22 <ltinkl> jwb: I discussed this with cschaller
15:56:23 <Kevin_Kofler> 2. Runtime only is entirely uninteresting and outside of our scope.
15:56:28 <jwb> ltinkl, on the list?
15:56:30 <Kevin_Kofler> What matters is the workspace and the apps.
15:56:47 <Kevin_Kofler> Users don't even SEE the runtime. And developers only see it if you install the -devel packages for it.
15:56:57 <jreznik> jwb: yeah, it should happen on the list
15:57:05 <Kevin_Kofler> Installing only the runtime parts with no workspace, no apps and no -devel packages is entirely useless.
15:57:13 <rdieter> Kevin_Kofler: kde-runtime is just a baby step in the right direction
15:57:20 <rdieter> not the final destination
15:57:20 <jreznik> rdieter: +1
15:57:26 <ltinkl> jwb: nope, on RH IRC
15:57:30 <jwb> ltinkl, if it wasn't a public discussion, then whatever you discussed is completely non-final
15:57:42 <Kevin_Kofler> Yum/DNF/PackageKit-hawkey/whatever will just install the runtime stuff as dependencies on the latter (the stuff the users REALLY want).
15:57:50 * rdieter agrees with jwb , the discussion(s) need more transparency
15:58:18 <ltinkl> agree too, he is the boss of the RH Desktop team and they decide, period
15:58:27 <jreznik> so maybe instead of trying to refocus kde product, let's restart this discission on desktop list again
15:58:37 <jwb> ltinkl, if that is truly the case, then i will resign as liasion immeidately
15:58:52 <Kevin_Kofler> So basically I don't give a darn about whether Workstation ships our runtime as long as it's only that, and I'd oppose shipping GNOME runtime material (that isn't dragged in as a dependency of something) on the same grounds (it's just useless on its own).
15:59:10 <jreznik> ltinkl: even I completely disagree, you should at least to share it to the public (and to the team)
15:59:21 <ltinkl> jwb: frankly if you thought the Workstation process and decision making would be transparent, you are naive, sorry to say that
15:59:32 <rdieter> Kevin_Kofler: then focus on the kde product stuff, leave workstation to others that care (like me and jreznik, ltinkl)
16:00:12 * jreznik really believes in fedora workstation - a real free desktop, not gnome/kde product whatever
16:00:16 <jwb> ltinkl, i'm not naive.  i viewed it as an opportunity to correct some things.  if you didn't see that as being the case, why did _you_ volunteer for the WG?
16:00:25 <ltinkl> I (we) will provide the Workstation team/product with the help their need but doing any extra work like maintaining KDE there is nonsense imo
16:00:32 <Kevin_Kofler> <ltinkl> jwb: frankly if you thought the Workstation process and decision making would be transparent, you are naive, sorry to say that
16:00:34 <Kevin_Kofler> +1
16:00:35 <ltinkl> jwb: I was naive too :)
16:00:49 <Kevin_Kofler> * jreznik really believes in fedora workstation - a real free desktop, not gnome/kde product whatever
16:00:52 <Kevin_Kofler> Hahahahaha!!!
16:00:52 <jwb> ltinkl, would you like to step down from the WG?
16:01:08 <Kevin_Kofler> As long as it's controlled by the RH Desktop Team, this isn't going to happen.
16:01:12 <jreznik> ltinkl: why extra work??? it would be actually less work - all desktop related stuff in one place
16:01:24 <Kevin_Kofler> The WG needs to be dissolved and replaced with KDE, Xfce, Cinnamon, MATE etc. people from the community.
16:01:54 <ltinkl> jwb: ye, the WG doesn't do much publicly anyway, the product moves on behind closed doors anyway
16:02:00 <Kevin_Kofler> It won't be hard to find them, we have all been organized in SIGs from the beginning (unlike the closed-circle GNOME cabal).
16:02:32 <jwb> ltinkl, if you'd like to resign, please do so on the list so we can find a replacement.  if you'd like to include your reasons, i would appreciate it
16:02:59 <jreznik> it's true, that workstation wg is less transparent than other wgs and weekly public meetings, more discussion on the list, on RH IRC would help it a lot
16:03:14 <Kevin_Kofler> jwb: The problem is, I doubt you'd find a replacement from outside the Desktop Team with the composition that the WG has now.
16:03:22 <ltinkl> ye anyhow, let's move back to our cause
16:03:24 <Kevin_Kofler> So it's going to be even more in their hands.
16:03:47 <Kevin_Kofler> jreznik: The discussions ought to be on #fedora-meeting* chans, not on RH IRC.
16:03:54 <jwb> my apologies for interrupting your meeting.
16:04:20 <ltinkl> Kevin_Kofler: https://fedoraproject.org/wiki/Fedora_Plasma_Product#Mission_Statement is that how you meant it?
16:04:20 <jreznik> jwb: np, it's actually good thing to discuss
16:05:29 <Kevin_Kofler> ltinkl: Well, I'd remove the "will be aimed at providing educational and scientific software but" part and leave that only to the next sentence about add-ons.
16:05:31 <rdieter> jwb: I appreciate the interrupion
16:05:54 <ltinkl> Kevin_Kofler: do so pls
16:05:57 <Kevin_Kofler> Right now there are still 2 possibly conflicting goals in that sentence.
16:06:37 <Kevin_Kofler> https://fedoraproject.org/wiki/Fedora_Plasma_Product#Mission_Statement
16:07:03 * jreznik has to go
16:07:34 <Kevin_Kofler> As for KDE runtime stuff on Workstation – I don't care either way whether they end up shipping it, but what I definitely don't want to do is MAINTAIN it there.
16:07:52 <Kevin_Kofler> As for KDE runtime stuff on Workstation – I don't care either way whether they end up shipping it, but what I definitely don't want to do is MAINTAIN it there.
16:07:52 <rdieter> Kevin_Kofler: there's no difference
16:08:21 <Kevin_Kofler> How do you maintain something that isn't used by anything? It's not even testable that way.
16:08:32 <ltinkl> Kevin_Kofler: if it's pulled from the repos, it will be the same as in our Plasma Product
16:08:39 <Kevin_Kofler> Shipping libraries and runtime packages with nothing that uses them nor -devel packages is just useless.
16:09:03 <Kevin_Kofler> We'd maintain them for our Product and they can ship them or not ship them as they see fit.
16:09:06 <rdieter> Kevin_Kofler: its not useless, users, OEMs, etc... can know that it's part of the default/shipped platform
16:09:34 <rdieter> if you dont hold that as a value, fine, but I know it is of value to others
16:09:46 <tosky> if the base repositories are the same, once installed, people will install applications regardless of the base
16:10:34 <Kevin_Kofler> For me, installing libraries is the job of the depsolver, I don't want to have libraries (no matter what libraries!) on my system that aren't actively used by anything.
16:11:03 <Kevin_Kofler> So having KDE libraries without a Plasma Workspace and without any KDE applications is just pointless.
16:11:14 <rdieter> to *you*.  now, can we move on please?
16:11:22 <Kevin_Kofler> (unless it's for the "developers" user base, in which case, it needs the -devel packages, too!)
16:11:48 <Kevin_Kofler> KDE as a platform for developers would be a great thing for a Product that claims to target developers to ship.
16:11:55 <rdieter> (and I thought you didnt care to be involved in Workstation stuff? :) )
16:12:04 <Kevin_Kofler> But that means kf5-*-devel (or my proposed kf5-devel metapackage :-p ).
16:12:56 <Kevin_Kofler> If they ship only the runtime parts, we are going to be "the dead weight that's getting forced on everyone for political reasons and that makes the live image go above x.xx GiB".
16:12:59 <rdieter> can we get back to discussing plasma product?
16:13:06 <Kevin_Kofler> Is that really the reputation we want to achieve?
16:13:08 <ltinkl> yup pls
16:13:28 * rdieter has to go soon, so would like some progress there
16:13:41 <ltinkl> to wrap up our meeting (as we're running short on time), let's vote on the re-focusing of the Plasma product
16:13:55 <Kevin_Kofler> So, we had a proposal, we're still waiting for votes from most folks.
16:13:57 <ltinkl> I (we) can change the exact wording later after the meeting
16:14:09 <ltinkl> yes so +1 from me obviously
16:14:18 <rdieter> +1
16:14:19 <ltinkl> than, jgrulich, tosky, dvratil: ?
16:14:27 <Kevin_Kofler> +1 from me as already stated.
16:14:29 <jgrulich> +1
16:14:35 <tosky> +1
16:14:36 <dvratil> +1
16:14:59 <Kevin_Kofler> That's +6, we're 11 people, the proposal passes.
16:15:26 <ltinkl> mbriza: ?
16:15:33 <ltinkl> ok :)
16:15:58 <rdieter> we need to find the WG members who dont (regularly) attend these meetings, and either poke them to do better, or find replacements, imo
16:16:10 <Kevin_Kofler> #agreed We will refocus the Plasma Product into a core Plasma Product (maintained by us) and a Scientific Addon (maintained by the Scientific SIG).
16:16:30 <ltinkl> #agreed the current goal stays F22
16:17:02 <Kevin_Kofler> I thought that was obvious, but OK. :-)
16:17:10 <Kevin_Kofler> #info (The proposal passed with +6, -0, 0 abstentions, 5 absent.)
16:17:33 <mbriza> i will be here, i promise
16:17:33 <mbriza> :)
16:17:54 <Kevin_Kofler> mbriza: So, do you want to vote for the record?
16:18:05 <ltinkl> I updated the PRD accordingly to the front page mission
16:18:20 <mbriza> yes, +1
16:18:24 <Kevin_Kofler> #undo
16:18:24 <zodbot> Removing item from minutes: INFO by Kevin_Kofler at 16:17:10 : (The proposal passed with +6, -0, 0 abstentions, 5 absent.)
16:18:30 <Kevin_Kofler> #info (The proposal passed with +7, -0, 0 abstentions, 4 absent.)
16:18:31 <ltinkl> now, looking at our target audience at: https://fedoraproject.org/wiki/Fedora_Plasma_Product/PRD#Target_Audience
16:18:32 <Kevin_Kofler> :-)
16:18:53 <ltinkl> I think we should put the "Power User" in front, opinions?
16:19:16 <Kevin_Kofler> Agreed.
16:20:22 <tosky> and the rest, same order?
16:20:47 <ltinkl> I will resume the work on the tech spec in the following days/weeks (of course anybody is welcome too)
16:21:03 <Kevin_Kofler> Hmmm… I'd personally see "Developer" somewhere near the front, but then people will complain that we're playing on Workstation's lawn…
16:21:04 <ltinkl> tosky: I think it's fine
16:21:05 <rdieter> yes, my personal preference: 1 power user 2. content creator 3 developer  not sure where student/scientist fits, if at all anymore
16:21:29 <tosky> rdieter: with the scientific addon!
16:21:37 <ltinkl> so basically revesing the order? :)
16:21:41 <ltinkl> reversing even
16:22:00 <rdieter> tosky: sure, but the addon isnt available by default, why target someone who can't use the default product (without addon)?
16:22:32 <Kevin_Kofler> The targets for the addon should be listed in the PRD unless we (or the Scientific SIG) do a separate PRD for the addon.
16:23:00 <Kevin_Kofler> Of course, it should be mentioned that those would be covered by the addon and not by stuff shipped on the default image.
16:23:45 <rdieter> yeah something like that, or just keep them listed as-is.  I don't have a strong feeling either way
16:24:08 <ltinkl> I'll keep them with a remark "provided by the addon"
16:24:15 <rdieter> ok
16:24:27 <Kevin_Kofler> For the Content Creator stuff, do we want to keep Blender listed there? It's not a KDE/Qt app…
16:25:01 <Kevin_Kofler> I'd remove it.
16:25:32 <ltinkl> Kevin_Kofler: I'd keep it, it doesn't drag in any Gtk/Gnome stuff does it? (afaik it has its own toolkit)
16:26:18 <rdieter> keep++ (though it *is* pretty big)
16:26:42 <Kevin_Kofler> We aren't realistically going to ship it by default, are we?
16:26:52 <Kevin_Kofler> I doubt it makes sense to even ship all the Qt/KDE apps we listed by default.
16:27:18 <ltinkl> ye, we'll clarify that as we got thru the tech specs
16:27:32 <rdieter> let's worry about size constraints later, shoot for the moon for now
16:27:32 <ltinkl> I'd leave it open for now
16:27:33 <rdieter> ltinkl: +1
16:28:28 <Kevin_Kofler> Speaking of shipping stuff that drags in extraneous dependencies, are we still set on shipping Firefox, even after the DRM fiasco? :-(
16:28:40 <Kevin_Kofler> https://fsf.org/news/fsf-condemns-partnership-between-mozilla-and-adobe-to-support-digital-restrictions-management
16:28:56 <Kevin_Kofler> Yet another reason why IMHO Firefox is totally unacceptable.
16:29:01 <ltinkl> tough one
16:29:09 <rdieter> fwiw, the drm thing doesn't change my view any
16:29:27 <ltinkl> if it was for me and the least possible, I'd go with chromium
16:29:45 <ltinkl> faster, leaner, with some KDE integration
16:29:46 <rdieter> its just a(nother) api for 3rd-party implementers (like nsplugins are now)
16:29:59 <Kevin_Kofler> Chromium, ewww…
16:30:29 <Kevin_Kofler> (We'll have to deal with that crap sooner or later with QtWebEngine though, argh!)
16:30:59 <Kevin_Kofler> But as long as it's not in Fedora, it's not a realistic option.
16:31:46 <Kevin_Kofler> And Google also supports DRM in HTML5 (though Chromium will probably not support it, they're hardcoding it in the proprietary pieces of Chrome).
16:32:28 <ltinkl> Kevin_Kofler: yes
16:33:25 <Kevin_Kofler> I still believe a KDE/Plasma-based spin or Product needs to ship a KDE browser, i.e. Konqueror or Rekonq.
16:34:25 <ltinkl> I believe we don't have to discuss it here again (yet)
16:34:56 <rdieter> agreed, rehashing wont change anything here and now
16:35:17 <Kevin_Kofler> And the way Firefox tramples on your freedom (DRM etc.) and privacy (anti-phishing "protection" etc.) also ought to be a disqualifier!
16:35:42 <Kevin_Kofler> rdieter: Something changed since the vote: the DRM fiasco.
16:35:58 <Kevin_Kofler> Even if it doesn't matter to YOU, I hope it opens SOMEBODY's eyes!
16:35:58 <ltinkl> Kevin_Kofler: agree but pls pretty pls, not now :)
16:37:04 <ltinkl> anything else to conclude the meeting? any outstanding issues/problems with the current Plasma Product documents?
16:37:24 <rdieter> ltinkl: cant think of anything else *right now*
16:37:26 <Kevin_Kofler> Other than the mention of Firefox under "Integration" (sic!)?
16:37:56 <rdieter> ltinkl: mind posting something to kde@lists.fpo to remind folks to look it over again for feedback?
16:38:04 <ltinkl> rdieter: sure
16:38:09 <rdieter> danke
16:39:17 <ltinkl> are the Sci spin folks subscribed? I guess we should keep them in the loop
16:39:52 <Kevin_Kofler> At least Amit Saha seems to be following now.
16:40:37 <rdieter> ltinkl: good point, they have their own list... maybe post there too, or invite them to kde@...
16:43:26 * rdieter has to go soon
16:44:00 <Kevin_Kofler> Yeah, we're way over time, can we stop here please? :-)
16:44:36 <Kevin_Kofler> We started 15 minutes late and have already gone on for 90 minutes!
16:44:52 <Kevin_Kofler> Closing meeting in 30 seconds.
16:45:27 <Kevin_Kofler> OK, that's all for today (finally!), thanks all for coming, and see you (hopefully) next week!
16:45:29 <Kevin_Kofler> #endmeeting