15:07:03 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:07:03 <zodbot> Meeting started Tue Jun 10 15:07:03 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:10 <Kevin_Kofler> #meetingname kde-sig
15:07:10 <zodbot> The meeting name has been set to 'kde-sig'
15:07:16 <Kevin_Kofler> #topic Role call
15:07:18 * jgrulich is present
15:07:33 * Kevin_Kofler is present (despite the heat), who else?
15:07:34 * danofsatx-work is here
15:07:36 * pino|work is here
15:08:43 <danofsatx-work> btw, it's roll call - unless of course you wish us to state our roles as part of the SIG ;)
15:09:25 <Kevin_Kofler> #undo
15:09:25 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0xac87850>
15:09:28 <Kevin_Kofler> #topic Roll call
15:09:42 <Kevin_Kofler> :-)
15:09:42 <Kevin_Kofler> Better now?
15:09:43 <Kevin_Kofler> Sorry for the Engrish. ;-)
15:09:44 <danofsatx-work> heh ;)
15:10:19 * danofsatx-work is operating on lack of sleep and coffee, so please forgive the outbursts
15:12:03 <Kevin_Kofler> Is 4 people (one of whom is not even in that list of voting WG members) now the new attendance standard for the meetings?
15:12:36 <Kevin_Kofler> If the spelling of "roll call" is the most interesting thing to discuss, why do we even still do weekly meetings?
15:13:44 <Kevin_Kofler> I'd like to discuss the readiness of Apper AppStream support for F21, but without 8/11 of the WG, it doesn't make much sense, grrr…
15:15:09 <Kevin_Kofler> dvratil, mbriza, rdieter, rdieter_work, than: Ping?
15:16:24 <Kevin_Kofler> In particular, I'm also fed up of having to "run after" 90% of the people every week.
15:16:51 <dvratil> hi,
15:17:26 <Kevin_Kofler> ltinkl_: So can I consider you present?
15:18:31 <ltinkl_> Kevin_Kofler: yup
15:18:33 <ltinkl_> hi
15:20:15 <Kevin_Kofler> #chair jgrulich danofsatx-work pino|work dvratil ltinkl
15:20:15 <zodbot> Current chairs: Kevin_Kofler danofsatx-work dvratil jgrulich ltinkl pino|work
15:20:31 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, danofsatx-work, pino|work, dvratil, ltinkl present.
15:20:37 <Kevin_Kofler> #topic Agenda
15:20:56 <Kevin_Kofler> So, enough waiting, who doesn't show up loses…
15:21:09 <danofsatx-work> [09:01] <rdieter> hi, I'm going to miss all/most of the kde-sig meeting time today, got roped into taking a pet to vet at the same time
15:21:16 <danofsatx-work> from #fedora-kde
15:21:58 <Kevin_Kofler> So, agenda items please…
15:22:17 <Kevin_Kofler> As I already mentioned: readiness of Apper AppStream support for F21
15:23:00 <ltinkl> anybody knows more about this?
15:23:02 * ltinkl not
15:23:16 <ltinkl> there should be "some" support
15:23:29 <Kevin_Kofler> Jun 10 14:10 <rdieter> good topic to discuss though: ready to do official kde-4.13.3 builds for f20? (and possibly considering a kde x.y+1 update for f19 too)
15:23:34 <Kevin_Kofler> There was also this one.
15:24:18 <Kevin_Kofler> #topic readiness of Apper AppStream support for F21
15:24:34 <Kevin_Kofler> ltinkl: I must say I don't know all the details either, but here's what I know.
15:24:52 <Kevin_Kofler> * Apper is now built with AppStream support enabled in Rawhide/F21.
15:25:36 <Kevin_Kofler> * That support uses libappstream (not libappstream-glib as in GNOME Software, GNOME reinvented the wheel because libappstream was supposedly "not stable enough" when they wanted to use it).
15:26:11 <Kevin_Kofler> * The problem is, AppStream data is still not on the mirrors, and the current workaround is that it is shipped INSIDE the GNOME Software package.
15:26:41 <Kevin_Kofler> Needless to say, this means Apper can't realistically use it out of the box, because it can't really Require GNOME Software.
15:27:27 <ltinkl> isn't the appstream metadata shipped in a separate noacrh package?
15:27:33 <Kevin_Kofler> * Another issue is that AppStream is, in Fedora, generated exclusively from AppData, a GNOME-driven standard for per-application AppStream data that has upstream support mostly only from GNOME.
15:27:49 * ltinkl thought it was
15:28:19 <Kevin_Kofler> In particular, the core KDE software still does NOT ship AppData upstream, and we aren't shipping it by ourselves.
15:28:48 <Kevin_Kofler> This means the applications Apper users will actually be looking for the most do NOT have AppStream data in Fedora.
15:29:10 <Kevin_Kofler> IMHO, that needs fixing if we are to keep AppStream support enabled for the F21 release.
15:29:38 <Kevin_Kofler> ltinkl: Let me check the details.
15:31:07 <Kevin_Kofler> ltinkl: No, it's not.
15:31:09 <Kevin_Kofler> See for yourself:
15:31:13 <Kevin_Kofler> http://pkgs.fedoraproject.org/cgit/gnome-software.git/tree/gnome-software.spec
15:31:39 <Kevin_Kofler> ltinkl: No, it's not.
15:31:39 <Kevin_Kofler> See for yourself:
15:31:41 <Kevin_Kofler> http://pkgs.fedoraproject.org/cgit/gnome-software.git/tree/gnome-software.spec
15:31:51 <ltinkl_> :/
15:31:57 <Kevin_Kofler> See Source1 and Source2 there and the "# install AppStream data for Fedora" part, and no subpackages.
15:32:32 <Kevin_Kofler> IMHO, as long as that's not solved, AppStream support in Apper is a farce and must be disabled.
15:34:11 <Kevin_Kofler> If the data stays in packages, it needs to go into a noarch package that both libappstream-glib (not gnome-software!) and libappstream can Require.
15:34:12 <ltinkl_> I agree it's suboptimal but as the support is optional, it doesn't have to be completely disabled
15:34:17 <pino|work> (s/in Apper// imho)
15:34:56 <Kevin_Kofler> But really, that stuff belongs onto the repository to begin with.
15:35:18 <Kevin_Kofler> But Fedora Infrastructure is dragging their feet there. :-(
15:35:30 <Kevin_Kofler> So we should push for getting the subpackage.
15:35:46 <Kevin_Kofler> The other issue is the AppData for KDE software.
15:36:07 <ltinkl_> 17:35] <hughsie> yes, i think that's what we're going to have to do for f21
15:36:17 <ltinkl_> hold on :)
15:36:24 <Kevin_Kofler> AFAIK, all that's required there is that it is included in SOME package in Fedora, it doesn't have to be the package actually providing the software.
15:37:06 <Kevin_Kofler> So I propose we take the latest of those "AppData for KDE software" tarballs and stuff it into a dummy subpackage of kde-settings.
15:37:42 <Kevin_Kofler> (one that won't be actually installed by users, but just used for hughsie's AppData→AppStream compose)
15:38:17 <ltinkl_> Kevin_Kofler: sounds good
15:38:34 <ltinkl_> meanwhile hughsie will do the noarch package (in the following days)
15:38:50 <Kevin_Kofler> OK, that's good news.
15:40:19 <Kevin_Kofler> I'll check on the upstream status of AppData, I only know about the tarball from the upstream mailing list thread a while ago, I need to check if there's something more recent.
15:40:32 <Kevin_Kofler> (of AppData for KDE software, obviously)
15:40:46 <ltinkl_> [17:40] <hughsie> right, agreed
15:40:48 <ltinkl_> [17:40] * hughsie writes a spec file
15:41:21 <Kevin_Kofler> #info hughsie will do a noarch package with the AppStream data.
15:41:34 <Kevin_Kofler> #action Kevin_Kofler to look into the status of AppData for KDE software.
15:42:18 <Kevin_Kofler> ltinkl: I guess that's it for this topic, right?
15:42:59 <Kevin_Kofler> #topic ready to do official kde-4.13.3 builds for f20?
15:43:07 <Kevin_Kofler> So rdieter proposed this one.
15:43:18 <Kevin_Kofler> Any opinions here?
15:43:45 <Kevin_Kofler> IMHO, yes, but we should get kcm-balooadv dragged in by default somehow or our users will scream.
15:44:07 <Kevin_Kofler> As for F19, I'm honestly not sure what to do at this point.
15:44:29 <Kevin_Kofler> rdieter proposed pushing a 4.12 update there now, an idea I'm not sure I like.
15:45:01 <Kevin_Kofler> We'd be updating a very outdated KDE software compilation to a somewhat outdated one.
15:45:57 <Kevin_Kofler> 4.12 should really have been pushed to begin with, but it's too late to talk about that now.
15:48:11 <Kevin_Kofler> Proposal: Defer to next week when rdieter will (hopefully) be there…
15:48:25 <Kevin_Kofler> (Not much sense to "discuss" this if I'm the only one writing anything.)
15:49:57 <Kevin_Kofler> #info deferred to next week, no quorum
15:50:01 <Kevin_Kofler> #topic Open discussion
15:50:14 <Kevin_Kofler> Anything else? Otherwise, I'll be closing the meeting in 60 seconds.
15:50:27 <danofsatx-work> is there any update to sddm?
15:50:50 <ltinkl> oh ye, mbriza?
15:51:32 <Kevin_Kofler> danofsatx-work: I know mbriza submitted QAuth for review:
15:51:35 <Kevin_Kofler> .bug 1101235
15:51:38 <zodbot> Kevin_Kofler: Bug 1101235 Review Request: qauth - Qt user authentication library - https://bugzilla.redhat.com/1101235
15:52:00 <Kevin_Kofler> That package is a prerequisite for getting his latest code into Rawhide.
15:52:26 <Kevin_Kofler> (That library now handles the authentication stuff, that was previously internal to sddm.)
15:53:39 <Kevin_Kofler> He refactored the PAM code into a library because it can also be useful for other Qt/KDE applications.
15:53:58 <Kevin_Kofler> So now the import into Rawhide is blocking on that review request.
15:54:22 <Kevin_Kofler> What I don't know is whether there's any cool new stuff in QAuth or SDDM.
15:54:37 <Kevin_Kofler> There you best ask mbriza directly. :-)
15:55:29 <danofsatx-work> I've been offline for 5 days, so I wasn't sure if I missed any updates from him
15:56:25 <Kevin_Kofler> I don't have any.
15:57:32 <Kevin_Kofler> (other than that review request)
15:57:52 <Kevin_Kofler> So, anything else or are we done for today? (Time is running up.)
15:58:49 <Kevin_Kofler> OK, I guess that's all then, thanks for coming, see you next week!
15:58:52 <Kevin_Kofler> #endmeeting