15:03:05 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:03:05 <zodbot> Meeting started Tue Jun 24 15:03:05 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:10 <Kevin_Kofler> #meetingname kde-sig
15:03:10 <zodbot> The meeting name has been set to 'kde-sig'
15:03:15 <Kevin_Kofler> #topic Roll call
15:03:17 * jgrulich is present
15:03:24 * Kevin_Kofler is present, obviously.
15:03:42 * rkratky is here
15:04:30 <dvratil> hola hey
15:04:48 <than> present
15:05:02 <tosky> hi (but I need to leave soon)
15:05:04 <mbriza> hi
15:05:39 <rdieter> here
15:05:58 <jgrulich> tosky: we don't, because Czech team didn't make it qualification :)
15:06:06 <jgrulich> *in qualification
15:07:18 <Kevin_Kofler> #chair jgrulich rkratky dvratil than tosky mbriza rdieter
15:07:18 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich mbriza rdieter rkratky than tosky
15:07:23 <Kevin_Kofler> tosky: Me too. :-)
15:07:54 <Kevin_Kofler> #info jgrulich, Kevin_Kofler, rkratky, dvratil, than, tosky, mbriza, rdieter present.
15:09:50 <Kevin_Kofler> #topic Agenda
15:10:58 <dvratil> KF5 import update
15:11:10 <jgrulich> Qt 5.3.1 update + https://bugzilla.redhat.com/show_bug.cgi?id=1103185
15:11:18 <Kevin_Kofler> .bug 1103185
15:11:22 <zodbot> Kevin_Kofler: Bug 1103185 Qt 5.3.0 defaults to sse2 x86 support - https://bugzilla.redhat.com/1103185
15:11:31 <Kevin_Kofler> OK
15:11:50 <Kevin_Kofler> Let's start quickly, so tosky and I can watch soccer. :-)
15:12:00 <Kevin_Kofler> #topic KF5 import update
15:12:04 <Kevin_Kofler> dvratil: Your turn.
15:12:25 <dvratil> Tier 1 and Tier2 is imported and built
15:12:39 <dvratil> All Tier 3 and Tier 4 frameworks are in Bugzilla for review
15:12:55 <dvratil> it's a lot of packages, so if you have spare time, please help jgrulich with reviews
15:13:09 <Kevin_Kofler> #info Tier 1 and Tier2 is imported and built. All Tier 3 and Tier 4 frameworks are in Bugzilla for review.
15:13:16 <rdieter> awesome
15:13:18 <dvratil> I think we made about 6 packages today, but there's still lot to go
15:13:23 <Kevin_Kofler> Great, thanks!
15:13:55 <dvratil> and that's it. So far no troubles, which is rather surprising :)
15:14:04 <Kevin_Kofler> Let's move on.
15:14:11 <jgrulich> ltinkl did 2 packages today, so as I know 23 packages are remaining
15:14:23 <jgrulich> around 23
15:14:28 <Kevin_Kofler> OK
15:14:42 <Kevin_Kofler> #topic Qt 5.3.1 update, SSE2 issue (#1103185)
15:14:49 <Kevin_Kofler> .bug 1103185
15:14:55 <zodbot> Kevin_Kofler: Bug 1103185 Qt 5.3.0 defaults to sse2 x86 support - https://bugzilla.redhat.com/1103185
15:15:15 <Kevin_Kofler> #link https://bugzilla.redhat.com/1103185
15:15:36 <Kevin_Kofler> jgrulich: That's your topic.
15:15:54 <jgrulich> I'm going to do the update tomorrow as I wanted last week, but they delayed the release
15:16:12 <jgrulich> rdieter: can you please enable f20-kde and f19-kde targets in koji?
15:16:37 <rdieter> ok, will do
15:17:03 <Kevin_Kofler> #action jgrulich is going to do the update tomorrow. (Upstream delayed the release.)
15:17:42 <than> back to Bug 1103185
15:18:07 <Kevin_Kofler> That one should be "fixed" now, as in, it'll get automatically addressed when everything gets rebuilt for 5.3.1.
15:18:23 <Kevin_Kofler> We fixed qt5-qtbase.
15:18:25 <rdieter> Kevin_Kofler: than, I think, is arguing sse2 should be re-enabled
15:18:30 <than> do we want to enble sse2 by default ?
15:18:37 <Kevin_Kofler> No. It's against Fedora policies.
15:19:04 <Kevin_Kofler> 32-bit x86 packages must run on any i686, they MUST NOT require SSE2.
15:19:39 <Kevin_Kofler> SSE2-optimized binaries can be shipped in /usr/lib/sse2 (which we do for the relevant parts of Qt).
15:19:45 <tosky> if there is an official Fedora policy that can be used as reference (a link), then there is no much to discuss imho
15:20:06 <Kevin_Kofler> (Well, IIRC QtGui could use it, too, for the other stuff where it matters, it's already done.)
15:20:22 <than> Kevin_Kofler: do yu have link Fedora policies.?
15:20:22 * rdieter agrees with Kevin_Kofler, in the least, it wouldnt be nice to knowingly break things for some folks (older processors, otherwise supported by fedora)
15:20:24 <Kevin_Kofler> (all the JIT-enabled stuff)
15:20:54 <Kevin_Kofler> than: Let me dig it up, just a minuteā€¦
15:21:50 <Kevin_Kofler> This was discussed when F12 moved to requiring i686. The original proposal was to require SSE2 too, but it was rejected. No more recent decision has been made, so this is still valid policy (and IMHO it should stay that way).
15:22:04 <rdieter> http://fedoraproject.org/wiki/Features/F12X86Support   hinted-at here
15:22:44 <Kevin_Kofler> Yeah, I found that too now, but rdieter was quicker. :-)
15:22:56 <Kevin_Kofler> #link https://fedoraproject.org/wiki/Features/F12X86Support
15:23:22 <rdieter> http://fedoraproject.org/wiki/Talk:Features/F12X86Support   mentions sse2
15:23:40 <Kevin_Kofler> Right, there was some discussion on that. Also on the mailing list.
15:23:47 <Kevin_Kofler> In the end, it was decided to not require SSE2.
15:23:56 <tosky> just to be sure, is the runtime detection going to be enabled, so that if sse2 are there they are going to be used?
15:24:29 <Kevin_Kofler> tosky: Yes and no. Qt no longer supports runtime detection by itself. glibc does though, that's what the /usr/lib/sse2 stuff is for.
15:24:39 <than> ok, it's fedora police. we have to follow.
15:24:43 <Kevin_Kofler> So where it matters, a separate SSE2 build has to be made.
15:24:48 <dgilmore> rdieter: it does and says it was reverted
15:24:50 <tosky> ok
15:25:20 <tosky> so it's decided I guess
15:25:31 <Kevin_Kofler> The thing is, almost all SSE2-enabled CPUs also support AMD64/Intel 64.
15:25:46 <than> yes, we will build sse2 stuffd separate
15:25:49 <Kevin_Kofler> The only exception is early Pentium 4 CPUs (like the one I'm typing this text on).
15:26:02 <Kevin_Kofler> So very very few people actually benefit from 32-bit SSE2.
15:26:13 <tosky> or first eeepc on atom processor I guess
15:26:30 <Kevin_Kofler> People who have a Prescott or newer, or Athlon 64 or newer, should be running x86_64, not i686.
15:26:36 * rdieter has one of those eeepc's sitting next to me :-/
15:26:50 <tosky> aaaanyway
15:27:05 <tosky> can we proceed? :)
15:27:27 <Kevin_Kofler> Yeah, and I have an early P4 in front of me. :-)
15:27:40 <Kevin_Kofler> That's 2 machines, and there are the /usr/lib/sse2 builds for those.
15:27:49 <Kevin_Kofler> tosky: +1 :-p
15:27:53 <Kevin_Kofler> #topic Open discussion
15:27:54 <than> move on please
15:27:56 <Kevin_Kofler> Anything else?
15:29:01 <Kevin_Kofler> Looks like not. :-) So thanks everyone for coming, see you next week!
15:29:04 <Kevin_Kofler> #endmeeting