15:06:01 <pknirsch> #startmeeting Fedora Base Design Working Group (2014-06-27)
15:06:01 <zodbot> Meeting started Fri Jun 27 15:06:01 2014 UTC.  The chair is pknirsch. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:07 <pknirsch> #meetingname  Fedora Base Design Working Group
15:06:08 <zodbot> The meeting name has been set to 'fedora_base_design_working_group'
15:06:13 <pknirsch> okiedokie, ready now
15:06:24 <pknirsch> sorry for the delay, but lets get going.
15:06:39 <pknirsch> #chair masta haraldh dgilmore
15:06:39 <zodbot> Current chairs: dgilmore haraldh masta pknirsch
15:07:03 <pknirsch> Jreznink already mentioned he can't make it today, to lets just get started
15:07:35 <pknirsch> #topic Collect and discuss candidates for open positions in WG
15:07:51 <masta> howdy
15:07:55 <pknirsch> Heya :)
15:08:19 * pknirsch remembers he was supposed to send out an email regarding the open spots
15:08:21 <pknirsch> Ugh :/
15:08:25 <pknirsch> totally forgot that.
15:08:29 * pknirsch makes a note
15:09:08 <pknirsch> Did any of you have a chance to talk to other people yet that might be interested for the positions yet?
15:10:25 <masta> I've mentioned it to one person, but then quickly realized it would be best to formalize things... wait for a memo to be sent to devel
15:10:39 <masta> so... just casual chit'chat
15:10:58 <pknirsch> mhm
15:11:00 <haraldh> nope
15:11:15 <haraldh> haven't met any in person :)
15:11:42 <masta> we have one opening for sure, maybe two.
15:12:19 <pknirsch> aye
15:12:58 <pknirsch> I've had a chance to talk with a few folks, nothing definitive yet but some interest has been voiced. But let me put together the email and send it after the meeting today so i won't forget
15:14:02 <pknirsch> Alright, then lets move on to the next topic
15:14:14 <pknirsch> #topic Updated on help for Base WG (pknirsch)
15:16:37 <masta> ?
15:16:39 <pknirsch> Quick update here: We know have a new person here in our office in STR, Benedikt Morbach. He's an intern from the university in Chemnitz and will be working on the requires/buildrequires work over the next weeks and months. So we should see some first things from him in the next few weeks already.
15:17:03 <masta> excellent
15:17:24 <pknirsch> And he'll be joining us here on IRC starting next week, so we'll be able to involve him more directly then, too
15:17:41 <pknirsch> He's already picking things up really quickly, started doing package reviews on his first day here etc.
15:17:57 <masta> wow
15:18:16 <masta> that is great
15:18:16 <pknirsch> So i'm really happy we got him. So far he's been working mainly as a maintainer for another distribution (source based, derived from Gentoo) and maintains libreoffice there :)
15:18:32 <pknirsch> Which means he has some strong distribution work background
15:18:51 <pknirsch> While not rpm based, he's worked with Fedora and rpms before
15:19:19 <masta> sounds like a solid foundation
15:19:34 <pknirsch> And if he has some cycles left i thought we might hook him up with you masta  and dgilmore as well to see if he can help with some of the rel-eng stuff, too
15:20:24 <masta> pknirsch: ok, we will need to think of some tasks for him. Does he write python by any chance?
15:21:22 <pknirsch> He has done some work with python, but he's most proficient in C and bash (using bash scripts to build and maintain libreoffice, imagine that ;)))
15:21:47 <masta> well regardless we will think of things, we are supposed to be doing that anyways for attracting new participants to rel-eng
15:21:55 * pknirsch nods
15:22:12 <pknirsch> I really like him, he's been asking the right questions and just set off doing stuff :)
15:22:23 <pknirsch> (and reading through tons of FPC pages :)))
15:24:32 <pknirsch> Depending on some other stuff, we might get another person involved as well, but thats still a bit in the air due to other tasks on that persons plate.
15:24:55 <pknirsch> But hopefully that will be complete soonish, so we'll have another one being able to help a lot.
15:25:28 <pknirsch> So i'll introduce Benekdikt next week to all of you.
15:26:36 <masta> cool
15:27:20 <pknirsch> Ok, thats all from that topic from my side
15:27:47 <pknirsch> So lets open the floor for other topics
15:27:52 <pknirsch> #topic Open floor
15:27:57 <pknirsch> anyone got anything else?
15:30:26 <masta> so I was working on perl in the kernel, and after talking to the kernel team more... demoralized
15:31:02 <masta> I'm not the first to give this a try, and evidently perl is in the kernel deeply, so I'll have to work with upstream to untangle the mess.
15:31:31 <masta> probably move on to more low hanging fruit, for now, and keep the perl/kernel thing as a back project longer term
15:31:34 <pknirsch> mhm
15:32:04 <pknirsch> Is it due to the specfile and scripts used there or really in the kernel source and build process itself?
15:32:14 <masta> the later
15:32:30 <pknirsch> (not that i'd recommend messing with the specfile a lot either, but that would at least be a tad easier)
15:32:38 <pknirsch> oh my
15:32:45 <masta> Josh was able to enlighten me on the depth and width of the perl mess.
15:33:10 <masta> some kernel facilities use perl as an interface
15:33:21 <masta> ftrace for example, and I think one other
15:34:18 <masta> don't get me saying untrue things, but it's not as trivial as I had hoped, so won't bother with details that I would probably characterize wrong
15:35:34 <masta> that is all from me
15:36:48 <pknirsch> Oki
15:36:57 <pknirsch> thanks masta
15:37:07 <pknirsch> it was certainly worth trying :)
15:38:37 <haraldh> :-/
15:40:28 <pknirsch> Alright, if thats all for today thanks everyone for joining! I'll send out the email after the meeting now that we're looking for 1 new member for the WG at least to os-devel
15:42:05 <pknirsch> #action pknirsch Send out note to fedora-devel about looking for new WG member
15:42:36 <pknirsch> have a great weekend everyone! Which reminds me, next Friday the US folks very likely won't be around, right? :)
15:46:51 <masta> bye bye
15:47:58 <pknirsch> #endmeeting