14:10:58 <number80> #startmeeting Cloud WG
14:10:58 <zodbot> Meeting started Thu Jul  3 14:10:58 2014 UTC.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:10:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:11:19 <number80> #chair jzb roshi agrimm geppeto
14:11:19 <zodbot> Current chairs: agrimm geppeto jzb number80 roshi
14:11:34 <number80> #topic Hello everyone
14:11:57 <number80> let's do a roll call (I doubt we have a quorum though)
14:12:03 <number80> .hellomynameis hguemar
14:12:04 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
14:12:12 <jzb> .hellomynameis jzb
14:12:13 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@zonker.net>
14:12:16 <roshi> .hellomynameis roshi
14:12:17 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
14:12:26 <agrimm> .hellomynameis arg
14:12:26 <zodbot> agrimm: arg 'Andy Grimm' <agrimm@redhat.com>
14:13:23 <jsmith> .hellomynameis jsmith
14:13:24 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
14:13:25 <number80> jzb: do you have a link to the agenda ?
14:13:31 <number80> #chair jsmith
14:13:31 <zodbot> Current chairs: agrimm geppeto jsmith jzb number80 roshi
14:13:40 <roshi> quorum is 5 wg members, right?
14:13:47 <number80> roshi: yup
14:13:55 <jzb> number80: it's just a report in Trac for items marked with meeting
14:14:23 <number80> ok
14:14:29 <number80> #topic Working Group
14:14:56 <number80> We have a vacant seat since red_trela left, do we have candidates ?
14:15:02 <agrimm> o/
14:15:08 <number80> good :)
14:15:10 <agrimm> :)
14:15:34 <number80> since we're not enough here, I'll see to organize a vote on trac but it will be formality ;)
14:15:41 <agrimm> ok
14:16:08 <number80> let's move on
14:16:17 <number80> #topic Automatic Smoketests on Image Build
14:16:21 <number80> roshi ?
14:16:44 <roshi> well, taskotron is moving towards production release
14:16:49 <roshi> replacing AutoQA soon
14:17:03 <number80> great :)
14:17:05 <roshi> I'm working on some tools for testing images locally with fabric
14:17:26 <roshi> having some issues with the recent builds not getting nics for some reason when starting up
14:17:34 <number80> #info taskotron moving toward production and replacing AutoQA soon
14:18:04 <number80> roshi: which platform ?
14:18:09 <roshi> once I have some decent test coverage through fabric, it should be pretty easy to tie those into testing on actual providers
14:18:22 <roshi> qemu is what I'm using atm
14:18:30 <number80> ok
14:18:53 <number80> do you have a repository ?
14:19:06 <roshi> not yet - but it's on the agenda to do
14:19:09 <number80> ok
14:19:21 <roshi> can't figure out what to call it :p
14:19:34 <number80> #info roshi working on fabric-based test suite for cloud images
14:19:55 <number80> naming things is hard :)
14:20:19 <number80> anyone wants to comment ?
14:20:36 * jsmith has nothing to add
14:20:57 <roshi> anyone want to commit?
14:21:29 <number80> I may have some time to help you
14:22:04 <roshi> awesome
14:22:22 <number80> let's move on :)
14:22:31 <number80> #topic Deliverables and release engineering changes for Fedora.Next
14:22:37 <number80> https://fedorahosted.org/cloud/ticket/50
14:22:46 <number80> Anyone ?
14:23:17 * roshi has nothing on this
14:23:52 <jzb> I'll do this over the weekend
14:23:59 <number80> #info changes freeze is scheduled on 2014/07/08
14:24:07 <number80> ok
14:24:23 <jzb> #action jzb ticket 50: https://fedorahosted.org/cloud/ticket/50
14:24:37 <number80> so I guess we could move to the next topic
14:25:45 <number80> #topic start communication/collaboration on cloud image updates
14:25:51 <number80> https://fedorahosted.org/cloud/ticket/51
14:26:14 * mattdm is here
14:26:17 <number80> heya
14:26:22 <number80> #chair mattdm
14:26:22 <zodbot> Current chairs: agrimm geppeto jsmith jzb mattdm number80 roshi
14:26:23 * mattdm reads back
14:26:38 <agrimm> I can help with at least parts fo this
14:26:44 <number80> great
14:27:18 <number80> #task agrim helping on ticket 51: https://fedorahosted.org/cloud/ticket/51
14:27:22 <mattdm> yeah this is a big one with a lot of qa and releng impact
14:27:25 <number80> #undo
14:27:25 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x15714e90>
14:27:30 <number80> #task agrimm helping on ticket 51: https://fedorahosted.org/cloud/ticket/51
14:27:52 <number80> is there someone from releng around ?
14:28:10 <number80> I think that Frankie was helping there but he isn't here
14:28:11 <mattdm> dgilmore?
14:28:34 <roshi> I haven't seen Frankie in a while
14:28:52 <number80> he still answer his emails
14:29:54 <number80> oddshocks: about fedimg, any update ?
14:31:01 <dgilmore> mattdm: whats up?
14:31:56 <number80> dgilmore: what's the rel-eng status for cloud images ?
14:33:59 <mattdm> perhaps crucially -- do we need to go through a special spins process with the new cloud image types?
14:34:34 <dgilmore> number80: we have things building, im working on being able to build an attomic image. waiting on oddshocks work for automated uploading. as far as doing updated images nothing has been done. the cloud wg needs to get with releng and qa and sort out how they will be done
14:34:52 <dgilmore> mattdm: spins process is really not functinal
14:34:54 <number80> great
14:35:07 <dgilmore> mattdm: lets get the kickstarts in
14:35:22 <dgilmore> mattdm: we need some pacthes to koji for docker images
14:35:46 <mattdm> yeah everything _but_ docker images is there.
14:35:59 <mattdm> the fedora-atomic docker host one is there but not really doing atomic
14:36:11 <number80> #task cooperating with releng/QA to define cloud images update process
14:36:43 <mattdm> does anyone not me want to drive the releng/qa cloud image update process/policy definition?
14:37:08 <agrimm> mattdm, I will help
14:37:17 <number80> too big to chew for me at the moment
14:37:21 <jzb> mattdm: +1 you
14:37:31 <mattdm> agrimm awesome
14:37:38 <jzb> mattdm: note, Colin and I had a discussion about this topic (I think) yesterday as well.
14:37:52 <jzb> mattdm: we need to re-sync next week
14:37:58 <jzb> mattdm: but go you
14:37:59 <jzb> :-)
14:38:01 <mattdm> #action mattdm to keep moving this forward; agrimm to help
14:38:20 <mattdm> is lsm5 around on the docker image creation?
14:38:26 <roshi> I can put it on the QA meeting agenda for monday if you want to talk to the group about what you're looking for
14:38:54 <number80> could we move to the next atomic (I could shuffle to the docker image deliverables)
14:38:57 <mattdm> roshi monday's probably too soon.
14:38:58 <number80> ?
14:39:21 <roshi> fair enough mattdm
14:39:25 <mattdm> number80 I'm not sure I understand the question there :)
14:39:54 <number80> well, we already have a meeting agenda item about the docker images, so I suggest we focus on it :)
14:40:11 <mattdm> oh :)
14:40:25 <mattdm> so https://fedoraproject.org/wiki/Changes/Docker_Container_Image
14:41:07 <mattdm> I can ping lsm5 about this. And Dennis was saying that jgreguske was working on some koji changes.
14:41:14 <number80> #topic Docker image
14:41:28 <dgilmore> mattdm: right, i believe he was going to be done this week
14:41:42 <dgilmore> if he gets them done ill pull them in and update koji asap
14:42:28 <number80> #info dgilmore and jgreguske are working on updating koji to support docker images creation
14:43:57 <mattdm> #action mattdm to ping lsm5 about that too (as he is the feature owner)
14:44:12 <number80> https://fedorahosted.org/cloud/ticket/65
14:44:46 <number80> maybe we could move to project atomic ?
14:45:45 <mattdm> yep go :)
14:46:58 <number80> #topic Project Atomic
14:47:03 <number80> https://fedorahosted.org/cloud/ticket/64
14:47:07 <number80> mattdm, jzb ?
14:47:38 <jzb> number80: we're working it ?
14:47:59 <mattdm> dgilmore: did you post the list of work items from the meeting the other week?
14:48:00 <jzb> (sorry, still on conf call)
14:48:16 <jzb> I think colin sent a note to infra about some of the things needed, I need to check
14:48:34 <number80> jzb: just following the agenda :)
14:49:36 <mattdm> agrimm has offered to help here too
14:50:00 <mattdm> I think we're basically waiting on some way for the actual ostree trees to be produced
14:50:04 <number80> #action agrimm is helping on ticket 64: https://fedorahosted.org/cloud/ticket/64
14:50:38 <number80> mattdm: are we missing tools or integration in fedora infrastructure ?
14:51:41 <mattdm> number80 integration. maybe also tools. basically, the "tree" is the remote repository (created from rpms)
14:51:47 <mattdm> and nothing is creating or updating that
14:51:57 <mattdm> we need a hook in koji/bodhi/somewhere to do it
14:52:10 <mattdm> and somewhere that it will go _to_
14:52:24 <mattdm> and the distribution channel once it's created
14:52:38 <mattdm> colin and dgilmore and others were working on this but I'm not sure of the exact status
14:52:45 <number80> #info looking for integrating of ostree trees into fedora infrastructure
14:52:46 <mattdm> or exact how other people might get involved
14:53:15 <agrimm> mattdm, I thought the compose server was going to listen to fedmsg for updates?
14:53:24 <agrimm> maybe I'm wrong there
14:53:46 <mattdm> agrimm and you may be right. if that's being worked on, awesome
14:54:34 <mattdm> Just because I'm not in the loop doesn't mean it isn't happening :)
14:54:36 <agrimm> I think that's what colin and dgilmore discussed last week.  I was remote and didn't catch the whole conversation, though
14:55:02 <mattdm> walters, dgilmore -- if there's help needed with that someone can plug into, let us know?
14:55:09 <jzb> off call
14:55:15 <jzb> mattdm (and others)
14:55:33 <jzb> was discussing all the pieces with walters yesterday that need to happen for Atomic
14:55:42 <jzb> wondering - should we try to track in Trac
14:55:46 <jzb> or in a Kanban?
14:55:54 <jzb> we'd discussed setting up a Kanban for cloud group
14:55:57 <jzb> but it never happened
14:56:12 <jzb> since there's so many groups involved here
14:56:18 <jzb> mattdm: thoughts?
14:56:22 <jzb> agrimm: ^^
14:56:26 <jzb> etc.
14:56:39 <number80> jzb: I'd favor a kanban for following advancements
14:56:39 <agrimm> "a kanban" == a board in trello, or another tool?
14:56:49 * agrimm doesn't know the tooling fedora uses these days
14:56:53 <jzb> agrimm: well, we'd talked about setting up an open source one instead of Trello
14:56:55 <mattdm> I'd love to see a kanban board. but maybe updates in the trac ticket as a summary even then?
14:57:00 <number80> agrimm: preferably open source tools
14:57:01 <jzb> there's something I think we can get in openshift
14:57:06 <jzb> mattdm: sure
14:57:13 <mattdm> "the open source one" = cantas, created by some red hatters
14:57:16 <roshi> cantas is what it's call iirc
14:57:18 <jzb> mattdm: ah, thanks
14:57:22 <agrimm> jzb, number80 :  if you have a tool to suggest, awesome
14:57:26 <jzb> I was just about to ask what the name was
14:57:28 <jzb> agrimm: ^^
14:57:30 <jzb> cantas
14:57:37 <agrimm> got it.  thanks, roshi
14:57:45 <jzb> OK, I'll see if I can openShift-ize an instance this weekend.
14:57:45 * agrimm can try to quickstart it
14:57:50 <jzb> or agrimm can
14:58:00 <agrimm> either way, jzb
14:58:02 <jzb> I'm not going to hogg the fun
14:58:04 <jzb> er, hog
14:58:09 <agrimm> I'll do it
14:58:10 <number80> agrimm: https://github.com/onepiecejs/nodejs-cantas
14:58:16 <jzb> agrimm: rock
14:58:24 <frankieonuonga> hi jzb
14:58:32 <agrimm> oh, wait, it's done?
14:58:33 <frankieonuonga> am I in time for the meeting
14:58:46 <jzb> frankieonuonga: well, for at least 2 minutes of it ;-)
14:58:46 <mattdm> frankieonuonga late but it's still going on :)
14:58:47 <number80> #action jzb trying to setup a cantas instance for the cloud SIG
14:58:52 <agrimm> heh, we have quorum now?
14:58:55 <agrimm> :)
14:58:58 <number80> :)
14:59:09 <number80> well, let's move to the last agenda item
14:59:22 <frankieonuonga> mattdm: sorry guys..data centre madness here.
14:59:30 <frankieonuonga> next time I will be sure to be early
14:59:48 <mattdm> frankieonuonga np. read back and see logs -- there's some stuff you were interested in that we talked about :)
15:00:11 <frankieonuonga> sure...I will look at the logs on email :-)
15:00:22 <number80> #topic next steps on test plan
15:00:24 <number80> https://fedorahosted.org/cloud/ticket/61
15:00:30 <number80> roshi ? ^^
15:01:03 <roshi> adam is working on syncing all the test docs from the different WGs
15:01:18 <roshi> he was on vacation this week (mostly) afaik
15:01:32 <number80> #info adamw is syncing all tests docs from all WGs
15:01:39 <roshi> I'm just trying to get some basic sanity tests together so people can actually run tests
15:02:07 <roshi> I'll get with adam next week and see what he needs, or what the status is
15:02:25 <number80> ok
15:02:30 <number80> anyone ?
15:04:06 <number80> next ;)
15:04:14 <number80> #topic open floor
15:05:48 <number80> #action number80 organize agrimm formal cooptation in the WG
15:06:22 <roshi> cooptation?
15:06:40 <agrimm> apparently that's a real word
15:07:12 <number80> sorry
15:07:15 <number80> #undo
15:07:15 <zodbot> Removing item from minutes: ACTION by number80 at 15:05:48 : number80 organize agrimm formal cooptation in the WG
15:07:47 <number80> #action number80 organize the vote to welcome agrimm in the WG
15:08:16 <number80> according our governance document, we need to get approval (lazy consensus) from the remaining members
15:08:22 <number80> here it is: http://fedoraproject.org/wiki/Cloud/Governance
15:08:56 <agrimm> seems fair
15:09:24 <number80> I don't think anyone will complain :)
15:09:43 <frankieonuonga> agrimm: I usually take bribes in terms of coffee :-P ...just fooling around
15:09:49 <number80> anything else before we end this meeting ? :D
15:11:51 <jzb> number80: nope, make it so!
15:12:13 <number80> ok, thank you gentlemen for attending :)
15:12:17 <number80> #endmeeting